1149 posts
  • Affiliate Level 1
  • Author Level 3
  • Beta Tester
  • Collector Level 2
+3 more
fillerspace
says

I’m going to try some of these suggestions…nosniff sounds promising.

2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

I’m going to try some of these suggestions…nosniff sounds promising.

posted a topic on stackoverflow but didn’t get a proper answer yet

would be nice if you can post any updates on on this here

1149 posts
  • Affiliate Level 1
  • Author Level 3
  • Beta Tester
  • Collector Level 2
+3 more
fillerspace
says
1149 posts
  • Affiliate Level 1
  • Author Level 3
  • Beta Tester
  • Collector Level 2
+3 more
fillerspace
says

IE9 tries to download even regular css files, but this seems to ensure that the styles are applied to the page:

header( 'Content-Type: text/css' );
header( 'X-Content-Type-Options: nosniff' );
header( 'Expires: Thu, 31 Dec 2050 23:59:59 GMT' );
header( 'Pragma: cache' );
echo( $style );
exit;
2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

Ok, I’ve found the problem:

WordPress wraps p tags around my shortcodes and since I’m using block elements in my form (and shortcode) I’ve and block element inside a block element – which isn’t allowed.

Removing the surrounded p’s solves the problem.

This took my about 10 hours of my life!

by
by
by
by
by
by