1080 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 6-7 years
  • Kuwait
  • Referred between 10 and 49 users
  • Sold between 1 000 and 5 000 dollars
Madness says

i never had this kind of problems before and i really dont know why its happening!

ok i have a main site lits call it “site” which loads a gallery “gallery” and the gallery loads a xml “xml”

i have them all in a folder ” main “

when i have the site and the gallery and the gallery,s xml in that ” main ” folder everything works just fine!

when i create a folder for the gallery inside that ” main ” folder and put the gallery , the gallery,s xml and that folder … the gallery works fine alone …

how ever when i load it in the main ” site ” it wont load! i get and error saying that is failed to load the gallery xml ! WTF ?!

the gallery is suppose to load the xml not the main site …

see what is happening ?

the gallery works fine alone , when i load it to the site it wont work!

2479 posts Premium Scripts, Plugins and Themes
  • Bought between 10 and 49 items
  • Elite Author
  • Exclusive Author
  • Has been a member for 6-7 years
  • Interviewed on the Envato Notes blog
  • Microlancer Beta Tester
  • Referred between 200 and 499 users
+1 more
LucidStudios says

when your main.swf file loads gallery.swf file from gallery folder then gallery.swf file points to the same path as main.swf.

So in gallery.swf file you load gallery.xml using:
xmlObject.load("gallery/gallery.xml")
1080 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 6-7 years
  • Kuwait
  • Referred between 10 and 49 users
  • Sold between 1 000 and 5 000 dollars
Madness says

THANKS ! :)

it works now , one thing though , the gallery doesnt work alone now … it only works with the site , which is what i wanted!

2309 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 10 and 49 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 100 and 1 000 dollars
  • United States
theflyingtinman says
THANKS ! :)

it works now , one thing though , the gallery doesnt work alone now … it only works with the site , which is what i wanted!

If you want to be able to test the gallery as a standalone in its own folder you could make a variable in gallery.swf to hold the folder to the XML file which you add on to the front of the XML filename. In gallery.swf it would be initialized to ”” (no subfolder) but when you load gallery.swf in your main site you could overwrite the folder variable with “gallery\” from the main site before it loads the XML file.

by
by
by
by
by
by