407 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in Europe
PaddyTaylor says

Hi all. A call for help from any WP wizards. I am not a developer but I have some Wordpress knowledge and agreed to help a friend. Their IT people seem a little unorgnaised so I have limited faith in how their server is set up.

I installed an XML content file to the WP (fresh install) it all works fine EXCEPT when the permalinks are on default it is fine BUT I cannot change them like normal (button is different). http://postimage.org/image/dah8o7jy9/ Instead it just takes me to the permalink settings page.

If I then change it to “Day and name” the links change as they should BUT the pages are “Not found” http://postimage.org/image/zbxgrk4a5/. Interestingly it says here “Port:80” when to log into FTP I had to use SFTP on Port 22.

This is above my grade and wondered if anyone new what could be causing it?

Any help gladly appreciated. Thank you all in advance

3328 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 4 years
+1 more
organicbee says

what happens when you change the permalinks via the general settings? (Settings -> permalinks)

can WordPress write the htaccess file?

also is it a custom post type?

161 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Located in Europe
  • Has been part of the Envato Community for over 1 year
+1 more
themebros says

And is mod_rewrite enabled on the server?

407 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in Europe
PaddyTaylor says

Wow you guys are fast and amazing! If I change the (settings > Permalinks) thats when it comes up as not found – what I tired originally.

I do not think it is a custom post type – just using a page that is part of the theme. The home page shows up because the link is the www.url.com but all other pages e.g. www.url.com/pagename are “not found” (even though in the page editor it shows the permalink to be www.url.com/pagename)

“mod-rewrite” on the server – sorry thats over my head – How would I know that? Is it something that the main server controls or something I can find via ftp?

Excuse my stupidness- still learning but SO grateful for the rapid replies

161 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Located in Europe
  • Has been part of the Envato Community for over 1 year
+1 more
themebros says

Create a new php file (name it whatever you want) with this in it:

<?php

phpinfo();

?>

Open it up in the browser and do a search for mod_rewrite.

3328 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 4 years
+1 more
organicbee says

also check the htaccess file(it will be hidden most likely) Click Click

161 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Located in Europe
  • Has been part of the Envato Community for over 1 year
+1 more
themebros says

Yeah, i suggest using Filezilla, if the .htaccess is there you’ll see it.

407 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in Europe
PaddyTaylor says

Thank you guys SO much.

mod_rewirte does not appear. Only “rewrite”: url_rewriter.tags a=href,area=href,frame=src,input=src,form=fakeentry a=href,area=href,frame=src,input=src,form=fakeentry

There are lots of mod_so, mod_alias etc etc but NOT “rewrite”

In htacess file there is :
  1. BEGIN WordPress
  1. END WordPress

Thats it. Sorry if I did something wrong. I am beginning to guess this is the problem. Thank you again

161 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Located in Europe
  • Has been part of the Envato Community for over 1 year
+1 more
themebros says

You’ll need to contact the hosting provider and ask them about mod_rewrite. But not sure what kind of hosting provider does not have that feature enabled.

407 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in Europe
PaddyTaylor says

Oh trust me it took them 3 weeks to change file permissions even when I made them a demo video! Nothing surprises me BUT THANK YOU SO SO MUCH – thought I was going out of my mind as never seen the permalink button do that on a page before (v inexperienced compared to you guys).

Thank you again.

by
by
by
by
by
by