17 posts
  • Referred between 10 and 49 users
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Europe
  • Has been a member for 2-3 years
  • Bought between 50 and 99 items
webmandesign says

Thanks for sharing. :)

Well, that’s why I opened this thread. I was frustrated that I couldn’t find a solution for this anywhere. Still don’t have it and my customer went on by creating his pages from scratch…

I wasn’t able to recreate the error since which makes is more misterious one!

36 posts
  • United States
  • Bought between 100 and 499 items
  • Has been a member for 4-5 years
  • Exclusive Author
danyno45 says

Hi everyone, any fix on this issue?

87 posts
  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Has been a member for 2-3 years
  • Grew a moustache for the Envato Movember competition
  • Referred between 100 and 199 users
  • Bought between 10 and 49 items
+2 more
MVPThemes says

I had the exact same issue after the Wordpress 3.5 release, which forced me to remove the XML data from my themes. How are other authors providing dummy content if this is the case? Are they providing an SQL database or something?

36 posts
  • United States
  • Bought between 100 and 499 items
  • Has been a member for 4-5 years
  • Exclusive Author
danyno45 says

I had the exact same issue after the Wordpress 3.5 release, which forced me to remove the XML data from my themes. How are other authors providing dummy content if this is the case? Are they providing an SQL database or something?
I just contacted my theme author. Waiting for a reply.
2 posts
  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • Thailand
repoulin says

I was told to follow the directions. I guess I couldn’t do it correctly and just did all my posts by scratch. Took some trial and error to learn the layout and features. It was probably quicker since I never got the solution either. Good luck.

36 posts
  • United States
  • Bought between 100 and 499 items
  • Has been a member for 4-5 years
  • Exclusive Author
danyno45 says
17 posts
  • Referred between 10 and 49 users
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Europe
  • Has been a member for 2-3 years
  • Bought between 50 and 99 items
webmandesign says

I don’t think this is resolved issue yet, but it haven’t happened since to me.

As tips for you guys: firstly, activate the theme the XML is meant for (and all the possible required plugins) and then try to import the XML file.

Tip for theme authors: I know this doesn’t really resolve the issue I’ve started this thread with, but I found a good practice to move all downloadable content (images for example) in XML file at its end. By default WP creates this (or smilar) XML structure: first are imported taxonomies, then downloadable media and then content (also with downloadable media somewhere). So what I do before I distribute the theme demo XML is just open the XML file and cut and paste all the attachments post types at the end of XML file (surely before closing tags </channel></rss>). This helps when there is a problem with importing images as all the text content is imported at the beginning of the file and all attachments are being downloaded just after this text content is imported. At least something ;)

RockNRollaDesigns
RockNRollaDesigns Recent Posts Threads Started
17 posts rocknrolla
  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Referred between 50 and 99 users
  • Exclusive Author
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
RockNRollaDesigns says

One of my buyer had the same problem. Trying to import the .xml file, but it shows “Failed to Import: Invalid Custom Post Type”, this method resolved this issue for us, may be it would be helpful for you guys too:

Solution:

1) Download and Install 7zip.
2) Right click on your .XML file -> 7zip -> Add to Archive
3) Change the “Archive format” to gzip and hit “OK”. You’ll now see your file with a .gz extension on it.
4) Try to import/upload the file again (selecting the .gz you just created not the .xml file) and it should work.

This looks like a only solution for now, but would like to hear an explanation for this issue. :)

17 posts
  • Referred between 10 and 49 users
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Europe
  • Has been a member for 2-3 years
  • Bought between 50 and 99 items
webmandesign says

3) Change the “Archive format” to gzip and hit “OK”. You’ll now see your file with a .gz extension on it.
4) Try to import/upload the file again (selecting the .gz you just created not the .xml file) and it should work.

Wou, if this works, I eat my head, guys! :) And would really love to hear the explanation too ;)

Thanks very much for sharing!

2 posts
  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
asamra says

hi webmandesign, I bought your theme Les paul and I got this error “Fail to import ..” . I googled it and tried many solutions but I found the answer on http://wordpress.org/support/topic/failure-to-import-and-invalid-post-type-errors same as RockNRollaDesigns answer I gzipped the xml file and re-import it. it took a little long time to import but finally it works :) But you may need to delete pages and post created by the failed import.

by
by
by
by
by
by