4264 posts ThemeForest Reviewer
  • Envato Staff
  • Reviewer
  • Community Moderator
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Venezuela
  • Has been a member for 5-6 years
  • Microlancer Beta Tester
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
+9 more
Ivor Reviewer says

Hi I have this problem, why WordPress is showing me the wrong links? I mean It puts the Link name and the link path automatically

For example: This is a link ( and the path in parentesis )

204 posts Bold WordPress Theme Development
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 5-6 years
  • Interviewed on the Envato Notes blog
  • Referred between 200 and 499 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+1 more
srhnbr says

When does this happen? And what links are these? Can you provide a better example?

4264 posts ThemeForest Reviewer
  • Envato Staff
  • Reviewer
  • Community Moderator
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Venezuela
  • Has been a member for 5-6 years
  • Microlancer Beta Tester
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
+9 more
Ivor Reviewer says
When does this happen? And what links are these? Can you provide a better example?

Thanks Sarah, look at this screenshot http://qkpic.com/d22ea every single link is showing that problem. The main nav is just this:

<div id="slidetabsmenu"> <?php wp_list_pages('title_li=&depth=1'); ?> </div>
204 posts Bold WordPress Theme Development
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 5-6 years
  • Interviewed on the Envato Notes blog
  • Referred between 200 and 499 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+1 more
srhnbr says

that’s interesting. Hmm… not really sure why this would be happening.

By the way you should wrap your wp_list_pages with an unordered list

4264 posts ThemeForest Reviewer
  • Envato Staff
  • Reviewer
  • Community Moderator
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Venezuela
  • Has been a member for 5-6 years
  • Microlancer Beta Tester
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
+9 more
Ivor Reviewer says
that’s interesting. Hmm… not really sure why this would be happening. By the way you should wrap your wp_list_pages with an unordered list

Yeah sorry I just type that quickly, that is wrapped by the UL tag

352 posts
  • Author had a File in an Envato Bundle
  • Author had a Free File of the Month
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 50 and 99 users
  • Sold between 10 000 and 50 000 dollars
+1 more
danharper says

That is very odd, and Google isn’t returning any results. Could you paste the source that is generated here?

Also, what software are you running your local web server on? If it’s WAMP , move to XAMPP . I’ve found WAMP has a ton of problems, somehow, with WordPress.

4264 posts ThemeForest Reviewer
  • Envato Staff
  • Reviewer
  • Community Moderator
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Venezuela
  • Has been a member for 5-6 years
  • Microlancer Beta Tester
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
+9 more
Ivor Reviewer says
That is very odd, and Google isn’t returning any results. Could you paste the source that is generated here? Also, what software are you running your local web server on? If it’s WAMP , move to XAMPP . I’ve found WAMP has a ton of problems, somehow, with WordPress.

I’m actually using MAPM Pro, I have searched in Google too without any results, this is the source code , Thanks a lot.

352 posts
  • Author had a File in an Envato Bundle
  • Author had a Free File of the Month
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 50 and 99 users
  • Sold between 10 000 and 50 000 dollars
+1 more
danharper says

Well, the source is fine:


<li class="page_item page-item-2">
  <a href="http://localhost:8888/sleek/?page_id=2" title="About">About</a>
</li>

<li class="page_item page-item-3">
  <a href="http://localhost:8888/sleek/?page_id=3" title="About Us">About Us</a>
</li>

So it won’t be the server causing it.

I can only think of two things:

  • You have some CSS styling which displays a link’s URL after the text (see this tutorial) – that is usually used to display links in a print CSS file. Do you have any code like that in there?
  • Have you tried it in a different browser? You may have an extension installed which is causing it to happen for some reason.
415 posts
  • Bought between 1 and 9 items
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
osigrandi says

How are your permalinks setup?

162 posts
  • Bought between 1 and 9 items
  • Elite Author
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 10 and 49 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 50 000 and 100 000 dollars
+1 more
ponjoh says

Really weird. I have no idea what could be the cause of that. By the way, I noticed that you’re using the Din Pro font with Cufon. Remember that it’s a commercial font so you can’t use it if you plan on selling the theme on TF.

by
by
by
by
by
by