412 posts
  • 6 Years of Membership
  • Affiliate Level 1
  • Author Level 5
  • Beta Tester
+6 more
patrickjansen
says

After days of puzzling I’m getting demotivated.
Are there any authors out there with advanced xml loading knowledge, willing to do freelance job bug-fixing an xml load issue? Spending too much time already…

3256 posts
  • Affiliate Level 4
  • Author Level 9
  • Collector Level 2
  • Top Monthly Author
+11 more
ParkerAndKent
says
After days of puzzling I’m getting demotivated.
Are there any authors out there with advanced xml loading knowledge, willing to do freelance job bug-fixing an xml load issue? Spending too much time already…

Post the code using pastie.org and give us a link to your xml file ;-)

Parker

189 posts
  • 6 Years of Membership
  • Affiliate Level 1
  • Australia
  • Author Level 5
+3 more
mbudm
says

You are probably already doing this, but i find loading the xml file in firefox a great idea.

Just this morning I had a weird bug where it my new template got stuck on a particular image and after checking the jpg wasn’t corrupt etc i realised it had to with the xml file… I pooped it into firfox and it told me immediately that I had a duplicate id attribute … the sort of thing that is hard to spot when you scan the xml file in an editor.

Or as PK gum* says – you could pastie it for us

  • I grew up in the uk – it keeps reminding me of it sorry ;-)
412 posts
  • 6 Years of Membership
  • Affiliate Level 1
  • Author Level 5
  • Beta Tester
+6 more
patrickjansen
says

@mbudm: yup, especially firefox shows the issue/’phenomena’. But as far as I checked the xml nodes are correct, no errors with them.

I simply haven’t been able to pinpoint if it’s the xml file, the scripting or the flash player. For the past days I’ve been doing a huge number of different experiments and strip-downs to the bare essesntial.
I prefer not to paste it publically but do show it to regular authors who inquire about it. It’s a 2000+ lines code and don’t want to overcomplicate it on the forum

8586 posts Community Moderator
  • United Kingdom
  • 7 Years of Membership
  • Moderator
  • Winner
+10 more
MSFX
Moderator
says

AS2 or 3?

412 posts
  • 6 Years of Membership
  • Affiliate Level 1
  • Author Level 5
  • Beta Tester
+6 more
patrickjansen
says

AS3

8586 posts Community Moderator
  • United Kingdom
  • 7 Years of Membership
  • Moderator
  • Winner
+10 more
MSFX
Moderator
says

can you post a link to the xml and what node you’re trying to get?

189 posts
  • 6 Years of Membership
  • Affiliate Level 1
  • Australia
  • Author Level 5
+3 more
mbudm
says
I prefer not to paste it publically but do show it to regular authors who inquire about it. It’s a 2000+ lines code and don’t want to overcomplicate it on the forum

How about trying to load the same xml file into a test fla with much less code – then you will at least narrow down to whether th eprb is as3 or xml?

412 posts
  • 6 Years of Membership
  • Affiliate Level 1
  • Author Level 5
  • Beta Tester
+6 more
patrickjansen
says

Ok, moment of truth. Let’s see if I can become an alltime fan of Doru, who god helps me seems to have pinpointed out a fix.

Is there anybody who can NOT view the samples players AND listen to the sound-tracks on this preview link?
Any "Yes-can-see/hear"-s will make me a happy man, ... any "No-doesn’t-work"-s , please don’t be joking around, it’s been nervewrecking too long already ;)

8176 posts
  • Author Level 6
  • Trendsetter
  • Weekly Top Seller
  • Community Superstar
+8 more
doru
says

On my comp works fine ;)

Firefox 3.5.3 and IE8 don’t know what version I never use it.

There’s a slight moment of loading time till the player appears, maybe a simple preloader could help. Its not that long on my comp but on slow connections could become a problem.

by
by
by
by
by
by