412 posts
  • Author had a File in an Envato Bundle
  • Beta Tester
  • Bought between 1 and 9 items
  • Brazil
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
patrickjansen says

I’m stumbling upon a strang phenomena with a new item I uploaded. Locally all works ok every time, only from server it behaves completely weird.

I have a xml mp3 player which loads xml data from file. But from server it get’s stuck not loading the xml file properly. And I’ve noticed that many times if I view xml file in browser then after that when viewing the html/swf file it DOES load properly.

About the code;

public var myXML:XML
public var mySongs:XMLList;
public var loader = new URLLoader();
public var urlreq:URLRequest;

then it should load the xml file name from variable xmlmusicdatafile into a loader

urlreq = new URLRequest(xmlmusicdatafile);
loader.load(urlreq);
loader.addEventListener(Event.COMPLETE, setinit);
loader.addEventListener(ProgressEvent.PROGRESS, showxmlloadprogress);

If I trace(loader) right after .load it does trace [object URLLoader] but neither function setinit() nor function showxmlloadprogress() is being executed. It hangs on loading the xml file.

the xml code by the way is simple
<?xml version="1.0" encoding="utf-8"?>
<musiclist>
  <musicitem>
    <itemname>life-is-creative-patrick-jansen.mp3</itemname>
    <title>life is creative</title>
    <artist>Patrick Jansen</artist>
    <album />
    <link />http://marketplace.envato.com/user/patrickjansen/portfolio
  </musicitem>
</musiclist>

If anybody has any clue or idea i’d appreciate it. Or if anybody wants to take a look at the file, email me directly (regular authors only).

I’m stuck in a black hole of knowing the xml load action has been triggered but the xml file never really started loading (showxmlloadprogress never starts tracing anything)

Any suggestions?
P.

4136 posts
  • Bought between 1 and 9 items
  • Brazil
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 5 000 and 10 000 dollars
tsafi says

Ola P .

This should be something simple; I notice also there is some looping killing this on start base on my CPU . Your zip for download is also not showing anything. If you don’t solve it by tomorrow send me a sample of your simple player I will look at this or just the xml code trigger with your preload code .

Your file doesn’t load at all.

You have my mail if you need me.

vejo você depois .

Tsafi

755 posts
  • Beta Tester
  • Bought between 100 and 499 items
  • Croatia
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 50 and 99 users
  • Sold between 50 000 and 100 000 dollars
djankey says

did you import

import flash.events.*;
import flash.net.* 
also try to place .load function after listeners

412 posts
  • Author had a File in an Envato Bundle
  • Beta Tester
  • Bought between 1 and 9 items
  • Brazil
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
patrickjansen says

Yes, i have those. For those interested in testing it on server… check test file

755 posts
  • Beta Tester
  • Bought between 100 and 499 items
  • Croatia
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 50 and 99 users
  • Sold between 50 000 and 100 000 dollars
djankey says
Yes, i have those. For those interested in testing it on server… check test file
your script is working…
412 posts
  • Author had a File in an Envato Bundle
  • Beta Tester
  • Bought between 1 and 9 items
  • Brazil
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
patrickjansen says

yes, locally from disk it works fine. Did you try on a server?

by
by
by
by
by
by