1194 comments found

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
vtheme Purchased

Hi

I am sure this is buried in this forum somewhere… but having a hard time finding it.

I have a custom field in a post that is an external URL to an image. I want to make that URL the featured image.

I have edited single. php to access the image and do have it showing in the post, but want to be able to Set it as the Featured Image…. is this possible?

Thanks a ton for your themes !!

ThemeBlvd

Hello,

I apologize, but this isn’t really something I can do for you or that would be part of the theme.

You could maybe do something like this from your Child theme’s functions.php:

http://wpforce.com/automatically-set-the-featured-image-in-wordpress/

... But instead of taking the first image in the post pull it from your custom field.

Default-user
vtheme Purchased

very good – thank you!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

I have 3 questions after checking out most of the documentation.

1) Anytime I make a change to a builder, slider, widget, and click save or update, the changes don’t appear on a page until I go into pages and update each page. With my previous experience with wordpress, changes would appear on pages when i saved the changes. I didn’t have to go through and update every page to see the changes.

2) On my home page, I have a slider setup with a slogan section + button. Is there an easy way to make this button centered underneath the slogan? Can i easily make it a smaller button too?

3) You know how you can choose things like bokeh, grunge, wood, etc. If I upload a custom background image, what size should I make it?

Thanks again and sorry if some of this is in documentation!

ThemeBlvd

1) lol… Is there a question in there somewhere, or is this just a complaint?—I understand the confusion and I’ve got some improvements to this in the next update, which will allow you to edit custom widget areas, basic sliders, and widget area assignments all from the Edit Page screen.

2) No, sorry there’s no feature to adjust these things. In the next update, there will be a an option to change the size of the slogan button, but not anything to put the button underneath the slogan.

You may just want to put some centered text and a button with the [button] shortcode in a Content element of the builder, opposed to using the slogan element at all.

3) The background images used by the theme are about 1200×600. The common width that most people are viewing your website at will be anywhere from 1000px to 1500px.

4) And if I were you, my next question would probably be, “When is the next update going to happen?”—And honestly I do not have an answer to that at this time, unfortunately.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi, could you please advise on how to move the social media buttons from the Header addon section to “themeblvd_header_menu_addon” so that they appear in the right side of the primary menu navigation bar?

How do I do this through the child theme functionality?

Thanks a lot for any help! Anya

ThemeBlvd

It’s quite simple if you’re just moving around functions that are already there.

http://dev.themeblvd.com/tutorial/the-wordpress-functions-you-need-to-know/

remove_action( 'themeblvd_header_addon', 'akita_header_addon' );
add_action( 'themeblvd_header_menu_addon', 'akita_header_addon' );

This “akita_header_addon” function might not work perfectly when shoved into the main menu. So, you may want to have a look at how it’s constructed in /includes/theme-functions.php and consider doing your own modified version to hook to “themeblvd_header_menu_addon”.

Default-user

Hey, thanks so much for the help, and I had been looking at that WP Functions You Need To Know page, just couldn’t figure this out.

So I added the remove and add lines to my child theme functions.php and uploaded that, but nothing changed… the social buttons remain just where they were in the header. Any suggestions?

And there is no “theme-functions.php” in my includes folder; only “options.php” but I can’t find the addons there.

Thanks again, Anya

ThemeBlvd

You must be using a very old version of Akita. What version are you currently using?

ThemeBlvd

If you’re using a setup prior to Akita 1.1, there’s just an extra step you have to do with the code I placed earlier:

function my_hooks(){
    remove_action( 'themeblvd_header_addon', 'akita_header_addon' );
    add_action( 'themeblvd_header_menu_addon', 'akita_header_addon' );
}
add_action('after_setup_theme', 'my_hooks');

And the akita_header_addon function used to be located in functions.php of the main parent theme.

Default-user

Hey, thanks for your replies. I went ahead and downloaded and installed the latest version of Akita, but the original edit to the child theme functions.php still hasn’t worked—the social media links remain in the header.

One more issue that I was having in the old version and was hoping would be fixed with the updated install but wasn’t: my homepage slider keeps appearing at the top of the Post List page, though I haven’t checked the box for any slider there and selected “Post List” for the template. Also there are no headlines for the posts, just the text… something isn’t right.

Thanks again, Anya

Default-user

One more note on the Post List page issue—the problem appears when I select the page as the designated Posts page in the Settings – Reading section. If I select a different page as the designated posts page, that page gets the homepage slider and weird layout, but the previous page now has a normal Post List layout… any suggestions? Thanks!

ThemeBlvd

So the answers here are all pretty simple. If you’d like a long explanation on the why for any of these, let me know.

I went ahead and downloaded and installed the latest version of Akita, but the original edit to the child theme functions.php still hasn’t worked—the social media links remain in the header.

Open up the Child theme that now comes in the latest package and look in its functions.php. See how the theme’s framework is included at the top? You need to copy that part to the top of your Child theme’s functions.php

my homepage slider keeps appearing at the top of the Post List page…

There’s nothing to fix. You’re just getting mixed up on some concepts. The short answer is don’t select any posts page at all from Settings > Reading.

Create a page. Apply the “Post List” template to that page. That page is your blog. You don’t need to do anything else.

If you still have a problem, show me a link to the page.

Default-user

Hi, so, I’m actually using the functions.php that came with your updated Akita child’s theme (so the call to the framework php is there, followed by the call for the custom.css) and all I did was add the two lines you suggested originally for moving the social buttons to the right side of the nav bar:

remove_action( ‘themeblvd_header_addon’, ‘akita_header_addon’ ); add_action( ‘themeblvd_header_menu_addon’, ‘akita_header_addon’ );

But nada. Am I misunderstanding something? Thanks much for all the help—I do appreciate it.

For the posts, I went ahead and did a custom builder page for the posts and manually pulled the slider from there. Sounds like just not calling it out under Settings would have done it to though. Just used to having to id the posts page there.

Thanks again, Anya

ThemeBlvd

I apologize, I put the wrong name in the function. It should be “akita_social_media”—

remove_action( ‘themeblvd_header_addon’, ‘akita_social_media’ ); add_action( ‘themeblvd_header_menu_addon’, ‘akita_social_media’ );

Default-user

Yup, that dropped them down into the nav bar—thanks! It’s trying to use the link functionality of the nav, so looked broken but is just going to need some css editing. Thanks again.

Here’s maybe a dumb question, but php isn’t my language: is the following line in your child theme functions.php correct, or does “TEMPLATEPATH” need to be replaced with an actual path? require_once ( TEMPLATEPATH . '/framework/themeblvd.php' );

One more: it seems that just dropping a favicon.ico into the root or wordpress main folder isn’t enough to have it show up (I’m on the latest Firefox). Can you recommend the best way to get the favicon called up (perhaps from the child theme’s images directory) as well as apple icons? Is there a functions.php way to do it?

Thank you. Anya

ThemeBlvd

In PHP , a “constant” is similar to a variable, except for it can be passed throughout the entire script without needing to pass it globally through to each function, as you would with a variable.

TEMPLATEPATH is a constant that WordPress sets up. So, that’s not something you need to change. It’s already using WordPress to pull the directory of your Parent theme. If it weren’t, in your customization you’re doing, you’d be ending up with the “akita_social_media” function in both locations and not removed from the header. ;-) ... put the code before the framework is included temporarily and you’ll see what I mean by the result.

You can try using this plugin for the favicon: http://wordpress.org/support/plugin/theme-blvd-favicon

It’s a newer plugin. I haven’t really gotten much feedback on how well it works for people.

Default-user

Hey, just to follow-up:

There doesn’t seem to be a need for a favicon plugin—the following bit in the Child theme functions.php works and lets you use the favicon image from the child theme’s images folder: function add_favicon() { ?> <link rel="shortcut icon" href="<?php echo bloginfo('stylesheet_directory') ?>/assets/images/favicon.ico" > <?php } add_action('wp_head', 'add_favicon'); ?>

The updated code for moving the social buttons did get them into the nav bar, but I gave up on trying to adjust the css to make this work—there was too much, and then kept failing on the responsive resizing. Heads-up though that this is an option people might really appreciate in future versions of the theme.

New issue for you if you don’t mind one more: the slider doesn’t work for the phone size of the responsive layout—it breaks out and just stacks all the images vertically. I assume this is an error, but if not, is there a way to then get rid of the slider in the smallest layout and just feature the first image or something? Stacking a dozen images doesn’t seem like a great solution.

Thanks again, Anya

Default-user

Quick note—in the original version of Akita (I think 1.0), the slider did not break down at the phone-size but kept functioning as a slider. I’d love to get that functionality back in this current version. Thanks.

ThemeBlvd

This is now just a setting on the slider. When you’re editing your slider, look at the bottom of the Slider Settings in the right column.

Default-user

Oh I missed that—thank you!

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
burnworld Purchased

Great theme, just switched over to using it. I am having an issue when using the shortcode to display the posts. For the thumbnail it wants to pull in a https:// url for the image instead of a http:// Because of this the images are broken when added to the page: http://www.burnworld.com/blogzone/

How can I have the correct url’s shown on these pages? Also it may be best to hard code this but each

tag should be

on content-list.php, content-page.php, content-search.php, and content-grid.php becuause you are getting multiple H1 tags which is not good for SEO .

ThemeBlvd

So, this shouldn’t have anything to do with the theme specifically. We’re just using default WordPress functions to pull the featured images for the posts. When WordPress does this, it’s constructing the URL based on whatever your site URL is.

There has to be something you’ve done on your site with “https://” previously that you’re leaving out here or that you’re overlooking? Maybe your blogurl/siteurl both aren’t setup with http under Settings > General? Maybe you’re using some 3rd-party plugin that changes the upload directory or modifies image URL ’s? Maybe you previously had it as https and now you’ve changed it, but haven’t refreshed your cache (noticed you were using W3 Total Cache)?

Default-user
burnworld Purchased

Strange, I never set it up under https. I cleared everything but when you view the source code it still shows that the images are https:

I don’t believe that I used anything that would change this.

The home page that shows the lists are showing the correct image under http://

It’s only when I use the shortcode is when it shows https://

Any other ideas are very welcome. :P

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
fusionx22 Purchased

This is more a question for other end users, but if you care to comment, Jason, please do!

Does anyone have any tips for customizing the content-404.php template? I’d like to add some more functionality, like give a list of related posts/pages, depending on how they arrived at the 404 page. Fir instance, if they came from Google, grab the keywords and do my own query, etc. Or, if they came from the site, grab the permalink, parse it, and do another query.

Any other ideas for making this template more useful to the end users would be very welcome!

ThemeBlvd

A question like this might be better suited for our support forum. http://support.themeblvd.com

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Portfolio section question:

1) Can I make the featured image for a post grid/portfolio section larger?They are thumbnail size right now.

2) Can I change the color and text displayed on the buttons in the post grid section? This is through the theme options>post grid section. I’m guessing I’d have to use Custom CSS or edit a php file?

Random question: - Can i upload a custom picture for the main navigation menu?

Thanks again for the great support and theme. My site is really coming along!

ThemeBlvd

Hello,

1) There is a plugin you can use to help adjust the sizes of the images used in Grids, but please keep in mind that this is still a customization you need to make to the theme, as the the current image sizes have been designed around the maximum widths of the columns.

http://wordpress.org/extend/plugins/theme-blvd-image-sizes/

2) Sorry, but there is no feature this and this would be a customization you’d need to make to the theme.

For CSS changes, it’s a good idea to use a tool like firebug or Google Chrome’s built-in developer tools to locate them and then put the edits either in your child theme or in the “Custom CSS ” option on your theme options page.

.post_grid .read-more { ... }

Also, here’s a helpful tutorial on how to use Firebug – http://vimeo.com/20917974. The only thing I’d suggest not doing is actually making edits to the theme’s CSS files, as it shows at the end of that video. However, the video serves as a good introduction to Firebug and how it can be used to find what CSS is effecting certain areas of your site without ever digging around in any files.

Can i upload a custom picture for the main navigation menu?

No, apologies, but there’s no feature for this either. But if you’re referring to the background image of the main navigation, you can also accomplish this with CSS customizations, as well.

  • Bought between 1 and 9 items
  • Has been a member for 3-4 years
elliscain Purchased

Is there a way I can add a Slider to my header.php file? What is the PHP code? Thank you!

ThemeBlvd

Hello,

There is a function you can use to display a slider called themeblvd_slider.

themeblvd_slider( 'your-custom-slider-id' );

I wouldn’t actually edit header.php though, as this is a file that changes quite often with theme updates. It’s better to use to the theme’s hook system from your Child theme.

http://dev.themeblvd.com/tutorial/primary-framework-action-hooks/
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years

Hi there, hope you are well and dinky. I placed a slider into the primary content area of a custom layout built from scratch. It shows up on the page, but immediately below the slider is a message saying “slider does not exist”

Please could you advise on getting rid of this error message please?

Thank you! I did try your support forum but the site was down for maintenance.

ThemeBlvd

Please provide a link to the issue.

larryfroot

Hello again…I just had another careful look, sorry to have bothered you but the problem was a typo – duh…however, when I corrected it, I now have two of the same sliders on the page.

larryfroot

Hello yet again, I just had a brainwave, I deleted the shortcode for the slider, and now I only get the one. Job done. Bit weird though.

larryfroot

Finally, I got to the bottom of it; there isn’t a glitch in the theme, it was my own stupidity. I had used a custom template for the links page and included the slider in it, and as I had been away from the site for a while I forgot that fact and was also inserting the shortcode for the slider in the actual page itself on top of the slider being called in from the custom template. The slider does not exist message was coming from the original typo whilst the slider from the custom template was displaying. when I corrected the typo I found two sliders displaying. I am often a dork, but fortunately it’s rare I get the opportunity to demonstrate this tragic fact on such a public arena.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

The slider on the demo page stays the same height regardless of whether or not the slide is a full image, an aligned image, or a video.

My homepage slider changes height to adjust for each slide type, even the video type (I’m embedding a YouTube video, not Vimeo).

Is there a way to make sure that my slider stays the same size regardless of what I put it? I don’t see a way to set this in the slider itself or in the layout builder.

ThemeBlvd

Hello,

When the slider is in the featured area, it should have a fixed height applied of 350px. Is your homepage slider not up in the featured area of your custom layout? Can I see a link to what you’ve setup?

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

My slider is not in the featured area, it’s in the primary area. We prefer the appearance it has there. I’ll e-mail you a link. Can I apply a fixed height somehow when it’s in the primary area?

ThemeBlvd

You could just take the styles applied to the #featured area and do the #main area also.

#main .element-slider .standard-slider-wrapper li.slide {
    height: 350px;
}

====

For CSS changes, it’s a good idea to use a tool like firebug or Google Chrome’s built-in developer tools to locate them and then put the edits either in your child theme or in the “Custom CSS” option on your theme options page.

Also, here’s a helpful tutorial on how to use Firebug – http://vimeo.com/20917974. The only thing I’d suggest not doing is actually making edits to the theme’s CSS files, as it shows at the end of that video. However, the video serves as a good introduction to Firebug and how it can be used to find what CSS is effecting certain areas of your site without ever digging around in any files.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Perfection, thank you!

  • Bought between 1 and 9 items
  • Has been a member for 3-4 years
DaveLopez Purchased

Hey Theme,

On your Live Preview page for Shortcodes I think you’re missing the shortcodes directory in the path. You show…

/framework/frontend/assets/images/icons/{your-icon-name}.png

but it should be…

/framework/frontend/assets/images/shortcodes/icons/{your-icon-name}.png Let me know if I'm wrong. Thanks! -dave

ThemeBlvd

Yup, you’re right. Thanks!

  • Has been a member for 3-4 years
  • Spain
  • Bought between 10 and 49 items
SYSCOVER Purchased

Hi!! your Theme Blvd WPML Bridge fail with the wordpress new version 3.5 don’t see any page in admin panel

best regards

ThemeBlvd

Hello,

I just tested out the WPML Bridge plugin out with WP 3.5 and all is working as it should over here. Can you tell me specifically what’s missing or what you’re expecting to be there that isn’t? Are you to new to using the WPML Bridge plugin or possibly not understanding fully how it works?

  • Bought between 100 and 499 items
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 50 and 99 users
  • Sold between 100 and 1 000 dollars
  • United States

Hey Jason… is there a way to put in a custom header image into the header, and turn off all the other stuff, like the logo and social network linkers.

I could always make a transparent gif or png that is the size of whatever I want to link to the homepage so that is not a big deal. If you would like, you can email me at topher @ toe-fur.com and I can actually give you access to the site and the image in question.

ThemeBlvd

Why not just put a large image in for the header logo that spans the width of the layout and just leave the social icons and header text options blank? Wouldn’t that be the result you’re trying to achieve?

TopherWelsh

I guess that might work… I’ll try it out. I actually put in a transparent GIF image that was the exact size to link everything, but it did some wierd spacing issues. I think…. it is because the logo is meant to site in the header with some buffer between the top and the bottom. So I don’t think that would work.

ThemeBlvd

You’d just remove the padding from around header’s content area with CSS.

ThemeBlvd

I just saw your site from your post in our forum. Just put nothing in the header and then make it however tall you want with CSS:

#header_content { height: 100px; }

And you’d just fudge the number until it is the amount you’re going for, I guess?

=======

For CSS changes, it’s a good idea to use a tool like firebug or Google Chrome’s built-in developer tools to locate them and then put the edits either in your child theme or in the “Custom CSS” option on your theme options page.

Also, here’s a helpful tutorial on how to use Firebug – http://vimeo.com/20917974. The only thing I’d suggest not doing is actually making edits to the theme’s CSS files, as it shows at the end of that video. However, the video serves as a good introduction to Firebug and how it can be used to find what CSS is effecting certain areas of your site without ever digging around in any files.

  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Author had a File in an Envato Bundle
  • Bought between 50 and 99 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 500 and 999 users
+1 more

Please use the new support forum

We’ve recently setup a new support forum and we’re trying to slowly push all support over there. In the near future, we will be making it mandatory that all support given to verified buyers will be done there. Just a heads up!

http://support.themeblvd.com
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
MissAlice Purchased
Dear Jason, Dear All, Thanks a lot for your support . ISSUE : TRIPDAVISOR LOGO in www.baliberty.com I can’t find a way to make the TripAdvisor logo widget RESPONSIVE in my right sidebar. The code given by Tripadvisor is : <script src=”http://www.jscache.com/wejs?wtype=rated&uniq=699&locationId=3229234&lang=en_US”></script>

Would you have any idea ? Thans a lot Miss Alice

ThemeBlvd

I think the javascript is just putting a fixed width onto the widget’s content, so I’m not sure there’s much you can do about that. Maybe you could just hide it when the site scales down—http://www.jasonbobich.com/wordpress/how-to-adjust-which-widgets-display-on-mobile-devices-and-tablets-with-theme-blvd-themes/

Default-user
MissAlice Purchased

Thanks a lot for your answer, Jason. By the way, the only way was to to a screen shot of the Tripadvisor logo and then to insert it with the URL link in a widget. The result is finally responsiv !

  • Bought between 50 and 99 items
  • Exclusive Author
  • Has been a member for 3-4 years

Is this compatible with WP 3.5?

ThemeBlvd

Yes, it is.

  • Bought between 1 and 9 items
  • Has been a member for 3-4 years
elliscain Purchased

How can I give “Editors” access to using sliders? I do not want to give everyone Admin rights but it seems that only Admin have the right to use Sliders. Can you please help or recommend how to give Editors access to using sliders? THANK YOU!

  • Bought between 1 and 9 items
  • Has been a member for 3-4 years
elliscain Purchased

I found this code in themeblvd.php. Could I possibly copy/paste this “admin” section of code and add in the same code but with “editor”?

function themeblvd_setup() { $setup = array( ‘admin’ => array( ‘options’ => true, // Entire Admin presence ‘sliders’ => true, // Sliders page ‘builder’ => true, // Layouts page ‘sidebars’ => true // Sidebars page ), THANKS for your guidance and direction in solving this. The client really needs her Editors to be able to access the slider feature.

ThemeBlvd

You can do this fairly easily from the functions.php file of your Child theme. Check out this article: http://dev.themeblvd.com/tutorial/changing-user-role-access-for-admin-modules/

  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Author had a File in an Envato Bundle
  • Bought between 50 and 99 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 500 and 999 users
+1 more

Use of support forum mandatory as of January 1, 2013

We’ve recently setup a new support forum and we’re pushing all support over there. Just a heads up!

Starting January 1, 2013, we will be making it mandatory that all support given to verified buyers will be done there.

No support will be given through the ThemeForest comment system. The only exceptions will include pre-sale questions and any issues you may have accessing the support forums.

Support Forum: http://support.themeblvd.com

Support Terms: http://support.themeblvd.com/help/#terms

by
by
by
by
by
by