535 comments found

  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 2-3 years
  • United States

Hi Vasterad!

Everyone loves the AZOMITE site and we are starting a few more this summer – so thank you for everything!

Question: For legal reasons, the company would like to change the “Formal Claims Disclaimer” Link (last line of bottom quadrant left on every page) to a link in yellow or orange so it is more visible.

http://www.azomite.com

1) Where do we change this in the CSS? Is it possible to do it once in the CSS for all pages, or are we stuck manually changing it on all 133 pages?

Thanks in advance!

Mila

Vasterad

Put somewhere in CSS something like that:

a {color: #xxx;} a:hover {color: #yyy}

Cheers.

milaminute

Thanks for the super speed!

Does this go once on the CSS page? Or css on each individual page?

Will this only change the one line? Or everything on the list?

We only want the one specific line under KEY INFORMATION to change. THANK YOU!

milaminute

*And not only hover – we want the text itself to be color. It is within a specific ul class=”links-list”

Or maybe we could put a red dot or something before it… just not sure how to do this within the template perimeters….

Vasterad

Could you clarify your last 2 comments? I really don’t understand what do you want to change now. :P

milaminute

Hi. Sorry. Just uploaded an image for you :)

http://www.azomite.com/centum.jpg
Vasterad
.links-list li a { color: #222; }
should helps.
milaminute

Thanks but where does this go? I tried it here and nothing happened

a href=”resources/claims.html” .links-list li a { color: #222; }

Vasterad

style.css at the bottom of file ^^

milaminute

OK thanks will look. This will only do the one line? We don’t want all eight line items to change.

Vasterad

Oh, if you want only to make more visible last item then add this:

.links-list li:last-child a { color: #222; }
milaminute

It wouldn’t work for me – so I just added style=”color: #F60”

before the text. Will just do edit/replace on all the files unless you have a magic solution.

Thanks for being there :)

Vasterad

.links-list li:last-child a { color: #F60 !important; }

It works (tested via firebug). Just add “important”. Cheers.

milaminute

Will the above enable me to do it in just one spot for the whole site?

Where did you do this? On style.css? Or on the index page?

I only want the one line of text (not hover) at the end of the list changed.

I only see a .links-list li:first-child a, .links-list-alt li:first-child a { margin: -3px 0 0;

Do I need to add a “last child” line – and how will it know I only want the one last item text color changed?

Vasterad

Just paste that code I gave you at the bottom on style.css and look at effects… :P

milaminute

I did :(

At the very bottom after the mobile code as well as added to the last line of * List ====================================*

and nothing happened :crying:

milaminute

OK!!! I added it with the bold red } to my test and it migrated to the right spot – whoo!

Except, it’s coloring the first line, not the last http://www.azomite.com/centum.jpg

Can you tell what happened? I would like it to color the bottom line of the list…

Thank you!!

milaminute

Disregard!! I lost my mind. I kept at it and it’s working. You are the best! Hoping the test uploads like I want it to! :D !!!!!

Vasterad

Let me know if there is something else I can do for you.

milaminute

Thank you! I figured out how to add the white hover to the last-child without bugging you! Whoo! Whoo! :)

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Two things I was looking for in styles.CSS and can’t seem to locate: 1. a “current” page navigation menu selection class, such as along the lines of:

  • Home
  • and 2. breadcrumbs such as along the lines of Home » About Us

    Was it included in this current style.css version or am I looking in the wrong place?

    Thanks!

    Vasterad

    There’s no “current” class and you need to add it by yourself to css.

    SebastianDangerfield

    Just saw the new update now includes “active page” for the menu nav. Many thanks!

    Vasterad

    Np. :P

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years
    mart2012 Purchased

    Hey Vasterad! I’ve finally got to the stage of actually launching my website, but… images on some pages are overlapped for some reason. Tried all sorts of solutions but hit an absolute dead-end now. Any pointers as to why that is happening? I’ve googled this issue and quite bunch of results are pointing at isotope.js, i.e it loads up before images are finished loading and messes up the page as a result. Any ideas how to fix that? Thanks!

    Vasterad

    Could you provide a screenshot or something? It’s impossible to help without seeing an issue. :P

    Default-user
    mart2012 Purchased

    Hm… Weird, but seems to work after adding the following piece of code to line 317 of custom.js:

    $(window).load(function() {

    Will flush my browser cache to see if it actually helped.

    Btw, thanks a lot for your prompt response!:)

    Vasterad

    Sure thing. :P

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years

    Great template. Worked great. My customer was happy!

    Vasterad

    Thanks. :)

    • Bought between 1 and 9 items
    • Has been a member for 2-3 years
    • United States

    Hello Vasterad. Changing the background color was very easy following your package directions but, I can’t find where I can change the color of text hyperlinks from the default green (#72b626) to blue (#2db2ea)?

    Thanks in advance.

    Vasterad

    in basic.css :)

    Default-user

    Go it, made the changes. thank you.

    Vasterad

    Sure thing. :)

    • Bought between 10 and 49 items
    • Exclusive Author
    • Has been a member for 2-3 years
    • United States

    Hi Vasterad,

    Hoping your summer has been fun!

    Has anyone here – or there – mentioned Twitter changing their API?

    Our tweets have vanished suddenly. I have already been in the twitter support room and it could take forever for an answer.

    I was hoping you have maybe heard of a code change in your travels.

    Thanks in advance so much!

    Mila

    PS – Crap – apparently it has changed. Do you know how this effects your code? If you can post a revision, we would all be eternally grateful. https://dev.twitter.com/blog/api-v1-is-retired

    Not sure how these new display requirements effect us: https://dev.twitter.com/terms/display-requirements
    Vasterad

    Download latest version of Centum. There’s Twitter with API 1.1 but need changes in each HTML file (one line of <script>) and you need to configure auth keys (it’s described in documentation).

    Cheers.

    milaminute

    OK great – thanks. Just bought a new one. Noticed the twitter.php file also. Will do above. Thanks again :)

    milaminute

    Ugh – I hate twitter right now. Do you have a live Centum url I can see to look at the code and figure out what to do? I’m not sure how to “create an app” on twitter. Can I call it anything? Would like to line it up with what someone else may have done as a Centum solution.

    Thanks :)

    Vasterad

    Let me Google it for you: http://www.ning.com/help/?p=4955 :D

    milaminute

    Good Lordy – I tried googling it and could not find anything!

    See? You are magic! :shocked:

    Except it’s not really an app – we just need Oauth settings and access tokens. Do we just pretend to be making an app to get those?

    Vasterad
    Do we just pretend to be making an app to get those

    Yes, you need to make an app to get keys.

    milaminute

    Thanks. Do you have a live Centum url that has been updated that I can look at?

    And do we have to name any of these four items on the app page something specific to align with your twitter.php or css code?

    Your application name, Your application description, Your application’s publicly accessible home page, Callback URL:

    milaminute

    I updated both the above page as well as the twitter.php with all the correct keys and secrets and nothing happened.

    Does it look like I did anything wrong?

    http://azomite.com/index_test.html http://azomite.com/twitter.php
    Vasterad

    But what would you like to see on updated live Centum? Twitter API 1.1 is supported since 6 march (last update) and works as you can see on demo live preview. ;)

    Open twitter.php and you’ll see required fields.

    'oauth_access_token' => 'token-here',
    'oauth_access_token_secret' => 'token-here',
    'consumer_key' => 'token-here',
    'consumer_secret' => 'token-here',
    Then change one line of code in HTML where Twitter is placed on:
    $.getJSON('twitter.php?url='+encodeURIComponent('statuses/user_timeline.json?screen_name=Vasterad&count=1'), function(tweets){
    milaminute

    Thanks.

    I input all the crazy token numbers in the place where it says ‘token-here’.

    Am I supposed to put our twitter account at the top of the .php page where you have: statuses/user_timeline.json?screen_name=MikeRogers0&count=2

    I get a message that says “no URL SET” when I go to twitter.php – do I need to put a url somewhere?

    Twitter’s dev says “We strongly recommend you move to 1.1-era Streaming API paths now.” As though Json may be over at some point. Do you have any ideas how to customize Centum to have a streaming frigging API. I hate twitter right now. :(

    milaminute

    I did all of the above three times. When you got your keys and secrets, did you do something special on the app page? Like with permissions (ours is read-only) or the callback link or something? We’re missing something somewhere…. Thanks.

    milaminute

    So bagged it, and customized a widget. But it doesn’t look nearly as good as your work. http://azomite.com/index_test2.html

    Maybe tomorrow with fresh eyes, we can see what I did wrong. Nite nite. :)

    milaminute

    I got a second set of ‘oauth_access_token’ => ‘numbers-here’, ‘oauth_access_token_secret’ => ‘numbers-here’, ‘consumer_key’ => ‘numbers go-here’, ‘consumer_secret’ => ‘numbers go-here’,

    And tried the $.getJSON(‘twitter.php?url=’+encodeURIComponent(‘statuses/user_timeline.json?screen_name=azomite&count=1’), function(tweets){

    With lower case, cleared cache – and nothing is working.

    http://azomite.com/index_test.html
    Vasterad

    Please run fresh package on your server for test. Currently I cannot reply because I don’t have access to my PC. :P

    milaminute

    Good idea. I will try tomorrow. If it doesn’t work, I’ll email you the two files and see if your magic eyes can see what I did wrong. Happy Thursday. :grin:

    • Bought between 10 and 49 items
    • Has been a member for 5-6 years
    • Spain
    mrgubu Purchased

    I have an issue with non-english characters (spanish in my case). Even if I change the meta Content-Type to ‘charset=ISO-8859-1’ , the template shows extrange characters (the typical rhombus with a ? inside) instead the right ones. How I can solve this issue? Thanks

    Vasterad

    It’s probably because of wrong unicode in your text editor. Try to use Notepad++

    • Bought between 1 and 9 items
    • Has been a member for 2-3 years
    • South Africa
    shabsta Purchased

    Please explain “Please run fresh package on your server for test”

    Also getting complaints about the API

    Vasterad

    It’s because you don’t know how to cofgirue app in Twitter mu deal customers. :) After putting keys in the Twitter.php you should wait a moment. Of course be sure your hosting has PHP.

    Default-user
    shabsta Purchased

    Hi Vasterad,

    Thanks for the update. I have downloaded the latest zip of the theme and uploaded twitter.php, made the changes as per the instructions, and provided all the twitter details.

    Updated code on home page to test and still no joy.

    Are there any other files dependant on this to work which may have also been updated?

    Vasterad

    Hi, sorry for last comment. It was written on smartphone and was a bit undreadable. :) Regarding Twitter, please find this line in twitter.php and set as “false”. Let me know if this helps.

    'use_whitelist' => true // If you want to only allow some requests to use this script. 
    • Bought between 1 and 9 items
    • Has been a member for 1-2 years
    • Poland
    listek29 Purchased

    Hi, i also have problem with new twitter API. I did all of it:

    “Open twitter.php and you’ll see required fields.

    'oauth_access_token' => 'token-here',
    'oauth_access_token_secret' => 'token-here',
    'consumer_key' => 'token-here',
    'consumer_secret' => 'token-here',

    Then change one line of code in HTML where Twitter is placed on:

    $.getJSON('twitter.php?url='+encodeURIComponent('statuses/user_timeline.json?screen_name=Vasterad&count=1'), function(tweets){

    but it still does not work. Please help me…

    Vasterad

    Please read documentation first, you need to authorize your domain in Twitter app…

    Default-user
    listek29 Purchased

    Ok! I read your all documentation… and i did this:

    Step 1: Created an application on https://dev.twitter.com/ Website: http://www.example.com/test Callback URL: http://www.example.com/test/

    Step 2: I generated: Consumer key Consumer secret Access token Access token secret

    Step 3: I opened twitter.php and pasted all (Consumer key, Consumer secret, Access token, Access token secret).

    Step 4: I changed line in HTML code where Twitter is placed on.

    and nothing happened… what else should i do? How can i authorize my domain?

    • Bought between 10 and 49 items
    • Exclusive Author
    • Has been a member for 2-3 years
    • United States

    Hi listek29, we’re in the same boat. Will try again tomorrow and weekend and compare notes. The twitter support rooms are hilarious, everyone is so mad at twitter!

    Here are two discussion links that have been (sort of) helpful. We’re posting as AZOMITE.

    https://dev.twitter.com/discussions/18496 https://dev.twitter.com/discussions/11564

    Worst case scenario (really worst) is to use a modified “dark” widget – that looks sort of okay with Centum, but not nearly as nice as Vasterad’s work.

    http://azomite.com/index_test2.html
    • Bought between 100 and 499 items
    • Has been a member for 1-2 years

    Hi Vasterad,

    congratulation for this greate Theme. But i have now the same problem as milaminute and listek29.

    I´ve registrated the domain, i´ve created the token and my provider supports php. But it´s doesnt work :o(

    What can we do?

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years
    • Poland
    listek29 Purchased

    Hi milaminute, I think we are doing something wrong because everything works fine on live demo preview. I wrote to Vasterad what I do step by step. Maybe give us some advice.

    • Elite Author
    • Sold between 100 000 and 250 000 dollars
    • Has been a member for 2-3 years
    • Envato Studio (Microlancer) Beta Tester
    • Bought between 100 and 499 items
    • Referred between 200 and 499 users
    • Exclusive Author
    • Europe

    I’ll make a clear guide with screenshots this weekend. Maybe that’ll help you to run Twitter widget with 1.1 API. :)

    • Bought between 100 and 499 items
    • Has been a member for 1-2 years

    Hi Vasterad,

    thank you for you help. One last question. It´s possible that the Flickr Picture of the stream in the footer can open in a new windows?

    Best regards Mike

    Vasterad

    Hi, unfortunately not because widget is generated automatically by Flickr and cannot be “controlled”. :P

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years
    • Poland
    listek29 Purchased

    Vasterad thank you for help, i’ll wait for guide.

    Vasterad

    Sure, please give me 2/3 days to provide guide that I promised. I’ll post comment with link here. :)

    Default-user
    listek29 Purchased

    Ok, no problem! :)

    • Bought between 10 and 49 items
    • Exclusive Author
    • Has been a member for 2-3 years
    • United States

    Thanks listek and Vasterad too :). I noticed that the php page has a line that says // We’ll get the URL from $_GET[]. Make sure the url is url encoded, for example encodeURIComponent(‘statuses/user_timeline.json?screen_name=MikeRogers0&count=10&include_rts=false&exclude_replies=true’)

    Are we supposed to add the url anywhere else besides the account name space in the getJSON html footer ‘widget’ area?

    And who is Mike Rogers anyway? (j/k)

    Thanks for your help. Twitter has made this hard for everybody….

    Vasterad

    Instead of “MikeRogers” should be your twitter nickname. Seriously, I don’t get how do you can’t run this widget. :D

    milaminute

    No – just kidding about Mike. I have done everything both you and twitter said.

    • Bought between 10 and 49 items
    • Exclusive Author
    • Has been a member for 2-3 years
    • United States

    listek29 – when you click on the html link that you put on the page (with your account name) do you get an error that says” URL not authorized” also?

    Like this:

    http://www.azomite.com/twitter.php?url=statuses/user_timeline.json?screen_name=AZOMITE&count=1
    Vasterad

    Did you add domain on ”@Anywhere domains” page?

    milaminute

    Yes. And thanks for showing me how…

    Vasterad

    Hey, check your mailbox. Looks like we’ve found solution. :P

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years

    Just to add my comment regarding the Twitter issues.

    Within Twitter.php , I had to change the Whitelist setting to False ; this then resolved the URL not authorized problem. Have I missed something? What else would I need to edit if Whitelist was set to True?

    Vasterad

    Damn, you’re right! Whitelist need to be set as false!

    • Bought between 10 and 49 items
    • Exclusive Author
    • Has been a member for 2-3 years
    • United States

    Wait, wait, what’s up with the whitelist??? Hell’s bells. Will give it a shot tomorrow. I noticed this and thought the “GET” wasn’t Getting.

    So where exactly does “False” need to be input?

    $url = $_GET[‘url’]; if($config[‘use_whitelist’] && !isset($whitelist[$url])){ die(‘URL is not authorised’);

    :ohrly:

    Vasterad

    Check your mailbox.

    'use_whitelist' => false // If you want to only allow some requests to use this script. 

    I’ll update all themes and make clear guide how to run Twitter widget with 1.1 API in the evening. :)

    milaminute, I’ll show you my upcoming release as you’re regular customer and would be nice to hear your feedback. Reply me via email. :P

    milaminute

    WHoo! Found it! http://azomite.com/default1.html

    Thank you and johnnytoxic too!

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years
    • Poland
    listek29 Purchased

    Hi, Whitelist changed and everything started to work! Thanks milaminute, johnnytoxic and Vasterad for our conversation. :)

    Vasterad

    No problem. :P

    by
    by
    by
    by
    by
    by