Discussion on Cleaner Business & Portfolio WordPress Theme

118 comments found

  • Bought between 10 and 49 items
  • Spain
  • Has been a member for 1-2 years

Hi, WPExplorer. Nice work.

I’ve installed Cleaner and it’s fully operative. But I have a few issues, specially with translation. My site have two languages (spanish&catalonian), with his respectives mo&po installed, but in catalonian version the post’s date (months&days) is always in english.

I have a similar case with the title ”% Comments” at the end of a post page. It’s always in english in both translations.

There are some hover link colors that still remaining in original blue, despite I edited the style.css.

Link to my site: http://www.atrau.org/content

Thank’s for your help.

WPExplorer

Hi there,

Thank you for the purchase, sorry you are having these issues and I’ll be sure to get them fixed asap. Could you contact me via my profile page so I can send you some updated files to see if it fixes the issues with the date and the comments? Also could you let me know what plugin you are using for the translations so I can see why it might be conflicting – thanks!

Also please let me know which links are still blue as I didn’t see any.

Thank you for the purchase! We’ll get these issues resolved soon hopefully & thank you for reporting them.

Vakudesign

Thanks for your quick answer. You have an email. ;-)

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Couple of questions for you. How do I add the menu at the top and make it in the order I want. I have typed and edited the pages and added content like on an about page but when about is clicked on there is nothing and I have published it.

Also how do I change the color of the footer? Thanks for all your help.

WPExplorer

Hi there,

  • In WordPress you setup your menus under Appearance->Menu. Here you create your menus, add items, re-order them..etc. If you are not familiar with the WordPress menu system there are lots of guides and videos on the web for this.
  • This is very simple, you just need to add some custom CSS for this. Example:
#footer { background: YOUR CUSTOM HEX COLOR; }
  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Couple of questions for you. How do I add the menu at the top and make it in the order I want. I have typed and edited the pages and added content like on an about page but when about is clicked on there is nothing and I have published it.

Also how do I change the color of the footer? Thanks for all your help.

WPExplorer

*Duplicate question.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

When I update do I just do the saem thing as I did when I installed the theme? And will I have to edit my site when it is updated?

WPExplorer

Easiest is to just replace the updated files via FTP.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

How do I get the about me page to assign to the menu. I have completed my page but when I click it in the menu it says : This is somewhat embarrassing, isn’t it?

It looks like nothing was found at this location. Maybe try a search?

And when on the page and I can choose to assigne that page to a parent there is no about in the menu. Not sure what I am missing.

WPExplorer

I really don’t understand the question…Are you new to the WordPress menu system? All you need to do is go to Appearance->Menu and click to add your page to the menu.

If you are getting a 404 page, that mean the page does not exist….the only reason this would happen is if you haven’t added it to WordPress. If you have, you can try re-saving your permalink settings to see if it helps.

Here is a video guide for using your menu – http://www.youtube.com/watch?v=EXvj-Ujp1tQ

  • Bought between 50 and 99 items
  • Has been a member for 5-6 years
gzupfer Purchased

Hi,

Thanks for the terrific work.

Is there an easy way to allow for Full-Width portfolio posts? In older themes of yours (surplus) there is an option in the Single Portfolio Options:

Layout Style > Select your portfolio post style > Full Width

Any easy way to do this for cleaner and illustrate?

Thanks!

WPExplorer

Hi,

I left these options out because I’ve been trying to keep the themes more bloat-free so they are easier to use, update and maintain.

If you want to simply make all the portfolio posts full-width, this is very easy and I can walk you through it.

I don’t mind making an update to the theme if you think people will find it useful – contact me via my profile page. I just can not give you an ETA because the next few days are super busy for me.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
timdav Purchased

Hello AJ,

First of all, my compliments on this beautiful minimal theme!

I have some trouble changing the buttun titles ‘Learn More’ at services and ‘View All Projects’ at portfolio.

On the previous comment page i read i can change them in content-portfolio.php and content-services.php.

The ‘Learn more’ title i found at ‘content-services.php’, but i could not find the ‘View All Projects’ in the ‘content-portfolio.php’ file.

At line 63 from ‘content-services.php’ i changed this text: title=”<?php _e(‘Learn More’,’wpex’); ?>” into: title=”Lees verder” (which means ‘Read further’ in Dutch). But the button title did not change.

It is obvious i need to change more then just the title only.

Could you tell me what else i need to do to change the ‘Learn More’ title, and maybe tell me on which line i can find the ‘View All Projects’ title?

Tim

WPExplorer

Forgive the delay Tim,

- Thanks for the kind words!

- Are you not using the .po files for translations?

- If you want to edit them manually it is pretty easy. Looks like you already found the text for the services, if you notice the text shows up twice in that same file. The title=”” is for the hover over, but right after is the actual button text.

For the “View All Projects” (on the homepage, right?) this would be located at templates/template-home.php on line 187. Again you need to alter the value in 2 places for the link.

Default-user
timdav Purchased

Nice, thank you.

However, i didn’t had to change the ‘content-services.php’. I just changed both button names in ‘template-home.php’.

:)

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
thakala Purchased

Hello,

Thanks for very nice theme. Is there any way to set the order in which products are displayed on home page? It seems that latest product added is always aligned on the left and so on, but can I override this manually?

Cheers, Tomi

WPExplorer

Hi Tomi,

Yes posts by default in WordPress are ordered by their publish date. It’s pretty easy to re-arrange though – http://www.wpexplorer.org/knowledgebase/changing-post-order-portfolio-services-highlights-staff-etc/

Default-user
thakala Purchased

Excellent, thank you!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

I am having trouble with my portfolio. It appears on the screen and I can update it. But I cant preview any of the portfolio from the main page or in the individual pages. I keep getting a hourglass or waiting icon and I never get to see the page.

Default-user

I get this message, The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

SORRY I AM A BEGINNER.

WPExplorer

That is very strange. Sounds more like a server issue. Can you first try and re-save your permalink settings at Settings->Permalinks?

If that doesn’t work, it could be the server isn’t configured correctly for your domain. You can contact me via my profile page and I can have a quick look.

Default-user

That worked, thank you so much.

Can you recommend a site for beginners so I wont bother you as much?

WPExplorer

Normally if you have an issue and you “Google” it you can find an answer, there is a lot written about WordPress out there.

I also keep an FAQ for this theme here – http://themeforest.net/item/cleaner-business-portfolio-wordpress-theme/4820367/support

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

The images I am posting on my page and as the featured image is blurry. Not sure what I am doing wrong. I have check the imaged on the demo site with firebug so that I can create the graphics that I need but something is not right.

Also how do I insert a photo on to a page description. When I add media it will only add it in a vertical line. I cant place it next to each other in a horizontal line.

WPExplorer

Hum, this is strange. I would really have to take a look at the site though in order to help you out. Can you ping me the URL via my profile page contact form?

If you are not liking the default style (multiple images create a slider) you can place media into the “Post Media Alternative” metabox. This will override the default slider/featured image.

  • Bought between 50 and 99 items
  • Has been a member for 2-3 years
primesg Purchased

Hi, I did a mistake and purchased your theme instead of this one:

http://bigwig.themes.pixelentity.com/

My client wants that template instead, but I got confused and bought yours. Your theme is great, however, I can’t use for this project, as I did the mistake of buying it and it’s not what client expects. If you can understand this and give me a refund I would appreciate.

Thanks, Tiago

WPExplorer

Hi Tiago,

I do understand these mistakes happen, unfortunately I am just a seller on ThemeForest so I have no control over sales/refunds. You would have to submit a ticket for Envato support – http://support.envato.com/

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years

Hi, I have version 1.04 and I can not seem to get the default slider to work. How do I activate it?

WPExplorer

You need to enter the slider shortcode under Apperance->Theme Options -> Home tab

Default-user

There is no Theme Options under Appearance. There is however “Cleaner Settings” on the main menu at the bottom under settings. And it does have a Homepage tab. But It only lists sections 1-4 and Number Of Posts.

WPExplorer

Sounds like maybe you are commenting on the wrong theme…You don’t have the purchases tag next to your name and what you mention doesn’t sound like this theme.

Default-user

The theme title is “Cleaner Business WordPress Theme” by AJ Clarke version 1.04 and it takes me to this page when I click on the authors name, http://www.wpexplorer.com/ It may be an old version because I purchased it as part of a package with other themes. But still I can’t get the slider to activate.

WPExplorer

That might have been a theme that was available almost 2 years ago on another website – possibly Mojo Themes. It was not this theme though. Does it look like this theme?

http://wpexplorer-demos.com/cleaner/

If not, then it isn’t this theme and thus it is not supported here.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

I just downloaded Cleaner and I’m completely lost. Outside of getting my logo and favicon uploaded I’m not sure what to do next. Is there a good online tutorial somewhere?

WPExplorer

Hi,

Thanks for the purchase! Documentation is included with the download (in HTML format) that you can read through and see how it all works. There is also included .xml sample data you can upload to have the site look like the demo I also have a video guide which would probably be the most useful – http://themeforest.net/item/cleaner-business-portfolio-wordpress-theme/4820367/faqs/16372

Default-user

Thanks, that got me a little bit further, but how do I replicate your “services” and “portfolio” pages without having them on my homepage? Also, I found your instructions for creating a “contact” page but don’t get a menu item on my dashboard. Thanks again for your help.

WPExplorer

Have you checked out the FAQ page? It explains how the custom post type archives work – http://themeforest.net/item/cleaner-business-portfolio-wordpress-theme/4820367/support

Default-user

OK, still making progress, I imported all of the sample data which helps, however something something is wrong with all of the portfolio stuff and the actual services page did I somehow not get everything installed?

Default-user

my url is www.carrielindeman.com

WPExplorer

Your services menu link is going to the wrong page, the correct one is here:

http://carrielindeman.com/services/

For your portfolio, it looks like your server did not download all the images and add them to your site. Probably a permissions issue, you’ll want to upload your own images anyway, so it shouldn’t be an issue.

I suggest you have a look at the video guide, the theme should only take 5-10 mins to get it all setup.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
Saccom Purchased

Hi, I have purchased this got it to my site, activated the template but it is nothing like what is in the sales slides. I expected that the pictures everything would come with it and then one by one I could work out how to remove one of the default pictures and put in my own.

Is this not the case, I am assuming I have done something wrong as all I get is the ‘Cleaner Logo’ on the top right of my page.

Any pointers to a simple install of the full Theme I bought would be great, what I mean is this theme would be on my site just like this site I purchased it from, then I start editing words and pictures because I would under stand what I would be editing.

Thanks, Noel.

WPExplorer

Hi Noel,

The reason why we can’t have the theme automatically add content to a site upon uploading is because if someone already has a site setup it can really create issues and add a bunch of stuff they don’t need.

But, don’t worry, sample data is included! If you download the full purchase “all files and docs” then you will find a folder called “SampleData” and an .xml file in there that you can import to WordPress using the WordPress importer. Please check out the FAQ – http://themeforest.net/item/cleaner-business-portfolio-wordpress-theme/4820367/faqs/16370

  • Bought between 50 and 99 items
  • Has been a member for 5-6 years
gzupfer Purchased

Hi Alex,

When using the flex slider for portfolio items, I noticed the alt tags for all the images are set to the portfolio posts title. Example: if I created a new portfolio item with the title “Blue Dog” all of the images attached to this post show alt=”Blue Dog” even if image alt tag from the media library is different.

How can I change this so the image alt will display the alt tags set in the media library for the image? Also, is there a way to display the captions for the images for the flex slider?

Thanks.

Default-user
gzupfer Purchased

Ok, I found it in content-portfolio.php

line 61 alt=”<?php echo the_title(); ?>” />

how do I modify this to get the default alt tag for the image?

and… to add a caption?

thanks

WPExplorer

Thanks for letting me know of the issue, I’ll fix it up. Showing the alt tag is very simple. Would look like this:

<?php echo get_post_field('post_excerpt', $wpex_portfolio_img->ID); ?>

If you notice the title tag on the link is correct.

To add captions just echo the same thing below the image, Then style it however you want via CSS.

Default-user
gzupfer Purchased

I did that and it doesn’t seem to work. Here is what I tried:

<?php foreach ( $wpex_portfolio_imgs as $wpex_portfolio_img ) : ?>

  • <?php echo get_post_field('post_excerpt', $wpex_portfolio_img->ID); ?>
  • <?php endforeach; wp_reset_postdata(); ?>
    • Bought between 50 and 99 items
    • Has been a member for 5-6 years
    gzupfer Purchased
    <?php foreach ( $wpex_portfolio_imgs as $wpex_portfolio_img ) : ?> <li class="slide"> <a href="<?php echo wp_get_attachment_url( $wpex_portfolio_img->ID ); ?>" title="<?php echo get_post_field('post_excerpt', $wpex_portfolio_img->ID); ?>" class="view" rel="group"><img src="<?php echo aq_resize( wp_get_attachment_url( $wpex_portfolio_img->ID ), wpex_img( 'portfolio_post_width' ), wpex_img( 'portfolio_post_height' ), wpex_img( 'portfolio_post_crop' ) ); ?>" alt="<?php echo get_post_field('post_excerpt', $wpex_portfolio_img->ID); ?>" /></a> </li> <?php endforeach; wp_reset_postdata(); ?>
    WPExplorer

    The function:

    get_post_field('post_excerpt', $ID ); 
    

    Gets the image “caption. If you want the actual ALT attribute for the image maybe try the following function instead:

    get_post_meta($wpex_portfolio_img->ID, '_wp_attachment_image_alt', true);
    
    Default-user
    gzupfer Purchased

    Yes! Thank you!!

    • Bought between 1 and 9 items
    • Has been a member for 2-3 years
    mdh777 Purchased

    Hello AJ, I just purchase the theme and am really excited to use it!

    I really want to start with all the sample data but after following your instructional video I get a big list of all sample items FAILED! – Please help.

    I have some WP experience but am still a novice on many areas.

    Thanks a ton!

    WPExplorer

    Great ;)

    - Did you activate the theme before uploading the sample data? - If the items that “failed” are images, this is most likely due to your server permissions.

    it’s a bit hard to help without knowing what are the items failing.

    http://themeforest.net/item/cleaner-business-portfolio-wordpress-theme/4820367/faqs/16370
    mdh777
    mdh777 Purchased

    Theme is active and working but mostly void of content. I did start adding things as I originally didn’t intend on using the sample data. but having the sample data and replacing them as I build would be a huge time saver.

    I don’t see any server permission limitations with my host (bluehost). Could I email you the failed import log? Or is there a way to reset the theme to original install?

    WPExplorer

    You can contact me via my profile page if you want me to look at the error log.

    To reset the theme just bulk delete your pages/posts and media.

    I personally find the sample data just more time consuming, I think adding content fresh is much quicker. Is there anything in particular you are finding hard to understand?

    mdh777
    mdh777 Purchased

    I guess you’re right. I’m getting most of it figured out.

    1. One small but annoying thing is near the bottom of some pages it says “0 Comments” even though I’ve disabled comments in every way.

    2. Also, how do I change the bg color for the header, body and footer?

    Thanks for your help!

    WPExplorer

    1. Oh ya, that is annoying. It’s an easy fix though ;) Contact me via my profile page and I’ll send you the updated file. Thanks for letting me know about this!

    2. These would be simple CSS customizations. You can do it either by editing your style.css file manually or preferably using a 3rd party custom CSS plugin to add your edits or a child theme.

    • Bought between 1 and 9 items
    • Has been a member for 1-2 years

    Hi -

    Does this theme support WPML?

    Thanks

    WPExplorer

    I haven’t personally tested it with the plugin but it has been coded correctly and .po/.mo files are included so I see no problems as well as a few people I know that purchased the theme are currently using WPML.

    A lot of themes have issues with WPML because they use get_posts() and do not disable the filters. I personally use WP_Query to create my custom queries which is much better.

    If you do find any issues with WPML just let me know and I’ll get them fixed up!

    • Bought between 1 and 9 items
    • Has been a member for 0-1 years

    I was working on my portfolio and did not make any major changes just editing photos, and when I went to view it there is no longer a menu at the top of the page. The menu bar that I created is completely gone for some reason. I checked the menu in the dashboard and it is still all there but is no longer showing on the home page. I logged out and logged back in and still the same thing. What has just happened?

    WPExplorer

    That is very strange.

    Can you double check your menu areas (Manage Locations tab in WP 3.6) to make sure that its still in use?

    Default-user

    Yes that has been done and the menu is still correct and can be seen behind the scene. It is just not showing on the site. I sent you a private message also. I also tried deleting one of the links and adding it back to see if it would pop up and still nothing.

    Default-user

    I also added a few plugin this week and had them for a few days before this happened so it should not be them. I added a Hot File plugin for a password protected download and a Jquery Updater.

    WPExplorer

    That is very strange. I’ll have a look at the email you sent me as soon as I get to it, thank you for the patience.

    Default-user

    Thanks, I really appreciate it! I have spoken with several people and it is strange to them also. I know its not the plugins because I removed them and nothing changed.

    WPExplorer

    Please make sure WP_Debug is enabled – http://codex.wordpress.org/WP_DEBUG

    Going through emails right now, hopefully your’s isn’t buried too much.

    • Bought between 50 and 99 items
    • Has been a member for 5-6 years
    • United Arab Emirates
    ekanse Purchased

    Hello,

    I just bought the theme and I must say its great. I am having trouble listing my portfolio on the home page. It doesn’t seem to work at all :( I can’t see it. I have followed your instruction in the video:

    http://www.youtube.com/watch?feature=player_detailpage&v=DTiHR3fRryU

    Could you please help me!

    Thank you, Waqas

    Default-user
    ekanse Purchased

    Sorry forgot to mention. I don’t even see menu :( Here is the link to the site: http://marinamunck.redmountmedia.com/

    WPExplorer

    1. I think the issue with the portfolio items is that when you imported the sample data it appears you didn’t check to import any images. So there is no featured images to show.

    2. You need to set you menu locations under Appearance->Menu

    by
    by
    by
    by
    by
    by