Discussion on Cleaner Business & Portfolio WordPress Theme

118 comments found

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi there,

I purchased this theme and am almost finished completing a client’s website – it looks great! My only concern/question for you is that I have added another “Service” (Asset Management) however it is not showing up on the main services page. Also, when I try to preview this new service after I published it, I am getting a 404 error. Any idea why this is happening?

site: http://critohospitality.com

Thanks!

WPExplorer

Hi there,

Services do seem to be working just fine on your site. Are you sure the post is published and not just drafted? Maybe there is a conflicting slug…what happens if you change the slug/permalink for that service?

Default-user

I tried a few things and still no luck. I added a new service called “test” and here’s what shows up: http://critohospitality.com/services/test/ as well as it doesn’t show up on the main services page. Not sure what’s going on!

WPExplorer

have you tried re-saving your permalinks at Settings->Reading?

It’s really impossible for me to know what could be wrong unless you can share your login credentials with me to look.

Default-user

I’m happy to provide you the credentials to take a look, I have tried everything thus far. Can I message you privately?

WPExplorer

Yes, message me via my profile page contact form: http://themeforest.net/user/WPExplorer

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

In there a way to get rid of the “learn more” link and not make the image a hyperlink on the services page? I really don’t need an extra page of description.

Also, can I hide the comment count on pages?

WPExplorer

There was a bug prior if you disabled the comments it still showed the count. But it should be fixed now. If you still have a bug, please contact me via my profile page so I can check it out and give you a fix if necessary.

Removing the hyperlinks would require you to edit content-services.php. Check out line 60, simply remove the link here. If you want I can send you the updated file via email. Just message me via my profile page.

-AJ

  • Bought between 10 and 49 items
  • Has been a member for 0-1 years

Hiya, Am enjoying using the Cleaner theme – thanks very much! I’ve added my Google Analytics tracking code in the theme options box, but nothing seems to be happening – I have no data and GA tells me it’s not installed. What can I do? Thanks, Beth

WPExplorer

That’s great Beth!

There might be a bug in the theme. Do you think you can contact me via my profile page and share the URL and logins so I can have a look?

If not, I can do some extra testing locally, but its quicker if I can just log into your site and have a look.

Sorry for any troubles, AJ

Default-user

Just as your reply came in I realised I was making the most ridiculous mistake – I was working on a few sites at once and was pasting the code to the wrong site!! I’m so sorry, just ignore my earlier message, and thanks for getting back to me so quickly! B

WPExplorer

Haha, no worries, I understand ;)

  • Bought between 100 and 499 items
  • Has been a member for 3-4 years

Ok, I am missing something here… I can disable comments on the pages but it still shows the “0 Comments” on the page. Where do I go to turn that feature off? I don’t want nor need it to show that there aren’t any comments.

Is there a button I am not clicking on or a coding issue?

WPExplorer

Sorry there is a small typo on my part. I am uploading the updated theme now. If you want to contact me via my profile page I can send you the updated comments.php with the fix via email.

Sorry for the troubles, AJ

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
Tytia Purchased

I know it’s probably right in front of me, but how do I disable Comments on Pages? Also on the Contact page there is a 0 comments at the bottom. How do I get rid of that??

Default-user
Tytia Purchased

I got a plugin to disable comments, but the “0 comments” is still showing up at the bottom of the page.

WPExplorer

There was a small typo on my part, which I fixed a couple days ago actually:

http://www.wpexplorer.org/changelogs/cleaner/

You can download and update the whole theme or if your main concern is with the comments, simply re-download the theme and replace the comments.php file via FTP.

Sorry for the troubles! AJ

Default-user
Tytia Purchased

Okay, I re-downloaded the theme and replaced the comments.php file via FTP but I still see the 0 comments at the bottom. Is there something else I failed to do? Something I need to update in WP or should it automatically be fixed as soon as that file is replaced?

WPExplorer

Strange..Do you want to PM me via my profile page and I can send you the file via email so you can test?

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
Tytia Purchased

One more question. Is there a way to NOT have double spacing on Pages if I hit return?

WPExplorer

Hum,

That is just how WordPress works. If you want to not have a double space what you do is hit shift+enter while in the editor.

Default-user
Tytia Purchased

Thank you!

  • Bought between 10 and 49 items
  • Has been a member for 0-1 years

Hi AJ, My ‘cleaner’ site isn’t working correctly on an iPad, on two counts:

1. The home page content isn’t appearing – the slider is there but beneath this I have content – a large heading, then more content divided into 3 Symple columns – these are not showing up at all, there is just a big white space on my client’s iPad!

2. I wanted to bring blog posts in like highlights but this was not in the theme options, so I’ve put a plugin widget in the site footer… unfortunately this now seems to spill over the page container, forcing everything on the page over to the left, with just the blog widget poking over to the right at the bottom. Are you able to offer any advice on this?

I would actually prefer to put in an element on the home page which pulls in the three latest blog posts, just like the ‘services’ and ‘portfolio’ home page sections. This may be a long shot, but is there a bit of code from one of your other themes which can be used to do this? When I originally purchased this theme, I thought for some reason that as well as ‘services’ and ‘portfolio items’ there was also a ‘blog’ element for the home page.

Thanks! Beth

Default-user

I should add, the website is currently under construction and has a holding page, so if you need a login I’ll need to know how to contact you privately to give you one. Cheers! B

WPExplorer

Hi Beth,

It would be a lot of help if I could check out the URL. Do you think you can send that to me via my profile page? Please link back to this comment so I know what the initial questions where. Thanks!

-AJ

Default-user

Thanks AJ, I’ll create a temporary login for you and send you the details via your profile page :) Beth

WPExplorer

Cool. There is a lot of tickets at the moment and will get to you as soon as possible. Thanks for your patience.

  • Bought between 100 and 499 items
  • Has been a member for 4-5 years

This theme is awesome.. I am having one issue however with the responsive display of the menu and footer elements. The footer shows as 3 columns on responsive devices and they overrun each other and my menu isn’t showing up at all on responsive displays.. Can you help? Thanks,

WPExplorer

Glad you like it!

I’m not seeing the problems with my live demo. Do you have the same issues? http://wpexplorer-demos.com/cleaner/

If you can show me the URL – best to PM me via my profile page – I can take a look for you!

AJ

Default-user

Thank you for your prompt reply and I greatly appreciate it! I shot you an email with the URL!.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
Tytia Purchased

How do I make a parent page un-linkable? Basically I just want it to be a header for the links below. Is this possible? Is there a plug-in that can do this if it’s not possible within Wordpress itself?

WPExplorer

You would create a custom link and use a # symbol for the URL.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
Tytia Purchased

Thanks for all your help, but I have a few more questions.

Can I change the font size for the menu? Can I change the font size on pages? Can I change the hover color on the menu? And I’m totally pushing it here, but can I somehow add a small image on the bottom footer by the copyright text? Trying to figure out where to put a BBB Accredited business badge.

I’m doing this site for a friend and all these changes are by their request. I quite like it just the way it is!!

Any help is greatly appreciated.

WPExplorer

All the font changes and hovers are just basic CSS edits you can make in your style.css file or via a child theme or custom css plugin. If you don’t know how to code I would recommend microlancer – http://www.microlancer.com/explore/wordpress-customization

You could add an image in the footer widgets via a textwidget using HTML or you can edit footer.php directly to add it. I’m not quire sure where you would put it so it looks good, you might have to tweak the design a bit to make it work.

  • Bought between 50 and 99 items
  • Has been a member for 5-6 years
gzupfer Purchased

Hi Alex,

Anyway to change the max height and/or make changes to the nature of the image sizes for the default slider for portfolio item pages (single-portfolio)?

Example: http://modernprefabs.com/prefab-homes/bright-built-home/great-diamond/

If you click through a few images, the renderings are very tall compared to the first image—how could I limit the height?

Thanks.

WPExplorer

By default the images on the single portfolio resize to fit the element but they don’t crop, so that you don’t lose content.

You can easily change the cropping though by editing functions/image-default-sizes.php lines 57-59:

//portfolio post
if( $args == 'portfolio_post_width' ) return '700';
if( $args == 'portfolio_post_height' ) return 9999;
if( $args == 'portfolio_post_crop' ) return false;

Change the 9999 height value to the height you want and then change the “false” to “true” so that it hard crops them.

Default-user
gzupfer Purchased

Thanks Alex—

I can’t say enough about the great product and service you provide. I have purchased > 40 themes over the years and your product + service are #1. Thanks.

WPExplorer

Thanks for the kind words ;) I hope you’ll consider my themes again in the future!

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
jono713 Purchased

Hi WP Explorer,

How can I make the Fonts on the homepage the same as the rest of the site, standard text is larger than the rest when using the Page Type = Home.

Thanks in Advance

Jonathan

Default-user
jono713 Purchased

Ok I think I worked it out do I remove {padding: 0 0 30px; font-size: 18px; color: #81888d;} from .home-content in the CSS file so it looks like this: /*tagline*/ .home-content,

Will that cause errors?

Default-user
jono713 Purchased

Ok I tried what I initially thought would fix it, but no luck the above is incorrect as everything now looks like a H3 is that because I added a , after .home-content

And will below fix my issue?

.home-content { }
WPExplorer

Hi Jonathan,

I’m not quite sure what the issue you have is…Are you trying to just make the tagline font smaller? By default the tagline is much larger because it’s intended to be just a couple lines as shown in the demo: http://wpexplorer-demos.com/cleaner/

I can help you with the CSS to override that, if you can confirm that’s what you need to do.

Default-user
jono713 Purchased

I think I have sorted it thanks :)

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
Tytia Purchased

What should I size the layerslider images too? The tops and bottoms of my images are getting cut off, so I’m doing something wrong.

And thank you for all your help. You’re very kind for answering all my newbie questions.

WPExplorer

Hi Tytia,

It depends on your slider dimensions. In the general settings for your slider you choose the specific height for your slider, so you’ll want your images to match that setting.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
jnorion Purchased

Hi! I have a couple of questions I haven’t yet been able to figure out, and hoping for some help.

1) On the page editing screen, there’s a box to paste a LayerSlider shortcode. This works perfectly as long as I’m using the default page template, but if I enable the Full page template the slider no longer appears. I can paste the shortcode in the page body, but then it doesn’t extend to the full width of the screen. Am I missing something in the settings for this?

2) Is there a way to have a text description/caption on Lightbox portfolio entries? The title appears at the bottom of the screen, and the image appears in the center, but none of the text shows up from the main content, the excerpt, or the alternate content.

Thanks!

WPExplorer

1. This is an error on my part. You can PM me and I’ll email you the updated template or you can edit it yourself. Open templates/template-fullwidth.php and on line 18 after the header add the following:

<?php wpex_page_slider(); // see functions/commons ?>

Thanks for reporting the bug!

2. Having the excerpt in the lightbox would be a bit complicated. This is a super lightweight lightbox script so it gets the tittle attribute of the link. The script itself would have to be altered to pull content from elsewhere – js/view.js

Default-user
jnorion Purchased

Awesome, thanks! I added the line myself… safe to assume that you’ll be adding that on your end so future updates won’t break the changes I made?

I’ll take a stab at that script. In theory it shouldn’t be complicated to pull from the image description or post content or something. Do you happen to have the non-minified version in a form that you could send me?

WPExplorer

Yes its already added for the next update ;)

No it shouldn’t be to hard to edit the function if you know your way around JS, its a very minimal script. I don’t have it, but you could use this: http://jsbeautifier.org/

Default-user
jnorion Purchased

Oh nice, I had no idea that utility existed. Worked perfectly! I’ll let you know if I come up with a solution on that.

Thanks again!

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years

This theme has been great to work with however my client has reported the home slider doesn’t load properly in IE.

It gets half way through the image and fills the rest in with black? The website is http://fortressfinancialsolutions.com.au/ It works fine in other browsers. Is this a common issue? could it have something to do with the speed of the slider or something?

Any help would be appreciated.

Thanks

WPExplorer

Hi,

By any chance do you know which version of IE so I can test?

You have done some really cool things with this theme, nice job!

Default-user

Thanks – he is using IE10 version 10.0.9200.16688.

WPExplorer

I’m having trouble recreating the error, looks fine to me:

http://cl.ly/image/1I35343b242a

Have you tested it?
  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
jono713 Purchased

The Blog page of this website was found to be using the tag . It is widely regarded that use of presentational elements like should be avoided.

How can I solve this? I get a warning from w3c as its the little logos on the blog page folder, author etc.

WPExplorer

I’m not sure you pasted the whole message. What “tag” is it referencing.

The “little logos” are font icons, which is actually a lot better method then adding images to the site. It’s the more “modern” and better way of adding icons to your site.

Do you have a screenshot of the error? I’ll be glad to help.

Default-user
jono713 Purchased
<i> </i> is the tag it mentions! apparently it’s on the blog page 13 times.
WPExplorer

Yes the i tag is perfectly fine to use.

In old versions of HTML the i tag was italic, but now (in HTML5) for text in an “alternate voice”, such as transliterated foreign words, technical terms, and typographically. Hence the usage for icons.

I don’t understand where you are getting the notion that it shouldn’t be used. Is it W3C telling you not to use it?

Default-user
jono713 Purchased

All pages were found to be W3C compliant.

This is excellent and means that this website can be read by the widest possible range of applications.

This website was detected as being HTML5.

One page of this website was found to be using the tag <i />. It is widely regarded that use of presentational elements like <i> </i>should be avoided.

Replace all the instances of presentational tags with a semantic alternative.

This means where possible, use semantically correct HTML and then style it with CSS

Does that provide further information? We use the Pro W3C report.

Thanks

Jonathan

WPExplorer

Hi Jonathan,

My guess is that their plugin is outdated. Because as I mentioned the tag was not recommend in HTML4 and under (better to use CSS for that back in the day). But with HTML5 it doesn’t matter. Unless it gives you problems, it isn’t anything to worry about.

Default-user
jono713 Purchased

Thanks for your help :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
jono713 Purchased

Is it possible to make the anchor text of the Read More links on the blog page the post title instead of just read more? i’m trying to make it as search engine friendly as possible.

WPExplorer

Yes you can. However in terms of SEO the best would be to actually remove the link, because the title itself already has a link on it.

The following CSS would hide it.
.blog-entry-content .readmore { display: none; }

To actually change what it says you would have to edit content.php and content-video.php. Use the_title() function to replace the text – http://codex.wordpress.org/Function_Reference/the_title

Default-user
jono713 Purchased

nice one dude! 5* theme & support

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years

Hi – I have used this theme for a client and it looks great, only problem is that on IE the home slider is only half loading and then filling in the rest with black? It also doesn’t stretch the featured images to full width?

This is the site – http://fortressfinancialsolutions.com.au/

any help would be greatly appreciated.

Thanks

WPExplorer

On what version of IE? So I can have a look.

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Hi. Firstly I want to say this is a brilliant theme! I’m having a couple of problems however.

The content (heading) on the main page isn’t showing up on the iphone (chrome reader). There’s only whitespace. If I copy it however, I can see that the text is actually there but it appears white. Is there any way to fix that?

I’m also having trouble removing the 0 comments on the pages. I’m sure it’s a simple thing, but I can’t seem to find it.

WPExplorer

Gad you like it, thanks for the purchase!

1. The “content” are you referring to what I have on the demo as “Say hello to the Cleaner WordPress theme….etc”. If so, if you have a lot of content in there and not just a couple lines, I suggest maybe try going into the theme panel and in the homepage tab disable the animation for this region.

2. There was a small bug with the comments heading a while back, Its hard to know if you have the bug or you simply haven’t disabled comments for the post. Can you verify that comments are in fact disabled? If they are, PM me via my profile page and I’ll send you the fix via email.

-AJ

Default-user

1) that fixed it 2) i’m an idiot :)

Thanks alot!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

I’m having a couple of issues that I wanted to see if you had a solution for.

1) On an iPad my home page copy doesn’t show up 2) In Firefox the slider on the home page stalls out.

my site is carrielindeman.com

Thanks!

WPExplorer

1. Can you try disabling the animation on the homepage tagline via the theme options? You have quite a bit of content that might be causing the problem.

2. I’m not seeing any issue in Firefox. What do you mean by “stalls out”? Have you tried clearing your browser cache?

by
by
by
by
by
by