Discussion on Crafty - Responsive Retina-ready WordPress Theme

46 comments found

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
sondzin Purchased

Hello,

I just purchased your the Crafty theme. When I install the theme it states that the theme installed correctly. When I try to activate it, I get a white screen. Nothing! If I go to the site, it’s just a white page! If I install the theme by uploading the crafty folder, I then can go to the themes page and when I click activate, I get a server error.

Yes, I have extracted the crafty.zip file for uploading when I try to install from the themes page in Wordpress. I am not trying to upload the entire theme files and documentation zip file.

Any ideas??

Thanks, David dw@whitmyre.com
66Themes

Hi David,

Thank you for your purchase! Please have a look at this comment, you might be running on an old version of PHP. Try updating PHP on your server.

Kind regards, 66Themes

Default-user
sondzin Purchased

That sounds like the problem. What version of PHP does it need to be?

Thanks, David

Default-user
sondzin Purchased

I was able to get the theme to load without any problem. Thanks!

66Themes

You’re welcome!

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
sondzin Purchased

I have the Crafty theme loaded and I am putting content into the theme.

1. My logo is appearing very small. I have tried several different size logos and they always look very small.

2. Also, I cannot get the slideshow to work. It just shows the rotating circle. I am choosing the Nevo Slider and have specified several slides using images in the Media Library and adding text for each one.

3. It is not loading the tweets. Just says Loading latest tweets.

My domain is brightdart.com

Please let me know what to do.

Thanks, David

66Themes

Hi there,

thanks for purchasing my theme!

1. To keep logo’s within proportion, a maximum height has been applied. You can increase this by pasting the following CSS in the Custom CSS option box in Theme Options:
header .leftArea .logo {
   max-height: 60px;
}
You can increase/decrease the value as required.

2. When editing the homepage, click the ‘Show Content Designer’ button and then open the General Page Properties tab. There, you can select the slider you wish to use.

3. I’ve noticed a small error in the path to the PHP file which loads the tweets. Please follow these steps to fix it:

Open footer.php and inside this file replace:
modpath: '/wordpress/wp-content/themes/crafty/functions/tweet/',
With:
modpath: '<?php echo get_template_directory_uri() ?>/functions/tweet/',

Now open functions/widgets/widgets-twitter. php and do the same.

Hope this helps!

Kind regards, 66Themes

Default-user
sondzin Purchased

Thank you very much for the information. It was most helpful. Some things worked and some did not.

The sizing for the logo worked great. Setting up the slideshow in the Content Designer worked.

However, changing the modpath for the twitter widget did a couple things. First, it broke the slider again. Slider went back to rotating circle. When I put the modpath line back to the previous state, slider worked again. I was very careful with the replacement of the line in the footer.php (and widgets-twitter.php). I have made lots of edits to the files in editor in previous sites.

When I did change the modpath, it took away the “loading latest tweets”, but put a dot in front of Latest Tweets in the footer. I also placed the Google Maps widget in the footer. The Find Us was below Latest Tweets with the new modpath line, but now is to the left where I expected to see it with the original modpath. I hope this all makes sense.

Also, in the content designer, when creating a text block or a feature box, can I specify a link if clicked or can I code a link into the text? Will a text block take html?
66Themes

Glad it helped!

For the Twitter modpath: strange it didn’t work.. try removing just /wordpress from the path, see if that works.

A text block supports the full tinymce editor which supports inline URLs. The Feature Box only supports plain text however.

Cheers!

Default-user
sondzin Purchased

Removing /wordpress from the path did not help. It breaks the slider and puts the dots next to Latest Tweets and Find Us as well as putting Find Us below Latest Tweets.

66Themes

I think the path is correct but something else might be going wrong.. Just to be sure, did you setup your Twitter App and entered the data in index.php as outlined in the documentation?

Default-user
sondzin Purchased

Hello, yes I followed the instructions to create the twitter app. It is still saying Loading latest tweets. The information does work, however, you can see that I am using the WooDojo Tweets widget with the same information. I would much rather use yours. I like the bar that goes across with the tweets. Where else might I have something wrong where I am calling out twitter info in the theme?

Default-user
sondzin Purchased

Regarding the above comment, you can go to my site and see this: www.brightdart.com

66Themes
Could you put back the path I suggested?
modpath: '<?php echo get_template_directory_uri() ?>/functions/tweet/',
I would like to take a look at the site with the correct path in place and see what the error is. Also, since you increased the height of the logo, the caption in the slider is out of place, to fix it paste the following CSS in the Custom CSS option box:
.backgroundSlider .slideCaption {
   bottom: 70px;
}

Kind regards, 66Themes

Default-user
sondzin Purchased

I put the path back in and it didn’t break anything. But the tweets still aren’t loading.

Regarding the slider caption box. Hadn’t noticed, but I actually like it floating. Now I know how to have it either way. Thanks.

66Themes

The path is definitely correct, but it’s now throwing a 500 Internal Server Error. No idea why, could possibly be a syntax error in the index.php file. Is it possible you could send me an e-mail with login details for your site, so I can have a look at the file myself? You can use the contact form on my profile page.

Thanks!

Default-user
sondzin Purchased

No probelm. Just sent you login details.

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
sondzin Purchased

Usig the Crafty theme, when I add a Contact Form into a container in Content Editor, the only option there is to edit is Extra Class. Should there be more? How do I build a contact form? Or is that done somewhere else?

Thanks, David

66Themes

Hi there,

no the contact form is provided as just a basic contact form, suitable for most common, simple messaging.

This is because there are many, many great plugins available for form handling. I, like many authors, strongly recommend using the Contact Form 7 plugin for creating powerful & dynamic forms. Rebuilding this kind of functionality would just be reinventing the wheel!

Kind regards, 66Themes

Default-user
sondzin Purchased

I completely understand and agree. I did see the form that was there, but will do probably use Contact Form 7 or another I’m familiar with.

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
sondzin Purchased

I tried to use the Menu Badges feature. I checked Description on the Screen Options, then added short desriptions on each menu item in the menu. I assume you put the description in the Description box of the actual menu item. Did that, but nothing in either IE or FF.

66Themes

That’s indeed how it works. Just tested it and it should work fine. Keep in mind the badges only work inside the dropdown menus, but I don’t see any on your site yet.

Default-user
sondzin Purchased

Ah. Okay. Didn’t realize that. As the site fills out, I’ll have some submenus. Thanks!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi,

Cool Theme…thanks for building. I’m having a problem loading it to WP though. I get a white page when I load Crafty, and when remove functions.php it works, but I’m still not able to make any changes in admin, and everything goes to a white page again. Btw, I’m using php 5.3.8. Any suggestions that would help me get your theme to work?

Thanks! DM

66Themes

Hi there,

please check your e-mail, I’ve send you a reply.

Kind regards, 66Themes

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there,

Just a quick question with the theme, i want to be able to modify the form on the contact us page in terms of size but i cant seem to figure out how to do it!

Thank you

66Themes

Hi,

please take a look at this comment as someone asked a similar question.

Let me know if you require any more assistance!

Kind regards, 66Themes

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there, just a quick question..in the theme where the portfolio items are that slider tends to move up or down for example: on my 15” display laptop that slider looks fine but on my 22” apple display the slider moves up onto the main slider.

I need a fix for that asap!

Thank you

66Themes

See below

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there, just a quick question..in the theme where the portfolio items are that slider tends to move up or down for example: on my 15” display laptop that slider looks fine but on my 22” apple display the slider moves up onto the main slider.

I need a fix for that asap!

Thank you

66Themes

Hi,

That’s strange.. Is it possible you could create a screenshot of the issue and post it here? Thanks!

Cheers!

Default-user
Magix_ Purchased

Hi there,

Ive shown you two images. One if from the 22” display and the other is from a 15” display. The macbook interface one is the 15” and the windows based one is the 22” one.

if you follow this link you’ll find the screenshots:

22” – http://imgur.com/ienXrWC

15” – http://imgur.com/8qXnEai

Thanks.

66Themes

Thank you for the images. Unfortunately, I can’t tell what the problem is by just looking at the screenshots, is there a live site I can have a look at?

Kind regards, 66Themes

Default-user
Magix_ Purchased

No the website is currently under maintenance, i can send you me wordpress details through a private message or so, so you can go and have a look?

66Themes

That would help greatly! You can send me a message using the contact form on my profile page.

Cheers!

  • Bought between 10 and 49 items
  • Exclusive Author
  • Germany
  • Has been a member for 5-6 years
elvis24 Purchased

I like to have a Text logo like “ C rafty” in the preview. But if I leave the Custom Logo Image empty, there is only the slogan. Can you help?

Default-user
elvis24 Purchased

I tried to use C rafty But it doen’t work. Also I like to have the same on the Footer like in in preview. But with this code and the Font Source Code Pro for Headings, it looks different.

Default-user
elvis24 Purchased

The headings doesnt change cause of an error. The core generates this: “font-family: Zeyada);” it must be “font-family: ‘Zeyada’;” and it will work. I changed it with the option own css code, but can you please change it for the next update? So I finaly need the solution for the logo text now.

66Themes

Hi there,

thank you for your purchase! The text logo as used in the preview is just put in there for the demo site only. Like with any theme to use your own logo you can upload an image.

Of course, if you want the text logo as in the demo just send me an e-mail using the contact form on my profile page and I’ll send you the required code!

Thanks for the heads up about the heading font! An update has been issued and is pending review.

Kind regards, 66Themes

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there,

Just wondering on the template,

when on the portfolios page there is that small grid to navigate around.. how can i change the link to that page?

it looks like this:

http://i.imgur.com/VEgw4tL.png

Thanks.

66Themes

Hi,

you mean change the URL of the button? You can do that in the following file: single-portfolio.php. On line 42 you’ll find this code:
echo '<a href="' . $homeLink . '/' . $slug['slug'] . '/" class="overview" data-icon="?"></a>';

You can replace ’ . $homeLink . ’/’ . $slug[‘slug’] . ’/ with your own URL for example http://google.com

Kind regards, 66Themes

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

I’ve just bought the WordPress version of Crafty to go with the HTML version I already have – and love!

I can’t figure out how to get a sidebar to show on Posts. I’ve added widgets to the default sidebar in Appearance but nothing shows. Also I want the sidebar to be on the left. Is there a simple tick box option or is it more difficult. I don’t know how to create a custom sidebar.

66Themes

Hi there,

thank you for your purchase, glad you like it!

When creating a new Post, go to the Content Designer and open the General Page Properties tab. Here you can set the page layout: left sidebar, right sidebar or full-width. And you can select a sidebar to use in the option below.

To create new sidebars, go to Appearance -> Theme Options and create them in the Custom Sidebars option.

Kind regards, 66Themes

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there, On the template i have adjusted it not to have a search box, the only issue is, is that on a mobile device, the search comes up and i dont really know how to get rid of it, please help. Thanks.

Default-user
Magix_ Purchased

never mind, i got it.

66Themes

Great, let me know if anything else comes up!

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
fhuard Purchased

Hello,

As for the loading loop, it looks that if I put the [layerslider id=”8”] into the page it works directly but on the home page it doesn’t appear.

http://www.tufoilcanada.ca

Cheers, Franco

66Themes

Hi Franco,

to get the LayerSlider to appear on the homepage, go to Appearance -> Theme Options, click the Sliders tab and select the LayerSlider. Right below you’ll find a field to enter the shortcode for your slider.

Now go to edit your homepage and open the Content Designer, click the General Page Properties tab and select the slider you wish to use! Which in your case is the LayerSlider.

Kind regards, 66Themes

Default-user
fhuard Purchased

In the theme option, I have selected the Layerslider.. and in the general page properties, I only see Page Description, Custom Page Title, Page Layout and Page Sidebar. I don’t see any place where I can select to see the slider or not.

So my main page have a loading cercle and nothing appear.

66Themes

Did you select Homepage as the template?

Default-user
fhuard Purchased

No I have created my own homepage page

66Themes

Well make sure you select the Homepage template. You can do this when editing a page by selecting the ‘Template’ menu under ‘Page Attributes’ in the sidebar.

Options for selecting the slider will then appear.

Cheers!

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there,

Just wondering.. when i enable the twitter option to show on the footer of the site, where the tweets should show it only says “loading tweets” but nothing really ever shows up.

Is there something that i was meant to do but didnt do? i put in all the account details etc but still nothing.

Thanks. Magix_

66Themes

Hi,

did you setup your Twitter APP and enter your app details as outlined in the documentation?

Kind regards, 66Themes

Default-user
Magix_ Purchased

Hi there

Yes i ran through all the steps and it didnt work.. thats not really my main concern at the moment, i sent you guys an email yesterday with some support i need.

if you could kindly take a look at that please.

Thanks.

66Themes

Hi,

I checked on FTP and see you haven’t entered your Twitter App details yet. I have answered your questions and sent you more info on the subject via e-mail!

Cheers!

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years

Hello,

I just purchased this theme, and tried to upload it to my Synthesis account. I unzipped the file and tried to upload the zipped file within the themes file folder called “crafty.zip”. I received an error: “The uploaded file exceeds the upload_max_filesize directive in php.ini. I really like this theme, and I hope we can resolve this. Am I choosing the correct file? Thank you!

66Themes

Hi there,

Thank you for purchasing my theme! You are indeed uploading the right file. It seems your host has set a maximum file size you can upload.

If you know how, I’d recommend uploading the theme via FTP. Just unzip the package and copy the ‘crafty’ folder, containing all the theme files, into the themes folder of your WordPress installation.

Kind regards, 66Themes

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
Magix_ Purchased

Hi there,

Recently on my website i have changed the email address i want to use for the contact in the theme options area.

As soon as i changed it, i used the form to see if it worked and it doesnt work anymore. I changed it back to the initial email address that was set and the form started working again.

Am i missing something? or somewhere where i have to change some other settings.

The settings i changed were: Theme options > Contact details > E-mail address.

Please help! Thanks.

66Themes

Hi,

That’s odd, I just tested it and it works fine for me. Please check the following:

Are you sure you entered a valid e-mail adress?

Do you get the success message after submitting the form?

Have you checked your spam folder?

Kind regards, 66Themes

Default-user
Magix_ Purchased

Hi there,

Yes i have carried out all of the above and it does not work.

Im not quite sure why.

Thanks.

66Themes

Thanks for checking. Seems the problem was with the file sending the message. I’ve made a small change to yourmail-form.php file and it seems to be working fine now!

Default-user
Magix_ Purchased

Hi,

Thanks for trying. However the issue is still there?

When i look into the main email account where the mail should be coming…its not actually coming through.

Default-user
Magix_ Purchased

Am i meant to enter the password for the email account somewhere so it knows? or am i even missing out any settings?

66Themes

I just tried changing the address to mine and I got the e-mail via your contact form, so it really is working fine. You don’t have to enter any settings.

Try entering another e-mail address, see if you get it there.

Default-user
Magix_ Purchased

Hi,

I changed the email address and it is receiving so i guess there is something wrong with the email account that i am trying to use?

66Themes

Great! Any e-mail address should work. If you entered the address correctly it should either be in your inbox or SPAM folder. Otherwise, the mail server might have a SPAM filter installed which prevents the e-mail from ever arriving at all.

Cheers!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hello, I am trying to adjust the homepage slider image so that it absolute positions from the bottom edge instead of the top, it always seems to somehow re-adjust to positioning from the top. I’ve tried overwriting several class elements I think are related with top:auto; bottom:0px; nothing seems to work.

66Themes

Hi there,

My apologies for the late reply! Try pasting the following CSS in the Custom CSS option box in Appearance -> Theme Options:
.wrapperInner {
    top: auto;
    bottom: 25px;
}

Adjust the values as desired. Let me know how it works out!

Kind regards, 66Themes

Default-user

It does not seem to work, I am using the flex slider on the home page, and desire to have the top portion of the slider image hidden during layout adjustment instead of the bottom.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hello! Thank you for your work, we really like the design! We have some problems, though. Slideshow is not appering, we’ve read all instructions and comments below , so we saved sample page as “default template” in Page Attributes and went to content designer, general page properties, choosed fullwidth and footer slidebar. In appearence theme option slider option we have selected “FlexSlider Responsive Slider” and uploaded pictures and text. And there is still this circle on main page. What are we doing wrong? Sorry to bother you, but we both are 0 in design and trying our best. THANKS Sasha and Rodrigo

66Themes

Hi there,

Thank you for your purchase, glad you like it! Did you follow the installation instructions as outlined in the documentation? I see you missed some, for example setting up the homepage and the permalink structure.

To setup a slider, create a new page with the Homepage template and then go to the Content Designer and the General Page Properties tab, you’ll find an option for selecting the slider there.

Kind regards, 66Themes

Default-user

Hello again! So we are making some progress, thank you very much for you support. Just one little question as I can see this problem with Loading tweets in twitter streaming widget already took a place, but i didn’t get any clear answer ( i tried to change modpath: ’<?php echo get_template_directory_uri() ?>/functions/tweet/’,) but it’s not working. all twitter api is set up. Can you please help us here a little bit?) Thank you!

66Themes

No problem!

Try removing wordpress from the modpath so it looks like this:
/wp-content/themes/crafty/functions/tweet/

Let me know how it works out!

Kind regards, 66Themes

Default-user

No( Maybe i am doing something wrong!( Can we contact via email, please?

Default-user

and now (after manipulations in (functions/widgets.php) the whole web site is not loading , so we kinda of really need help!!!!))))

66Themes

Hi,

sorry to hear you’re having troubles! Of course you can contact me, just use the contact form on my profile page.

When sending me a message, it would help greatly if you could include login credentials to your WP site and FTP server.

Kind regards, 66Themes

  • Bought between 100 and 499 items
  • Exclusive Author
  • Has been a member for 4-5 years

I am 100% lost with the slider on this theme. Part of the reason WordPress is such a great tool is that it will allow for easy updates to items such as sliders, images, pages, etc. – but somehow this theme is next to impossible to figure out.

Where do I go to add slides to the Nivo Slider? I have this slider selected in the Home page options as well as in the theme options but don’t know where to add slides and captions now.

Default-user

Nevermind – figured it out. You may want to add this to your theme documentation.

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
brouge Purchased

hi i upgraded to wordpress 3.7 and now the content editor can’t show the content – it loads but you cannot see it – blank – please help soon, it’s important to use the content designer for editing. thomas

brouge
brouge Purchased

to be more precise – i can see content in the normal backend mode and in the content editor mode. but when i hit the little pencil, it happens to disappear and only is there in html mode.

66Themes

Hi there,

is it possible you could send me login details to the WP installation so I can have a look myself? You can use the contact form on my profile page to send me a message.

Thanks!

Kind regards, 66Themes

by
by
by
by
by
by