1835 comments found

zsystems Purchased

Still loving Devlopr!

P.S. Themeforest needs a “delete post” button and a real forum. This comment section and a lack of search capability is horrible.

displayinline

Glad to hear that ;)

About the suggested features, these would be a great improvement for sure! They have been requested for a long time, the dev team of ThemeForest is currently working on some new features, let’s hope they’ll add these ones soon!

jf Purchased

Quick question – I am about to start my project.

RTL please right to left?

Last question – is it using bootstrap? if not, can I add bootstrap and build my project using your masterpiece along with Bootstrap?

Thank you :)

displayinline

Hi!

The RTL version is included in the template package, in the folder html-rtl/: the markup is exactly the same as the LTR version, only the CSS and JS change.

On your second question, this template does not use bootstrap. I guess you can add some styles from bootstrap (they should work quite fine), but you need to make sure they do not conflict with each other. My advice is to take the time to remove all styles from the template that you don’t need, before adding those from Bootstrap.

Let me know if you need more details! ;)

hectorh30 Purchased

Hi. Another small issue. I just updated to version 1.5 and icons on Firefox got messed: Here’s how they look both in Chrome 28 and Firefox 22 over Ubuntu.

Thanks in advance again.

displayinline

Hi,

This is strange, they work perfectly fine in Firefox Windows and Mac, so they should display the same in Ubuntu… Unfortunately, there is not much we can do, as we can’t target specifically Firefox Ubuntu.

You may try to change the vertical-align properties for all icon styles (in styles.css, from line 1887 to 1959) to a custom value:

vertical-align: -0.1em;

But this will cause slight alignment differences between browsers and platforms.

I think this is something which will be fixed in the future by the Moz developers, as this looks like some kind of inconsistency between platforms ;)

Sorry I can’t help more!

Default-user
hectorh30 Purchased

Yeah, it’s working on Firefox 22 for windows :’( Thank though.

akrall Purchased

I think I broke something… my buttons are now showing up the icons anymore, for example:

<a href="#" id="test_email_relay_host_button" name="test_email_relay_host_button" class="button compact    icon-mail">Enviar</a>

this is showing up as a %Enviar instead of the icon.

How can I check if something is broken?

EDIT: I found my own answer. Didn’t realize it until I pasted my code here… there was a hidden TAB between compact and icon-mail… that was messing things up… I thought I’d leave the comment here just in case anybody stumbles into the same thing.

displayinline

Glad to hear you found the solution ;) Thanks for sharing!

Hi,

We have a requirement to show some reports in a iframe (same domain). So we had to include all developr js and css files into the report jsp that we are opeing in a iframe. Is there any way to refer all js and css from parent page? We want to minimize # of calls to server.

displayinline

Hi,

You may try this solution, it will allow you to dynamically include the parent’s page CSS in your iframe. For the javascript, use the syntax parent.function() to use the parent’s scripts.

Hope this helps! ;)

Default-user

Thanks for your pointer but we have used developr template (datatables, inputs, modals etc.)in iframe content as well and want to refer all js files (like setup.js, input.js, modal.js etc.) and css files from parent html. Is it possible?

displayinline

Well, due to browsers security restrictions, this seems not possible from the searches I made… However, combining and minificating the scripts will help a lot – for instance, on a basic page, you can do the following:

  • Concatenate and gzip the 3 scripts to one file of 55ko
  • Concatenate and gzip the 8 stylesheets to one file of 40ko

Also, the browser’s cache will handle most requests if the correct expiration headers are sent.

Hope this helps! ;)

In his display picture on the page ThemeForest has a system image on a tablet, it side menu (green) is detached from the side, inside a box.how do I leave it on the desktop too? Thank you.

displayinline

Hi,

Just download these modified files and overwrite the existing ones, and your app will be using the tablet-style menu on all large devices too:

Hope this helps! ;)

freelabrasil

thank you!

Great template! Is there support for tabs, if so how to find it in the template?

displayinline

Hi, and thanks!

You will find the tabs demo page here, and the documentation includes a comprehensive section on the markup and the plugin capabilities :)

mediaroot Purchased

@kmpoaquests I appreciate if anybody can share with us the idea of integrating the login page of this great theme with the wp-admin.php of wordpress.

Thanks in advance…

displayinline

Hi,

You make try this tutorial, and use the Wordpress codex reference page as detailed reference. With this you should be able to integrate the template quite easily ;)

Hi, I have a content panel, which show a table from database.

<ul class="files-list mini open-on-panel-content"> <li> <a href="ajax-demo/favlist.php" class="file-link"> <span class="icon file-gif" />My Fav List</a> </li> </ul>

So the problem here is it is taking a bit time to load the table in the panel-content and moreover freezing the UI.

I would like speed up the loading and with a loading symbol. And can i know why is it freezing the UI.

the page you can find here under “file manager” option. http://pms.leadsys.com

username:admin pwd:admin@leadsys

displayinline

Hi,

Actually, the content panel plugin shouldn’t cause any freeze, as it always uses asynchronous callbacks. This issues seems to happen because your loaded content includes external scripts: the page needs to download them first before rendering the loaded content, thus causing a freeze.

You should rather include the external script in the main page itself (as it will most likely be used anyway), and only embed your initialization code in the loaded content.

About showing a loading symbol, if you want to add one before the table is loaded, download the latest version of the plugin, and use something like this:

$('.panel-content').on('content-panel-load', function(event)
{
    $(this).setPanelContent('<span class="loader big" />');
});

Hope this helps! ;)

Default-user

Thanks that worked fine.. :)

Hi, I’m having a problem with responsive tables. When I add the class
hide-on-tablet
to the table header of that column it doesn’t hide it when I resize my browser to the tablet screen size. I do have the
developr.table.js
loaded but it’s still not working.

Is this a bug or something I can easily fix?

Below is the table im trying to get it to work on.

<table class="table responsive-table" id="total_rcon_history">
            <thead>
                <tr>
                    <th scope="col" class="hide-on-tablet">Moves</th>
                    <th scope="col" class="hide-on-tablet">Teamswap</th>
                    <th scope="col" class="hide-on-tablet">Kills</th>
                    <th scope="col">Kicks</th>
                    <th scope="col">Temp Bans</th>
                    <th scope="col">Perma Bans</th>
                    <th scope="col">Punish</th>
                    <th scope="col">Forgive</th>
                    <th scope="col" class="hide-on-tablet">Reports</th>
                    <th scope="col" class="hide-on-tablet">Used Reports</th>
                    <th scope="col">Admin Says</th>
                    <th scope="col">Admin Yells</th>
                    <th scope="col" class="hide-on-tablet">Player Says</th>
                    <th scope="col" class="hide-on-tablet">Player Yells</th>
                    <th scope="col" class="hide-on-tablet">Mutes</th>
                    <th scope="col">Total</th>
                </tr>
            </thead>
            <tbody>
            </tbody>
            <tfoot>
                <tr>
                    <td colspan="16">Total Commands Issued</td>
                </tr>
            </tfoot>
        </table>
Default-user

That was with just the basic table. No datatables.

Default-user

Ok I figured it out. In the CSS you have it named responsive-table-on but in the documentation you have it say responsive-table. When I changed it to responsive-table-on it hid the columns like it was suppose to. You might want to update that. ;)

displayinline

Thanks for your feedback! The mention to the class responsive-table is related to the use of the responsive table plugin, but the doc misses the class responsive-table-on for use cases without the plugin indeed. I will update this! ;)

is there a way to set the right fixed sidebar menu as it is but in the left?

the way it looks in the rtl version but aligned to the left? and arrows to the right?

Thanks

Default-user

and is it possible to have full width page without the shortcut bar? just the sidebar menu and the main content on full width ? Thanks

displayinline

Hi,

About the scroller, unfortunately it can’t be used on the whole page – but you can use it on the main content block, no problem ;)

To remove the shortcut bar, simply delete its markup and remove the class with-shortcuts from the body element, the template will automatically adjust.

Hope this helps!

Default-user

worked great! thx for your reply!

akrall Purchased

Hi displayinline, I hope you can share a little light on this, Im way out of my league on this issue:

Im using datatables and a plugin called columnfilter, everything works great except when I try to use columnfilters date-range type of filter, which uses dateppicker and everytime I define a field as date-range, I get this error while debugging “[object] has no method ‘datepicker’ “

I checked the code to see if I was loading just one instance of jquery and jquery-ui and everything seems to look ok…

What am I doing wrong?

Default-user
akrall Purchased

I figured it out!!! the template comes with jquery-ui-custom! note the custom part! seems you or whoever made it custom stripped out the datepicker data because I replaced it with the jquery-ui version compatible with jquery 1.8.2 and datepicker worked! so now my question is… what custom about this jeuqry-ui? what was added / removed from it?

displayinline

Hi,

This custom version of jQuery UI was only used for the documentation in earlier versions of the template, it has been removed now.

It was a minimal version of jQuery UI, with only the required components – nothing was modified. So you can safely replace it with your own version of jQuery UI ;)

Default-user
akrall Purchased

perfect! thank you displayinline!

ello

Wonderful work and distinctive but Li inquiry Always see Fully Responsive Admin Skin What is useful and what works

displayinline

Hi,

Sorry but I am not sure to understand your question. Could you reformulate it please? Thanks :)

hello, we are about to start a project with version 1.5 in the next days. You has in mind some updating important or with functions new for short? If yes, I will wait, if you have not planned anything, I’ll start with this version, which by the way is excellent.

displayinline

Hello!

I have no plan to add new big features in the near future, you can go on and start your project ;) The next updates will be maintenance updates mostly.

Let me know if you have any other question!

Hello Displayinline,

Did you received my email ?

Thanks!

displayinline

Hello, I just replied to it :)

Hello After upgrading to v1.5, still on the first page load (without resize) the datepicker always appears at the top of the page. If I click in the datepicker and again in the text field, the datepicker appears correctly.

Could you help me please?

Thanks again and sorry for my english.

displayinline

Hi,

I made several tests, but couldn’t replicate the issue, sorry… However, I noticed your date input is located inside a tab, which may be the source of the issue: if the tab is hidden when the page loads, the datepicker plugin fails to detect the input position – thus it displays on top of the page.

To fix, this, you may simply trigger a window.resize event each time the tab is shown, which will force the plugin to refresh the datepicker position:

$('.tabs-content > div').on('showtab', function()
    $(window).resize();
});

Let me know if this doesn’t help, we’ll look for another solution ;)

Default-user

Solved: $(’.datepicker’).focus(function() { $(window).resize() });

Thanks again.

displayinline

Great! Thanks for the feedback :)

akrall Purchased

Im usingmodals and I defined buttons for closing them and such but I was wondering, is there a way to use

<span class="close">?</span>

to close modals?

Default-user
akrall Purchased

for example, how can I use the class that puts a small X on the block in order to clse them? I want to put a small X on the top right corner of the modal in order to close it instead of using a button… I found the block calss that can have a X to close but could find a way to apply it to a modal

displayinline

Here’s an example implementation: add this style in css/styles/modal.css:

.modal > .close {
    z-index: 90;
    margin: 10px 10px 0 0;
}

Then open you modal like this:

$.modal({
    /* your options here */

    onOpen: function()
    {
        var modal = $(this);

        $('<span class="close">?</span>')
            .appendTo(modal)
            .click(function()
            {
                modal.closeModal();
            });
    }
});

Hope this helps! ;)

Default-user
akrall Purchased

You are the master! it worked perfectly! I still have gotten the hang of how javascript works on all cases. I would never have though about using it like this…. thx a lot!

akrall Purchased

Im using the formvalidator plugin and a button-group

                    <p class="button-height inline-large-label">
                        <label for="codecs" class="label">Codecs para Voz</label>
                        <label for="codecs-button-1" class="button compact blue-active">
                        <input type="checkbox" name="codecs" id="codecs-button-1" value="ulaw" class="validate[required]">
                        G.711 ulaw
                        </label>
                        <label for="codecs-button-2" class="button compact blue-active">
                        <input type="checkbox" name="codecs" id="codecs-button-2" value="alaw" class="validate[required]">
                        G.711alaw
                        </label>
                        <label for="codecs-button-3" class="button compact blue-active">
                        <input type="checkbox" name="codecs" id="codecs-button-3" value="g729" class="validate[required]">
                        G.729
                        </label>
                    </p>

but I can seem to find a way to make it so the validator makes sure that at least on checkbox button is checked… do you have any code around for this?

Thx displayinline!

displayinline

Hi,

You can use the minCheckbox[integer] option for this. Quoted from the plugin’s documentation:

Validates when a minimum of integer checkboxes are selected. The validator uses a special naming convention to identify the checkboxes as part of a group.

The following example, enforces a minimum of two selected checkboxes:

<input class="validate[minCheckbox[2]]" type="checkbox" name="group1" id="maxcheck1" value="5"/>
<input class="validate[minCheckbox[2]]" type="checkbox" name="group1" id="maxcheck2" value="3"/>
<input class="validate[minCheckbox[2]]" type="checkbox" name="group1" id="maxcheck3" value="9"/>

Note how the input.name is identical across the fields.

Hope this helps! ;)

Default-user
akrall Purchased

I tried this but for some reason it doesnt seems to be working but all other validation rules are working fine…. Ill try to debug whats going on… any way to turn on some sort of debug for the validation engine?

displayinline

Hi,

You’ll find all details on the plugin’s documentation page – and you can also check the Issues section, it is quite helpful ;)

akrall Purchased

Here is another one. When using tabs, I noticed that if you are also using the formvalidator plugin, seems there is something weird going on, if you have multiple tabs that defined a form and you use the formvalidaor that runs when you click on the submit button, if there are fields with errors on hidden tabs, they dont get validated and the form submits. I thought that the formvalidator would switch to the hidden tab that has the errors but it is not the case… how can I do something like that?

displayinline

Hi,

By default, the validation plugin won’t handle hidden inputs (such as one in the background tabs). To prevent this, simply set the option validateNonVisibleFields to true when initializing the validator.

To automatically display the first tab with a validation error, you can add the following failure callback:

$.validationEngine('attach', {
    onFailure: function()
    {
        $('.tabs-content').find('.formError:first').showTab();
    }
});

Hope this helps! ;)

Default-user
akrall Purchased

it did the trick! thx!!!!! this one was killing me… tabs are great but without a way to validate all tabs when submitting was a drag… thx man!

Hi,

Is there any way I can remove the animation of the modal window when it appears and disappears, because this is rather slow when the screen is fullscreen in size.

displayinline

Hi,

If you want to remove the background fade animation (which is the heaviest animation for the browser), simply edit css/styles/modal.css and remove the transition properties for the selector .modal-blocker.

If you also want to remove the window slide-in effect, edit js/developr.modal.js and change this code (line 945):

modal.centerModal().css({
    'opacity': 0,
    'marginTop': '-30px'
}).animate({
    'opacity': 1,
    'marginTop': '10px'
}, 200).animate({
    'marginTop': 0
}, 100);

To this:

modal.centerModal();

Let me know if you need more details! ;)

by
by
by
by
by
by