1769 comments found

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Do you have an estimate for when the 1.5 download will be updated with the current documentation? For example, your site has the updated icon list (http://www.display-inline.fr/demo/developr/template/icons.html) but the download does not. Thanks!

displayinline

Hi,

I can’t give a precise ETA yet, but you can use the example page icons.html included in the package as a reference, it shows the updated icons list.

Aside from that, the documentation is up-to-date ;)

  • Bought between 50 and 99 items
  • Has been a member for 6-7 years
jdevin Purchased

Hey they – I purchased this and like it a lot – but have a question – I’m currently using version 1.4 and noticed a few bugs and want to update what I have to 1.5 to see if some of those bugs get fixed. What is the easiest way to do this?

displayinline

Hi!

You just need to overwrite folders js/ and css/, and the file img/standard/srpites.png, and you are done ;)

If you made changes to any of these files, you can use a diff tool such as Winmerge to easily spot and merge the differences.

Let me know if you need more details!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
gsaliba Purchased

Hi displayinline. This Developr UI is amazing and has enabled us great flexibility. I do have one issue where I am trying to access an iFrame that is inside of a modal. I need to be able to call the jQuery selector to find a button on the page. I have been able to successfully do this by putting it in a div and manually assigning the iFrame an id.

For example:

$.modal({ title: ModalParams1, content: ‘ <iframe id=”ModalFrame” src=”’ + newURL + ’” width=”’ + (winW – (winW * .09)) + ‘px” height=”’ + (winH – (winH * .09)) + ‘px”></iframe> ’, width: winW – (winW * .07), height: winH });

$('#ModalFrame').load(function () {
     $('#ModalFrame').contents().find("#TransitionId_" + ModalParams[2]).click();
     ModalParams[2] = "";
});

As you can see this has created an issue for me having to size the div and size the iFrame for those pages that some from the other web app (same domain, so that is not the issue).

Creating a modal using the built in iframe support as follows is a great, easy, and dynamically controlled way of doing modal windows.

$.modal({ title: “test”, url: url, useIframe: true });

But I could not figure out how to access the iFrame through jQuery when the modal window is created this way? Your help is greatly appreciated.

Thank you. GSaliba

displayinline

Hi!

You can traverse the modal DOM object just like any other element, for instance:

var modal = $.modal({ title: “test”, url: url, useIframe: true });
var iframe = modal.find('iframe');
iframe.load(...

Is this what you are looking for? Let me know if you need more details! ;)

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Issue using entypo. I am using the icon on buttons. but for some reason when i load to server it breaks in IE. I have researched the issue and I cannot come to a solution. I think the issue might be that the site sit on https instead of http. It did work perfect in local host.

@font-face { font-family: “EntypoRegular”; src: url(“Entypo/entypo-webfont.eot”); src: url(“css/Entypo/entypo-webfont.woff”) format(“woff”), url(“css/Entypo/entypo-webfont.ttf”) format(“truetype”), url(“css/Entypo/entypo-webfont.svg#EntypoRegular”) format(“svg”); font-weight: normal; font-style: normal; }

Any suggestions would be appreciated?

displayinline

Hi,

From the code you posted, it seems you forgot to update the path of the .eot file, maybe the issue is here ;)

If you still have issues, make sure your server is sending the correct mime-type headers for webfonts. For instance, you can use this configuration with Apache.

Let me know if you still have the issue!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

I’ve run into a problem with the WYSIWYG editor on Android with the default browser and Chrome. Its basically unusable in any of those browsers, I am testing in Android 4.2. You can’t put text in it at all.

Is there a workaround to your knowledge? If not, whats the best method to load the plain <textarea> instead?

displayinline

Hi,

I made some tests, and on unsupported browsers the WYSIWYG editor just fallback on the standard textarea, as you suggest. Which version of the template do you use? Make sure you use a recent version of CKEditor for maximum compatibility.

Let me know if you need more details!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Is there a way to keep opened varios sections in the Accordion and to close a section when clicked?

Regards and congratulations for the great amazing work.

displayinline

Hi,

This is not possible by default, but easy to add: edit developr.accordion.js and add this code at line 44:

// Toggle mode
if (dl.hasClass('toggle-mode'))
{
    dt.toggleClass('closed');
    if (dt.hasClass('closed'))
    {
        dt.next('dd').stop(true).slideUp();
    }
    else
    {
        dt.next('dd').stop(true).slideDown();
    }
    return;
}

Then just add the class toggle-mode to your accordion, and it will work as you requested ;) This will be in the next update too, so you won’t need to worry when upgrading.

Hope this helps!

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years
andara Purchased

Hi, I purchased today your template but I´m not an expert in html,css… and I want to create a web app for a social network using your template, is possible to hire you or an expert in this template to do this job?

Thanks

displayinline

Hi!

Sorry, but I am not available for freelance work. You may post a message on the forum or check Microlancer, you will find many talented developers there ;)

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years
brobar Purchased

Good evening. I have stumbled upon a quirk (in CHROME) and wondered if you could lend some assistance. I found it in my own app, but then I tested it with your demo at (http://www.display-inline.fr/demo/developr/template/) and was able to replicate it.

When the browser has a small(er) height, and you scroll the menu down, the menu-footer background seems to disappear and turn white. See this image: http://oi39.tinypic.com/2qvvblz.jpg

Only when I grab the browser and stretch it down does it turn back to the dark background. See this image: http://oi43.tinypic.com/beu61s.jpg

It is really variable depending on how many menu elements you have in your system… however, you should be able to replicate it by going to your demo (http://www.display-inline.fr/demo/developr/template/), loading the page, giving your browser a window size of about 700 pixels in height and then scrolling the menu all the way down. Now grab the bottom of the browser and stretch it down and you should see it “pop” back to normal.

Is there a way to fix this so the background of the menu displays as normal even when the browser height is short? This seems to only be happening in Chrome (I tested in Chrome, Firefox and Safari… I don’t have IE to test it). I’m in version 27 of Chrome… I don’t know if this does this in all versions of Chrome or not.

displayinline

Hello,

I made some tests, and indeed it only occurs in recent versions of Chrome. As far as I can tell, this is something new, I never noticed it before…

It looks like the browser fails to draw the background of the menu block under the menu footer element. If you add transparency to the menu items, you will see that it stops right before the footer, for no reason.

I couldn’t find any solution for this (no CSS property seem to have any effect on this), but this looks like a glitch to me, so it should be fixed in future versions of the browser.

Sorry I can’t help more!

  • Bought between 50 and 99 items
  • Has been a member for 3-4 years

HTML: <input type=”checkbox” name=”inFldDrSearchSwitch” id=”inFldDrSearchSwitch” class=”switch mid-margin-right” value=”1” data-text-on=”YES” data-text-off=”NO”/>

Query: What will be JS statement to 1. Set the value “YES” or “NO” the control? 2. Retrieve the user selected value when the user either selects “YES” or “NO” in the switch?

I tried setting the switch value to “YES” by below code but of not use j$(’#inFldDrSearchSwitch’).prop(‘checked’, true);

displayinline

Hi,

When modifying a switch value with javascript, you need to tell the styling plugin to refresh the UI by triggering a change event:

$('#inFldDrSearchSwitch').prop('checked', true).change();

Since v1.5, you can also trigger a slightly different event: silent-change

$('#inFldDrSearchSwitch').prop('checked', true).trigger('silent-change');

This is useful if you already use the change event for listening the input and don’t want your change to trigger the callbacks. For instance, if you watch user changes:

$('#inFldDrSearchSwitch').change(function(event)
{
    if (this.checked) {
        alert('The switch is on');
    } else {
        alert('The switch is off');
    }
});

You will find more details on this in the documentation.

Hope this helps! ;)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

I am having a problem with the select class. It does not seem to work in AJAX loaded children forms on the iPhone. It works fine on the desktops, but not the iphone.

You can see it here…. http://web.impresssolutions.com/edit/form-editor.html Select Address from the menu on the iPHone and try to select it. This is the HTML:
<p class="button-height inline-label">
            <label for="taxes-showincart" class="label">Address Type</label>
            <select id="taxes-showincart" name="taxes-showincart" class="select full-width">
                <option value="0">International</option>
                <option value="1">United States</option>
                <option value="1">Canada</option>
            </select>

        </p>
displayinline

Hi,

I made some tests, and it seems you updated the form input plugin to its latest version, but not the corresponding stylesheet (css/styles/form.css). This is required, as some classes have been rewritten – this is why the select does not work on touch devices, as they require a particular z-index structure.

Updating the stylesheet should fix it ;)

Let me know if you still have any issue!

  • Bought between 1 and 9 items
  • Has been a member for 3-4 years

Hopefully I can save someone else the trouble of debugging this. If you ever want to show an instance of CKEditor (or TinyMCE) in the modal dialog, you need to initialize the editor in the “onOpen” event and destroy it in the “onClose” event. The modal script moves the DOM element around when it opens and closes the modal; iFrame based WYSIWYG editors like CKEditor and TinyMCE can’t be moved around like that without breaking. (Supposedly it does work in IE, there’s a first.)

http://ckeditor.com/forums/CKEditor-3.x/Moving-CKEditor-instances-around-DOM http://stackoverflow.com/questions/2535569/tinymce-editor-dislikes-being-moved-around
displayinline

Thanks a lot for the feedback! :) That’s good to know.

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years

Hi, you made a really good design for developr admin. I totally love it. But I have a little bit trouble with changing the shortcuts on the left side.

I change the name on the CSS (style.css), make them matches with the feature i will put on. And also change on my html page too. (Agenda => Calendar, Profile => User And I reorder all of them. Now, the calendar become colorful at beginning, and when i move the mouse over, it becomes the Map (in gray).

Then I try to copy the original html from your to my code. And all the icons become normal. (Even the CSS is the one I edited).

So my questions are: 1. The Shortcuts is only in style.css or anywhere else? 2. If only in the style.css, so it’s weird because I already change the name of that shortcut (.shortcut-agenda => .shortcut-calendar, .shortcut-contact => shortcut-profile) and when i copy the html leftside to my code, all the icons still can show normally. => do you have any js file store that name too? 3. Or anything related to those shortcuts that I missed, please tell me.

Thank you

displayinline

Hi,

Actually the icons are defined twice: once in style.css for mobile layouts (with the shortcuts in a drop-down), and another time in 768.css (in 3 different places) for tablet and desktop layouts. If you change them there too, everything should work as expected ;)

Let me know if you still have issues or if you need more details!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

we found that the template has built-in function to check IE browser version for ie7 and ie8. $.template.ie7 $.template.ie8

Do you have anything to check browser ie9 and ie10?

displayinline

Hi,

The template does not need to detect these versions using JS, so nothing is included. However, for ie9, you can simply check if the html node has the class ie9 (added using the conditional comments):

$.template.ie9 = $('html').hasClass('ie9');

For IE10, it is a bit more tricky, as this version has dropped support for conditional comments. You may try this solution, it should work fine.

Hope this helps! ;)

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Hi DisplayInline,

We are having an issue with the tabs displaying on iPads on pages with a heavy load. We pulling in data from a database and filling the data tables. It seems as if the tabs are the very last thing to load, and sometimes they don’t load at all. Is there a way to make them the first thing that loads?

Thank you!!

displayinline

Hi,

If you want the tabs to trigger as soon as possible, you can force the template setup before the Datatables configuration by adding this line just above:

$.template.init();

Note that this won’t change anything if the page is really heavy to load: the tabs can only be initialized once their content if fully loaded and ready. If the page itself is quite large, you may consider loading the tabs contents using ajax, for instance by using the showtabinit event callback:

$('#some-tab-content').on('showtabinit', function()
{
    var tab = $(this);

    // Show loading message
    tab.append('<div style="height: 100px; line-height: 100px; text-align: center"><span class="loader big" /> Loading...</div>');

    // Load content
    tab.load('tab-content.php', function()
    {
        // Setup Datatables for this tab here
    });
});

This event is called only once for each tab, when they are shown. Doing so will ensure your page loads fast, and only the required content gets loaded – for instance, if a tab is never opened, the content is not loaded, which result in lower server and bandwidth use.

Hope this helps! ;)

  • Has been a member for 1-2 years

Hello,

2)Is it possible to show the scroll whole time. Now its set to on-hover. How is that done?

           <div class="scrollable with-mid-padding" style="height:320px">
        <ul class="list events">
        <li><h4 class="icon-info thin"><strong>1472</strong> Contacts Updated</h4>
        </li>
         ........
                 </ul>
                     </div>

2) Is it possible to create a roll effect for the same. For example showing the updates in auto scroll feature.

Thanks Regards Rijz

displayinline

Hello,

1) You will find all options for the custom scroll plugin in the documentation, in Features reference / Organizing layout / Scroll. The option you need here is showOnHover: just set it to false.

Quick reminder: you can pass the options for the scroll plugin using the inline data-scroll-options attribute:

<div class="scrollable" data-scroll-options="{"showOnHover":false}">
...
</div>

2) The custom scroll plugin relies on the native scroll of the browser, so you can control the position of the content by setting scrollTop like you would with a regular scroll bar. The final implementation details depend on what you exactly trying to do.

Hope this helps!

Default-user

Thanks for the quick reply that solved the scroll hover problem.

In Auto scroll I would want the updates from database to appear and just keep repeating in the block as Auto scrolling down. Is there any sample code that i can have look at.

That would be of great help. Thanks.

  • Has been a member for 1-2 years

Hi I have one more query regarding the select class.

Here is my dynamic chained select list:

      <select id="application" name="application" form="form-login"  style="width:200px">
                                      <?php echo $opt->showTech(); ?>
                              </select> <select id="country" name="country" form="form-login" style="width: 200px; top: 0px; left: 10px;" >
                                    <option value="0">Select a Geography...</option>
                                </select>
And below is the script for generating the items in select options:
        <script type="text/javascript">
      $(document).ready(function(){
    $("select#country").attr("disabled","disabled");
    $("select#application").change(function(){
selected="selected" value=" ">Choose one</option>");
    $("select#country").attr("disabled","disabled");

    $("select#country").html("<option>wait...</option>");
  var id = $("select#application option:selected").attr('value');
    $.post("php/select_country.php", {id:id}, function(data){
        $("select#country").removeAttr("disabled");
        $("select#country").html(data);
        });
    });
     });
   </script>

The problem here is when I use the class “select” for styling it is not working as desired. Why is it breaking the code?

Please suggest a fix. Regards Rijz

displayinline

Hi,

As stated in the documentation, every time you directly modify a styled select using javascript, you need to tell the styling plugin to refresh by triggering a change event:

$("#country").html("<option>wait...</option>").change();

If you already use the change event, you can use the custom event silent-change instead:

$("#country").html("<option>wait...</option>").trigger('silent-change');

With this, your styled selects should work as expected.

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years

I have a problem with the Custom Select dropdowns. I have pages with ajax loaded Select drop downs. They work fine if the page is loaded with the ajax-fetched values, but as soon as this value changes and loads them with a new set of values, the span element of the Custom Select has the old values. Is there a way I can reinitialize the select plugin? or how do I go about this? Your help will be appreciated, thanks. :)

displayinline

Hi,

When you dynamically change the content of a styled select, you need to tell the styling plugin to refresh by triggering a change event:

$('#select').change();

If you already use the change event, you can use the custom event silent-change instead (since v1.5):

$('#select').trigger('silent-change');

With this, your styled selects will show the right values ;) You will find more details on this in the documentation, in Features reference / Form / Selects.

Let me know if you need more details!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

For updating to 1.5 from 1.4. There were some bug fixes in my color.css that I want to know if they should be put in the new colors.css. For instance:

.black-inputs .radio > .check-knob, .black-inputs.radio > .check-knob,

displayinline

Hi,

This is not required anymore, the corresponding styles are defined in styles/form.css.

Let me know if you need more details! ;)

Default-user

Oh, excellent! Thanks!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
  • United States
UITS Purchased

Regarding http://themeforest.net/item/developr-fully-responsive-admin-skin/discussion/2085628?page=68#comment_4091050 , would this still work:

if ($('html').hasClass('no-generatedcontent') || $.template.ie7)
displayinline

Hi,

Not really, you would still have the issue with the older Android devices, as it is caused by the false negative on generatedcontent.

In which context do you want to use this?

UITS
UITS Purchased

It was just a technical thought exercise. I figured since it returned a false negative on generatedcontent but your solution would return a positive on $.template.ie7 then putting the two together in an OR statement would be a more robust solution.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
  • United States
UITS Purchased

FYI, Nexus 7 bug: switching from landscape to portrait with menu open causes incorrect menu position. Here’s my solution:

$(document).on('change-query', function(event) {
       if ($.template.mediaQuery.name == 'mobile-landscape' && $(bod).hasClass('menu-open') && ($(document).height() > $(document).width())) {
           $(bod).removeClass('menu-open');
           window.setTimeout(function() {
               $(bod).addClass('menu-open');
           }, 0);
       }
});

...possibly related to http://themeforest.net/item/developr-fully-responsive-admin-skin/discussion/2085628?page=70#comment_4192819

displayinline

Hi again,

This is possibly related, as both browsers use the Webkit engine. And your solution looks great, thanks a lot for sharing! :)

by
by
by
by
by
by