Discussion on Elision - Retina Multi-Purpose WordPress Theme

1924 comments found

leilakim Purchased

WARNING! THEME LOADS VERY, VERY SLOWLY and is VERY PROBLEMATIC!!!

Hi! Anyone who is thinking of purchasing this theme should be warned:

1. This theme takes way too long to load, especially on mobile devices. I have a very simple site and only the plugins required by the theme. Other users report the same issue on this theme and the author’s other themes.

No one, especially a casting director, is going to wait this long for a site to load. This site is NOT MOBILE FRIENDLY. In doing research, I’ve noticed that this author has the same issue on their other themes as well.

2. After hours of customization, I entered the custom CSS code (as directed by the author) to fix the footer content not showing and everything reverted back to the defaults! This included side area – off, logos, heading/footer and tile settings. It was like doing the site all over again.

3. Every now and then, the Side Menu OFF keeps turning back ON. It’s like random settings arbitrarily revert back at random times.

I did notice that you have to make each change individually, save, then update. You have to do this even if the settings are within the same group. Tedious, but I can even live with that. Cannot live with the long load times.

4. Mobile version does not update with changes right away.

All the customization and beauty of the site is really nice, but not at the expense of function. In reading all the tech support issues (which the author has set on private by default), the explanations are very poorly written. Many times, you have to kind of guess what the author is writing.

If I don’t get a fix for the extremely slow load times, I will request a refund.

QODE
QODE Author

Hi,

In order to be able to inspect any of the issue you reported, you will need to submit ticket to https://qode.ticksy.com/ and include WP admin access. Please post ticket ID here so we can locate your ticket easily.

Our demo site doesn’t have reported issues, so we need to figure out what went wrong on your end. Our support is professional and will help you.

Qode

Default-user
leilakim Purchased

Hi there!

Actually, your demo site takes an extremely long time to load as well. I just never caught that because I was distracted by the beauty of the theme.

I have submitted a ticket but did not receive a response.

If this is my fault, I will recant my original comment and apologize profusely.

fresign Purchased

Hi,

I’m absolutely loving the theme. :) There is one issue though. Sometimes parts of the site won’t load. e.g. a background image, normal image or e.g. the Aeolus carousel plugin. After pressing F5 the site loads right. This has been tested on different webservers, different client and browsers.

And sometimes the site feels kind off slow-loading.

Are there solutions for these two issues?

Thanks in advance!

Kind regards! Fresign

QODE
QODE Author

Hi,

Could you please submit a ticket to https://qode.ticksy.com/ with a link to your site and temp wp-admin access so our support team can take a closer look at these issues and see what they can do to help.

Qode

MondoMan Purchased

Apologies in advance if this is a bit of a “newb” question. I want to modify the behavior of a blog page but not sure how. I want to load older posts at the bottom of the page under an “Archive” banner. The first problem I’m running into is that if I use a Blog Template on the page, via Page Attributes, then add something to the page via “Visual Composer” the blog posts load under the added content. What would I need to do to get the content to load under the blog posts?

Also, I was trying to load the archived (category) posts via the “Latest Posts” and then giving them a category slug. I’m sure there is a better why to do this so I thought I would ask.

Thanks for any help you can give! Love the theme!

Hi! It has been over 2 days and no response. I submitted a support ticket about this theme. It loads extremely slowly on mobile devices (just like your demo theme). Also, settings seem to revert back to default for no reason.

by
by
by
by
by
by