Discussion on Galka - Professional Responsive OpenCart theme

366 comments found

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
kenett Purchased

Hi Koev,

How do i add links from Information to the navigation menu? I checked header.tpl and was suspecting that it is the line of code below but i didn’t want to mess with the responsive aspect of it.

<?php $menuType = $this->config->get('GALKAControl_menu'); if(($this->config->get('GALKAControl_menu') != null) && ($this->config->get('GALKAControl_status') == '1')) { include(DIR_TEMPLATE . $this->config->get('config_template') . '/template/common/' . $menuType); } else { include(DIR_TEMPLATE . $this->config->get('config_template') . '/template/common/OpencartDefault_menu.php'); } ?>

Please advise.

Thanks!

theAlThemist

Hello kenett,

could you please explain EXACTLY what you want to achieve? Send me an e-mail if you wish.

Default-user
kenett Purchased

I solved this issue already. Thanks.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Is your theme multi-store ready?

Default-user

You may disregard this question (I saw one of your earlier replies to identical question)

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

On iPhone when scrolling down, the image can move a bit right/left as well. This gives ‘unstable’ feel. Can this be avoided?

theAlThemist

The theme is responsive down to 380px because of the default OpenCart tables. iPhone portrait screen size is 320 px. The theme works fine on iPhone in Landscape orientation.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Does slider on homepage allow video? If not, which plugin do you recommend?

theAlThemist

Hello Six2013,

no, the current slideshow module doesn’t allow video. Unfortunately I can’t recommend you an extension that does this, but I’ll be adding layer slider to the theme soon, which supports video content too. You can check the slider of my latest theme “Varna” and see it in action. :)

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
kenett Purchased

Hi Koev,

The Product Compare page, how do i make it to look like your sample? Meaning to say without the Slider, Welcome and Banner. Please take a look at the site i am building – http://202.176.223.216/store/index.php?route=product/compare. The page shows the slider, the 3 banners, the welcome section and the Special section.

I want it to be just like your sample, (http://dimitarkoev.com/galka/index.php?route=product/compare) with nothing but the tables only.

Please advise ASAP.

Thanks!

theAlThemist

Hello kenett,

it looks like those modules are enabled in “Default” layout. Product compare is one of the pages using the default layout.

Other possible reason could be if you’re using “all pages” mod in your store and the modules are enabled for all pages.

Just check your modules (slideshow, welcome, specials) settings and change them accordingly OR create a separate layout for the Compare page under System>Design>Layouts

Default-user
kenett Purchased

Fixed. Seems like i change the default page to the Home page.

Thanks!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Koev Do you have any solutions to automatically insert images to subcategories and refine search ? i have about 9000+ images to insert

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Well in fact to categories

theAlThemist

Hello bytes100,

I am afraid it’s not possible. There are many Import/Export tools available on the market. You could probably try one of them.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Koev,

It looks like Custom CSS via admin not working on my end. However, when i insert the code directly to stylesheet_red.css (i’ve appplied red skin), the styles got applied.

Could you please check at your side if I’m missing something?

Regards.

theAlThemist

Hello granger777,

could you please send me an e-mail with temporary admin access to your store so I could check what could be wrong? I have tested on my side and everything works fine with custom CSS if the code is correctly written.

Default-user

Well, if it works on your end, then—fine, I can live with it for the moment. I’m on localhost now. Thanks for taking the time!

  • Has been a member for 0-1 years

Hi i wanna include a link to UNSUBSCRIBE right from the newsletter .. Can you help me with the code which will directly Unsubscribe the user from the list.

theAlThemist

Hello rohitthakkar,

it looks like you never purchased this theme or anything else on themeforest.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Koev

Can you tell me where to remove the “span.cat_preview” in the mega menu i want to take out the image and title .

Colin

theAlThemist

See my answer to your next questions.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Also the fullscreen background is behind main body ?

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

the container i mean not the body

theAlThemist

Yes, of course the background is behind the main container. It’s a PAGE BACKGROUND, not container background.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Ignore the reference to background I was seeing white space Its just the “span.cat_preview” in the mega menu I want to remove

Colin

theAlThemist

Hello bytes100,

there are two ways to do this:

1. Manually remove the code from GALKA_menu.php OR hide the span with CSS. Keep in mind, in both cases you would need to restyle the other menu blocks in order to take the whole available space.

Default-user

can you tell me excactly which code to remove in GALKA_menu.php Thanks

theAlThemist

Line 33 where it says:

if ($categories_2) {$output .= '<span><ul class="children"> ' . $catCustomTop . '<span class="cat_preview"><h3>' . $category_1['name'] . '</h3><img src="'.$picCat.'" alt="' . $category_1['name'] . '" /><p>'. mb_substr(strip_tags(html_entity_decode($category_1['description'], ENT_QUOTES, 'UTF-8')), 0, 100) . '...' .'</p></span> ';}</ul></span>

you would need to change it to:

if ($categories_2) {$output .= '<span><ul class="children"> ' . $catCustomTop . ';}</ul></span>
Default-user

I tried that it just wiped out the entire header and menu and flexslider well just about everything

theAlThemist

Hello bytes100,

it sounds like you didn’t deleted the right part of code. It’s a pure PHP code and even a single dot or comma could cause errors if not written/deleted properly.

If you’re not familiar with PHP I would strongly recommend you to hire a developer to make the customizations for you. It’s a few minutes work and wouldn’t cost more than 10 USD if you find the right developer.

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Hi Koev

is it possible to have a sold colour from the meny system up to the top of the page and the full with of the page like it is with the footer

cheers

Mike

Default-user

actually just after resizing the header borderless to the same size as the header

theAlThemist

Hello shiningwebsites,

it’s possible for the entire header container and the top bar with currencies, languages, links only. The central part would stay always white. If you need to change it entirely you would need to add some styling via CSS (either in stylesheet file or the custom CSS field in admin).

I am afraid I don’t understand the second part of your question regarding the header borderless. It’s just a style used when there are modules activated in header.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Whilst Waiting for a reply to my previous question I now have a problem with the flexslider at the moment I have 3 images 1920×580 1 image resizes past 960-964px the other 2 disappear at anything bigger than 960-964 which is also when the menu changes can you give me any advice/help please Koev

theAlThemist

Hello bytes100,

I am afraid I don’t understand exactly what the problem is. Could you please explain more and give me a link to see the problem “live”?

Default-user

Its ok , That bit is sorted now ,spaces in folder name

theAlThemist

Good. I am glad you found it. :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

hi, i have a big problem with this theme, i think that it is a bug… when i on admin disable “Login Display Prices:” choosing “Yes” on home page, featured produtcs with “Special” prices .. i see a error:

Warning: Division by zero in /home/demo/httpdocs/2014/testgalkatheme/catalog/view/theme/GALKA/template/module/featured.tpl on line 45 :( can u fix this problem??

theAlThemist

Hello benjo2412,

I’ll check this now and update the theme if needed. Thank you for your feedback.

Default-user

ok thanks Koev :) however waiting your fix , i have fixed for now so, on: catalog/view/theme/GALKA/template/product/category.tpl

before: $res = ($val1 / $val2) * 100;

i have added this strings: if ($val2 < ‘0.0001’) { $val2 = $val1; };

and now it works fine :)

theAlThemist

Hello benjo2412,

that should also work, but the real problem is actually the missing price. I’ll fix it another way.

  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users

hi koev.

let me first say: EXCELLENT theme! ;-)

installed it yesterday an got 2 or 3 questions:

where can i edit the three turquois images? for some reason i do get a duplicate of the BIG slider above there (same content, but smaller than the big one above)!?

where can i edit the welcome message?

and this might be a bug (title of shop at “modules > GALKA Latest News”)? :)

more to come. thanks and greetings.

theAlThemist

Hello absoluto,

1. These are just a standard banner set of three image created under System>Design>Banners and than applied to an instance of the Banner module with position “Header”. Keep in mind they would only look like this if enabled in Header together with the Flex Sldieshow! Otherwise they would look like a standard banners.

2. It’s caused by the custom titles coloring for the theme specific modules. The whole theme is getting overhauled at the moment and update with many improvements and new features would be released soon.

Default-user

hi koev

> 1. These are just a standard banner set of three image created under System>Design>Banners
- that´s what i did, too.

> and than applied to an instance of the Banner module with position “Header”.
- sorry, but can you explain this a litte more in detail, please? thanks!

> Keep in mind they would only look like this if enabled in Header together with the Flex Sldieshow!
- i got the flex slideshow enabled, so this should be fine then. but it isn´t. any ideas?

> 2. The whole theme is getting overhauled at the moment and update with many improvements and new features would be released soon.
- any date for this update? i go to go online by mid next week…

and as you are fixing things up. maybe you wanna consider this ‘bug’, too? your megamenu got a greater width when applying a custom tab to the navigation. normal menu items got this width:

‘custom’ tabs are wider:

thanks and greetings.

theAlThemist

> and than applied to an instance of the Banner module with position “Header”. > – sorry, but can you explain this a litte more in detail, please? thanks!

Which part you did not understood? Did you enabled the Banner module under Extensions>Modules? Check the theme demo admin and see how are things organized. Also, you could check the system documentation and see the basics of working with opencart here – http://docs.opencart.com/display/opencart/OpenCart+1.5+Home > – any date for this update? i go to go online by mid next week…

2. The whole theme is getting overhauled at the moment and update with many improvements and new features would be released soon.

I can’t give you a strict date, but it should be probably ready till the end of the next week

3. I’ll check the menu width issue. Thanks for your feedback.

Default-user

hi koev.

ich solved the banner issue.

cheers, mate!

theAlThemist

I am glad you found it. :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

hi, i have find another bug/problem… if i have a product of 1000$ .. and if i set “Special” of ths product to 400$ on product page frontend, the percentuage number on top of big photo, give me this number: “Sale—3999900%” i have seen that this problem there is when special is lower of 50% of price of product.. :(

theAlThemist

The problem is most probably caused by wrong price format – e.g. dots and commas not in the right place. Your prices must be in the default opencart format – e.g. ”$1,111.11”.

Default-user

yes, i have already tryed variuos prices, with some formats, the problem there is ever time if special is 50% of price of product.

theAlThemist

Could you please send me an e-mail with temporary admin access to your store? You can see here it works fine with correct price format – http://dimitarkoev.com/galka/index.php?route=product/product&product_id=43

Default-user

yes, i have put some prices how your product, and too to my website there is not problems, but if on your product u set price of product to 1500$ .. u will see some error “sale—1399900%” can u set exactly so? Price of product 1500$ and Special to 200$ ? so u have some problem

Default-user

ok, i have sended you account of administrator and link to my demo site

theAlThemist

Hello benjo2412,

I think I have found the problem. Check your Italian language pack in catalog/language/italian/italian.php and make sure the following code is as follows:

$_[‘decimal_point’] = ’.’; $_[‘thousand_point’] = ’,’;

It looks like in your italian language file they are swapped like this:

$_[‘decimal_point’] = ’,’; $_[‘thousand_point’] = ’.’;

If you change the store language to English the % works fine.

Default-user

mh yes it is ’.’; and if i change to ’’; the % works fine.. but on thousand the prices exactl are 1.500,50 to example.. not 1500,50 :( however for now it is ok.. thnaks

theAlThemist

Just swap the signs. Make decimal point to be ’.’ and thousand point to be ’,’

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
Hello I have a problem with the size of product images in my homepage. it is size 80 * 80 I would like to enlarge http://agoradeal.com/

cordially

theAlThemist

There is nothing on the page URL you gave me, but it sounds like you didn’t set the proper image size in the module (latest, featured etc.)

Default-user
you can go around again on my site to see http://agoradeal.com/index.php?route=common/home
Default-user

thank you

theAlThemist

Hello abdel-eleonore,

as I already said, there is no store on this URL. It’s only a login form and christmas background!

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

hello ! getting error :vqmod/vqcache/vq2-system_engine_controller.php on line 67

theAlThemist

Hello jasthaulamrit,

As I said – it looks like you never purchased this theme.

by
by
by
by
by
by