Discussion on Hitched - Responsive WordPress Wedding Theme

78 comments found

Hi. Sorry my English, i´m Brazilian. I buy this theme and he not work install for me. When i try automatic install, the message show to me: “Need file style.css”.

I try upload by Ftp and when i try activate, this message show to me.

Warning: require_once(/home/spacod/www/carolegustavo/wp-content/themes/hitched/inc/admin/OSFAdminPage.class.php) [function.require-once]: failed to open stream: No such file or directory in /home/spacod/www/carolegustavo/wp-content/themes/hitched-wordpress-theme-1.6/hitched/functions.php on line 136

Fatal error: require_once() [function.require]: Failed opening required ’/home/spacod/www/carolegustavo/wp-content/themes/hitched/inc/admin/OSFAdminPage.class.php’ (include_path=’.:/usr/local/lib/php’) in /home/spacod/www/carolegustavo/wp-content/themes/hitched-wordpress-theme-1.6/hitched/functions.php on line 136

I try on Wordpress 3.2.1 and 3.5.1. I need help please.

att.

Studio164a

You can add the RSVP form by installing the Visual Form Builder plugin that comes with the theme package. Take a look at page 15 of the documentation for step-by-step instructions on how to create it.

Cheers, Eric

Default-user

I did it, but on the documentation learn how to add the form on de new page. I want add this in the foot of page, like a demo online.

Studio164a

Ah, sorry for misunderstanding your question. To add the form to the homepage, go to edit your page and follow the instructions on page 17, starting with:

After you have created the form, go to pages > add New page and create a page called RSVp (or any other name you’d prefer). For Template under page attributes, select Fullwidth page. above the page area, you’ll see a little extra icon next to the add media button. Click this button, which will bring up a window where you can select the form you just created and insert it into the page as a shortcode.

Cheers, Eric

I hate to ask a dumb question…but here I go anyway…

Where do I find the documentation?

Studio164a

Hi Tokazama2,

The documentation is a PDF inside the main zip file you download from ThemeForest. Just unzip the zip file and it’ll be in the folder :)

Cheers, Eric

Hello,

I just downloaded the Hitched theme and unzipped it (themeforest-3787396-hitched-responsive-wordpress-wedding-theme-wordpress_theme.zip).

I did not see documentation within the ZIP. Can you point me to the folder?

Thanks

Minesh

Hi again,

I asked about the documentation a few minutes ago. Just saw something strange. I originally downloaded the theme zip of size 3.715M. I just downloaded it again and it is now 36.1M and it has the documentation in it.

Did I do something wrong? I installed the previous on to my dodaddy account.

Should I uninstall and re-install the bigger zip file to my site?

Thanks

Minesh

Studio164a

Hi Minesh,

That’s very odd indeed! No idea why that would have happened, but perhaps there was something going on in Envato when you first downloaded the zip. Use the second one. Also, note that you only need to install the hitched.zip zip inside of the main zipped folder, rather than the main zip.

Cheers, Eric

If anyone is having problems getting their front page to look like the sample at http://164a.com/hitched-wp/

I think I figured it out. Whenever I paste it here it messes up the code. If you want to look at the code you can view it here:

http://www.ahacpa.org/kathy/Hitched-front-page-code.txt

The reason user mpatel1967 had 2 different download sizes is because Envato offers you two download options when you purchase a WordPress theme. He probably just clicked on different ones the two different times he downloaded.

The first option is the ‘Main File’ which has the documentation, installable theme zip file, PSD’s (when the author decides to include them), etc. It’s the entire product.

The second option is to download just the ‘Installable WordPress file’ which is the .zip you can upload straight into Wordpress to install the theme, and nothing else extra. This .zip is contained inside the ‘Main File’ zip.

Studio164a

Hi there,

Thanks so much for posting this! It’s been a while since I’ve purchased a ThemeForest theme myself, so I wasn’t aware of this. Really appreciate you posting it here for everyone’s benefit :)

Cheers, Eric

Hi,

I am looking at the example and love the home page.

1. How did yo get the “Our Story”, “Details” and “From the Blod” labels over each column? 2. How dod you make the map sort of fit in the column?

Thanks

Minesh

Studio164a

Hi Minesh,

Those labels are added using the Section Label style, which you can select under the Styles dropdown.

For the map, I am using the pw_map shortcode. Example:

[pw_map address="1 Cavenagh Street, Darwin" height="120px"]

Cheers, Eric

Hi again,

Getting better and sorry for what may be dumb questions. I removed the widgets from my pages, but how do I get the main body to span over what is now dead space where the widgets were?

Thanks

Minesh

Default-user

That it what I was honing on, but I added it to the custom.css file within the child site. Here is the link…www.babylovesboo.com

Thanks

Minesh

Studio164a

Hi Minesh,

Looks like it needs the !important tag. So change it to this:

#content {
    width: 100% !important;
}

Also, be sure to set the title for the blog on the Hitched Theme Settings page.

Cheers, Eric

Default-user

There it is! That worked. Thanks for all your help!

Minesh

kraaitje Purchased

Thanks for this nice template.

Two questions: 1 – How do I get three column mainpage with headers like the demo (our story, wedding, from the blog) 2 – Is it possible to embed a vimeo video in the slider?

thanks.

Studio164a

Hi kraaitje,

The three-column layout is done using the [column] shortcode. The headers are achieved by styling them as Section Headers (under the Styles dropdown). I will paste the demo site’s content for the first panel below:

[column width="33%" divider="true"]
<h2 class="section_label">Our Story</h2>
<h4 class="alt"><strong>Walter & Harriet
</strong></h4>
Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.

Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

[/column]

[column width="33%" divider="true"]
<h2 class="section_label">Wedding</h2>
<h4 class="alt"><strong>Ceremony</strong></h4>
<strong>Saturday 24th March 2012</strong>
Two o'clock in the afternoon
Wind in the Willows
Healesville, Victoria (<a href="http://164a.com/hitched/">Get directions</a>)
<h4 class="alt"><strong>Reception</strong></h4>
Following Ceremony
At five o'clock in the evening

[pw_map address="1 Cavenagh Street, Darwin" height="120px"]

[/column]

[column width="33%" last="true"]
<h2 class="section_label">From the Blog</h2>
[recent_posts count=3]

[/column]

Unfortunately, it isn’t possible to add a video to the image slider.

Cheers, Eric

Hi,

I can’t seem to get the border around the images to go away, I’ve checked the style.css:

} img { border: 0px; }

and checked that the border is set to 0 in all other possible locations.

What can I check next?

Studio164a

Hi snowgoodeSA,

Try setting box-shadow: none !important; for the images.

Cheers, Eric

Hi Eric,

Odd thing happening when I view the site from my cell phone.

I see my website come up, and I see a “Menu” button with drop down arrow to the right. When I click on it the drop down arrow, I would expect to see the menu items, but nothing shows. This happens when I hold my phone vertically.

If I rotate my phone horizontally, all the menu items are visible

I am on a driod Mototrola phone.

Do I need to make any setting changes?

Thanks

Minesh

Studio164a

Hi Minesh,

Could you send me the link to your site? I’ll check it down on my phone to see if I can reproduce the issue. Sorry for taking so long to reply. We’re in the process of finishing off a new theme.

Cheers, Eric

Warning: require_once(/home/content/17/11210217/html/WordPress/wp-content/themes/hitched/inc/template-tags.php) [function.require-once]: failed to open stream: Permission denied in /home/content/17/11210217/html/WordPress/wp-content/themes/hitched/functions.php on line 136

Fatal error: require_once() [function.require]: Failed opening required ’/home/content/17/11210217/html/WordPress/wp-content/themes/hitched/inc/template-tags.php’ (include_path=’.:/usr/local/php5_3/lib/php’) in /home/content/17/11210217/html/WordPress/wp-content/themes/hitched/functions.php on line 136

What do I do?

Studio164a

Hi casey_daws,

It sounds like either there are issues with the permission settings of files inside your theme directory, or things didn’t upload properly. Before anything else, try re-uploading the theme; if that doesn’t resolve the issue, take a look at the permission settings for the files inside your theme directory.

Cheers, Eric

Default-user

Still not working at all. I download file then add the hitched folder to my themes. Its shows the theme in my themes but as soon as I activate it I sill get the same error. I have no clue where the permission settings are located.

Studio164a

Hi casey_daws,

The permission settings are for the actual files.

For more information about file permissions, take a look at the Codex article on the topic:

http://codex.wordpress.org/Changing_File_Permissions

Find out what the permission settings are for the file located at wp-content/themes/hitched/inc/template-tags.php and let me know.

Cheers, Eric

The dots on the slider on the hompeage don’t work when you click on them. How can this be changed?

Studio164a

Hi supplementalsounds,

Could you send me a link to your website?

Cheers, Eric

Default-user

Thanks for your response. My site is not live yet. It does it on your demo site too.

I’m using Chrome btw, if that matters.

Studio164a

Hi supplementalsounds,

Interesting—I hadn’t noticed that before, I’ll work on a fix and will upload that.

Cheers, Eric

I can’t thank you enough for this great design! BUT, I am having serious trouble with the slider and carousel on the main page. When I create the gallery, it appears in both pulldowns. So I made two galleries, to seperate the header slider, from the other. It worked on one update, but now I can’t get it to work again. I read the documentation but I am stumped! Am I missing something simple here? Thank you!

Studio164a

Hi sdfilmmaker,

Could you send me a message via the contact form on our profile page, with a link to your site?

Cheers, Eric

ray_trace Purchased

Hi, purchased your theme. it’s nice, worked great except for one exception that drove me crazy for a day:

Parameters passed to order galleries were not working.

Dug into your code (no time for you to fix). In functions.php there is a conditional statement starting line 658:

if ( empty( $match ) || strpos( $match[1], 'ids' ) === false /* Match found without "ids" specified */ ) {      
    $images = get_posts( array( 'post_type' => 'attachment', 'posts_per_page' => 1, 'post_status' => 'any', 'post_parent' => $post>ID, 'orderby' => 'menu_order', 'order' => 'ASC' ) );

The following else condition looks like this:

list( $a, $image_ids, $b ) = explode( '"', $match[1] ); 
          $images = get_posts( array( 'include' => explode( ',', $image_ids ), 'post_per_page' => -1, 'post_type' => 'attachment', 'post_status' => 'any' ) );

You’re missing the ‘order_by’ and and ‘order’ parameters on the else statement.

I added them in and now gallery ordering is working.

I’m very surprised no one has mentioned this earlier.

l8r :-)

Studio164a

Hi ray_trace,

Thanks for the heads up! I’ll work this fix into the next release.

Cheers, Eric

aliahhall Purchased

When I try and activate this theme I get this error:

Warning: require_once(/home/setuptab/public_html/wedding/wp-content/themes/hitched/inc/admin/OSFAdminPage.class.php) [function.require-once]: failed to open stream: No such file or directory in /home/setuptab/public_html/wedding/wp-content/themes/hitched-wordpress-theme-1.8/hitched/functions.php on line 136

Is there a solution?

Studio164a

Hi aliahhall,

It looks like you’ve uploaded the entire folder that you downloaded from ThemeForest. Instead, just upload the hitched folder inside of the folder you downloaded; or install the hitched.zip file.

Cheers, Eric

Default-user
aliahhall Purchased

Yup that’s what I did. Thank you.

aliahhall Purchased

I have been following the instructions and am stumped at the “Creating Your Site Menu” section on page 3. I have a menu on my site that is working when I chose other themes but when I chose this theme and preview my site. . . there is no menu on the interface at all.

http://www.setuptab.com/wedding/

I have gone through the instructions several times. . . deleted the menu and re-created it making sure to pick it as the Primary Navigation field but. . . it seems to never show up. :-(

Hi, Pre-Purchase question! I’m very interested in this theme, but was wondering if there was any way to customize the colors used. I see it has 2 predefined color schemes. It would be great if I could modify the theme’s colors tho to match the colors of my wedding. Let me know if this is a feature that comes with the theme or if there is some way I can make the modifications.

Thanks!

Studio164a

Sorry for the delay in getting back to you—I have been on a holiday for the past couple weeks, and unfortunately I had very poor wifi.

You can certainly create your own colour combination, but access to a tool like Photoshop is recommended, since there are graphical elements that need to be changed to a different colour (the banners, ribbon, widget headers, etc)

Cheers, Eric

Default-user

Hi Eric,

Thanks for the info, no problem on the time it took!

Since I do have photoshop, do you think it would be relatively easy to change the colors using that? Are the graphics layered for easy color changes?

I would like to make it navy blue and yellow to match the wedding colors we plan to choose.

Thanks again,

karl

Studio164a

Hi Karl,

In the main PSD that comes with the theme, each element is on a separate layer (i.e. the whole ribbon, the section labels, the backgrounds), but these are not broken down any further (i.e. with the ribbon – the dotted lines and the shadows are all part of the one layer).

Having said that, if you use some of the Image Adjustments – particularly the Replace Colour option, you can select particular colours and change their Hue. It would take a bit of time, but is doable.

Additionally, the non-graphical colours (like text colours) would need to be updated via CSS.

Cheers, Eric

schubertd Purchased

Hey Eric,

I love this theme! Thank you so much for creating it and supporting it so well. It made creating a website for my brother’s wedding so easy.

Is there an easy way to set the buttons to open in a new window? I’m using them on my Registry page, and I want the links to online stores to open in a new window so users will return to the site if they close out of the online store. Here’s the page I’m working on: http://www.brettandcourtney.net/?page_id=50

I want the buttons to open new windows just like the Bed Bath & Beyond banner does.

Thanks!

schubertd Purchased

Never mind… I figured it out myself. I changed the code for the button function in the inc/shortcodes.php file to be as follows:

if ( !function_exists('osfa_button_shortcode') ) {
    function osfa_button_shortcode($atts, $content = null) {
        extract(shortcode_atts( array(
            'variation' => '', 'large' => false, 'link' => '', 'blank' => false,
        ), $atts));        

        if ( strlen( $variation ) )
            $variation = ' alt_'.$variation.' ';

        if ( $large ) 
            $large = ' large';

    if ( $blank )
        $blank = 'target=\"_blank\"';

        // return '<button class="submit'.$variation.$large.'">'.$content.'</button>';
        return '<a href="'.$link.'" class="button submit'.$variation.$large.'">'.$content.'</a>';
    }
}

Now it’s working just how I want it to! :)

Studio164a

Glad you were able to figure it out :)

To allow for future updates, I’d suggest using the child theme and sticking your modified version of osfa_button_shortcode in there. That way, you can upgrade to future versions without worrying about losing your changes.

Cheers, Eric

by
by
by
by
by
by