145 comments found

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Category problem.

I have 2 categories – each has a page with their blog shortcodes:

[symple_blog count=”-1” columns=”4” pagination=”false” thumbnail_crop=”true” thumbnail_hard_crop=”false” title=”true” excerpt=”true” excerpt_length=”100” read_more=”true” category_id=”41” tag_id=”“]

So, on the archive page the categories items are displayed correctly. However, on viewing a post, then using the previous and next buttons – the categories are jumbled together – in other words they are all included, when they should be showing just the category of the posts.

Am I missing something obvious here ( I tried putting a tag and its id – this just broke the category listing pages).

Am I missing something obvious.

A response would be nice :) – my previous questions seem to have fallen on stony ground.

Default-user

This is what one of my categories tell me:

http://www.xxxxxxxxx.xxx/wp-admin/edit-tags.php?action=edit&taxonomy=category&tag_ID=41&post_type=post

So – the simple blog shortcode with category_id=”41” displays the posts in the category – why then do the post links at the base of the page not step through ‘only’ the posts in the category?

Default-user

It gets worse – from one of the category pages – the links at the bottom of the page cycle through just 2 posts – not the 10 or so in the category.

WPExplorer

Sorry for the delay on this.

By default the next and previous links don’t rotate through posts in the same category. It’s a very simple tweak though if you want it to. Just open single.php and change the two functions next_post_link and previous_post_link so where it says “false” it says “true” instead.

Most customers prefer next/previous to cycle through all posts for SEO reasons.

Default-user

Still struggling with this. I have followed your directions and changed ‘false’ to ‘true in single.php (previous & next). It makes no difference at all (btw – I am using a child theme).

Again – all I want is post navigation to be restricted to the current category only.

Thanks,

Mike

Default-user

In fact, the navigation is behaving oddly – I have a case study (a single post in a category) – the navigation cycles between my last portfolio post and the case study page. That is just not right.

Default-user

Portfolio navigation has the same problem.

WPExplorer

Couple of things…

The original issue you had was over 2 months ago, things have changed A LOT since then. Make sure your theme is up to date – http://www.wpexplorer.com/changelogs/total/

You can see now all the next/previous functions are at framework/next-prev.php

I just noticed there isn’t a way to disable the same category loop so I added a new filter “wpex_prev_post_link_same_cat” that will be included in verision 1.53. But right now if you want you can add the function before it “wpex_post_has_terms” if you want to your child theme and return false if you don’t want to loop through items in the same category.

Default-user
wmike1503 Purchased

My version is 1.21 – so how do I update it? The download link on this page just downloads 1.21 again.

framework/next-prev.php doesn’t exist.

Again, I don’t think you understand the problem. I do want to cycle through category posts – but only the selected category – not all of them.

WPExplorer

Ah crap, I thought you were using a different theme…

Ok so by default the theme does cycle between items in the same category, see content-portfolio lines 128/129.

It isn’t possible to edit these WordPress functions to loop through items of a category of choice. You can have a look at the core – https://core.trac.wordpress.org/browser/tags/3.9.1/src/wp-includes/link-template.php#L0

If you want items to cycle between specific categories would require some advanced edits to the theme, it’s not very simple so it isn’t something I can just copy for you to paste into your theme, sorry ;(

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

More problems.

I have setup a portfolio – setup a page with my portfolio shortcode and portfolio category. This page displays fine.

However – clicked to open the full article takes me to my home page – happens with all the articles in the portfolio – the url is showing correctly.

What is going on?

This url is correct – the page it is opening is not:

http://www.thexxcorporation.com/portfolio/is-apple-still-cool-the-coolest-answer-is-not-to-care/

And, why am I not getting any response here. I though support was supposed to be good?

Very disappointed.

Mike

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Sorry to be a pain.

Still having difficulty with the shortcodes. Here is my headings code:

h1 { font-size: 130%; margin: 0 0 20px; } h2 { font-size: 120%; }

My page http://www.thexxcorporation.com has the following shortcode:

[symple_heading style=”double-line” title=”Who we are” type=”h1” font_size=”” text_align=”left” margin_top=”10” margin_bottom=”10” color=”undefined” icon_left=”” icon_right=”“]

It matters little what I do here (I’ve even tried putting the font- size within the heading shortcode – nothing) – I can’t make this header reflect the h1 or h2 or any h tag.

Again, am I missing something?

I’ve looking through every line of the style.css and can’t find anything that can sort this out.

Cheers,

Mike

BTW – I seem to have got the child theme working – many thanks for that.

Default-user

In fact – I’ve looked more closely at this. By just using a simple tag like H1 – the font size is correctly displayed.

However, trying to use the symple headers – results in just one style (the one shown on my site) – it matters not if any other element is selected such as double line for instance – only the one style displays – rather defeats the point of the header codes.

Mike

Default-user

Any suggestions, please?

WPExplorer

Hi Mike,

Oh on this specific theme there is some code overriding the header styles. The symple shortcodes plugin was updated recently and those header styles are new. I forgot impact altered these. The fix is simple. Send me a private message and I’ll zip over the updated theme. Please remind me when you email me what the issue is (lots of customers).

Sorry for the delay on this.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Attempting to setup up a slider using portfolio items.

I have selected portfolio items, selected the category.

I get ‘no slides found’ checked what sparse documentation there is – nothing of use in impact or slider documentation.

Suggestions, please?

nb I still seem to be getting no response from these requests.

WPExplorer

Are you trying to setup a slider on a portfolio post like this – http://wpexplorer-demos.com/impact/portfolio/full-width-slider/

Or are you trying to create a Revolution slider or portfolio items?

Default-user

No – I want the slider to show posts – the slider will be on a page – so, I have selected posts and category – no slides are found.

Currently, I have to manually create each slide – hardly user friendly.

I suspect this is either a theme issue of a Wordpress issue. I have tried alternative slider plugins – same problem. I have tried a different theme – same problem.

Any suggestions, please?

WPExplorer

Sorry I remember talking with you in the past via email and I see you have an open email without a response – shit! I will reply to your email right now.

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years

We’ve been using IMPACT for awhile now – great theme :-) Unfortunately after the last update we seem to be running into some issues.

1. I have one blog post out of order. The date is right, I’ve doublechecked several times and I also tried turning off post types order (which not only didn’t resolve the issue, but of course messes up the rest of the site :-). Any thoughts? Because this is a live site I haven’t wanted to try deactivating the theme….

2. Since the update the site doesn’t want to load quickly until after refreshing – it’s weird. It happens to home and to login. Not sure that has anything to do with the theme, but just mentioning it in case you have problems connecting.

http://www.duehrandassociates.com http://www.duehrandassociates.com/blog-3/ (may 14th post in middle of the page)
Default-user

We’ve resolved #2 but we still are struggling with number one. We tried to change the shortcode to hardcrop the thumnbails “true” – it put one blog post in order, but then put another one out…any ideas on this?

WPExplorer

Sorry for the delay!

Regarding the order, this layout is a masonry layout so items are placed the closest possible to the previous item, this can sometimes cause issues with order. What you can do though is add a min height to your items to keep them all in rows, such as this:

@media only screen and (min-width: 960px) {
    .recent-posts-entry-details { min-height: 180px; }
}
@media only screen and (max-width: 959px) and (min-width: 768px) {
   .recent-posts-entry-details { min-height: 220px; }
}
Default-user
siteducky Purchased

Thank you! I actually found that in our case, while we had gotten the images consistent, it was differing title lengths that was causing our continued issue. By adding html line breaks and nonbreaking spaces to the shorter titles, making all titles two lines, it fixed the date order!

WPExplorer

Nice ;)

by
by
by
by
by
by