127 comments found

Brilliant work mate, i have purchased you admin template with a Regular Licence. But i have a question, i would like to make it work with MySQL. I would like to make the login form work with mysql with the Form Validation you have on the this template.

Will have to make a js file to do this or not?

tzd
tzd Author

Thanks, i’m glad you like it. There is no server side validation included (just client side, you can use lga_validation function included in login.js and modify to your needs). You can integrate this Template with any server side language (php/asp/rubby …) and any database (MySQL/SQLite/PostgreSQL …)

Hello thanks, could you help with jquery login form to connect to a mysql database. I dont know how to do it, i have had a look in to it. Is it some thing to do with ‘submitHandler’. this is what i wrote but do i have to do to get it to work.

lga_validation = {
    init: function() {
            validator = $("#form_login").validate({
            submitHandler: function(form) {
                var username = lusername;
                var password = lpassword;
                $.post('mod/user.php', {username: username, password:password}, function(data) {
                    if(data.error){

                    } else {

                    }
                });
            },
            rules: {
                lusername: {
                    required: true
                },
                lpassword: {
                    required: true
                }
            },
            messages: {
                lusername: {
                    required: "<strong>Username</strong> is required (type anything)" 
                },
                lpassword: {
                    required: "<strong>Password</strong> is required (type anything)"    
                }
            },
            errorLabelContainer: $("#allErrors")            
        });
    }
}
tzd
tzd Author

Hi, submitHandler is a callback for handling the actual submit when the form is valid. I don’t know much about php/mysql but i think you should check if username and password stored in database match username and password entered by user and if they match you should redirect user to secured page.

biofunk Purchased

Hello, width of “select_a” element not equals width of “inpt_a” element in forms. Can you help me with this problem?

tzd
tzd Author

Hi, thanks for buying. To make this select width equal to other form elements width add this to style.css (v1.2):

.formEl_a select – width: 398px (line 205)
.formEl_b select – width: 318px (line 218)

Default-user
biofunk Purchased

Thnx for reply.

amik Purchased

nice template… so light… anyway.. can i make font bigger than this ?

tzd
tzd Author

Hi, thanks for buying. Base font (12px) is set in body (you can change it there). If you want to change other fonts size you can use firebug (http://getfirebug.com/) to find out where font size declaration is in style.css.

Hi all, I’m from Vietnam. I want to buy using your template but not Visa card. Now I do to have it. Thank you and look forward to help. Theme is great.

tzd
tzd Author

Hi, I think that you need a credit card to buy a template from themeforest thru Paypal.

qudoos Purchased

hi again, fieldset/legend does not seem to work. Anyone else has this issue?

tzd
tzd Author

Hi, can you post your code or link to your website? I’ve tested fieldsets/legend in ff3.6, ff5, ff7, ie8, ie9, opera, safari, chrome and it looks ok (ie7 it’s not ok, will fix it in next release)

JLBUK90 Purchased

Hi, Quick question I can’t seem to find the answer in the code, on the content slider, the alphabet only goes to P, but in the js code it goes to Z.

How do I fix this?

Thanks

tzd
tzd Author
Hi, thanks for buying.
Content slider in this demo uses custom items (a-p):
$('#contact_slider').sliderNav({items: ["a","b","c","d","e","f","g","h","i","j","k","l","m","n","o","p"]});
if you want to show full english alphabet (a-z) you just need to delete this items:
$('#contact_slider').sliderNav();
qudoos Purchased
I open the form.html file provided in the template. Add a field set as follows test

or anywhere in the form, it does not properly work. What I see is the word test without a border that usually shows with fieldsets. am I applying it wrong?

tzd
tzd Author
Hi, fieldsets should be set like this:
<div class="formEl_a or formEl_b">
  <fieldset>
      <legend>Fieldset, lorem ipsum...</legend>
          <div class="sepH_b">
              <label class="lbl_a" for="input_a">Label</label>
              <input name="input_a" class="inpt_a" id="input_a" type="text" />
          </div>
  </fieldset>
</div>
qudoos Purchased

I see

Fieldset, lorem ipsum…

without any border

(sorry I did not realize that my code did not show, I guess the site encodes it or removes it)
qudoos Purchased

I downloaded the template again and fieldset works. I might have screwed up something. Thanks for the support.

mandeepl Purchased

HI, I cant seem to configuer the file explorer, what do i need to change? thanks

tzd
tzd Author
Hi, thanks for buying.
This file manager is initilalized by this code:
$('#elfinder').elfinder({
    url : 'lib/elfinder/php/connector.php',
    lang : 'en'
});
Instead of using this connector.php You can use connector.minimal.php.
Replace this code in connector.minimal.php:
'roots' => array(
    array(
        'driver'        => 'LocalFileSystem',   // driver for accessing file system (REQUIRED)
    'path'          => '../files/',         // path to files (REQUIRED)
    'URL'           => dirname($_SERVER['PHP_SELF']) . '/../files/', // URL to files (REQUIRED)
    'accessControl' => 'access'             // disable and hide dot starting files (OPTIONAL)
    )
)
with this:
'roots' => array(
    array(
        'driver'        => 'LocalFileSystem',   // driver for accessing file system (REQUIRED)
        'path'          => ../../../../uploads/',         // path to files (REQUIRED)
    'URL'           => dirname($_SERVER['PHP_SELF']) . '../../../../uploads/', // URL to files (REQUIRED)
        'alias' => 'uploads',
    'accessControl' => 'access'             // disable and hide dot starting files (OPTIONAL)
        )
    )
In your root folder create folder “uploads” and give this folder read/write permision (chmod 777).
Extended documentation can be found here: https://github.com/Studio-42/elFinder/wiki
Elfinder forum: http://elrte.org/redmine/projects/elfinder/boards/2
azrael13 Purchased

I’m having a problem with the data tables and implementing a php/mysql connection.

As soon as I try and inject some php and mysql loop into the data table section of code all the jquery features break.

Is there something I am missing. I’ve done php and mysql with jquery before and have not had a problem. Could there be something specific to the data table js that I’m not aware of.

Any help you could pass along would be greatly appreciated.

Oh and I wanted to add how I love this template.

Cheers.

tzd
tzd Author
Hi, thank you for buying Lagu Admin Template. I think that the problem is with the number of columns. In el_table.html there is a data source (type based) sorting aplied:
$('#data_table').dataTable({
    "aaSorting": [[ 1, "asc" ]],
    "aoColumns": [
        { "bSortable": false }, //1 column
        null, //2 column
        null, //3 column
        { "sType": "formatted-num" }, //4 column
        { "sType": "formatted-num" } //5 column
    ]
});
There is 5 columns in this example, if you do not have 5 column or your data is diferent than used in this example you need to adjust this option "aoColumns": [] or remove this option. I hope that helps. More info about sorting: http://datatables.net/plug-ins/sorting

Hi Tzd

I love the theme – I have 1 question though. Every time I load a page, all hidden content (e.g. collapsed menu items in sidebar) displays for a moment and then hides. Is it possible to get rid of this ‘flicker’?

Keep up the good work.

tzd
tzd Author

Hi, thanks. I fixed this ‘flicker’ (this fix will be included in next release).

valbercj Purchased

Dear Friend,

The tynemice and upload form doesnt work.

tzd
tzd Author

Hi, what do you mean by “The tynemice and upload form doesnt work”. File explorer is not working? (I posted my answer regarding file explorer few comments above).

Really like this template will purchase asap. Good job!

tzd
tzd Author

Hi, thanks. I’m glad you like it.

I cant see the left menu for switching bgs and fixed / fluid layout on mine. Any tips for getting this working?

tzd
tzd Author

Hi Shaun, thanks for buying. Style switcher is not included. I will send you html file with this style switcher asap (I will include this file in next update).

atomaka Purchased

With the latest update, button sizes are not matching up with a tags that are emulating buttons (on Chrome at least). You can view an example of this by going to the forms link on your preview and seeing the three buttons at the top of the page. The button is sized differently than the two a tags. In a previous version, all three of these buttons matched sizes.

tzd
tzd Author
Hi, sorry for that. I was testing something and forgot to delete height from:
.btn_a,.btn_b,.btn_c,.btn_d {font:700 12px/25px Helvetica, Arial, sans-serif;height:25px}
.btn_aS,.btn_bS,.btn_cS,.btn_dS {font:100 11px/20px Helvetica, Arial, sans-serif;height:20px}
.btn_aL,.btn_bL,.btn_cL,.btn_dL {font:700 14px/32px Helvetica, Arial, sans-serif;height:32px}
It should be:
.btn_a,.btn_b,.btn_c,.btn_d {font:700 12px/25px Helvetica, Arial, sans-serif}
.btn_aS,.btn_bS,.btn_cS,.btn_dS {font:100 11px/20px Helvetica, Arial, sans-serif}
.btn_aL,.btn_bL,.btn_cL,.btn_dL {font:700 14px/32px Helvetica, Arial, sans-serif}
I will include this fix in next update.
stewart Purchased

In your example have the Template options: on the left running when the Lagu buy your Admin find that this option is not working, change background color, fluid etc.

At,

STEWART

tzd
tzd Author

Hi, thanks for buying. Style switcher will be included in next update.

whips Purchased

tzd, nice template, I have been using with no problems so far, but now I have one small question. I want to add a custom validation method to the form validator in addition to the “required”. Can you point out how I can achieve this? Thank you.

Never mind, I found out how to do it. Thanks for a wonderful template
whips Purchased

TZD , There is one thing I would like to achieve but is unable to. Can you tell me how to get 2 tab instances on a single page. I have tried to follow the documentation but I couldn’t get it to work. When I put 2 tab instances, a click in the first tab instance is affecting tabs in the second tab instance, but I want the two instances to be independent. Thanks in advance for your help.

tzd
tzd Author

Hi whips, it’s true what aliosa27 says but you can do this easy way:

You just need one JS call for tabs:
$(".tabs").flowtabs("> .pane");
and html code:
<ul class="tabs cf tabsB">
    <li><a href="#">Tab A 1</a></li>
    <li><a href="#">Tab A 2</a></li>
    <li><a href="#">Tab A 3</a></li>
</ul>

<div class="pane cf">
    <div class="dp50">
        <ul class="tabs cf tabsB">
            <li><a href="#">Tab B 1</a></li>
            <li><a href="#">Tab B 2</a></li>
            <li><a href="#">Tab B 3</a></li>
        </ul>
        <div class="pane">
            tab B 1 content
        </div>
        <div class="pane">
            tab B 2 content
        </div>
        <div class="pane">
            tab B 3 content
        </div>
    </div>
    <div class="dp50">
        <ul class="tabs cf tabsB">
            <li><a href="#">Tab C 1</a></li>
            <li><a href="#">Tab C 2</a></li>
            <li><a href="#">Tab C 3</a></li>
        </ul>
        <div class="pane">
            tab C 1 content
        </div>
        <div class="pane">
            tab C 2 content
        </div>
        <div class="pane">
            tab C 3 content
        </div>
    </div>
</div>

<div class="pane">
    tab A 2 content
</div>

<div class="pane">
    tab A 3 content
</div>

Example page: http://tzd-themes.com/lagu_admin/index.php?uid=1&page=multiple_tabs

by
by
by
by
by
by