315 comments found

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • United Kingdom

Hi there,

Thanks for the theme, I now have this up and runnig on my site and I love it.

However, when I use the pop-up theme changer panel when logged in as an admin on the store front and try to change the background image my site crashes! I then need to contact hosting to re-instate it.

Can you help with this please?

nicole_89

Hi

How does the website crash or is the browser crashing? Send me your store url and temporary admin access using the contact form on my profile page and I will check what is wrong.

spedward

Thanks for offering your assistance. It was when I was using the “Customise Theme” popup when viewing the store front… when clicking “Save” it was breaking the website and I had to ask hosting to fix. It doesn’t seem to be happening any more so I am wondering if it was something to do with hosting – a little confused to be honest.

I will let you know if it happens again and provide steps to replicate.

Thanks

nicole_89

Probably there was some problems file permissions, customize theme needs write permissions on some files and probably when saving it changed permissions or ownership and the http server couldn’t read the generated css file, if it’s fixed by the hosting provider probably it will not happen again.

spedward

yup, every time when I emailed support they told me “they cant see the problem” and it always seemed to magically fix itself just before they had a look at it. They are opencart hosters with a strict SLA – so it is funny they never see the issue but it magically resolves when opening a ticket lol

nicole_89

Probably they have different file ownership/file permission for http server and php and they change file permissions/ownership back every time you open a ticket :)

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi – are you able to give me the steps to removing the search box? thanks

nicole_89

Hi

You need this feature on nicole fashion or nicole shop?

Default-user

I was hoping not to have it on the homepage at least is this possible?

nicole_89

I also added search hide option to nicole fashion, the update with the new feature will probably be approved in a few hours, check last update section on theme page and redownload the theme from themeforest.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Is there a possibility that the mobile menu can work just like the one on the Nico theme? As that menu works more user-friendly on mobile devices so as the iphone.

nicole_89

I will add this feature in the next update probably next week.

Default-user

Cool, thanks!

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • United Kingdom

Hi again,

I have searched your comments / help files but cant find an answer.

I was wondering how I can remove the zoom feature on product pages?

Thanks

nicole_89

Hi

You can change product page image gallery to Opencart default gallery or Flexslider from customize theme > sliders & gallery > product page.

spedward

Superb! I totally missed this before. Really love your theme. Thanks again

  • Bought between 10 and 49 items
  • Has been a member for 0-1 years

Hello,

I was just wondering if it’s possible to make the footer stretch across the whole screen?

We would like to have a footer background color, but have it stretch across the entire page rather than just in the middle.

Thanks!

nicole_89

Hi

The layout is boxed but you can make the footer expand by adding the following css in stylesheet/stylesheet.css

div#container 
{
    width: auto;
}

div#menu 
{
    margin: 0 auto;
    width: 1060px;
}

div#header {
  margin: 0 auto;
  width: 1000px;
}

div#content 
{
  margin: 0 auto;
  width: 1000px;
}
Default-user

Thanks for the response!

That has fixed the footer, but now the responsive site is too wide.

Is there something I can add to ‘responsive.css’ to fix that?

nicole_89

You can wrap the wide css into a media query to make it work only for desktop @media (min-width: 1000px)

@media (min-width: 1000px)
{
    div#container 
    {
        width: auto;
    }

    div#menu 
    {
        margin: 0 auto;
        width: 1060px;
    }

    div#header {
      margin: 0 auto;
      width: 1000px;
    }

    div#content 
    {
      margin: 0 auto;
      width: 1000px;
    }
}
  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
mabii Purchased

Hi Nicole,

I’m trying to use your theme with a store that’s part of a multistore configuration. The theme configuration panel doesn’t show up when I view the store, even though I’m logged into the admin panel. I think it’s because the domain name of the store is different from the domain name of the admin panel when using multistore. What should I do? Thanks!

nicole_89

Hi

The reason for the panel not showing up is that the admin and the store are on different domains/subdomains and the session cookie with the admin authentication is not shared between admin and theme panel from frontend.

I don’t know any other solution than having the same domain for both. If your store is not live yet you can force the panel to always be visible then make your changes to the theme and hide it after you finish. You can make it visible by changing

define('HAS_PERMISSION', $user->hasPermission('modify', 'design/layout'));

to

define('HAS_PERMISSION', $user->hasPermission('modify', true));

in /nico_theme_editor/editor.inc

Default-user
mabii Purchased

Thanks for your reply! That fix didn’t quite work, so I used define('HAS_PERMISSION', true);. I’ll ask the OpenCart people about whether the admin panel can be on the same domain as the store, when using multistore. Currently if you go to secondstore.com/admin it redirects to mainstore.com/admin and you get another session cookie. But maybe the redirection can be disabled without causing any trouble.

nicole_89

Sorry, I copy pasted the wrong code, it hat to be true like you set it.

You can try disabling the redirection, I don’t understand why it needs to redirect to another domain and not use the same as the one from front end, maybe the opencart developers can give you an answer.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
kels83 Purchased

Hi Nicole,

I found the responsive is not work well, i’m trying on iphone and ipad, while switching from portrait to landscape, it won’t automatic fit to screen, may i know is it opencart compatible problem? i’m on 1.5.5.1

Thanks

Default-user
kels83 Purchased

what i mean is rotate the phone or tablet

nicole_89

Hi

The theme is compatilbe with 1.5.5.1, the problems on mobile show only after rotate or they also show if you load the page directly in landscape mode?

Could you also send me a screenshot? and also iphone/ipad and safari version would be helpful.

Default-user
kels83 Purchased

the problem solve after replace

<meta name=”viewport” content=”height=device-height, width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no” />

now another problem is, if load page directly in landscape and rotate to portrait (product page) it having this problem

http://x-cow.com/~ellonest/tmp/IMG_1035.PNG

nicole_89

Does this problem happen only after rotate or also when loaded directly?

Default-user
kels83 Purchased

load directly in landscape ok and rotate to portrait problem

Default-user
kels83 Purchased

Hi Nicole,

Already reply your email with screenshot attached, hope you able to help me out there.

Thanks

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
mabii Purchased

Hi Nicole,

I’m running the latest version of OpenCart from github. On a fresh install I’m receiving the following error:

Notice: Undefined property: Loader::$model_localisation_language in [...]/upload/catalog/view/theme/nicole-fashion/nico_theme_editor/editor.inc on line 220

Any advice? Thanks

nicole_89

Hi

Probably you are using opencart 2.0 or some other unreleased branch of opencart, the theme only works with 1.5.6.1 or below.

Unfortunately I don’t know what changes are made to the latest opencart version to give you a hint on what to change but to get rid of the above notice you can disable the theme editor by removing the includes to editor.inc from header.tpl and other template files.

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
mickym Purchased

Hi Nicole

just like you provide options to disable display of powered by in footer, is there a way to disable affiliates, brands, etc.? I found 2 vqmod xml freebies to do that but they dont like themes i think…

thanks

nicole_89

Hi

You mean the links from footer? These are very easy to remove, just edit /template/common/footer.tpl line 66 and remove

      <li><a href="<?php echo $manufacturer; ?>"><?php echo $text_manufacturer; ?></a></li>
      <li><a href="<?php echo $voucher; ?>"><?php echo $text_voucher; ?></a></li>
      <li><a href="<?php echo $affiliate; ?>"><?php echo $text_affiliate; ?></a></li>
      <li><a href="<?php echo $special; ?>"><?php echo $text_special; ?></a></li>

Or if you want to remove the whole extras column delete from line 63 to 71

  <div class="column">
    <h3><?php echo $text_extra; ?></h3>
    <ul>
      <li><a href="<?php echo $manufacturer; ?>"><?php echo $text_manufacturer; ?></a></li>
      <li><a href="<?php echo $voucher; ?>"><?php echo $text_voucher; ?></a></li>
      <li><a href="<?php echo $affiliate; ?>"><?php echo $text_affiliate; ?></a></li>
      <li><a href="<?php echo $special; ?>"><?php echo $text_special; ?></a></li>
    </ul>
  </div>
  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
mabii Purchased

Thanks again for the five-star support!

nicole_89

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • United Kingdom
spedward Purchased

Hi there,

On the products images page I am getting the little thumbnail scrolling area even know the listing only has one image. This wouldnt be such a problem only the thumbnail image for the ONE main image also is not being displayed in the thumbnail scrolling section either.

Can this be fixed?

nicole_89

Hi

This is fixed in the next update, the thumbnail will not be shown if there is only one product image.

The should be approved in a few hours, after that you need to download the theme again and update template/product/product.tpl

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Is there a possibility to show the attributes/ specifications tab as the first tab and the description tab as the second tab?

nicole_89

You can do this by editing template/product.tpl line 464 and change

<div id=”tabs” class=”htabs clearfix”><a href=”#tab-description”><?php echo $tab_description; ?></a>
<?php if ($attribute_groups) { ?>
<a href=”#tab-attribute”><?php echo $tab_attribute; ?></a>
<?php } ?>

with

<div id=”tabs” class=”htabs clearfix”>
<?php if ($attribute_groups) { ?>
<a href=”#tab-attribute”><?php echo $tab_attribute; ?></a>
<?php } ?>
<a href=”#tab-description”><?php echo $tab_description; ?></a>

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
mickym Purchased

Hi again,

when we add a URL to a new menu option, is there a way to force it to open into a new tab.

thanks.

nicole_89

Hi

I added a new option for menu editor to choose link target, the update should be approved in a few hours, files changed

Default-user
mickym Purchased

hi nicole – thanks for updating the theme – unfortunately it is not saving the _blank – it defaults to _self and stays like that. theme editor says saved, i refresh, it goes back to _self.

nicole_89

Hi

Sorry, I rushed to add the feature and I missed some bugs, I fixed it and just tested on my demo store, the update should be available in a few hours, you can check last update section theme.

After update you need to update the same 3 files as in the previous update.

  • Has been a member for 0-1 years

Hello Nicole,

I am using Opencart 1.5.6.1 with the theme ‘Nicole-fashion’ with Safari browser on Mac. I receive the error displayed below in the checkout page as soon as I choose either Registered account or Guest checkout and press continue. I highly appreciate any clue as to why I am getting this error. I checked all the settings and researched the net but couldn’t get a resolution.

SyntaxError: JSON Parse error: Unrecognized token ’<’

OK

{country_id Dawhah”,code Ghuwayriyah”,code Jumayliyah”,code Khawr”,code Wakrah”,code Rayyan”,code al Batinah”,code ash Shamal”,code Said”,code Salal”,code width=”4” height=”5”><param name=”movie” value=”//www.youtube.com/v/12iSsN5scTU?version=3&hl=en_GB&rel=0” ></param><param name=”allowFullScreen” value=”true”></param><param name=”allowscriptaccess” value=”always” ></param><embed src=”//www.youtube.com/v/12iSsN5scTU?version=3&hl=en_GB&rel=0” type=”application/x-shockwave-flash” width=”4” height=”3” allowscriptaccess=”always” allowfullscreen=”true” autostart=”true”></embed></object>

<script> (function(i,s,o,g,r,a,m){i[‘GoogleAnalyticsObject’]=r;i®=i®||function(){ (i®.q=i®.q||[]).push(arguments)},i®.l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,’script’,’//www.google-analytics.com/analytics.js’,’ga’);

ga('create', 'UA-45956425-1', 'fortheloveoflolly.com');
ga('send', 'pageview');
nicole_89

Hi

Please the account from which you made the purchase to ask support questions.

Thank you

Default-user

Thanks Nicole for your reply. The theme is used for the site www.fortheloveoflolly.com. I have not been involved in the purchase of the theme. I was asked by the owner of the site to handle its maintenance so I am not sure if the original developer has purchased it via www.fortheloveoflolly.com or some other account. Would you be able to find out by checking the site name? Otherwise, I need to ask the owner to get in touch with the person who purchased the theme.

Best regards.

Default-user

Hi again Nicole. I just saw a post from (305evon1000) to which you have replied with regard to a query relevant to the site www.fortheloveoflolly.com. So I presume the site is eligible for support?

nicole_89

Hi

I still need purchase confirmation because of sale reversals, you can either ask 305evon1000 to confirm or send me the purchase code trough my contact form

Thank you for understanding.

Default-user

Thanks Nicole. Will do.

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • United Kingdom
spedward Purchased

Hi there,

I am using the Cloud Zoom on the Product page.

I have recently downloaded a popular extension that swaps the main image with the “product option” image selected and also provides a different type of zoom.

The “product option” image swap works fine but the zoom doesn’t.

Reading the extension notes it states: Please remember that vQmod extensions are NOT stand-alone plug-ins. They depend on a search for lines of code that exist in the core “source” code. If the core code has been changed or if another vQmod extension needs to modify the same line then it is possible the extension will fail.

To this effect would you be able to tell me if this new vQmod extension is being effected by something that is already installed in your theme and if so, how I can remove the conflict?

Thanks

nicole_89

Hi

There is probably a minor difference like an extra new line from the original code.

You can post vqmod errors from the vqmod log so I can see what code the vqmod extension fails to find and I will change the code so that it will match.

spedward
spedward Purchased

Thank you so much for your help. Really is second to none. Here are the errors requested:

*5_Fri.log -- Date: 2014-04-11 10:54:02 ~ IP : 82.43.147.171 -- REQUEST URI : /index.php?route=product/product&path=70_76&product_id=79 MOD DETAILS: modFile : /home/s534771/public_html/vqmod/xml/product_image_swap_zoom.xml id : product_image_swap_zoom version : 1.0BETA vqmver : 1.0 author : ocextensions.co.uk

File Name : catalog/view/theme//template/product/product.tpl(0) VQModObject::applyMod – SEARCH NOT FOUND (ABORTING MOD): id=”image” />

MOD DETAILS: modFile : /home/s534771/public_html/vqmod/xml/product_option_alt_image_swap_zoom.xml id : product_option_alt_image_swap_zoom version : 1.0BETA vqmver : 1.0 author : ocextensions.co.uk

File Name : catalog/view/theme//template/product/product.tpl(1) VQModObject::applyMod – SEARCH NOT FOUND (ABORTING MOD):

nicole_89

I downloaded the extension and tested the xml, all search strings match with the current version of product.tpl, from the error message I see that the file vqmod tries to change has an invalid path, is missing theme name.

catalog/view/theme//template/product/product.tpl

I don’t have much experience with vqmod so I don’t know why the path is invalid, you can try editing product_image_swap.xml directly and hard code the theme name inside

search for

catalog/view/theme/*/template/product/product.tpl

and replace with

catalog/view/theme/nicole-fashion/template/product/product.tpl
spedward
spedward Purchased

Hi there, this unfortunately didn’t work. Could you explain how to remove the cloud zoom function instead?

nicole_89

You can enable the default opencart gallery for product page image gallery from customize theme > Sliders & Gallery > Product page > Opencart default gallery

spedward
spedward Purchased

Is there a way to keep the Cloud style just without the zoom?

nicole_89

You can disable it by setting position to anything except inside, for example right and both Width of the zoom window and Height of the zoom window to 0 (zero) in customize theme > sliders > cloud zoom

by
by
by
by
by
by