857 comments found

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi, I’ve set-up a gallery but there is a problem with how it displays when clicked.

The gallery style I’m trying to get is like your demo: http://cadengrant.me/themes/photorific/gallery-with-thumbnails/

and the page is laid out in the same way but there are no next/prev buttons or thumbnails overlayed nor are there page 1-2-3 buttons at the base.

How do I implement the style?

Also, I don’t seem to be able to apply a background image to gallery pages (I’d like to put a wildlife image on the wildlife gallery, landscape background to the landscape gallery etc)

Thanks Rich

CadenGrant

What is the URL of your gallery?

To get the lightbox next/prev buttons and thumbnails, etc, you need to open up the gallery.php file and taxonomy-gallery_category.php file and find where it says rel=”prettyPhoto” and change it to rel=”prettyPhoto[gal]”

As for the pagination, you have to have a certain number of images added. To set the number of images you want to display on the gallery page before the pagination is displayed, you’ll need to go into the “Photorific” admin options in your WP dashboard, and under the “Gallery Options” tab, enter the number of images you want to be displayed on your gallery/gallery category page.

Unfortunately, with Photorific, gallery pages can’t have custom background images, they just use the default background image set in the admin panel.

Default-user

Thanks Caden. I’ll give it a go with the styles. It’s a shame about the custom background image. Can I use the homepage slider?

http://www.richardjanephotography.com
CadenGrant

Only the default background image will be shown on gallery pages unless you hardcoded it in to customize the background images for different categories. Maybe by using is_category if you have any basic PHP or WP experience.

Otherwise, sorry.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 50 and 99 items
  • Has been a member for 2-3 years

Hi,

Sorry but I can´t activate the gallery with thumbnails as shown here: http://cadengrant.me/themes/photorific/gallery-with-thumbnails/ ? I’d just be happy being able to have next and previous image functions.

CadenGrant

To get the lightbox thumbnails as well as the next/prev arrows, open up portfolio.php and search (ctrl + f) for rel=”prettyPhoto”, and replace it with: rel=”prettyPhoto[gal]” and that should do it.

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
  • Italy

Hallo Caden,
my name is Andrè. I decided to buy your beautiful theme for the functionality that you published in your demo, specifically in “Gallery with thumbnails” page (http://www.cadengrant.me/wpthemes/?theme=Photorific).
So my question, that has been made by tens of users but I have not yet understood, is: how do you create a gallery exactly the same (with title page and the thumb of the same category) to your published here?

I’m trying to figure out how to do it for days, I read your documentation many times but I am not yet able to deliver my work.
Can you help me, please?

Thanks

CadenGrant

I’m sorry but I’m not quite sure what you mean. Do you mean you want the title to show on the gallery page? If so, you need to open up gallery.php, and on line 10 you’ll see this:

<div class="fullwidth_content">
            <div class="blog_post">

Change it to this:
<div class="fullwidth_content">
<?php the_title(); ?>
            <div class="blog_post">

</div></div></div></div>
  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
mcedin Purchased

I miss the swedish letters in headlines. The problem shows in headlines, menu. Tried to find a solution, by change the font – no one works.

CadenGrant

Download the Bebas Neue font here: http://www.dafont.com/bebas-neue.font

Then generate the cufon file here (make sure you select the correct characters): http://cufon.shoqolate.com/generate/

Then reupload the generated file to the themes /js/ folder overwriting the previous font cufon file.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Caden,

Love this theme, it’s awesome. I was wondering if there’s a simple solution to have posts on the blog page as short Summary’s with a ‘read more’ option rather than full text?

Any help would be greatly appreciated, thanks!

Steve http://www.stephenarmenti.com
CadenGrant

Hey Steve

You could do that yes, check out the_excerpt function codex here: http://codex.wordpress.org/Function_Reference/the_excerpt
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi Caden,

I sent you an e-mail yesterday, but have since read all the posts and understand that this is the best way to contact you (I also see that you work hard for your money!).

I love the theme and documentation, but am having three specific issues:

1) When I create a mew menu sidebar (or even use and existing one) it does not render properly. The menu items appear to be spaced erratically (though in the correct order) and the lines and arrows seem to appear in random locations. Any idea what I’m doing wrong?

2) I cannot get me portfolio items to order properly. I made the code fix that you’ve posted here to the portfolio.php file, but it hasn’t fixed it. I also see that you’ve suggested the same code modification to the taxonomy-portfolio_category.php file, but I haven’t made any changes to that file since I can’t find the code to replace in that file (it isn’t there).

3) I love the Photorific settings menu, but when I make changes to background color, font color, etc. they don’t take effect. I have to make them manually in the CSS file. Am I doing something wrong?

Again, love the theme, and anxious to get it up and live.

Robert

P.S. – For now I have the site on a server on my local drive, so I’m not sure I can provide you with a link…

CadenGrant

Instead of sending me a link could you take a screenshot for me so I can see what the menu is doing?

Did you change the order of the images in the “Page Attributes” section in the order input box?

For your third question, that just means the theme was installed incorrectly. When you install the theme via WP theme installer, it doesn’t work. You need to upload via FTP .

OR, you could just take the “picturethis” folder inside the main .zip file you downloaded from here on ThemeForest, zip it, and then upload that via the WP theme installer.

Also, for some reasons, whenever I’ve tested WordPress themes on localhost, they’ve messed up quite a bit so that could be affecting some of your other problems you’re having as well.

  • Bought between 10 and 49 items
  • Canada
  • Has been a member for 3-4 years

Hey Caden,

Unreal theme dude, so rad.

I have one quick question, is there a quick and easy way to change the menu font size? I’ve done some hunting around through the code and it appears to be all linked to the Cufon width and height.

Thanks again for your hard work, everything looks awesome!

-Brandon

CadenGrant

Thanks man appreciate it :)

In the style.css file, around line 240, you should see this:

#sf-menu ul li a strong {
    font-size: 18px;
    color: #fff;
    display: block;
    z-index: 300;
}
#sf-menu ul li a span {
    clear: left;
    font-size: 14px;
    color: #a0a0a0;
    margin-left: -3px;
}

Change the font size there :)

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
mmilin Purchased

Hi, I probably missed something … I defined 3 gallery categories with photos in each but the name of the categories are not displayed on the top of the pages. Could you help please ?

Another question : i would like to have one gallery with two columns, another with 3 columns, and again another with thumbnails. I don’t if it is possible and how ?

Thanks in advance Mikaël

CadenGrant

Category titles are not listed on the tops of category pages. To do this, you’ll need to open taxonomy-gallery_category.php or taxonomy-portfolio_category.php (if you’re using gallery custom post type or portfolio custom post type) and in that file in the #content div, add this line:

<?php printf(__('%s', 'framework'), single_cat_title('',false)); ?>
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Caden:

An update from my previous post and additional questions:

1) Regarding the menu. It still does not render properly. Upon investigating further the issue arises, when menu items are indented in the Appearances -> Menu area. In other words, a list will render properly if they are all on even ground as far as hierarchies, but the moment a sub-menu is created (via indenting) the arrows and lines in the menu rendering are thrown off. Still trying to get to the bottom of this one…

2) I solved the ordering of portfolio items by downloading the “Post Types Order” widget. Works like a charm.

3) I never did get the color menu to work, but just modified the CSS

As for new items:

1) Is there an easy way to modify the Photorific – Recent Posts widget to display specific portfolio items as opposed to blog posts?

2) Is there an easy way to shut off the feature where photos are opened in a black box when clicked on?

Many thanks, loving the theme and learning a lot through the process.

Robert

CadenGrant

Instead of sending me a link could you take a screenshot for me so I can see what the menu is doing?

For the color, I just responded to your last comment which explains how to fix this.

For widgets, you could do that, but you’d have to go in and modify the widgets file in /framework/functions/widgets.php and customize the query to pull ‘portfoliocpt’. In the widgets file where it says $r = new WP_Query($query); if ($r->have_posts()) : ?>

Try changing that to this and see if it works for you:

$args = array(
    'tax_query' => array(
        array(
            'taxonomy' => 'portfoliocpt',
        )
    )
);
$r = new WP_Query( $args );

Are you clicking to the prettyPhoto lightbox that opens when portfolio images are clicked? If so, yes it’s possible but it depends what you want it to do instead. Let me know.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Thanks Caden.

1) I’ll send a screenshot image by e-mail.

2) I’m going to try the reinstall once I have the site up on my hosting server (wanted to get the design close before uploading).

3) I tried changing the widget code as you suggested, but now everytime I try to view a page I get this error:

Parse error: syntax error, unexpected ’<’ in [.....]\wp-content\themes\Photorific\photorific\framework\functions\widgets.php on line 27

Note: I omitted the earlier parts of the file path (in brackets above).

4) Lastly, yes, I’m clicking on the lightbox. I’d prefer it either does nothing, or links to the single portfolio page

Many thanks,

Robert

CadenGrant

Sorry I haven’t gotten back to you. I’ll check your email shortly.

I don’t remember the code, but if you show me I’m sure I could find what’s putting out that error. What it basically means is you have an extra < floating around in your PHP code that shouldn’t be there.

4) You can open up the page template, and remove the <a href=”” rel=”prettyPhoto”> and then the ending a tag </a> or just change the path of the URL to the_permalink();

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Probably a crazy stupid question, but I’m going to ask it anyway. Is it possible to make every page like the homepage, with the full screen slideshow?

For example: You make a portfolio and you put the links in the bar on the left so you do not need a gallery.

Credits for making such a beautiful theme!

Thanks.

CadenGrant

I’m not completely sure what you mean? Whatever you want to do should be possible, you’d just have to edit some code most likely.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
  • Ireland

Hi,

I have just purchased your theme, and I have used other themes before but I can’t seem to get the background images up or the navigation menu! I have gone through the documentation attached and I’m just at the very begining stages, any of the images I have uploaded have not come up. im sure its something simple i’m missing and any help would be great.

CadenGrant

What is the URL of your website and I’ll take a look?

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

Default-user

Hi,

I think what the problem is, is that I installed it to greendragonacademy.com and then I couldn’t find the problem, so I uninstalled the theme (deleted it) and tried to re-upload it but couldn’t do so. Is there any way to fix this?Thanks so much

CadenGrant

Chances are you maybe have a plugin installed that is keeping it from working. If so, try disabling any plugins you have until it starts working.

If this doesn’t work and you still need help, please submit a thread at the support forums here: http://www.stunningwp.com/support

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Caden:

OK, I’ve reinstalled the template and did so on my hosted server.

1) the color picker now works (the key was to install only the unzipped “photorific” folder, not the unzipped “Photorific” folder. On top of that, it was essential to delete the pre-existing index.php to get the theme to work.

2) I’m still having trouble with the widget code replacement you sent. It doesn’t work and in fact prevents all pages (even admin pages) from viewing (I just get the “parsing error”). Keep in mind I’m a coding novice (less than). I’d really like to get this to work.

3) Re: Lightbox, I deleted something like rel=pretty phot from portfolio.php and from the portfolio taxonomy file. This has the desired effect, but for the fact that every time a portfolio image is clicked, the browser reloads the page. I’d rather it just not even be an option to click the thumbnail.

4) Menus are still an issue (I sent some screen shots to your g-mail yesterday, is that the right address?)

Many thanks,

Bert

CadenGrant

I’ve responded to your other comment about this I’m pretty sure.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
Glennlrc Purchased

Hey I bought the photorific theme the other day, zipped the file, tried to upload it to my wordpress site, and kept getting this message:

Unpacking the package…

Installing the theme…

The package could not be installed. The theme is missing the style.css stylesheet.

Theme install failed.

I checked the folder of the theme and saw a .css file so I’m not sure what the problem is. Can you please tell me what the best course of action is?

Glenn

CadenGrant

As rdeforest said:

"Here’s what worked for me:
1) First, unzip it to a folder on your desktop (or elsewhere on your computer)
2) You should see four folders inside the unzipped “Photorific” folder (“documentation”, “license”, “photorific”, and “PSDs”)
3) Of these four folders, upload only the “photorific” folder via FTP to: [your site]/wp-content/themes
4) Login to the admin area of your site and activate the theme
You may first want to delete the theme folders that you tried to install previously.
Hope that helps.
Bert

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Glenn-

Here’s what worked for me:

1) First, unzip it to a folder on your desktop (or elsewhere on your computer)

2) You should see four folders inside the unzipped “Photorific” folder (“documentation”, “license”, “photorific”, and “PSDs”)

3) Of these four folders, upload only the “photorific” folder via FTP to: [your site]/wp-content/themes

4) Login to the admin area of your site and activate the theme

You may first want to delete the theme folders that you tried to install previously.

Hope that helps.

Bert

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

i just buy your theme, and i cant display any picture on the site..

can you give me manual how to use this theme

thanks

CadenGrant

The manual is included with the download from ThemeForest in the “documentation” folder.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Caden

Thanks for your support so far although I do have another question.

There is a problem with the sub-menu on my site where the sub-menu drops well below being inline with the menu item: Worst example here: http://www.richardjanephotography.com/?page_id=19

From this page, if you hover over the ‘Portfolio’ menu item, you’ll see that the sub nab is inline with the link to ‘Blog’ and not ‘Portfolio’ and is difficult to click on.

I expect that I need to update the css to an updated version but I have customised some elements and don’t want to replace the whole Theme files.

Could you tell me where I can find the code for just the sub-menu and where it is told to sit on the page?

Thanks Rich

CadenGrant

Open up the style.css file, and on line 225 you’ll see:

#sf-menu ul li ul {
    position: absolute;
    margin: 20px 0 0 224px;
    width: 18em;
    background-color: #000;
    border-color: transparent;
    z-index: 99999;
}

Try changing the margin: 20px to margin: 0 or margin: -10px until you find the right one.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

Default-user

Perfect thanks! sorted.

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

...and another!

http://www.richardjanephotography.com/?page_id=19

Can’t get the blog page to display a default (which is set and works on gallery pages) or custom image.

Thanks Rich

CadenGrant

Sorry but I’m not sure what you mean by “display a default”. If you want to create an account on the support forums here, and start a new thread explaining a bit more what you mean then I’d be glad to get it sorted for you.

Default-user

Caden

Apologies for the brackets confusing things. I can’t get the blog page to display a default background image or a custom image.

http://www.richardjanephotography.com/?page_id=19
CadenGrant

I don’t mean to make this more difficult for you or take too much time, but could you submit this question to the forums? I’m trying to get all support moved over to the forum as there’s a search function which should help finding solutions to problems. Hope you understand. You can sign up here: http://www.stunningwp.com/support/ and I’ll help you as soon as I can.

Thanks

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi,

I bought your Theme today and it is very beautiful! Can you assist me to add the 2nd. level navigation in the menu? I can only add items on the first level…

thanks a lot! André

CadenGrant

Once an item is added to a menu, those menu items can be rearranged. Placing the mouse cursor over the menu item title, when the mouse cursor changes to 4-arrows, hold the left-mouse button down, drag the module to where you want to place it, then release the mouse button (this is called drag-and-drop). Remember you can drag a menu item slightly to the right of the menu item above it to create a hierarchy (parent/child) relationship in the menu.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

  • Bought between 1 and 9 items
  • Canada
  • Has been a member for 2-3 years
leelou Purchased

Hi Caden,

1. Is there a way of having 2 gallery pages – either completely separate galleries, or one ‘gallery category’ of gallery items on one page, and other ‘category gallery’ items on another page? I can’t figure how to do this. 2. Also when you have a “submenu” with 2 items – Can I have a drop down menu without the parent leading to any page – even a blank? 3. Still trying to get thumbnails of posts to appear on the sidebar….where do I set that?

Thanks!

CadenGrant

For your first question, yes it is possible to have separate gallery pages. Just create your gallery category, and make sure you have a few posts in them.

Then navigate to “Appearance > Menus” in your WP dashboard, and in the top right corner of your screen, click the tab that says “Screen Options”. Make sure in this drop down you have it selected to display gallery category pages. Then it should list them under your pages and posts, etc. Just add them to your menu and that will do it.

2) I’m not exactly sure what you mean here? Can you explain a bit more?

3) You need to use the “Photorific – Popular Posts” and “Photorific – Recent Posts” widget to display thumbnails. Also, the thumbnails that are displayed are called featured image. So in your post, on the right under “Featured Image”, click the “Set featured image”, upload the image you want to use for that post, and select “Use as featured image”. That should fix your problem.

PS. Feel free to subscribe to my newsletter and I’ll keep you up-to-date with theme updates, new themes and even some freebies!

Also, from now on, all support requests will be dealt with on the support forums here, so be sure to register for future support.

by
by
by
by
by
by