Discussion on Purity: Responsive, Clean, Minimal & Bold WP Theme

2599 comments found

Hello, I have a few pre-purchase questions, please. 1. Does this theme support child themes? 2. Does the portfolio post type support post_tags? If so, can the portfolios be filtered by tag? 3. What is the default single portfolio layout and can it be set? Thanks so much in advance, Cecile

Veented

Hello Cecile,

Thank you for the interest!

1. Yes, it does. :)

2. I’m sorry but portfolio can be only filtered by categories.

3. The default one is the right sidebar one. But you may of course change it to left sidebar or fullwidth (where you can built any layout with shortcodes). :)

Regards,
Filip

Default-user

Hello Filip, Thanks for the quick response! 2. Can they have tags though? I’d like to have a tag cloud. Maybe the best would have categories AND matching tags… 3. Will there be a way to change the layout of my 200 current portfolios without having to go through each? (I probably would want the full width one). Best, Cecile

Veented

Hello again,

2. I’m sorry but that feature does not come out of the box and will require some tweaks in the code.

3. Yes, you may set a global default template. :)

Regards,
Filip

Hi, I think this is similar to problems someone else has had, but I don’t want to experiment with removing code unless I know it’s going to work. When I am in my blog view http://whatthefrench.com/blog/ I get pixelated huge versions of things that are supposed to be thumbnails and/or smaller pictures. When I click on the actual blog post http://whatthefrench.com/what-the-french-release-date-quickly-approaches/ everything looks good. Could you tell me what I need to change? Thanks!

Veented

Hello there,

Blog thumbnails are being automatically resized to fit the content width (which is 662 pixels in this case) so your images should be at least that size. Since your image is truly thin, it gets stretched that much. If you want your images to remain their original sizes, please open the functions.php file and remove this part completely:

if($layout == 1){
        $width = 662;
        $height = 220;
    }elseif($layout == 2){
        $width = 494;
        $height = 200;
    }else{
        $width = 460;
        $height = 290;
    }

Regards,
Filip

Hi! Two questions. First I really love the themes :)

One. I’ve changed the themes color in the theme options to blue and saved it, but it is not seeming to change, it is still a dark orange.

Second. This is probably kind of noob-ish, but, how do I link one of the portfolio thumbnails to an outside link? I have a video that I worked on with a team, and it is on another website. I can’t seem to figure out how to make it go to the site, instead of going to the next page with the description stuff.

Thanks :)

Veented

Hi again,

As I thought, the style-dynamic.php file is not being loaded properly. Please contact your host provider and write them that you get a “500 Internal Server Error” when trying to load the /wp-content/themes/purity/css/style-dynamic.php file. :)

Regards,
Filip

Default-user

Hi Tauris,

I am still having trouble getting the style-dynamic.php file to work. I actually just transferred hosts. I did a completely new reinstall of wordpress and installing the theme. I also imported the ‘purity-demo-content.xml’ file before installing my own stuff, and the style-dynamic.php still isn’t loading correctly.

Veented

Hello there,

Please send me your WP login information through my Profile Page and I’ll take a closer look at the issue.

Regards,
Filip

Hello Filip,

I just installed the theme this morning and I keep getting the following error when trying to update pages, change settings, add photos, etc.

Fatal error: Call to undefined function get_option_tree() in /home/inthispl/public_html/wp-content/themes/purity/functions.php on line 641

I saw a comment from someone with the same error that some files might be missing but I already checked and I don’t think that’s the issue.

Could you please help? I need to re-launch my client’s site on Monday! Thanks,

Cecile

Veented

Hello Cecile,

It’s truly odd, could you please send me your WP login information through my Profile Page so I can take a closer look at the issue? I do not remember anyone with a similar issue recently.

Regards,
Filip

Default-user

Sent you an email last night…really hope you can fix this! Thanks!

Veented

Hi again,

I’ve just replied your e-mail. :)

Regards,
Filip

Cestola Purchased

Hello! Firstly, congratulations for you theme, it’s exactly what I was looking for. Two quick questions.

1. I have used the translation panel but I don’t know how can I change the language of the months (AUG, MAY…) of the posts since it’s a dynamic attribute.

2. I don’t know why, but both Set featured image and the Upload system are not working for me, just the add media button. I mean, I can upload any media to the gallery but, then, when clicking Insert into post, the images are not inserted properly, they just don’t appear. I have been researching and I have read that maybe it is because of the 3.5 WP version. Could you, please, give an answer for this?

Thanks in advance, IR

Veented

Hello again,

First of all, you do not insert the images (used for thumbnails and galleries) via the Featured Image but the “Image 1” and so on fields. Featured Image is not being used. If it still doesn’t work through the Image-1 field then please send me your WP login information and I’ll debug it for you.

Regards,
Filip

Default-user
Cestola Purchased

Hello, I have sent you my WP login information by email. I have created a new user (author rol) and I gave you the login data for this user. If you need my login data(admin) I’ll writte you again by email. Thanks

Veented

Hi again,

I’ve just replied it. :)

Regards,
Filip

agnessa Purchased

Hi Filip, Would it be possible to modify the main page of the site so that 1. we have small photos below or above each blog post (maybe using the featured image)? At the moment, there’s only a selection of 3 or 4 previous posts. 2. we have the recent posts above the Slider? We’ve tried a few things but cant quite figure it out Many thanks in advance for your help/advice, A

Default-user
agnessa Purchased

Many Thanks Filip, emailed you yesterday. Let me know if you need more info. Cheers, A

Veented

Hi again,

I’ve just sent it to you. :)

Regards,
Filip

Default-user
agnessa Purchased

Thanks Filip for your quick response, really appreciate! A

Hey Fillip,

I just updated the theme and some things moved around on me that I’d like to move back.

On the blog archives page, we’d like the date and title to appear above the featured image. You had shown me the code to move in the right-sidebar template, but now when I move it I get all kinds of errors.

Thanks! Sean

Veented

Hello Sean,

Please send me the code I’ve once sent you via my Profile Page and I’ll update it for the latest theme version. :)

Regards,
Filip

Hey Filip

How do I do when I don´t want the menu title to be the heading when I create a new page?

Best regards, Camilla

Veented

Hello Camilla,

Would you like to remove the page title area completely? If that’s what you mean then sure, just remove this part from your header.php file:

<?php if(!is_page_template('template-home.php')) : // if not home template ?>
        <div class="tagline inner">
            <?php include 'includes/page-title.php'; ?>
            <div class="clear" />
        </div>
        <?php endif; ?>

Regards,
Filip

Hey Filip.

On homepage and recent works is it possible to have a text line or two under the picture? (For describing the reason to watch)

Best regards and thank you. I bought your excellent theme a couple of days ago.

//Camilla

Veented

Hello again,

Wish I saw your other comment earlier!

I’m not quiet sure what you mean. Where exactly would you like to insert that text? Please be a bit more descriptive. And a screenshot would be great. :)

Regards,
Filip

Hello again.

I don´t want the title “Recent Work” abow the Portfolio-items showed on the frontpage.

And I don´t want the Blog-area to apear on the frontpage.

Is this possible?

Thank you and best regards, Camilla

Veented

Hello again,

I’d truly appreciate if you could use the “Reply” button instead of creating a new comment each time so we can have things a bit more organized here.

You may disable the Recent Work title by removing this line from your template-home.php file:

<h3><?php tr_translate('recent_work_title'); ?></h3> 

And to disable the Recent Posts area, just do it via the Theme Options / Homepage tab. :)

Regards,
Filip

Default-user

Thank you Filip.

It did not work with removing the code in my template-home.php file.

And when I disable the Recent Work there is still left a space for it. Can I remove that?

Best regards, Camilla

Veented

Hello,

Please send me your WP login information through my Profile Page and I’ll debug it for you.

Regards,
Filip

Hey Filip.

I bought your theme Purity few days ago. I like it very much but have som problem swith it. Can you help me?

I do not want the menu title to be heading on the page its linked to.

I do not want “Recent work” to be written over the blog posts on the front page.

I want the images under the slider on the front page linked to pages and not to blog entries. Is it possible?

My e-mail is camilla@rd.se

Best regards Camilla

Default-user

Hello again.

New question! How can a make the layout in Purity look lika this: http://www.torbografie.de/portrait/

Best regards Camilla

Veented

Hello Camilla,

As I can see, the website uses the FooBox plugin with some extra custom styling. :)

Regards,
Filip

Default-user

Thank you Filip!

Hi Filip,

Can you let me know why my menu options are not showing up in mobile width and how to fix it?

Firebug gives me this warning when my browser is in mobile width:

Warning: Invalid argument supplied for foreach() in /[rest of path]/themes/purity/functions.php on line 38.

I didn’t see any differences between the site I am working on (http://gospellifebowie.com/) and the theme’s demo site that would have an obvious impact on this.

Thanks, David

Veented

Hello David,

Just visit your Appearance / Menus tab and assign your custom menu to “Navigation”. :)

Regards,
Filip

Default-user

That worked. Thanks!

Veented

You are very welcome. :)

Regards,
Filip

I work for a non-profit and recently had someone purchase and donate this theme to us. I have been working in it today and I can’t seem to get the sidebar manager to work. I’m in a new install of Wordpress and have no plugins active.

Veented

Hello there,

I’d truly appreciate if you could post a comment via the account the theme was purchased on. It could only be once so I can verify the purchase. Please don’t take it personally, I just many situations when I can actually ended up giving support to ppl who didn’t even buy the theme.

Regards,
Filip

Default-user

Can I provide you proof of the purchase in some other manner? Going back to donors with problems with their donations tends to turn them off and prevent them from making other donations in the future?

Veented

Just send me your WP login information through my Profile Page and I’ll take a look at the issue.

Regards,
Filip

Hi, I sent an email but just saw this support forum….

I’d like to have a link to a Portfolio Category in a Sidebar. Is this possible? Basically, I’d need the category url, I’m just not sure where to find it.

Thanks! Brooke

Veented

Hello Brooke,

I’m sorry but you cannot link directly to a specific portfolio category. You may only insert a link to your portfolio page. :)

Regards,
Filip

Default-user

Thanks for letting me know. :D

Veented

You are welcome. :)

Regards,
Filip

Hi When I want to make a new page, I do not see templates for blog, why?

Regards elin

Veented

Hello Elin,

Just leave it with “Default Template” and set it as the Posts Page in the Settings / Reading menu. :)

Regards,
Filip

Great theme and great support! Thanks for your help Filip!

Veented

Hello there,

And thank you for the kind words, I truly appreciate it! I’m really glad I could help. :)

Regards,
Filip

agnessa Purchased

Hi Filip,

thanks for the php file.

There’s actually another issue since the new version update. I cant upload new photos onto the site. It’s ok from my desktop/file onto the Media Library but when I want to upload the actual image, its stay blank (on media uploader and multi file uploader).

Any idea how to fix this? (as well as being slower – displays text first, which was ok before the update)

Thanks again! A

Veented

Hello again,

I think I have just replied your e-mail? I appreciate if we could keep our conversation in one place so we can keep things more organized and not split around. :)

Regards,
Filip

Default-user
agnessa Purchased

Thank you Filip and sorry about the confusion. Here is the latest - 1. we’ve just uninstalled the twitter plugin but it doesnt make a difference (we still have the texts displayed before the photos or the slider) 2. we still cant upload any photos onto the site (blank page ) 3. not displayed properly on iPhone 5 (its there but all over the place, with a select page first button) All of these were fine before the version update :( Thanks again for your help! A

Default-user
agnessa Purchased

Hi Filip, Just wondering if you have any idea how to fix these bugs as the site doesnt look so great since the version update? Let me know if you need clarification Thanks again for your assistance and patience.

This website is amazing – I still love the clarity of the theme and if I have ever had questions it has been extremely easy to get feedback from the designer. Would HIGHLY recommend!!! You won’t regret it!

Veented

Hello there,

Thank you so much for the kind words, I truly appreciate it! I’m really glad you are satisfied with the purchase. :)

All the best,
Filip

epicswell Purchased

Hello,

I am having trouble with using a different google font. I have followed the directions and started over several times but always end up with the same result; looks like Arial and then hover color goes back to the default orange. The font I am trying to use is “Michroma” (http://www.google.com/fonts#QuickUsePlace:quickUse/Family:Michroma). Any help is appreciated. style-dynamic.php
.nav,h1,h2,h3,h4,.home_tagline h1,.tagline h1,.over span,.dropcap1,.dropcap2,.bold,.flex-caption { 
    font-family:'Michroma'; 
    text-transform:none; 
    font-weight:normal;
}

functions.php

            wp_register_style('google-font-heading', 'http://fonts.googleapis.com/css?family=Michroma');
            wp_enqueue_style('google-font-heading');
Default-user
epicswell Purchased

Sure, the website is http://www.dbdesigns.co

As for the font, after using the above code, the headers are definitely not using the Michroma font, but instead look like Arial. Also, when you hover over the menu items, the highlighted color is an orange color, not the tan color I had it set to and was working prior to changing these two files.

Veented

Hello again,

I can see a syntax error in your style-dynamic.php which means that you must have missed some semicolone or other character. Please send me your WP login information through my Profile Page and I’ll debug it for you. :)

But as for now, you may just change the “LeagueGothicRegular” part of your style.css file to “Michroma”.

Best Regards,
Filip

Default-user
epicswell Purchased

Thank you Filip for resolving the issue!

Hi Filip,

I’m finishing up the final touches of the website, http://kjarchitect.com. The remaining issues concern the blog – in particular the blog images – both on the blog pages and the thumbnails in the Recent Posts section on the homepage.

I imported my client’s blog from Blogger and at this point in time, all images are in the body of the posts, not inserted through the image gallery. This is a problem because they don’t show up as thumbnails on the homepage and that is a requirement of this project.

So the first question is this: when I insert images using the gallery function if there any way of “correcting” the placement of the image, i.e. have it appear below the post title and date rather than above? As for the size of the image, I read somewhere in the support forum that I can delete a section from functions.php to correct size issues thereby having it default to the image’s actual size.

However, if the image placement can’t be changed and if my client isn’t satisfied with that placement then we could stay with just using what we have – keeping the images in the body of the post – the downside is that we will miss out on the functionality you offer, sliders etc for blog images. But if we do go this route, I’ve learned a way from reading the forums to insert an image in the gallery so it will appear as a thumbnail in the Recent Posts section on the homepage but not on the Blog page (by removing code in the template for the blog page – right-sidebar-1.php.) I tried it and it seems to work. But now I need to also know how to change the code associated with the individual blog page (is it single.php?) to remove the image there too (or I’ll have double images).

The ideal solution would be to use the gallery images at their actual sizes and have them appear below (not above) the title and date, but I realize this might not be doable. So that’s the starting question which will determine how I need to approach solving this problem.

Thank you so much, Filip. As you know, I LOVE your theme, and working with you as been a VERY positive experience.

Judith

Veented

Hello Judith,

You are very welcome. And please drop me this message as a reply to our previous e-mails so we can have them somehow organised instead of split between here and there. :)

Regards,
Filip

by
by
by
by
by
by