Discussion on Purity: Responsive, Clean, Minimal & Bold WP Theme

2591 comments found

  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Exclusive Author
  • Bought between 100 and 499 items
  • Europe
  • Has been a member for 4-5 years

Hey everyone! We have some got news.

Since now, we are going to handle all support requests via our brand new Support Board. It consists of a Knowledge Base where you can find answers to commonly asked questions aswell as a Support Forums where you can post your inquiries.

The best thing about it and the main reason we’ve decided for such a step is a possibility to search the site content. It means that you may find an answer to your question immediately because someone could have already asked the same question in the past. :)

All the best,
Veented Team

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Thank you for the theme, learning to use it. Not very code- savvy, hence my question: how do I link a buy button in pricing boxes to specific url? I tried typing an url in place of ’#’ in shortcode, but it didn’t work. Thank you for your help. zosia

Veented

Hello there,

Please make sure that your URL starts with the http:// prefix. :)

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
agnessa Purchased

Hi Filip,

As discussed, we no longer have the option to add a thumbnail image on new posts (there’s only a featured image option)

Thanks again for your amazing support :) A

Veented

Hi again,

You are very welcome, I’m glad I could help. :)

As for the remaining issue, please drop me your WP login information privately so I can further investigate.

Regards,
Filip

Default-user
agnessa Purchased

Thanks so much Filip, all working now!! Have a great day A

Veented

Once again you are welcome! :)

Have a great Sunday,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

I have updated to the new purity formate and after I’ve done so one of the links on my Homepage Tagline, the “about me” will not link to the corresponding page. www.ashlieputman.com The other two links, “WORK” & “SEND ME A EMAIL” work just fine. I checked the coding in the theme options, homepage tagline area, and the coding for the “ABOUT ME” link matches the corresponding page so I’m not sure what the problem might be. Could you help direct me??

Thanks!

Veented

Hello there,

I can see that there are extra quotation marks (they are actually doubled) around the “About” page URL path. Just remove them. :)

And if you have any other questions, please post them on our new Support Forums. :)

All the best,
Filip

ashlieputman

I’m sorry Filip, this is probably silly, but where do I find the “About” page URL path to remove these quotes?? Is it under the purity theme options? I’m not locating any double quotes anywhere :(

Veented

Hi again,

I’ve just replied your post on the forums!

http://veented.com/support/forums/topic/linking-homepage-taglines/


Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi there, i was wondering how to remove or shrink the right hand side of the blog that says comment and date posted.

Cheers

Default-user

And is it it possible to use the font form the earlier edition?

Veented

Hello there,

We’ve just opened a brand new Support Forums. Can you please repost your questions there? It will be easier for other users to find the answers in case they have the same questions in a future. :)

Regards,
Filip

Veented

Hi again,

Since your first question have been asked over and over again, I’ve decided to add it to our Knowledge Base:

http://veented.com/support/knowledge-base/how-to-remove-the-comments-count-block/

All the best,
Filip
Default-user

Hi Filip, how do we access the place to edit the code? and is it possible to use the original font?

Cheers

Veented

Hello there,

You will need to use an FTP client like FileZilla and then connect to your host.

As for the second question, just open the Theme Options / Appearance tab and change the heading font to League Gothic. :)

Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 5-6 years

Hi,great theme! Is there any way i could get an image on the contact page, so preferably 2 columns, one with the contactform, one for an image on the right?

Veented

Hello there,

Thank you for the kind words. :)

And it is of course possible but would require some additional tweaks in the code (template-contact.php and style.css files) which is beyond the scope of our free support.

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

I already regret to have purchased this unfinished product—which forces me to browse though help manuals etc. instead of just working.

> Installing Theme from uploaded file: themeforest-639774-purity-responsive-clean-minimal-bold-wp-theme.zip > > Unpacking the package… > > Installing the theme… > > The package could not be installed. The theme is missing the style.css stylesheet. > > Theme install failed.

Disappointing.

Veented

Hello there,

First of all – thank you for choosing Purity.

As you may see, the theme has already got over 4000 sales with the average rating of 4.58 which means that most of the people are really satisfied with their purchase.

Regarding your issue – it’s the most frequently asked question here on ThemeForest. If you have googled your problem, checked the forums or our Support Board, you’d have found the solution right away:

http://veented.com/support/knowledge-base/missing-stylesheet-error/


And in case you ever occur any other issue, please post your inquiry on our forums instead of posting these kind of comments. Thank you!

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
nbp Purchased

Hi, We have site with the contact form. The issue we are getting is that the site is not displaying the Google Maps on homepage.

The URL of the site is: http://newblackpress.com/contact

Please help.

Thanks nbp

Veented

Hello there,

First of all, please make sure that your hosting/server has the cURL tool enabled. :)

Regards,
Filip

Default-user
nbp Purchased

Hello Filip, Appreciate for your reply. Curl is enabled its some sort of javascript in map.ui.jquery file that is creating error.

Please help.

Thanks NBP

Veented

Hi again,

I’ve just replied your forums topic:

http://veented.com/support/forums/topic/maps-not-working-on-site/

Regards,
Filip

  • Bought between 100 and 499 items
  • Has been a member for 2-3 years

Hello – beautiful theme.

Just added WooCommerce and see that it’s not playing well with sidebar. Any quick suggestions before I begin hacking the CSS? :)

http://austinletter.twelvetwo.net/shop/bonus-report-1/

Thanks!

Clay

Veented

Hello Clay,

Thank you for the kind words, we are glad you like it. :)

And we are sorry but we haven’t really tested Purity with WooCommerce so we cannot guarantee it’s gonna work perfectly fine. Yet, we do not claim so in the theme’s description!

However, when you create a template file for the plugin, please see the structure of: template-page-right.php file. It should have just the same elements. :)

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hello,

Beautiful theme, really happy with it! I wondered how to create the static video layout for the homepage and where to upload videos and insert videos for the blog. Thanks in advance!

Kind regards,

Geraldine

Veented

Hello Geraldine,

Thank you for the kind words!

Please check the Theme Documentation for more information about the Static Video homepage layout. And I’m really sorry but blog does not support videso by default.

All the best,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • United States

My custom sidebars aren’t showing up. Is there a way to fix this? Example: http://logzies.com/logzies-in-action/

Also, the sidebars that come with the theme have no way to control which side of the page they are on. Is there a fix for this too? Example: http://logzies.com/contact-us/

Veented

Hi there,

Can you please drop me your WP login information via the contact form located on my Profile page so I can further investigate? :)

Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
  • Italy
filojoy Purchased

Hello, how to set Title and Tagline for blog page like is set on demo site? I just can’t find an option and infact my blog title and tagline are empty

Veented

Hello there,

You need to create a new page that will be set as the “Posts Page” in the Settings / Reading menu. :)

Regards,
FIlip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Filip! I am really enjoying using your Purity theme, and I appreciate the help you’ve provided. I have a few more questions for you.

1. I want to decrease the space between the Page Title and the page content, as well as the space between the Heading 5 text and the material below it. (See attached screenshot.) I’ve looked st the style sheet and can’t figure out where these spacings are set. (I’m new at this!) It looks like there are dividers there, but I can’t find them anywhere in the style sheet. Can you help me with this?

2. The image I uploaded as a logo shows up perfectly on my laptop, but on my iPad it is just a box with a question mark. Any idea why this is happening? Otherwise, the site works fine on my iPad.

3. The site does not work well at all on my iPhone, which is a disappointment. Can you explain why this might be, when it works perfectly on my iPad (except for the logo problem)?

Thanks very much!

Bob Stillman

Veented

Hello Bob,

We’ve opened a brand new Support Forum as you can read in a comment at the top and we would truly appreciate if you could repost your inquiries there. Here is the link:

http://veented.com/support/

If someone has ever got a similar question to yours, they will be able to find the answer quickly. :)

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

I really love the theme. I’m using it to build www.briankgolden.com, which is almost done. I have a few questions. If it’s better to put them in separate threads, let me know.

1. One of the items in my main nav menu is bigblittleg, which is pulling all posts with that Category. When those posts accumulate in this Archive page, how do I control which sidebar is used on that page? I just assumed it would default to the Archive/Search sidebar…how do I control this?

2. Is there a way to control the size of the tagline text which appears at the top of pages. The default is just really small…

3. On certain sidebars, there are lines appearing between each sections of the sidebar. This is good. But on others, there is not. This is bad. Did I press the wrong button in one of the css files or something?

Thanks.

Veented

Hello there,

1 & 3. That’s truly odd. Can you please send me your WP login information through my Profile Page so I can further investigate? :)

2. Just add this rule to your style.css file:

.tagline span { font-size: 15px; }

All the best,
Filip

Default-user

I tried to add that sentence to my style.css but it didn’t change the thing I hoped to change. Where specifically should I add it? Do I need to delete anything in the style.css to make it work properly? I am mailing you my WP login through your profile page now. Thank you.

Veented

Hi again,

Just place it at the very bottom of the file, do not delete anything! You may also try adding an ”!important” attribute, like:

.tagline span { font-size: 15px !important; }

And I’ve just replied your e-mail. :)

Regards,
Filip

Default-user

Thank you, but this still did not work. I tried cut and pasting it right at the bottom of the style.css sheet but the taglines are still the exact same size they were before. Maybe I am describing it wrong. I am talking about the text that you see on my site on the http://www.briankgolden.com/essays/ page to the right of “Essays” which currently reads “My best prose…”

And I got your email, thank you, I look forward to hearing from you tomorrow.

Veented

Hi again,

I can see the page tagline being bigger now. Please refresh your website few times because it’s your browser caching an older version of it. :)

And thank you for pointing out the issue with sidebars. I’m going to release a theme update quickly.

All the best, Filip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi, thanks a ton for the theme. I’m new to this and having a few problems you can hopefully assist me with:

1. The portfolio page is not supporting any of my youtube pages under the “video” tab. The black box with the classic youtube time-scrub appears but reads 0:00 and says “video error”

2. I would like to apply that video portfolio to the home page as well.

3. I cannot figure out how to link to the portfolio from my menu as the portfolio pages don’t appear under the choosable “pages” drop down.

Thank you!

Default-user

(I fixed the #1. problem still having trouble with 2 and 3)

Default-user

And if possible, I’d like to add several videos on one page! (Am an event videographer, so several under a “weddings” page would be ideal)

Veented

Hello there,

1. I’m glad you have figured it out!

2. I’m not quiet sure what you mean – can you please be a bit more specific?

3. In the Appearance / Menus tab, just click on the “Screen Options” (top right side of the site) and check “Portfolio”. :)

All the best,
Filip

Default-user

2. I am trying to link a video from youtube to the homepage (which is not a portfolio page), so how would I go about doing that? The widget is too small and thus far I have only been able to put in a video if it is a portfolio page.

Also previously the portfolio page worked and now it is giving me a 404 page not found error.

Default-user

To clarify on the 404 error, everything works in preview until I hit update.

Default-user

Essentially I would like to embed a YouTube video into my home page and have it take up the entire page basically.

Veented

Oh, now I understand. In this case just visit the Theme Options / Homepage panel and insert your YouTube embed code (iframe) into the Homepage Custom Content area. :)

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hello – My name is Max and even though I purchased the html / css version of purity, I decided to also purchase the wordpress version as I thought it may be able easier to work with. here is my issue.

I installed wordpress into my domain name in the folder wordpress1. Then I uploaded and activated the Purity WP theme. If you go to my site which is maxgilpin.info it now defaults to maxgilpi.info/wordpress1/

How do I get rid of the wordpress1 in my url line?

Thanks

Max

Veented

Hello Max,

Thank you for purchasing both versions of Purity! :)

As for your issue, please follow this guide:

http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Moving_a_Root_install_to_its_own_directory



Regards,
Filip

Default-user

Hi Filip

Prior to requesting your help. I did follow the steps in that guide but unfortunately I am still having issues. which you can see if you put maxgilpin.info into your web browser. I am not sure if the issue is with the .htaccess file, the index.php file, or something else but I am stuck.

Veented

Hello Max,

I stronly suggest you to make a fresh installation of WordPress (on a brand new database). Please remove the wordpress1 folder and create a new one for your fresh WP files.

Before you begin installing Wordpress, please visit your website’s main URL (maxgilpin.info) and see if it still tries to redirect to the /wordpress1/ subfolder. If so, let me know. :)

Regards,
Filip

Default-user

Filpi – Got it working – here is what I had to do

1) Logged into my register.com control panal and removed wordpress 2) Logged into my domain using ftp and deleted wordpress1 directory, index.php and .htaccess file 3) Logged into my register.com control panal and installed wordpress 3.5.1 in wpress directory 4) Tested : defaults to maxgilpin.info/wpress/ 5) Logged into WP and updated to 3.7.1 6) Tested : defaults to maxgilpin.info/wpress/ 7) Logged into WP and changed site address (URL) from http://maxgilpin.info/wpress to http://maxgilpin.info 8) Logged into my domain using FTP and – copied index.php4 and .htaccess file from root to my computer then deleted them from root – copied index.php and .htaccess from wpress folder to root directory 9) Tested : Fatal error: require(): Failed opening required ’/data/21/3/60/16/3223505/user/3598901/htdocs/wp-blog-header.php’ (include_path=’.:/usr/share/php:/usr/services/vux/lib/php’) in /data/21/3/60/16/3223505/user/3598901/htdocs/index.php on line 17 10) Logged into WP, went to setting > permalinks and presses save changes 11) Tested : Fatal error: require(): Failed opening required ’/data/21/3/60/16/3223505/user/3598901/htdocs/wp-blog-header.php’ (include_path=’.:/usr/share/php:/usr/services/vux/lib/php’) in /data/21/3/60/16/3223505/user/3598901/htdocs/index.php on line 17 12) Edited index.php in root and replaced require( dirname( FILE ) . ’/wp-blog-header.php’ ); with require(’./wpress/wp-blog-header.php’); 13) Tested – All Looks Good 14) Logged into WP and installed Purity 15) Tested – All Looks Good

Veented

Hello again,

I’m really glad you got it working. And thank you for a detailed guide, I’m sure someone may find it useful in a future. :)

All the best,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Filip – if you visit my site maxgilpin.info and click on the work link, you will see the the word Work between my logo and some text. I’m trying to figure out how to remove that section but if in the edit page section I remove the word Work it also removes the menu item??

Help?

Veented

Hello there,

I’m guessing that you just want to disable the Page Title section. To do that, simply open the header.php file and remove this part:

<?php if(!is_page_template('template-home.php')) : // if not home template ?>
        <div class="tagline inner">
            <?php include 'includes/page-title.php'; ?>
            <div class="clear" />
        </div>
        <?php endif; ?>

All the best,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years
ryebag Purchased

I visited the support page. The Blog page isn’t loading posts! I have blog set to “Default Template”. It’s not working. How can I seriously not figure this out after an hour. Stupid.

Veented

Hello there,

Please visit the Settings / Reading menu and make sure that you have your Blog page set as the “Posts Page”.

Regards,
Filip

Veented

Oh, I’m so sorry for multiple replies. I’ve had a bad 3G connection on my iPhone and that’s the effect. :/

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Philp – using the default template in the purity for wp template, I have chopped my resume into 4 .png files and am inserting them into the page using the add media. Two Questions

1) For some reason I have a border around the images, how do I get rid of that?

2) When importing, I have selected center but the images are not centered on the page – suggestions to fix?

www.maxgilpin.info > work > resume

Thanks

Max

Veented

Hello Max,

We have recently opened a brand new support board for our WP themes:

http://veented.com/support/

Can you please repost your question there? We’d truly appreciate it. :)

Regards,
Filip
  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hi Filip,

One of the people maintaining our site wants to change slides in the slider but can’t. He has Editor permissions. Do you need Administrator (or a different level) permissions to change the Purity slider? Is there a way to change people’s permissions on just the slider? I can see several people in the organization wanting to be able to do this, but most of them are not technical people so I don’t want to give them access to all of the technical aspects of the site.

Thanks, David

Veented

Hello David,

The access to the Slider menu is equal to an access to the Theme Options panel. So yes, the administrator level is required to make slider modifications.

All the best,
Filip

Default-user

Hi Filip,

Is there a way to get rid of the Restore Default button on Theme Options permanently then? I gave admin rights to one person specifically for updating the slider, and the first thing he did was click Restore Default and reset our homepage! So now I have to go redo all that work. :(

It really seems like editing content on slides should be the role of an Editor, not an Administrator.

Thanks, David

Veented

Hello David,

With a little modification, you may enable that button just for a specific user. To do that, please open the /purity/admin/front-end/options.php file and edit this line:

<form method="post" id="import-data">            
              <input type="submit" value="<?php _e('Restore Default') ?>" class="button button-framework import-button import-data" />
              <?php wp_nonce_field( '_import_data', '_ajax_nonce', false ); ?>
        </form>

to:

<?php if(get_current_user_id() == 1) { ?>
<form method="post" id="import-data">            
              <input type="submit" value="<?php _e('Restore Default') ?>" class="button button-framework import-button import-data" />
              <?php wp_nonce_field( '_import_data', '_ajax_nonce', false ); ?>
        </form>
<?php } ?>

Where “1” is that specific user ID. :)

All the best,
FIlip

by
by
by
by
by
by