Discussion on Purity: Responsive, Clean, Minimal & Bold WP Theme

2591 comments found

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
180360 Purchased

Thank you for the great template and even better support, especially for someone like me that has no idea what I’m doing. I really appreciate it! :)

Veented

Hello there,

And thank you so much for the kind words, I truly appreciate it! I’m really glad that you are satisfied with the purchase. :)

All the best,
Filip

  • Bought between 50 and 99 items
  • Has been a member for 3-4 years
lparigi Purchased

my slider is broken…. how do I fix this problem?

thank you

Veented

Hello,

There was an issue with jQuery not being loaded properly and I’ve released a Theme Update to fix the problem. Please redownload the theme files and upload them to your server/host replacing the old ones. :)

Files changed: functions.php, header.php, whole /js/ folder.

Best Regards,
Filip

Default-user
lparigi Purchased

I just did the updates but it’s not working… functions.php, header.php, whole /js/ folder.

Veented

Hi again,

Can I see the website URL?

Regards,
Filip

Veented

Hello again,

Your files are still outdated. Please make sure that you replace the old ones.

Regards,
Filip

Default-user
lparigi Purchased

on the ftp server it says last updated Yesterday… so i dont understand how it would not be changed?

Veented

Hi again,

I inspect your website and I still see the old files. Have you got any cache plugins installed? Are you sure that you have redownloaded the files from ThemeForest again?

Regards,
Filip

  • Bought between 50 and 99 items
  • Has been a member for 4-5 years
iacovou Purchased

Hi Tauris…

my portfolio filtering doent seem to work and also my lightbox gallery in a single portfolio item. I dont know what i did wrong…can you help me fix this?

Many Thanks

Veented

Hello there,

Just make sure to select specific portfolio categories that you would like to be displayed on your portfolio PAGE while creating/editing one. :)

Best Regards,
Filip

  • Bought between 50 and 99 items
  • Has been a member for 4-5 years
I just updated the Theme as you suggested. Home page slider is working but NONE of my toggles are. See the project toggles here: http://www.athenianrazak.com/?page_id=632 They do not open. And these ones: http://www.athenianrazak.com/?page_id=70

Will not close. We did some customization back when your theme first launched. Any insight will be greatly appreciated.

Veented

Hi again,

Your /js/custom.js file is outdated. Please update it to the latest version. :)

Best Regards,
Filip

Default-user

I just updated the custom.js file and same thing – neither toggles are working…

Veented

Hi again,

I can see that you have modified the classes of the toggle shortcode what breaks them. After you changed it from “toggle-container” to “toggle-container-project”, you will also need to update it in the custom.js file (Toggle part).

Regards,
Filip

Default-user

Just did that too. Still no change. Bio toggles open, project toggles closed but will not open at all.

Default-user

Could it be something in the header.php or functions.php file(s)? Other than the JS folder, they are the only files I replaced.

Veented

Hello,

You haven’t done that correctly. Open the custom.js file and replace these two lines:

jQuery('.toggle-container-project').click(function () {
        var text = jQuery(this).children('.toggle-container-project');

to:

jQuery('.toggle-container-project').click(function () {
        var text = jQuery(this).children('.toggle-content-project');

Regards,
Filip

Default-user

My mistake. I see where I went wrong. Bio toggles are still set to default of open. How can I set the default to close?

http://www.athenianrazak.com/?page_id=70
Veented

These are not toggles but tabs and that’s how they are supposed to work.

Regards,
Filip

Default-user

Yes but previously, before the update, they were set to all be closed. Now they are all open. How can I set them back to default of closed?

Default-user

NM. I found it. I just changed the custom.js file line 87 to jQuery(”.tabs”).tabs({ selected: null,collapsible: true});

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
abelher02 Purchased

I helped my girlfriend create her artist website using the purity template and she couldn’t be happier. She doesn’t know very much about computers but the template was really easy for her to use. Her website is beautiful and it has really helped her career. Thank you!

You can see her website that employs the PURITY template here: www.mariadifranco.com

Veented

Hello there,

And thank you so much for the kind words, I truly appreciate it! I’m really glad that you are satisfied with the purchase. :)

All the best,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi Tauris,

Something seems to have broken the homepage slider, portfolio filtering, and direct lightbox capabilities of the theme in our implementation of it: http://panacheeditorial.com/ – I have tried to replace the JS folder from the update, but it does not seem to work. Any chance you could take a look? We appreciate your time and consideration.

Thanks, David (david@panacheeditorial.com)

Veented

Hello David,

It’s not only the /js/ folder that you need to update but also functions.php and header.php files. :)

Best Regards,
Filip

  • Has been a member for 1-2 years

Thank you Tauris for the amazing PURITY template!

I also want to thank you for the quick response to my query, I really appreciate your help.

-Maria

Veented

Hello Maria,

And thank you for the kind words, I truly appreciate it! I’m really glad that you like the theme. :)

Best Regards,
Filip

  • Bought between 50 and 99 items
  • Has been a member for 4-5 years

For those whom may be undecided on whether to purchase this theme or not. Let me testify right now that this Theme is TOPS above all others I have used and the theme author’s support is nothing short of AMAZING! Even a year after my purchase, he still has helped me with updates and small bug fixes! Thank you a million times over Filip! You da’ man!

Veented

Hello there,

And thank you for the kind words, I truly appreciate it! I’m really glad that you are satisfied with the purchase. :)

All the best,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Is there any way to create a portfolio post with a full width? With no additional photos/videos/etc except that which is added in the post body?

Veented

Hello there,

I’m sorry but this feature doesn’t come out of the box and will require some further modification of the code.

Best Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years
vcolfari Purchased

Hi Filip,

Under Settings/Reading, I’ve selected “for each article in a feed show summary,” but the entire article is displayed. Is there something I’m missing? Thank you for the help!

Oops, nevermind. I figured it out. :-)

Veented

Hello there,

I’m glad you have figured it out yourself! :)

Best Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 5-6 years
antreasv Purchased

Hello Filip! This is Andreas again with www.liveinathens.net (the one that commented on “Spacing” by mistake the other day!)

I hope to find you well.

You see I have this problem with a plugin that I’m using and I’d like to ask you if you see any conflict with the theme, because a small function is not working with the new version of Purity.

Please visit http://liveinathens.net/test-2/ Before the update, when you clicked in the date field (arrival or departure) a small datepicker apeared that helped you pick a date from a calendar. Now it’s gone :(

Can you be of any help please? Yours Andreas

Veented

Hello Andreas,

I can see an error just in the plugin’s script file. Are there any plugin updates available for download? If yes then please perform an update.

Regards,
Filip

Default-user
antreasv Purchased

I have preformed the latest update of the script.

Could you be kind enought to point the error that you see so I can contact the script author?

Thank you in advance.

Andreas

Veented

Hi Andreas,

I’ve got an idea what could be causing the issue. Please open the functions.php file and edit this part: “1.8.2” to: “1.8.23”.

Let me know how it goes.

Regards,
Filip

Default-user
antreasv Purchased

Unfortunately still no luck :(

Veented

Hi again,

I can see that there is even a newer version of jQuery UI. Please change the “1.8.23” part to “1.10.0”. :)

Regards,
Filip

Default-user
antreasv Purchased

Yeay!!!

Thank you Filip

Yours work is art! :)

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years

Hi there! First of all, thanks a lot for the great theme. I’m having a look to my boyfriend website wich use Purity. Here is his website: www.levell.be His site was working perfectly until 4 days ago. Now when you go on a project (in the portfolio), when You click on the main picture, nothing happens anymore (there was a whole gallery with other pictures). he didnt’ change anything? How can I hlp him to fix that? Thanks a lot for your help.

Veented

Hello there,

Thank you for the kind words, I truly appreciate it!

As you can read few comments above, there was an issue with jQuery not being loaded properly and I’ve released a Theme Update to fix the problem. Please redownload the theme files and upload them to your server/host replacing the old ones. :)

Files changed: functions.php, header.php, whole /js/ folder.

Best Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi there

Love the theme. I have had this theme installed for a while, but just checked on it and the lightbox has broken. Does not work on portfolio posts. It was working fine before, haven’t touched it, Any suggestions?

The site is juliusgibson.com

Thanks!

Veented

Hello there,

As you can read few comments above, there was an issue with jQuery not being loaded properly and I’ve released a Theme Update to fix the problem. Please redownload the theme files and upload them to your server/host replacing the old ones. :)

Files changed: functions.php, header.php, whole /js/ folder.

Best Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years
vcolfari Purchased

Hi Filip,

Next to my “Recent Posts” items in the sidebar widget, there is a gray square. Is this supposed to be an avatar, the photo associated with the blog post, or something else? How do I edit this? Thank you!

Veented

Hello there,

The gray square shows up when a specific post hasn’t got an Image-1 set on it (there is simply no image as a base for a thumbnail). :)

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
jonsp Purchased

All of my post and portfolio thumbnails have stopped working. I’ve replaced the js folder items, functions.php, and header.php, but this has not resolved the issue.

I’ve also replaced the timthumb.php in the includes folder in case that was somehow related, and again no luck.

My site is http://jonschelanderpugh.com

Thanks!

Veented

Hi there,

All of your jQuery scripts work fine. It’s the TimThumb script not working and it’s related to your permalink structure. When you visit this link: http://jonschelanderpugh.com/wp-content/themes/purity/includes/timthumb.php it displays the 404 page error. Please try reverting your permalinks back to default and test it again. :)

Regards,
Filip

Default-user
jonsp Purchased

I set the permalinks to default, and the problem still exists.

Veented

Hi again,

Could you please send me your WP login information through my Profile Page so I can debug it for you?

Regards,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
redclove Purchased

Hi Filip,

Suddenly my filters in my portfolio are not working, I recently updated to WP3.5 and am thinking it has to do with that. Does that make sense? I see that you have updated Purity as well, what is the safest way to update the theme while protecting my content?

Thanks

Matt

Veented

Hello Matt,

As you can read few comments above, there was an issue with jQuery not being loaded properly and I’ve released a Theme Update to fix the problem. Please redownload the theme files and upload them to your server/host replacing the old ones. :)

Files changed: functions.php, header.php, whole /js/ folder.

Best Regards,
Filip

redclove
redclove Purchased

Thanks, so if I only replace functions.php, header.php, whole /js/ folder, I am completely up to date? Sorry for the reiteration, I need to be sure, can’t do with any down time! ;)

http://www.mattdurant.com
Veented

Hi again,

That is correct. :)

Regards,
Filip

  • Has been a member for 1-2 years

Hi,

I bought this theme a few months back and the development of my website has taken longer than expected. I am now in a place where i have hired someone to complete the website development and they have toke me that the theme is out dated. Would it be possible to be sent an updated version?

Many thanks, Wayne

Veented

Hello Wayne,

First of all, I cannot see the “purchased” badge next to your nickname. As for the updated theme files, you can download them from the “Downloads” tab on an account the theme was purchased on.

Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
Meinsler Purchased

Filip,

Your suggestions to get the slider working again were right on the money. Thanks for your help and your quick response.

well done, John

Veented

Hello John,

You are very welcome. I’m glad everything works fine. :)

All the best,
Filip

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hi Filip, Two questions. 1. How can I make the Contact page full width? Since the maps widget included wasn’t working properly, I’m using a different one in the page content, so I need the page to have no side bar. 2. The alt text/caption for the logo and more importantly the slider images on the home page are not not showing up in the home page code. I believe this is very important for SEO. How can I make the logo and slider images’ alt texts and/or captions be displayed as tags in the code like on a normal wordpress page?

Cheers, PN p.s. I did try emailing you privately about question #1, but maybe you didn’t see it, so I thought I’d try here again. :)

Veented

Hello there,

I’m really sorry, I must have missed your e-mail. I’m getting more and more everyday!

1. Please open the template-contact.php file and remove these three lines:

http://pastie.org/5983553 (note that they don’t appear together)

2. The caption text does appear in the theme’s code. Could you please be more descriptive about the problem?

Best Regards,
Filip

Default-user

Thanks! Issue number one solved :)

As for my second issue with the caption/alt tags, let me explain…

I have, in my media library, edited my images to have a caption and alternate text. But when I used those images in the slider on the home page or for the logo in the header, no alt or caption tags for those images seem to be appearing in the source code of the page. I don’t want to show the captions on the page, but i do want the alternate texts or captions to be seen by search engines. Does that make more sense?

-PN

Veented

Oh, thank you for clarifying. Please send me a private message and I’ll provide you a quick code modification to achieve it. :)

Regards,
Filip

Default-user

Hi Again! Thanks for all your help thus far – GREAT CUSTOMER SERVICE!

I’m having a problem now with my Contact page… not sure if it maybe has something to do with the above changes you had me make to make it full width… When the Send (submit) button is pressed, it does not show the “thank you” message like it used to – the send button does disappear but in it’s place is a little grey loading wheel. Fortunately it is still sending me the submission emails, but it is confusing my potential clients and I’m getting multiple submissions! Any help would be greatly appreciated!

Cheers, PN http://CitizenRecording.com
Veented

Hi again,

It could be a plugin conflict. Please try deactivating all you’ve got installed and test it again. :)

Regards,
Filip

Default-user

OK, tried that… It doesn’t seem to be a plugin conflict. Still getting the grey spinny wheel with the plugins deactivated…

Veented

Hi again,

Could you please send me your WP login information through my Profile Page so I can debug it for you?

Regards,
Filip

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years
cabo_bol Purchased

Hey !

I just bought the theme however am having issues uploading the file to the theme on Wordpress. It just times out – i have read about changing the timing expiration via php but have no idea how to execute that?

My memory got upgraded to 64mb so its not that i dont think.

Veented

Hi there,

First of all, please make sure that you unzip the first .zip file that you download directly from ThemeForest. It’s not the one that you need to upload. Please refer to this article: http://bit.ly/Kj1mOg :)

Best Regards,
Filip

by
by
by
by
by
by