173 comments found

  • Bought between 10 and 49 items
  • Has been a member for 3-4 years

One last question: (I guess that’s what you get for creating a q & a theme ;)

Is there anyway that I can add a field or two to the sign up form? I want users to be able to create a username, (which would be visible throughout the site and on their profile) but then also have to fill in their real name (which could be hidden from their profile and only available to admins).

I realize there might be some customization involved to meet this requirement.

Let me know.

esterndesign

Yes you could do this but you would need to add the inputs to the page and then send the data to the add new user function. Pretty straight forward. If you look at how the data is processed now you could do this pretty easily.

Then just save the data like how the other data is done in the add_new_user function in functions.php.

Hope that helps.

-esterndesign

Default-user

Brilliant! I’m not a coder, but your code is so clean that I think I may be able to follow your lead and figure it out.

Your service has been awesome. Thank you for all your help. Good luck with sales. It really is a powerful theme with so many application possibilities.

esterndesign

Thanks for the kind notes, really appreciate it! Please share your thoughts by voting for this theme on the theme page.

If you run into any hiccups let me know and i will try to help guide you through.

Enjoy the theme and thanks for the purchase!

-esterndesign

Default-user

I’ve added my rating for the theme. Hope I did that in the right place.

I’ve added the following fields to the sign up form as follows (after username and before password):

                                                        
                                <label><?php echo $t_first_name_text; ?>:<span class="asterixRequired">*</span></label>
                                <fieldset><input type="text" name="first_name" id="first_name" class="text" value="" /></fieldset>    

 <label><?php echo $t_last_name_text; ?>:<span class="asterixRequired">*</span></label>
                                <fieldset><input type="text" name="last_name" id="last_name" class="text" value="" /></fieldset>                 

I’m wondering if I need to make changes to the if ( isset($_POST['signup_post']) == '1') { beginning on line 16 in the signup.php file and then similar changes in the function.php file?

Could you please provide me with a little guidance on what changes to make here?

Thanks

esterndesign

Hi,

Here is the basic premiss that you need to do:

on sign-up.php:

- Need to have input to collect the data:
<label><?php echo $t_first_name_text; ?>:<span class="asterixRequired">*</span></label><fieldset><input type="text" name="first_name" id="first_name" class="text" value="" /></fieldset>    

<label><?php echo $t_last_name_text; ?>:<span class="asterixRequired">*</span></label><fieldset><input type="text" name="last_name" id="last_name" class="text" value="" /></fieldset>                 
- Need to grab _POST data for new values at the top of the page (as you were talking about in your comment):
$first_name = $_POST['first_name'];
$last_name = $_POST['last_name'];
- Pass the collected _POST variables to the function:
$message = add_new_user($username, $password, $first_name, $last_name, $confirm, $email, $redir);

on functions.php:

- Update add_new_user() function definition to have the values to be used:
function add_new_user($username, $password, $firstname, $lastname, $confirm, $email, $redir) {
- Strip out tags from the _POST vars to prep for db:
$firstname_stripped = strip_tags($firstname);
$lastname_stripped = strip_tags($lastname);
- For required fields, validate the values to see if they was entered and message user if NULL (empty):
if(isEmptyString($firstname_stripped)) return new WP_Error('forgot_firstname', $t_message_choose_firstname);
if(isEmptyString($lastname_stripped)) return new WP_Error('forgot_lastname', $t_message_choose_lastname);
- Set values for that user in the in the user array to be added in the wp_insert_user():
// Create the user
    $user_data = array(
        'user_login' => $username_stripped,
        'user_pass' => $password_stripped,
        'user_email' => $email_stripped,
            'first_name' => $firstname_stripped,
            'last_name' => $lastname_stripped
    );

That should be all. Hope that this helps you.

You will need to create the instances for these new translations in the translations.php page as well. Or you can hard code them, up to you.

Regards,

-esterndesign

Default-user

Amazing. I am so grateful for your support. You write clean code and I was able to follow your instructions and get everything working fine.

Just a note that in the latest update version of Feb 16th, myaccount.php, the heading code on line 94 for My Options is not displaying. I noticed an extra space and removed it, but I still can’t get it to display. I replaced it with the HTML from the previous version for now.

<h4><?php echo $t_my_options_heading; ?>: </h4>
esterndesign

Did you add the entry that was added to the translations.php page? That is the string that i am using here.

Look at the bottom of the translations.php file and you will see this entry that should be added.

Regards,

-esterndesign

Default-user

Thanks. The MyAccount page headings are working as expected now.

I’m encountering errors when I test the sign up form. It’s as though the First Name (and possibly the Last Name) field data is not getting posted. I am testing the errors and input one field at a time, and when I enter a name in the first name field I continuously get the error message to enter a first name.

These are the files that I’ve modified to get this working: signup.php ask-a-question.php function.php translations.php

I’ve quadrupled checked the code. But I can’t find the error. If I were to give you access to my site or send you the files would you be willing to help me troubleshoot. I’d be happy to offer a donation as I feel you have really gone the extra mile.

Let me know.

esterndesign

Yes just send me the admin login via my profile page contact form.

Regards.

-esterndesign

  • Has been a member for 1-2 years

double posted, reply to the below please.

  • Has been a member for 1-2 years

I’m interested but the thing already seems to be bugged.

For example type in this ’ onto the headline of the question and you will get a ’/ extra dash will be added I’m not sure what other errors I’ll find along the way I see this is a new theme – how many bugs are in this that you know off? thanks

esterndesign

Hi all of the bugs that have been reported are already fixed in the theme you would buy. I do my best to test thoroughly but minor ones get by sometimes. Rest asured that I try to provide the best support and address any defects with updates as soon as I can.

Hope this clarifies your questions.

Regards.

-esterndesign

Default-user

so that particular error is fixed? that’s great.

How easy would it be to install this theme onto WP? I’ll be using bluehost I’m very new to wordpress so I’m a little confused do you supply a guide for beginners like myself on how to install this – step by step? thanks again

Default-user

Sorry to spam but do you accept visa debit cards as a form of payment also this may be a silly question but the category names on the right of the theme can easily be edited right? thanks again.

esterndesign

There are instructions on what to do with the install. Knowing a little about wp is somewhat needed but you could start by checking out the getting started with Wordpress documentation on their site.

As for payments that is handles by themeforest and nothing that I control. If you have questions about that I would contact them. I only am someone that sell on their marketplace.

There are no bugs and all that were talk about are fixed.

Regards.

-esterndesign.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
droidsos Purchased

How can I get http://wordpress.org/extend/plugins/are-you-a-human/ to work with robust q&a

esterndesign

Hi.

I dont see a short php include way of adding that plugin to any page. Right out of the box it looks like that is only for the wp signip page. I would reach out the developer to see if they have this short code that can be placed on any page. Then this is how you would add this plugin to this theme.

Regards

-esterndesign

Default-user
droidsos Purchased

Hey I have found KeyCAPTCHA plugin. Which has a short code. ” To integarte KeyCAPTCHA with a Form please use the following instuctions: Copy the following tag with square brackets [keycaptcha] Open the page with settings of Contact Form 7 Paste the copied tag into “Form” section above the line which contains “

[submit “Send”]

” How would I incorporate this into sign-up and forget password pages?
esterndesign

Hi,

That is a short code that goes in the wp-admin for editing a page and or on the Contact Form 7 plugin. Both of which are not supported with this since this theme uses a custom signup page.

On the plugin page they have a section that says that you can contact their team to see if it will work with your solution.

https://www.keycaptcha.com

I would ask them for a php function code snippet that you can place on any page php page.

Hope that this helps out.

Regards,

-esterndesign

Default-user
droidsos Purchased

I have found a recaptcha wordpress php function I can use. I can enter <?php do_action(‘bwp_recaptcha_add_markups’); ?> at the end of a form and it will display the recapthca form. Unfortunately the recaptcha gets ignored when submitting forms

esterndesign

Are you able to get this to show up on the page? I dont seem to be able to get this to even populate on any page..

Regards,

-esterndesign

Default-user
droidsos Purchased

I am using BWP reCAPTCHA. I put it before the end of the form(s) I want it added to. Change the settings of that plugin to show for everyone (registered members). Here is an example http://droidsos.com/ask-a-question/

esterndesign

At this point i would reach out to the author of the plugin for some assistance. You may have to do a check to see fi that field was filed out or something. I would think that this should be included in the plugin code but i dont know.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
droidsos Purchased

also How can I add custom fields to questions, and custom fields to user profiles, and how do I customize the point system

esterndesign

Custom fields can be added like tHey being done now if you dive into the code. If you add to these you will want to make sure that you are validating the data and sanitizing it before it gets entered into the db.

You can look back at a previous post that i did to see the basic idea of what needs to be done to get pass and store the new values.

Regards.

-esterndesign

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Hello, this looks like a very nice theme, and I hate to do this to you. Is it capable of pulling information from yahoo answers API like this plugin? http://wp-answers.com/features/

esterndesign

Hi.

Not out of the box but i am pretty sure that this can be done with a plugin. Also i think that might be the way that the other provider is doing anyways. All that most of these plugins do is grab data from the Api from yahoo answers.

Regards.

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
droidsos Purchased

Iv’e figure out the points (// Define Point Level Values) in functions.php

esterndesign

Yes that is where the values ranges are defined.

  • Bought between 100 and 499 items
  • Germany
  • Has been a member for 2-3 years
81media Purchased

Hi there,

is there any easy way to localazie this there?

Kind regards.

esterndesign

Hi,

Yes this theme out of the box comes with localized translations.php file which has all of the items that need to be translated in one easy spot. Just edit this file in your native language and the whole site becomes translated. Only takes a few mins to complete this too!

Regards,

-esterndesign

  • Bought between 10 and 49 items
  • Has been a member for 2-3 years
solocreep Purchased

When clicking on a question on home page, user is not sent to question page. Can you help with the trouble shooting?

Thanks.

esterndesign

Hi,

Can you please provide some more details on this and what exactly and where on the page this is happening.

Feel free to message me via my profile page to send me an email of your site.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
infoineed Purchased

Hi,

Why some of the users are listed twice? Eg. http://ask.infoineed.com/leader-board/

Is there a way to hide admins from LeaderBoard?

Thank you.

esterndesign

Hi,

Questions:

- Do you have duplicate users in the db? - Have you modified the logic on the leader-board.php page? - Do you have any plugins installed that might be causing issues?

If these are all no, then please message me your site info for admin login via my profile here on theme forest so that i can verify that there are no issues.

I have not seen this before.

Regards,

-esterndesign

Default-user
infoineed Purchased

I had a plugin that syncs users from my main site. I uninstalled the plugin but still it shows twice. But the thing is it’s only few users listed twice. Its in the expert list too listed twice. Please help fix this.

esterndesign

Did you check your users.php page in wp-admin to make sure that there are not two instances there. Sounds like a db thing not just the plugin since my guess is that the plugin is adding users to both dbs.

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hi, is it possible to make the black navigation bar (categories) start at the right side from the logo?

esterndesign

Hi,

not out of the box, you would need to modify the css and possibly the header to achieve this.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
droidsos Purchased

Hey I am wondering if this will update automatically through WordPress updates. Also could you make a proper FAQ with general instructions on how to add fields and other customizations one would need.

esterndesign

Hi,

1.) It should, there are no modified core files so it is only theme files. When there are new releases i monitor the theme that it is still fully compatible with the new versions.

2.) I think this is a good idea and when i have some free time i will try to add these as i provide them to the question askers, when it makes sense.

Thanks,

-esterndesign

Default-user
droidsos Purchased

I meant when you update the theme will I get the update through wordpress?

esterndesign

No, it is like any other theme when there are updates you have to update via FTP with the changes files.

Regards,

-esterndesign

Default-user
droidsos Purchased

ok thanks. love your theme!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hi,

Could you please tell me how to change the default avatar images of the theme?

First I’ve tried to change it under settings->discussion but that didn’t change anything.

Then I’ve tried overwriting the files in the wp_content directory but that just changed the images in the preview. The actual avatar is being pulled from gravatar.com.

Please let me know how to change the default user avatars from this theme. Thank you very much.

esterndesign

commented in your other post.

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Sorry, I meant in the directory /wp-content/themes/robust-qa/images/! Overwriting the default-user-avatar-X.jpg files only changes the avatars in the preview (edit profile).

Thank you.

esterndesign

There could be a few things also happening:

1.) If you are using a cache plugin it could be cached and you might want to dump the cache.

2.) Could be browser cache. Reset browser data and do a hard refresh of your browser.

Updating the images in that folder should update them site wide. So you are doing the correct thing.

Regards,

-esterndesign

Default-user

Thank you for the quick answer. However, that’s weird because the actual file path of the avatar is: http://1.gravatar.com/avatar/fbabb49e2ae8431b283de5ba1ed139c0?s=50&d=http%3A%2F%2Fwww.wettfuchs.net%2Fwp-content%2Fthemes%2Frobust-qa%2Fimages%2Fdefault-user-avatar-1.jpg%3Fs%3D50&r=G

As you can see, the image file is being pulled from the gravatar server and I don’t know how to overwrite it there.

esterndesign

well i use the gravatar wp tag:

Here is the order how user icons show up: - If user has upload an image in edit profile - If no user upload image, check user email against gravatar site - If no gravatar image use the default images (which are defined in the edit profile as the default images).

The way the function works for gravatar it sends the default image to gravatar that is why it is showing up as a gravatar url. But technically it is powered by the theme images as noted before.

Hope that outlines what is going on.

Regards,

-esterndesign

Default-user

Hey, thanks for the answer but it’s not working like this. Please try yourself: http://www.wettfuchs.net/my-account/edit-profile/

You can pick one of the default avatars and you see the right preview there. However, once you picked them the original ones show up under the gravatar url. Alternatively check out this screenshot: http://wettfuchs.net/files/avatar_prob.png

IMG Url of the previews: http://www.wettfuchs.net/wp-content/themes/robust-qa/images/default-user-avatar-2.jpg

IMG Url of the actual avatar: http://1.gravatar.com/avatar/d7c498cac3fdb3b78a97bcc45c97b2d5?s=50&d=http%3A%2F%2Fwww.wettfuchs.net%2Fwp-content%2Fthemes%2Frobust-qa%2Fimages%2Fdefault-user-avatar-2.jpg%3Fs%3D50&r=G

We’re not using any caching plugin and I did a hard refresh. Seems like the files from our server once got uploaded to the stupid gravatar server and don’t get refreshed there. Can I just deactivate the use of gravatar somehow?

esterndesign

Hi,

I created a demo account on your site and i am not seeing the cache issue i see the first two images updated to use the custom ones you provided, see this image screenshot: http://tinypic.com/r/k3g3l/6

You can also see that the current avatar is set to the selected one. Also changing it and saving my Profile data does update if i select the second option as well.

My guess is that it is your browser caching the old image. You should try to do a reset of your browser cookies and website data.

I bet this will fix your issues.

You can always do a hard refresh: hold shift + ctrl + r

Regards,

-esterndesign

Default-user

No, it doesn’t. Let’s take this page for example: http://www.wettfuchs.net/leader-board/

All those users have the default-user-avatar-1 which is actually overwritten with our fox image. However, it still shows the original “black silhouette in front of white background” avatar because it doesn’t pull the latest version from our server.

esterndesign

I am not seeing this: http://tinypic.com/r/qzndw8/6

I see all of the default-user-avatar-1 using the correct image that was assigned.

Did you do the suggested browser reset? Are you still seeing issues?

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
guideaid Purchased

Fantastic I have spent 2 days trying to get a blog, page, Q&A in a lightweight responsive theme so far frustrating. Found yours and its up an running in an hour! I have a question and a problem …

Question: it seems you have used the core WP blog for the Q&A – is it possible to have blog functionality as well? Or at least user created pages with comments …

[context] the site (www.guideaid.org) is for developing world Doctors and Nurses their needs are; 1/ I am stuck – solution: Q&A 2/ Things I have done that worked – ‘the missing thing’ 3/ Experts analysis and commentary on literature, things people have done and answers to questions – solution: normal pages (with perhaps a template) [/context]

Problem: when I go to view a profile I get an error message … “Parse error: syntax error, unexpected T_OBJECT_OPERATOR, expecting ’,’ or ’;’ in /var/sites/g/guideaid.org/public_html/wp-content/themes/robust-qa/archive.php on line 111”

Thanks

Ian

esterndesign

Have you modified the code? This is not a bug out of the box. Looks like you have added a few fields to the edit profile page e.g. Twitter input. Based on that error you are probably not ending your line of code with a semicolon.

Hard to tell without looking at the php and i cant reproduce that error on your live site for user profiles.

Adding a blog ontop of the q&A theme is not part of the out of the box features. This would be something that you would need to produce on your own. You could use custom post types to do this action but then you would need to create the blog php pages.

Hope that i have answered your questions.

Regards,

-esterndesign

Default-user
guideaid Purchased

Very odd this was a clean install … although WP was on the box I removed it and re-installed. Presumably the MySQL kept the twitter field? But I have altered nothing and it occurred from the beginning? Editing the archive.php fixed it which is why you can’t see it on the live site. Anyhow no worries.

I can see how creating custom post type would do this I would want to share categories across Q&A and blog plus pages so that I could put on icon on search or browse results – interested in helping? Perhaps we should do this by email < ian at purves.net >

Default-user
guideaid Purchased

Obviously for a fee …

esterndesign

Hi,

not sure what is going on there. I will double check the dev box for this but i wasnt getting any php errors in my testing.

As for the modifications. At this time i am unable to do any enhancements my queue is very full and it is going to be a while for any at all free time.

Sorry for the inconveniences.

Regards,

-esterndesign

Default-user
guideaid Purchased

That’s fine … is there any reason why you didn’t create a custom post type for Q&A … so I don’t trip over a problem down the line

esterndesign

I guess that is one way that could have been done to make it more seamless with other blogs but the main idea was to have a site that was just for Q&A.

You could always have a similar site for a blog and cross-link between the two.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
guideaid Purchased

I have also noticed the problem error above clicking on dates and categories in the widgets.

In addition the WP default ‘answer’ presume in WP speak ‘comment’ to the WP blog (aka Question) is not visible but their is a heading saying “1 Answer” ... interestingly just answered another question and that does appear? So added another to the ‘original’ and nothing appears.

Thanks Ian

esterndesign

Not sure what widgets you are talking about. All of the standard widgets that come with WP are themed and functioning with this theme.

Regards,

-esterndesign

Default-user
guideaid Purchased

No worries got fixed as above

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
guideaid Purchased

Ignore additional comment about answer … assume default doesn’t appear as there is no registered user … second one didn’t as I had “comment author must have a previously approved comment”

esterndesign

Ok great, glad you were able to resolve your issues.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
guideaid Purchased

Problem fixed three $ missing from in front of author (two on line 111 one on line 353) ... seems odd no one else has commented on this??

Anyhow still interested in my question, Thanks Ian

esterndesign

Hi,

I dont see any of these issues nor are the $ missing from those lines of code on archive.php. Again i think these might be areas that you might of added on your own by adding more fields.

What is your question that is still outstanding, you had asked a lot of them. Can you please re-ask.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
guideaid Purchased

Hi, things going really well ;-) Got a slight issue with new user emails. It seems that the code starting ”// Email User with Login Info” in functions.php isn’t working. The email that is sent is …

Subject: [guideaid] Your username and password Date: Mon, 4 Mar 2013 12:02:24 +0000 From: WordPress <wordpress@guideaid.org> To: xxxxx@guideaid.org

Username: xxxxx Password: xxxxx http://guideaid.org/wp-login.php

Which is native Wordpress (I think) as a new user is setup and for example their points are set to 1 it seems odd the email code is bypassed. Do I need to configure something else?

Thanks Ian

esterndesign

Sounds like you were able to resolve the issues on your server on your own and was not the theme but the SMTP settings on your hosting env.

Have a great day.

Regards,

-esterndesign

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
guideaid Purchased

Sorry ignore me … I hadn’t installed the SMTP plugin to configure the mail … the last theme I used had it within and I forgot. Ian

esterndesign

Glad you were able to resolve this on your own.

Regards,

-esterndesign

by
by
by
by
by
by