Rockit Now - Music Band Wordpress Theme

Rockit Now - Music Band Wordpress Theme

Rockit Now is a wordpress theme specially designed for Bands and music websites. This theme is easy to modify and ready to be up and running out of the box. The PSD files included have been customized to allow fast skinning.

Main Features

  1. Event Managment
  2. Gallery Managment
  3. Album + Track Managment
  4. Slider Managment
  5. Sidebar Managment
  6. Powerfull Theme Options + Page Builder

This template comes in 8 pre made color variations. But it will only take one minute to create your desired color schemes by using theme options


Change Log: Older Versions

Dummy data import system is updated
all slider files are centerlized now
little styling issues resolved for Blog, Event and Album Description page
View Albums URL is now dynamic
Home page slider is fixed
Even count down widget background image is dynamic
PSDs are updated

For detailed log please check documentation

Change Log: Version 1.7

1 Theme option data lost issue on theme activation
2 RTL and Responsive
3 CSS and JS more improved.
4 Pretty photo css function removed and added for theme activation
5 Error Message added (like data not found etc)
6 Date format whole theme and wp format enabled
7 Theme made child theme enabled.
8 Added proper comment with all funtions
9 Added action and filter are placed in one function
10 Fixed undefined errors on fresh installation with isset or emtpy check
11 inline JS moved in function.js and made it fuction
12 Checked compatibility with latest wordpress version
13 W3C school validation
14 Default sidebar show on first time activation

Change Log: Version 1.8

1- update upcoming event widget
2- Fixed: footer menu issue.[file: style.css line#3292 replace height:69px with min-height:69px;]

Change Log: Version 1.9 (14 September 2014)
1: WordPress 4.0 compatibility 
2: Event map issue on event detail page
Change Log: Version 2.0 (12 January 2015)
Fixed: Page Builder Issue (changes were made in cs_meta_box.php on line # 210)
Added: Compatibility with Wordpress version 4.1