60 comments found

Awesome theme!

Do you also release it in plain html, Am interested in this theme for my existing site but I am not using wordpress…

feeleep

Thanks! I’m afraid not, this template is strictly made for WP.

does it support wpml (wordpress multilanguage) ?

feeleep

Yes it does. You can find pre-made .po file (used to localize theme) within ‘theme_localization’ folder.

msmith Purchased

Hi – when I upload the zip file directly into Wordpress, I get this:

Fatal error: Call to undefined function add_custom_background() in /home2/iqmindwa/public_html/wp-content/themes/sofa_avatar/functions.php on line 1198

Then the whole thing freezes!

Any idea why?

I’m using Wordpress 2.9.2 in Internet Explorer.

Mark

feeleep

It’s a WordPress 3.0+ theme and uses background feature. First thing you gotta do is to upgrade WordPress to 3.0.1 from your Admin. After doing so, an error will magically disappear. It’s always good idea to always be up to date with WordPress.

msmith Purchased

ok thanks – will do.

msmith Purchased

http://www.iqmindware.com/i3/

Any idea why my page tabs are not showing? I’ve created two pages (including a contact page)

It may be something to do with the fact I imported a whole bunch of pages from another blog?

Mark

feeleep

The reason of why certain pages do not show in main navig could be your pages are password protected or marked as Private. Please check out Appearance > Menus and see whether you’ve added/included these two in main navigation.

msmith Purchased

And one more question – I set the background to white, but I still get the black background for my blogs. How do I change this to look like the demo? Thanks.

feeleep

No need to modify CSS . From Admin menu select Appearance > Background and replace background color from there. Default black color of background is set to HTML element on behalf of being able to style BODY element from WP Admin.

msmith Purchased

Actually – I’m going to reinstall without all the pages from the previous blog and see how I do.

feeleep

As already mentioned, check out Appearance > Menus and seek for missing pages. Not sure what else could be wrong…

msmith Purchased

OK – sorry, figured out the menu’s pluggin – didn’t realize there was a dedicated page for it. Nice.

msmith Purchased

Question about Piecemaker:

If I want to change one of the images I’ve saved in the ‘Images Repository’ page, how do I do it?

I’ve tried just deleting an image and replacing with another image I want, but Piecemaker still displays the original image set.

feeleep

Piecemaker images are tied to Post ID. It’s not enough to just delete it from Post text Editor coz an image still remains in Media Library. When Piecemaker seeks for all photos whose parent ID is Images Repository page ID, it’ll pull all from Media Library.
Otherwise spoken, delete image from Media Library if you want to remove it for real. That’s how you remove images from any other Post or Page in disregard of theme used.

msmith Purchased

ok thanks. Sorted now. http://www.iqmindware.com/i3 Although sometimes the ORDERING of the images in Piecemaker seems different from the way I enter them in the post. Any idea why?

feeleep

You’ll have to sort your images in post Gallery! All of images are actually sortable as drag’n’drop and once you got’em all sorted – hit “Save all changes” button. Take a look at the screenshot here: http://sofarider.com/downloads/gallery_sort.png

msmith Purchased

OK -

Fantastic theme thanks – for my purposes the best I’ve ever seen! And great feedback on questions. Great job.

feeleep

Thanks a lot, it’s my pleasure to work here!

ianmack Purchased

Hi there – great theme. Am I missing something about the blog though? I cant see how to set it up anywhere. I created a page called Blog

http://kellychamchuk.com/blog/

To make it the blog index page, do I have to set a specific template?

Thanks for the help.

feeleep

No need to create an extra page for Blog because it actually belongs to category. So all you gotta do is to create category named Blog instead, make it branch to sub-categories – if required of course, and publish all of your posts there.
For a case you get confused with index page layout, it’s damn easy to switch to classic blog view; select Appearance > Sofa Avatar Options > Home page content layout. One of layout options reads “Classic Blog” and that’s exactly the one you gonna need.

msmith Purchased

Another tweeking question…

http://www.iqmindware.com/i3/

Do you know why when I click on the right featured content slider titles that the title above the main image moves from being centred to being raised off centre (if you see what I mean)?

No big deal, but any idea?

feeleep

Yeap, I see what’s wrong, one of your plugins (portfolio gallery or something similar) has loaded another instance of jQuery library which caused featured content slider not to work properly. If you use Firebug for Firefox, you can see 1 javascript error report too. Please try to deactivate that plugin, refresh front page and see whether the problem persist. If true, feel free to create a temp Admin account for me and I’ll be happy to solve it out.

msmith Purchased

Hi – much appreciated if you can look at this:

http://www.iqmindware.com/i3/wp-login.php?redirect_to=http%3A%2F%2Fwww.iqmindware.com%2Fi3%2Fwp-admin%2F&reauth=1

The temporary password is ‘temppassword’

Thanks.

feeleep

Problem solved. Next time you activate Super Cache once your website is ready for launch, otherwise it won’t let you see any change you made on back-end. On a side note, I did disable “Portfolio Slideshow” plugin which was in conflict with jQuery featured content cslider.

DELETE YOUR TEST ACCOUNT IMMEDIATELY , SOMEONE COULD HIJACK YOUR WEBSITE .

PS:
Next time send me login info on my private email address ;)

yuzhu Purchased

I just purchased your theme. Great work.

I notice that on my installation and in MSMITH ’s, that when you click the link of an item in the feature item box, it scrolls the page down to where the feature item box is.

but on your demo theme, it does not do this. the image simply changes.

how can I (or we) fix this from happening?

feeleep

YUZHU calendar loads another instance of jQuery library which causes featured content slider to stop working. Try to deactivate calendar plugin, get back to front-end, refresh and see whether the problem persist. If true (I doubt it does!), please provide a temp access to your WP Admin so I can make additional tests.

Default-user
yuzhu Purchased

yeah i disabled my-calendar and it still does it. i pm access to you.

feeleep

Ah, now I realize what was that short email about :) I thought someone is kidding me…no URL , no subject, only 2 words split by forward slash…I was about to contact Sherlock Holmes.

msmith Purchased

thanks for the fix!

feeleep

You welcome!

Hi,

Love the theme. I am trying to use an e-commerce plugin with the theme that worked on my previous theme. When I insert the code to display a buy now product button all that appears is a big grey box. ex. http://linkedinguy.com/services I believe this may be theme orientated. Is there a line of code in the style sheet I need to delete to get the button to display? Thanks for your help!

Paul

I love the theme, but I am having problems making the slider on the homepage work. Also, how can I create a tab for the homepage. Any help would be great! Thanks!

feeleep

In order to create a Home page link in main navig do the following:
1) From main Admin menu select Appearance > Menus.
2) Spot the panel named “Custom Links”. Enter your website URL to input field named “URL” and “Home Page” string to input field named “Label”
3) Hit “Add to Menu” button

As for the Featured Content Slider, could you please be more specific? And even better, to let me know your website URL . That’s how I’ll be able to tell you more.
Before getting too frustrated because it doesn’t work, please take 5 minutes break and swift through theme manuals, I bet you gonna find an answer/solution.

Default-user

Thanks for your reply and the help with the homepage. I have read through the manual a few times and I’m still having problems. I’m not sure what I’m missing. My URL is www.entertrainerblog.com/wordpress

Let me know if it would help for you to get in and use a temp password.

Thanks again for your help!

feeleep

Yes, temp Admin account for me would be great. However, before you do so, please be sure you have uploaded all of the slide images to previously created Page (aka Images Repository). This page needs to be selected on Theme Options page as the one supposed to feed Piecemaker. Select Appearance > Sofa Avatar Options from main Admin menu and look up for Piecemaker settings.

About my earlier comment regarding the “buy now” boxes. At the suggestion of the plugin author, I switched back to the default theme and I was able to see the buttons again, indicating there is some conflict with the theme’s styling. http://linkedinguy.com/services Thanks for looking into this. I’m hoping it’s just a simple css tweak.

Paul

feeleep
I don’t know why, all of “Add to Cart” buttons are inserted as OBJECTs inside of which the FORM is found. On top of that, OBJECT doesn’t use any class or ID (css) and there’s no way to style it separately from other/default object and embed tags which are used any time you insert (for instance) YouTube video. By default, OBJECT tag has the height of 360px (594px wide) and thus all of your “Add to Cart” buttons look screwed up.
Basically, you can do the following but be aware that all of your eventually inserted YouTube, Vimeo, etc. videos will now be shrinked to the size of “Add to Cart” button:
1) open “style.css” and go to line #382. It currently reads the following

#content .article object, #content .article embed  { width: 594px; height: 360px; margin: 7px 0; padding: 3px; display: block; clear: both; background-color: #F1F1F1; }

Set width, height, margin and padding to fit your button size.
2) If the same issue persist on index or category page, you’ll have to do the same for the line number 383 (right below the one you just have edit).

It’s true that the problem is with theme’s CSS but why the hell someone would wrap FORM element with OBJECT tag without using unique class (css)?!? That’s extremely stupid and non-professional.

Default-user

Hi Feeleep,

The plugin author added a CSS class for the plugin. Can you help me get it implemented in the theme? Here’s the dialogue between the plugin developer and myself:

All I have done is added a CSS class called “eStore_button_object” for the button object of eStore as requested by your theme developer. I am not a 100% sure as to what this theme is doing but I think if you add something like the following to your CSS it will take care of it:

.eStore_button_object{ height:auto; width:auto;

Hi,

I tried adding that to the end of my css file but it didn’t do anything. I’ve attached the style sheet. Do you mind showing me where I’d add that?

Thanks!

I don’t have knowledge of the CSS file for the theme you are using. You told me that your theme author complained because we didn’t have a specific class for the button object so I added a class for the button object. The class is called “eStore_button_object”.

So don’t you just need to tell your theme author that there is a specific class for that button object and he can do whatever he needs to do on the theme side?

feeleep
OK, you’ll have to send me an email with user and pass to your WP admin first. It’s great to hear that plugin author has added a class to an object element. I think you didn’t do anything wrong but rather a new class is out of scope. So instead of

.eStore_button_object{ height: auto; width: auto; }

...you would write

#content .article object.eStore_button_object, #content .article embed.eStore_button_object { height: auto; width: auto; }

Test it out, hopefully it’s gonna work.

I have done all this.

My temp login info: un: hudakconsulting pw: gocats0

Thank you.

feeleep

I don’t think it’s good idea to expose login info in such way. Please consider sending it to my private email address next time, right now I encourage you to dump that account completely.

Either way, your slider is working just fine. If you go to Appearance > Sofa Avatar Options and click on very first option (“Home page header elements”), you can easily pick what to display on Front page. I guess you overlooked that part somehow :)

by
by
by
by
by
by