277 comments found

  • Bought between 1 and 9 items
  • Brazil
  • Has been a member for 1-2 years

I think if you use phpmailer you will help many people who has problem in submitting the form, displaying SENDING by clicking the submit button. In my case that has modified the ajax.php to phpmailer, maybe just a change in main-r9.js solve the problem. Can help us all with this upgrade?

JoNa

Hello reflexsite,

Thanks for your message and recommendation! Please accept my apologies for the delay in my reply. I would be more than happy to implement the PHPMailer library in the Spark Template. However I must inform that the purpose of this great tool is mainly to handle HTML emails and attachments, which are not used by the Contact Form in the Spark Template. When it comes to simple text emails, the basic PHP mail() function performs better as it is less complex.

In your specific case, your Web Hosting Provider requires you to use the PHPMailer library in order to send emails via a custom SMTP server, as they have disabled the internal PHP mail() function. This is a very rare requirement, and replacing the default PHP mail method with the entire PHPMailer library might not be the best choice for everyone mainly because of the added complexity, for both performance and ease of configuration reasons.

Nevertheless, I am totally willing to assist you with the integration of the PHPMailer library on your installation! I have just replied to your previous message: please send me FTP credentials to your site and I will make sure that everything is working smoothly using the PHPMailer library.

I hope that you will find this information useful, and again please accept my apologies for my late reply! I look forward to your email, and please don’t hesitate to contact me for anything else – I’ll be more than happy to help! Best, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

JoNa – perhaps what I’m asking is outside the scope of your support, but it can’t hurt to ask. I love the theme and I’m currently using it for our church’s website and it looks great. All I want to do is add in a footer that would mimic the behavior of the header in the sense that it would always be visible. I’ve added code to the CSS file and what I believe to be the proper location in the index.html file but I cannot get a footer to work.

This is my CSS code:
footer { position: fixed; bottom: 0; left: 0; right: 0; background-color: #eee; display: block; z-index: 10; } footer section { width: 960px; display: block; margin: 0px auto; padding:12px 0 11px 0; position: relative; }
This is my implementation in the index.html file (outside the div main):
<footer> <section> <p>Test Test Test Test Test</p> </section> </footer>
JoNa

Hello stjohnsord,

Thanks for your message! and sorry for the delay. That seems interesting, I have just tried your CSS and it appears to work for me :)

We would need to adjust the main viewport however. To do that you’ll have to fix the height of your footer, let’s say 100px, and then move the #main element 100px from the bottom:

#main  {
    bottom: 100px;
}

That should do it, if that’s still not perfect then please share a link to your page so I can take a further look. Also I would recommend disabling the sticky footer for Mobile Devices.

I hope that helps, and please feel free to let me know if you need further assistance with this, I’ll be happy to help ;) Best, Jonathan

Default-user

Hi Jonathan,

Thanks for the feedback. I believe I have correctly implemented your suggestions but I’m still not getting it to work. I reloaded the index.html file that came with the package, added the code there (thinking I may have messed something up in my version) but still to no avail.

Here’s my #main declaration in the main-r9.css file:
#main {
    position: absolute;
    overflow-y: scroll;
    top:89px;
    left:0; 
    bottom:100px; 
    right:0;
}
and these are the footer and footer section declarations:
footer { 
    position: fixed;
    bottom: 0;
    left: 0;
    right: 0; 
    height: 100px;
    background-color: #eee;
    display: block; 
    z-index: 10;
}

footer section { 
    width: 960px;
    display: block;
    margin: 0px auto;
    padding:12px 0 11px 0;
    position: relative;
}

and finally my implementation within the index.html file (included the closing of the main viewport for reference):

<!-- #main -->
<footer>
    <section>

        <p>Test Test Test Test Test</p>

    </section>

</footer>

The website is www.stjohnsord.com and I would greatly appreciate any suggestions you have.

Sincerely,

Russ

JoNa

Hey Russ,

Thanks for the follow-up! I believe the issue is because your CSS is cached and therefore not reflected on the site. The CSS code you show me seems to be missing from: http://www.stjohnsord.com/min-merge-cache=css/skeleton-v1.1.css,flexslider-v1.8.css,main-r9.css,media-queries-r9.css,sprites-r7.css,theme-default-r6.css

To fix this you can either rename the file main-r9.css to something like main-r10.css (remember to also update the name in the HTML source), or more simply delete the “cache” folder found in the “static-server” directory. Once done make sure to clear the cache of your web browser (Control+Shift+Delete).

I hope that helps! In the future you might want to use the index-nophp.html file to experiment with CSS as this version doesn’t have any caching, and once you’re certain about your code then put it live by renaming the CSS file or eventually clearing the cache manually ;) Best, Jonathan

Default-user

Jonathan,

Brilliant! That did it. Thank you SO much for your time and support not to mention being so courteous and professional in doing so. Can’t believe I overlooked something so simple :silly:!

Obviously I have made some significant changes to the original as some of your design just wasn’t needed for our purposes, but I loved the color scheme, features and simplicity and I hope I have remained faithful to your original intent.

Again, I greatly appreciate you’re willingness to help me out with this!

Sincerely,

Russ

JoNa

Awesome! I’m glad that I was able to help! Congrats about your customization, it looks great :)

Please feel free to contact me again if you need any further help with anything, I’ll be happy to hear from you! Best, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi. Great template. However, whenever I send an email (Firefox or IE), the email sends ok but the button always says ‘Sending…’. It doesn’t seem to be getting a response passed back from ajax.php. Any advice please? Thanks!

JoNa

Hello captain_planet,

Thanks for your message and sorry for the delay! Could you please send me a link to your site so I can take a look at the exact error returned? If the email is being sent correctly then the problem is probably related to the success message not being correctly returned in JSON format.

That could be caused by a space or line-break at the beginning of the ajax.php file (before the <?php opening tag). If not, then it could be caused by an improper encoding.

Make sure that the ajax.php file is encoded in “Unicode UTF-8 Without BOM”. Depending on your text editor, you should be able to select this encoding upon saving of the file, or under the “Encoding” menu if your using Notepad++ (editor that I recommend).

I hope that helps and please keep me posted! I look forward to being able to help you further with this ;) Best regards, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

oh, btw, when I downloaded and tested it, the only page that would render was the ‘no PHP’ one. The others didn’t. I think the difference was the way the style sheets were declared…

JoNa

Hello captain_planet,

Thanks for your comment. You are correct the difference comes from the CSS and JS inclusion. Please see this FAQ: http://themeforest.net/item/spark-a-responsive-onepage-html5-website/1350924/faqs/9614

The no-PHP variant includes CSS and JS files traditionally, while the others include CSS and JS files through the Smart Static-Server: which purpose is to boost page-loading performance by minifying/merging/gzipping/server-caching and browser-caching all CSS and Javascript files!

I hope that clears things up, and please don’t hesitate to contact me if you need any further information, I’ll be happy to assist ;) Best, Jonathan

  • Bought between 1 and 9 items
  • Brazil
  • Has been a member for 1-2 years

@Jona,

Fortunately not getting support after more than 15 days of the request. The good thing is that I ran back and solved the problem alone. See how it looks. www.gracai.com.br.

JoNa

Dear reflexsite,

Thanks for your message, I’m really sorry for the exceptional delay experienced recently, I’m trying my best to assist as much people as I can and I get sometime overwhelmed, sincere apologies!

However I’m really happy that you were able to solve this problem by yourself! Congrats!

If you need anything else from me or if I can assist you with any other thing please don’t hesitate to contact me, I’d be more than happy to hear from you ;) Best regards, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Fixed my issue of the ‘Send’ button sticking. I removed this line from ajax.php on line 46: header(‘Content-type: application/json’);

Also, when the form returned success it blanked out the form and then validated, so the form elements turned red? So I commented this line out of main-r9.js (line 197): form.find(’#form-email, #form-name, #form-message’).val(’’);

JoNa

Hey captain_planet,

Thanks for the follow-up! Please send me a link to your site so I can take a look. This is not normal behavior – you shouldn’t need to edit the javascript.

I believe that the conflict you’re having with the JSON header comes from a space or line-break at the beginning of the ajax.php file, or possibly related to the file encoding (see my previous message to you posted earlier).

Please keep me posted, I look forward to be solving this for you ;) Cheers, Jonathan

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Hello. I just purchased this theme and I’ve uploaded to my domain like hundreds of others that I’ve done. For some reason the page does not come together correctly. It just looks like very basic HTML without any css. Here is a screen shot: http://deliverpdx.com/Capture.JPG

the file “index-nophp.html” opens fine locally and displays the site correctly.

JoNa

Hello srockhard,

Thank you for your message!

Short answer:
Simply use the “index-nophp.html” version. You can rename it to “index.html” to use this version by default.

Long answer:
The “index.html” version benefits from performance enhancements, which requires to run on a standard PHP web hosting. It usually works fine with most hosting providers, but in some cases you might need to do some adjustments – For further information please take a look at this detailed FAQ: http://themeforest.net/item/spark-a-responsive-onepage-html5-website/1350924/faqs/9614

The difference between the two files (“index.html” and “index-nophp.html“) is found in the way the CSS and JavaScript files are included. The “nophp” one calls the files directly, while the first one calls the files through a PHP script that will minify, merge, gzip and cache all CSS and JavaScript files.

I hope that helps! Please don’t hesitate to contact me again if you need any further assistance! If possible, please include a link to your site so I can look the error you’re encountering and provide you with informed advise ;) Best, Jonathan

Default-user

**SORRY…i got it working now ;) ...it was just the permissions on the Cache folder ;) thank you!

  • Bought between 10 and 49 items
  • Has been a member for 6-7 years

PRINTING – What do I need to do for the website to print. I get a blank in the print preview and the print itself.

thanks, anthony

JoNa

Hello anthony,

Thank you for reporting this! Let me take a look into that so I can see what is the cause and I will get back to you shortly!

Thanks for you patience ;) Best, Jonathan

  • Bought between 10 and 49 items
  • Has been a member for 5-6 years

Thanks for a great template. I am having an issue with a clients site, it was working fine for a year and now for some reason is not loading the sytlesheet correctly or the images. I have contacted the hosting provider and they say it is a memory issue, that the site is trying to use more than the 96Mb allocation and they are also trying to upsell me on a bigger package for the client (hosting). Can you please take a look at the site and let me know what has gone wrong.

http://bit.ly/1amVX5m

Cheers.

Default-user

Found the issue it was with the htaccess file. Now resolved.

JoNa

Hi urbantech,

Thanks for your messages, I’m glad that you were able to find and solve the issue!

Please feel free to let me know if there’s anything I can help you with, I’ll be happy to hear from you ;) Warm Regards, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

I sent you a message from your profile page. You should have my original message. If not then here are my questions, as I’ve explained I’m a beginner AND I’m not going to spend $40 on a wordpress theme.

1) How do I change the color scheme 2) How do I change the slide show to fit the whole width of the screen 3) Make the first Welcome screen smaller so it fits the page rather than scrolling down.

That’s it for now, I’ll get back to you if I have any more questions.

JoNa

Dear GSinghKhalistani,

Thanks for your comment! I just double checked but didn’t get your message, sorry about that! Could you please be so kind and open a support ticket at http://jona.maddim.com/support/ – I’ll be more than happy to assist you as much as I can.

Please note however that in order to make color modifications you’ll probably need basic elementary CSS knowledge, as only the WordPress version has a customization interface with an easy-to-use color picker, etc. I believe some editor tools allow to edit CSS colors via their interface but I would really recommend editing the CSS directly as it’s much cleaner and very simple once you got the syntax.

Thanks! I look forward to hearing back from you, I’ll do my best to provide you with all the help you need that I can provide ;) Warm Regards, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Thank for your reply, what about my other questions:

2) How do I change the slide show to fit the whole width of the screen 3) Make the first Welcome screen smaller so it fits the page rather than scrolling down. 4) Also, how do I change the font for the top navigation

JoNa

Dear GSinghKhalistani,

Thanks for your comment! Could you please be so kind and open a support ticket at http://jona.maddim.com/support/ – I’ll be more than happy to assist you as much as I can.

Thanks! I look forward to hearing back from you, I’ll do my best to provide you with all the help you need that I can provide ;) Warm Regards, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hello, I am trying to update the icons through the theme options. I am following your instructions as to picking new icons and downloading them through the IcoMoon App page. I place the downloaded file in the upload box, choose send to option tree, and then hit the save button (just like your video shows) but I get an error message as follows: “Icons: Unsupported file format. Please upload a ZIP file (.zip) under the Icons tab – compatible ZIP can be downloaded from http://icomoon.io/app/#browse."

I have tried this multiple times from multiple computers and I get the same results. Any information or assistance you can provide would be appreciated.

Thanks in advance for your time.

JoNa

Hi jmforman,

Thanks for your message. May I ask if you have the latest version of the Spark Theme? There was a known issue with some web hosting providers that affected earlier versions of the Spark Theme, and which I have resolved a while ago via an update.

Please let me know the version of the Spark theme you’re running, and if you can try updating it to the latest version available to see if that works for you.

Thanks! I look forward to your reply ;) Best, Jonathan

Default-user

Currently using version 4.0. Hosting is on Blue Host Pro account.

JoNa

Hi jmforman,

Thanks for your reply. Please update the theme to version 4.1 – It will solve the issue you’re having. See this FAQ for instructions on how to update the theme: http://themeforest.net/item/spark-responsive-retina-onepage-wordpress-theme/2372522/faqs/9828

Please let me know if you need any further help, I’ll be happy to assist ;) Cheers, Jonathan

PS for others: This comment concerns the Spark WordPress Theme, it’s not related to this Spark HTML5 Template.

Default-user

Worked great. Thanks for the info. Sorry I put this in the wrong thread!

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years
  • Jamaica

Nice, simple and fast loading. Be nice if you had a longer version with testimonials, portfolio of images and vids etc?

Do you have a longer expanded version? or do we need to drop the code in ourselves :crying:

thanks,

mase

JoNa

Hi mase,

Thanks for your comment! There are plenty of shortcodes available and ready to be used to create all the content you need, including responsive videos, etc. Not to mention the great TinyMCE Editor Visual Enhancer included which allows you to visualize columns, font-icons, etc. directly from within the WordPress Editor, making it super simple to create content!

Also the theme comes with lots of helpful demo content which you can use almost anywhere in your site.

I hope that answers your questions! Please don’t hesitate to let me know if you need any help with the customization, I’ll be more than happy to hear from you :) Best, Jonathan

  • Bought between 1 and 9 items
  • Brazil
  • Has been a member for 1-2 years

1) How do I change the slide show to fit the whole width of the screen

2) How do I change the icons on the site?

JoNa

Hello reflexsite,

Thank you for contacting me. Have you had a look at the Theme Options page under the “Icons” tab? Check out this short video for step-by-step instructions: https://www.youtube.com/watch?v=RtbSRLegw68 :)

Regarding the main slider, you can extend it to the full width available within the site’s layout by going to the Theme Options page, and under the “Main Slider” tab just select “Fullwidth”. If this isn’t enough and you would like the slider to actually use the full width of the browser, it would require you to edit the header.php template file and add the following code at the very end of the file:

<?php echo do_shortcode('[welcome_block]'); ?>

I believe images would also need to be adapted as well, take a look at /wp-content/themes/spark/core/shortcodes.php on line 464 (or look for “welcome_block“).

I hope that helps, please don’t hesitate to let me know if you need further assistance with this customization, I’ll be happy to hear from you! Sincerely, Jonathan

JoNa

Hi again reflexiste,

I’m really sorry I just figured out that your comment was about the “Spark HTML5 Website Template” and not about the “Spark WordPress Theme”!

Sorry for my unrelated reply! So let me answer your initial questions:

1) To make the slideshow fullwidth, edit the HTML code and delete the ‹div class="seven columns"›...‹/div› containing the left block, and change the class of the div containing the slider from “nine columns” to “sixteen columns”. Please let me know if you need help making this modification, I’ll be pleased to help! Feel free to send me a private message so I can send you an edited version of the template files that reflects this customization ;)

2) To change the icons on the site, simply replace the tags with your own custom ones. Please check out this FAQ entry for further details: http://themeforest.net/item/spark-a-responsive-onepage-html5-website/1350924/faqs/9613

I hope that helps! Again sorry for the confusion. Please don’t hesitate to contact me again if you need any further assistance, I’ll be happy to hear from you! Kindest regards, Jonathan :)

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hi Jona,

Submitted a ticket regarding issues with the mailer, keep getting an error message, have done everything required, full details in ticket, please advise?

Thanks HS

JoNa

Dear Siren_Search,

Thank you for contacting me, and please accept my sincere apologies for the delay in my reply. I just replied to your ticket.

I had a look at your site and tried to send a message using the contact form, and I indeed got the error “Message not sent, please try again later.” like you mention.

Usually this message appears because the PHP mail() function failed to send the email (it returned false). It could be related to the fact that your email address is not properly defined. Did you make sure to enter your email address correctly at the top of the ajax.php file on line 9? If yes, then it’s a possibility that your Web Hosting Provider doesn’t support sending emails, it’s very rare but I know of one case where a small Web Hosting Provider had disabled the ability to send emails via the PHP default mail() function for some reasons. You could try asking your hosting provider support why you cannot send emails using the PHP mail() function, perhaps they will be able to help!

I hope that you will find this information helpful, and please keep me posted! Please let me know if it’s still not working – I’ll be glad to assist further. Also feel free to send me FTP logins, or if you prefer just send me your customized “ajax.php” file so I can verify that you entered your email address properly and that there isn’t any mistake or unwanted character.

Deepest regards, Jonathan

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hi Jona,

Could really do with your support on this one, I submitted a ticket more than 10 days ago.

Thanks HS

JoNa

Dear Siren_Search,

Really sorry for the delay! I just replied to your ticket. Let me know if I can assist you further, I’ll be happy to hear from you. Best regards, Jonathan :)

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Follow up to previous comment – PHP Form Error

Just thought I’d say how pleased I am with the excellent support Jona offered me with this template – highly recommended!

I had an issue when using 123Reg hosting who had limitations on email handling which Jona resolved.

Many Thanks HS

JoNa

Thank you so much Siren_Search for the kind words, I really appreciate it! :)

by
by
by
by
by
by