Discussion on theGrid – Retina Ready One-Page Wordpress Theme

194 comments found

  • Bought between 50 and 99 items
  • Has been a member for 4-5 years

Uh oh , I posted a question in the comments section of the html version, when in fact I wanted to ask my questions over here :( sorry Then, how does your theme work with SEO ? Thanks B.

tommusrhodus

It’s a one-pager, so obviously you’re missing out on a few SEO checkboxes like multiple pages, and perhaps a slightly page speed drop, but other than that it’s ready to go, valid HTML5 etc :)

Cheers

  • Bought between 100 and 499 items
  • France
  • Has been a member for 2-3 years

Hello !

I would like to display more than five portfolio items on my homepage.

Is it possible ?

When i click on “Show this on homepage?”, only five items are displaied on the homepage.

I would like to display 10.

Thank you !

tommusrhodus

Hey there,

Ensure that your posts per page settings in “settings” => “reading” are set to 10 or above, and that each of the homepage posts would fall in your first 10 most recent posts.

Cheers

  • Bought between 50 and 99 items
  • Has been a member for 3-4 years
adamram Purchased

Hi can you give me the code to change the phone form field so that it will accept spaces? I need to use a US number format like xxx-xxx-xxxx since users naturally type numbers this way as opposed to a numeric string. It would be better to allow text to so users that type parenthesis and dashes like (xxx) xxx-xxxx are also not rejected. Thanks

tommusrhodus

Hey there,

Doing that would lead to a decrease in spam protection on your contact form which would then mean more spam messages would make it through to your contact email.

Are you sure you’d like to do this?

Cheers

Default-user
adamram Purchased

Hi Thommus, I changed the line in contact.php so the phone field is considered a text field like the comments. This works but let me know if there’s a better way. Thanks. PS. Great theme btw, one of the nicest I’ve purchased here.

tommusrhodus

Hey there,

You’ve done exactly what I would have mentioned, just be sure to keep an eye on it though and make sure you don’t get spam creeping through :)

Glad you like the theme, there’s actually a big code optimisation update coming soon as well :)

Cheers

Default-user
adamram Purchased

I’ll definitely keep an eye on it. Thanks, I look forward to seeing the update.

  • Bought between 50 and 99 items
  • Has been a member for 3-4 years
adamram Purchased

Hi When I create a block and uncheck the “show this block in homeview” box it initally does not appear on my homepage. Then when I visit the page where I do want it to appear I see it as expected however when I return to the homepage the block also appears and will not go away even after refreshing. Please let me know if this is some caching issue. Thanks

tommusrhodus

Hey there,

Please change the filter url of your home link from:

filter=*

to:

filter=.home

Cheers

  • Bought between 10 and 49 items
  • Canada
  • Has been a member for 0-1 years
SHARPP Purchased

Hello Tommus, I have purchased your theme and I really loved it. Thanks for a great theme. What I want here is to Install Sample data. Can you tell me how to do it so that it looks exactly the same as in the demo. It will be then easier for me to customize.

Thanks

tommusrhodus

Hey there,

Full sample data, and documentation including video documentation is included in the ‘main files and documentation’ download from your theme forest account.

Cheers

Default-user
SHARPP Purchased

Got it, thanks alot mate. Great support and documentation :)

  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 1-2 years

Im thinkin of buy this theme. Already use MY FOLIO. Great theme. Do you think there will be a category section for the portfolio in a later update? Just a separate box, with the same text style from other blocks.. would be awesome!

tommusrhodus

I’ve made a note of this, I’ll see if it’s something we can add to theGrid at some point in the future :)

Cheers!

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi, I just purchased this theme and when setting it up the demo data file: thegrid.wordpress.2013-05-01.xml is not installing – it stalls and doesn’t finish import/install? I’m on Wordpress 3.8.1

Any help would be appreciated, I’m under a tight deadline and really need to get this setup.

Great theme, really excited to play with it. Please let me know.

tommusrhodus

Hey there,

There’s a chance that the post attachments are doing this. try importing without checking the “import attachments” button and see if it does it :)

Cheers!

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi, thanks for the quick feedback earlier. I have another question below.

I changed the “About” filter to “Lawyers” in the Menus & Customize TG – all works fine with one exception. When I rollover the persons images and click the eye to read more about them – the Bio page opens fine. When I click the X button to go back to main site, I am loosing some of the boxes that were previously there.

The issue is the URL is changing: When I click in it’s – #filter=.lawyers When I X out it’s: #filter=.about

Is there anyway to remedy this?

Thanks!

tommusrhodus

Hey there,

Yeah totally! Open header-single.php in your theme files, you’ll see #filter=.about in there, just change that as you need :)

Cheers!

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi, I”m having a small formatting issue. I made the header background white and the background #f9f9f9 (very light). I’m getting a thin dark gray stroke line that runs horizontally between the header & background and the notch(V) in the center is white with no stroke. Is there any way to remove the stroke on the horizontal line or add a stroke to the notch(V)?

Also, I was working on this last night, stepped away and when I came back the Template Name in TG Page Builder had switched to my admin user name. It overwrote all my titles and populated empty fields with my use name. I had to go through and rewrite everything and my Template Name is still my user name. Should I leave it or can I change that back to home or do I chance breaking it again? Also, do I need to worry about this happening again in the future?

Thanks for all your help, all and all I love this theme.

tommusrhodus

Hey there,

1. Do you have a site URL I can take a quick peek at?

2. Hmm, that sounds odd, can’t even begin to imagine what happened there? I use this page builder across almost all my themes and this is the first I’ve ever heard of anything like that, so probably just a freak occurrence more than anything :)

Cheers!

Default-user

Here’s the URL: http://globalsportsadvocates.com.s92200.gridserver.com

Do you think it’s safe to change the template name back to Home?

tommusrhodus

Hey there,

Ok 1: add the following to :appearance” => “customise” => “custom css”

#wrapper::before { display: none; }

And 2. You can quickly backup your template(s) by going to “tools” => “export” => “templates” if you’re worried about any changes.

Cheers

Default-user

The custom css you sent didn’t change anything?

#wrapper::before { display: none; }
tommusrhodus

there appears to be pre and code tags wrapped around it, just compare what you’ve pasted to what you can see above.

Cheers

Default-user

Thanks for feedback on custom CSS – that worked.

On the contact form – it’s currently sending emails to the admins email address. Is there a way to use a different email address for this?

tommusrhodus

Hey there,

You’d want to modify contact.php in your theme files to use a static email address, e.g:

'test@email.com';

Where currently there’s:

get_bloginfo('admin_email');

Cheers

Default-user

Thank you!

tommusrhodus

No problem :)

Be sure to rate the theme from the downloads section of your themeforest account if you’re happy with the theme, and with my support :)

  • Bought between 1 and 9 items
  • Has been a member for 2-3 years

Hi, I built a site based on this theme and built it on a dev server. All was looking great. When it came time to launch, I downloaded the database and did a global search and replace of my dev server name, replacing it with my live server name. Now when I view the site I have lost all of my theme customizations: fonts and images are gone, colors are all black. But my text copy is there. Any idea of what step I have missed here? Please respond to agale@snowhaven.com as well as the email for this account.Thank you! Thanks.

tommusrhodus

Hey there,

We run all theme support through our ticket service:

http://tommusrhodus.ticksy.com

Please be sure to include your site URL so we can see your site and get a better idea of what’s happening.

Cheers!

Default-user

ok I will create an account and post there

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years

Hi Tom,

Firstly, Excellent theme. You Sir are a genius at design and typography.

I’m just about to pusrchase but have 2 minor queries:

1 – I understand that the URLs are ‘messed up’ because of the javascript/animations etc. Does this affect the SEO in any way? I noticed your features list doesnt say SEO optimized.

2 – in the contact form, is there a feature to send an automatic response to the person filling in the contact form? for example: I visit the site, fill in the contact form and when I hit send I receive an email with some message saying, ‘thanks for the message, get in touch soon etc’. ?

my website is going to kick ass when I’m done with it. thanks to your theme!

:)

Shamil

tommusrhodus

Hey there,

1. You should consider theGrid the same as any other one-page site in terms of SEO (no page changes) but other than that, the animations and #filters are there purely for design, search engines see the content as a full and proper single page.

2. This isn’t built in by default, I’ll have a think about this, could be a great addition for an update.

Cheers!

Default-user

Hi Tom,

Thanks for the quick reply.

Thats unfortunate. But can I query one more thing quickly:

I know you mentioned before, we can add multiple pages (individual pages with their own URL. (no #filter urls). This will then loose the fancy animations.

My question is, if I do that, and create multiple pages, would this then become a standard multi page website? (with SEO). I know your other theme widergrid is has SEO. Shamil

thanks in advance
tommusrhodus

Indeed, if you ditch the filters and go for standard pages then you’ll have all the usual SEO advantages of a multipage site.

Cheers

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Hi there

Your theme is perfect for a project I’m working on, but I’m working on it with an SEO agency.. so would like to know if it’s possible to use this theme on a page basis (i.e. not using the Jquery), so that each section was in fact it’s own page and could have it’s own SEO tags etc and each section would have it’s own URL.

If this is not something that it can do out of the box, please let me know if you could quote to make this possible?

Cheers for your help and great work!

tommusrhodus

Hey there,

Yeah you can split this into multipage with proper URLs, but, you’ll lost the section change animations :)

Cheers

Default-user

Thank you! I don’t mind losing the animations. Is this possible via the standard download by one of my developers /is this part of the theme, or would this be custom development that I’d have to pay you extra to do? Thanks again, appreciate your quick response.

tommusrhodus

Hey there,

The theme can operate in this way without any modification :)

Cheers!

Default-user

Great, thanks for the quick reply!

  • Bought between 10 and 49 items
  • Has been a member for 0-1 years
ethanmax Purchased

can i haz more than 4 isotopes wide?

tommusrhodus

Nope, 4 isotopes is the max width of the theme.

Cheers!

  • Bought between 1 and 9 items
  • Has been a member for 1-2 years

Howdy! I run The Grid on my site. I was just wondering how I add a short video to my page. I have been able to upload the video to the media library but can’t see a way of showing. Thanks in advance.

tommusrhodus

theGrid does not support adding video to the main page. I do have a beta version that allows you to add vimeo / youtube to the main page. Contact me through my profile contact form if you’d like me to send you this.

Cheers

by
by
by
by
by
by