96 comments found

ally_18 Purchased

Hi, have purchased this on a different account. Having a problem with installing the demo content. When I go to restore the database as mentioned in your documentation, I get an error that states the DB source is missing. Can you please help me?

Thanks :)

Default-user
ally_18 Purchased

Hi guys,

I’ve sent two emails and neither of them have been answered. Can I please get these looked at? It is rather urgent. Also, am I able to get a copy of the documentation sent to me? I can’t seem to find the copy that came with purchase.

Thanks,

themeboutique

Hi Alyce,

I just sent a response to your e-mail—regarding the docs, there should be three folders in the zip file you downloaded at ThemeForest:

  • Assets
  • Documentation
  • Licensing

In the “Documentation” folder, you’ll need open the index.html file to view the docs. I’ll send over the most recent copy, in the future if you ever need updated copy of the docs you can simply download the latest version of the theme here on ThemeForest and unpack the zip.

Default-user
ally_18 Purchased

Hello again,

Sent a reply back to that email and awaiting a response. It’d be great if you could reply back ASAP :) This project’s end date is nearing pretty quickly.

Thank you :)

cmunk3 Purchased

I cannot select image files in the wysiwyg with IMCE. I can see that others had the same problem.

themeboutique

Hi cmunk3,

This is a known issue related to the version of jQuery the theme uses, if you replace the entire contents of the themetastic_js_alter() function (found in the themetastic/template.php file) with the following code:

function themetastic_js_alter(&$javascript) {
    $path = current_path();
    $imce = strpos($path, 'imce');

    if ((!path_is_admin($path)) && ($imce === false)) {
        unset($javascript['misc/jquery.js']);
    }
}

The issue should then be resolved. :) If the problem for some reason persists, please let me know.

Default-user
cmunk3 Purchased

It worked thank you!

Hi,

You haven’t answered the two messages I’ve sent via your profile page. So, I’m asking here:

1- Does the slider fully support RTL? I need to try a demo. If it’s not possible, please you try adding some sample text to 3 slides and send me the print-screens. Last theme I bought from another author couldn’t support Persian font on more than 1 slide and the author haven’t helped me at all and the envato support wanted me to confirm with the author of the next theme that there are no problems regarding this issue BEFORE buying the theme. 2- Are there any commercial/customized module used on your theme? Or they’re all available on drupal.org? If there are commercial/customized modules, please name them.

thnx

themeboutique

Hi jkengt,

I started writing out a response here on ThemeForest and it got kind of lengthy, so I responded to your e-mail instead—sorry for the late reply.

Attached to the e-mail there will be a copy of the ThemeTastic documentation which explains more about the modules used, how RTL is setup, etc.

In my e-mail I tried my best to explain how the webfonts work with the slider, but to briefly summarize: webfonts are not added via the slider module, so any font can be used on any slide. ;)

If uploading fonts through the UI is an absolute must, and you don’t care to use CSS or modify html.tpl.php to implement the webfont, this module is a great solution:

https://www.drupal.org/project/fontyourface
Default-user

Got you email. thnx :)

ausov Purchased

dear colleagues!

our website sells membership to our paid online services on the same website.

q1: would we need an ‘extended’ licence for this theme? q2: how much is ‘extended’ licence? q3: can we modify the theme after purchasing? q4: is styling for drupal commerce components included/tested? q5: is styling for forum components included/tested?

thank you!

themeboutique

Hi ausov,

I’d need a little bit more information about your project to determine what type of license you would need—if it’s just one website, on one domain, then a regular license will be fine.

If your service is redistributing the theme in any form, however, an extended license would be needed (this runs $2400). Really, it depends on the nature of your service and specifics regarding your use of the theme.

Drupal Commerce and forum components have not been included or tested, you would need to configure and style these parts of your site on your own time.

If you’re just selling paid services, on one website, you’ll only need a regular license—and yes, you’ll be able to modify the theme after purchasing. :) If you need me to clarify anything, let me know!

Default-user
ausov Purchased

Thank you for the info.

Yes, we got one domain with one website. The website has multiple web applications built-in, a shop, blog, etc. We charge our users for using our online applications based on membership subscription. Would the standard licence fit here?

To save time with developing, approving and applying nice UI design, we would like to take a ready-to use theme as a sort of a base template. We would rewrite it for our needs using SASS/compass. This particular theme is just very close to what we already have, just more consistent and nicer. :)

Thank you

themeboutique

I think a standard license would work just fine here, yeah.

It sounds like you intend to use the theme on one, singular end-product (one website) and will not be redistributing the theme in a standalone product so I can’t see any reason to buy any an extended license—the $48 standard license should work. :)

Hi, that´s what i need, but a few questions before buying: - Can I have the video bigger at the home top slider? - At Page and Elements I see I can have a left side menu, but is it possible to have sub menu pages there also?

Thanks!

Default-user

Sorry, I´ve been mistaken. I thought this theme was wordpress theme. Don´t you have some theme similar for wordpress? :(

themeboutique

No problem, the WordPress version is also available here on ThemeForest:

http://themeforest.net/item/themetastic-flat-responsive-wordpress-theme/5231364
Default-user

Oh, thanks!

I have a problem with the map of the contact page. Despite having set the address I google maps always show other locations. Trying to change my address is always displayed in the same location that was never the one to set me

Default-user

It basically I now displays the map as if I had entered a place in Africa but it is actually set up a European address.

From the settings page contact can only enter the address and latitude and longitude

Default-user

I made a mistake .. I need the support for Wordpress ;)

themeboutique

Ah, no worries, I’m sure Damojo will be able to help out. ;) Thanks for the heads up!

FieldException: Es wurde versucht, eine Instanz eines field_weight-Felds anzulegen, das nicht existiert oder nicht aktiv ist. in field_create_instance() (Zeile 476 von /var/www/vhost/base.xyserver.com/modules/field/field.crud.inc).

....how we could fix this error which is upcoming after we want to create a new Revolution-Slider?

themeboutique

Hi ghaberfellner,

Can you please send me a message through my author profile page so I have access to your e-mail address? I will send you instructions with a few screenshots to help you resolve this problem, it’s an easy fix. :)

Hi I have a similar issue with Revolutionary Slider as ghaberfellner had – please see the error message below. Could you please help me to fix that? Many thanks.

FieldException: Attempt to create an instance of field field_image on bundle homepage_slider that already has an instance of that field. in field_create_instance() (line 509 of /srv/bindings/0a94c3e221b741d0b1c5cb1088c0c242/code/modules/field/field.crud.inc).

themeboutique

HI fra_master,

An update is going up on ThemeForest to resolve the issue you’re having, I just sent you an updated file via with some instructions via e-mail if you don’t feel like waiting around. :) If you have any questions, I’m here to help.

Default-user

Thank you so much, I have not received an email with instructions but I can download the update. Please let me know when it is live on ThemeForest. Many thanks

Hi,

I have created a portfolio of four projects but when I use “Next Project” button I got the following error:

“Notice: Undefined index: und in include() (line 40 of /..... /themes/themetastic/tpl/nodes/node—portfolio.tpl.php).”

How can I fix that?

Many thanks

Default-user

Thanks, Now, instead of the error message it shows 404 page. It cleared cache twice but still have the issue. It looks like it refers to a project that no longer exits; I initially had 5 projects in the portfolio but then I removed one from the content. After that I got the error message. Any ideas what is wrong? Many thanks

themeboutique

Yeah, I have a good idea of what’s going on—the issue is related to the pagination and multilingual setup. I am working on a fix right now. :)

Since there is no “file upload” field here on ThemeForest, do you want me to just e-mail you the updated template file? There is a good chance the update won’t be approved on ThemeForest until Monday, I figure e-mailing a copy will be the fastest way to get you the fix.

Default-user

Brilliant! It works like a charm ;)

ally_18 Purchased

If you are tossing up whether or not to get this theme, do it. The author offers great support and is an all round, friendly guy :) Good work on the theme, it’s amazing :)

themeboutique

Thanks a lot for your kind words, Alyce, much appreciated. :)

idgl Purchased

Hello,

we are trying to do a post with a video from Youtube, but the video doesn’t show at all, only the gray square and the video url we put. Is it normal? Which url we shoul put in here? Could you help us, please?

Thank you very much. Regards,

Default-user
idgl Purchased

Hello,

thanks for the advise! I’ve checked if “Full HTML” is using when enter the code, but it’s still happening. And about the “full Embed code” from youtube, I copy the code shown at “Share” option below the video (an example: http://youtu.be/VNkDJk5_9eU). Is it correct?

Thank you very much!

Default-user
idgl Purchased

Hello again,

the video URL example is this one: http://youtu.be/VNkDJk5_9eU . Could you please help me with this problem? I’ve tried everything I had in mind, but the video is not shown on the website.

Thank you very much again!!

Default-user
idgl Purchased

Ok, it’s solved now.

Thanks for your help!

AviadG Purchased

Hi there, I cannot find a way to delay the first slide termintation before the second one appears. Meaning that once the first slide finished the second one starts. How can I pause the slide with the layers so people can read before it changes to the next one? Thanks!

themeboutique

Hi AviadG,

The problem with centering captions when using the drag/drop editor is you’re “eyeballing” the caption location, the captions won’t technically be centered and this will effect how they resize on smaller devices.

What I did when setting up the demo was use basic math to determine the X and Y values for each “centered” caption. The maximum width of any ThemeTastic page is 1280px. So if your caption is 400px wide, you can calculate the X value like this:

1280 (screen width) - 400 (caption width) = 880px
880px / 2 = 440px margins on left and right

Use “440” as the X value when editing the caption—this will make sure the Revolution Slider plugin gives the caption a left: 440px property (which centers the caption). I recommend typing the value into the X field manually instead of using the drag/drop editor to make sure your value is precise. :)

Regarding the max 9999 delay values, could you send me an e-mail via my author profile page so I can send over an updated file for the slider? This version of the file will set the max delay value at 100000 instead of 9999.

themeboutique

Actually, I thought of an easier option for centering captions—the only problem is these changes won’t be reflected in the drag/drop editor (but they will show on the live site).

For the “X” value on a caption, manually type one of the following in the field:

left or center or right

And for the Y value:

top or center or bottom

If you give both the X/Y fields a “center” value and save your changes, the caption should be centered without the need to calculate a numerical value (as described in my previous comment).

Default-user
AviadG Purchased

Hi,

I could not have more than 2 captions on 1 slide when they are one below the other, after trying what you recommended above.

it might be the height of each caption, which is 80px high.

Nevertheless, since I have to deliver the website in the next few days and your new version for the theme is not available yet, I decided to have the captions cover each other when most of them are all set to X center and Y top. I gave them the same width so they cover each other exactly. It also looks good! Will be waiting for your next release. Thanks for the great support!

BTW, a great feature will be having the option to add a link to each caption. :-)

I will email you about the max delay value.

shrcc Purchased

Hi, I am new to drupal. I am trying to upload a background image into the theme but get the message ‘The file could not be uploaded’. Obviously my permissions are not set up correctly. What folder does it try and upload background images into? Also can you recommend a wysiwyg for drupal? Thank you

Default-user
shrcc Purchased

It is also not creating the thumbnails and other images when I replace the main images. So it just becomes blank?

themeboutique

Hey shrcc,

I’ll break down each question individually:

1. Image Uploads

I’ve never heard of this happening before, but if thumbnails aren’t being generated the problem is definitely related to permissions on the upload directory.

Drupal stores all uploads in the sites/default/files folder, you’ll want to make sure this folder and all child folders have the permissions set to 755. Once the directory is writable again, the problems you’re having with uploads should be resolved.

2. WYSIWIG

CKEditor has become the standard for Drupal and is even being packaged in core with Drupal 8.

On the drupal.org module page for CKEditor, be sure to read the section about “Advanced Content Filter” and disable this option immediately after installing CKEditor on your Drupal site. Disabling this option will prevent the WYSIWIG editor from stripping/reformatting HTML.

If you run into any problems or have additional questions, I’m here to help. :)

Hello. I want to buy this theme but I have a question. Have you removed Context completely? Now theme works with Blocks? Because I have very difficult to work with Context.

themeboutique

Hey sayjin93,

Yeah, we’ve removed Context completely—soon we are upgrading to Drupal 8, so the theme has been slimmed down to remove unnecessary modules. Context is no longer a part of ThemeTastic!

Hello friend I have installed the ThemeTastic theme and themetastic_features module in my existing drupal, according to documentation after enabling the themetastic_features I get the following error: PDOException: SQLSTATE[42000]: Syntax error or access violation: 1072 Key column 'field_slider_block_bid' doesn't exist in table: CREATE TABLE {field_data_field_slider_block} ( entity_type VARCHAR(128) NOT NULL DEFAULT '' COMMENT 'The entity type this data is attached to', bundle VARCHAR(128) NOT NULL DEFAULT '' COMMENT 'The field instance bundle to which this row belongs, used when deleting a field instance', deleted TINYINT NOT NULL DEFAULT 0 COMMENT 'A boolean indicating whether this data item has been deleted', entity_id INT unsigned NOT NULL COMMENT 'The entity id this data is attached to', revision_id INT unsigned NULL DEFAULT NULL COMMENT 'The entity revision id this data is attached to, or NULL if the entity type is not versioned', language VARCHAR(32) NOT NULL DEFAULT '' COMMENT 'The language for this data item.', delta INT unsigned NOT NULL COMMENT 'The sequence number for this data item, used for multi-value fields', field_slider_block_moddelta VARCHAR(129) NOT NULL DEFAULT '', PRIMARY KEY (entity_type, entity_id, deleted, delta, language), INDEX entity_type (entity_type), INDEX bundle (bundle), INDEX deleted (deleted), INDEX entity_id (entity_id), INDEX revision_id (revision_id), INDEX language (language), INDEX field_slider_block_bid (field_slider_block_bid), INDEX field_slider_block_moddelta (field_slider_block_moddelta) ) ENGINE = InnoDB DEFAULT CHARACTER SET utf8 COMMENT 'Data storage for field 19 (field_slider_block)'; Array ( ) in db_create_table() (line 2720 of /home/venice/domains/venice-stone.com/public_html/includes/database/database.inc). Also I realized that after getting this error, when I enter into modules list in drupal admin I also get that error! Also I took a look at database and could not find the table that this error is talking about! ( {field_data_field_slider_block} ) This error drives me crazy! :( What should I do to solve the problem!?
themeboutique

Hi heidarzadeh,

This is not common behavior, I would need to take a look at your site to diagnose the problem. Would this be possible?

Something went wrong with the Features module installation, and these tables were never created (this is why you can’t find the field_data_field_slider_block table does not exist and the error is being thrown).

For starters, we need to manually uninstall the “ThemeTastic: Features” module to we can get your Modules site working again. Do you know how to do this? If not, I can explain. :)

If you can create a temporary admin account I’d be happy to take a look, my e-mail is support@themeboutique.net.

themeboutique

After doing a bit more research, I’ve found the issue is related to the Features module. Here is a recent post from drupal.org where a user had the same problem when installing a module created by Features:

https://www.drupal.org/node/1604728 https://www.drupal.org/node/1679572

Nobody seems to know why this is happening, so I will prepare an alternate installation method for you. Does this work? For now, let’s just get rid of these errors by uninstalling the ThemeTastic: Features module. :) Let me know what I can do to help!

Default-user

I tried unistalling and installing ThemeTastic: Features module and now everything seems to work well. Thanks you for your kind reply. ;)

Does this theme support custom colors? I know there are preset color schemes, but I need a theme that allows for the input of hex color #’s on the theme setting page so I can choose my own company’s color scheme.

themeboutique

Hi gburlile,

Custom colors via theme settings will come in v2 (early 2015), right now customers have just been using a Find + Replace All command with their text editor to do custom colors.

All of the hex decimal values for the default “green” value are contained in the themetastic.css file, so changing to a custom scheme can be done in only a couple of clicks if you’re comfortable with that method. :)

by
by
by
by
by
by