Discussion on TheWall - Grid-A-Licious Blog and Portfolio theme

35 comments found

Hi feeleep, another great theme which I would like to purchase and have couple of questions.

1- Rather than have the menu on left, can I show the menu bar on top of the page? (like in Q and A template) 2- On homepage, we see the post excerpts with images, is there an option to add or include advertising? (like google ads) Thanks

feeleep

(1) Well, by default it’s on left hand side. That’s just how theme’s layout is composed. However, nothing prevents you from rewriting CSS and doing changes. By me it’s a tough job.

(2) You can place Google ads in sidebar, not sure about mixing up posts and ads. I never tried to do that so can’t speak about.

Hi there.

We have purchased the theme and am having some problem which we hope you are able to assist on. If you refer to the link below.

http://cn.trulyhongkong.com/category/%E7%BE%8E%E9%A3%9F/

We hope to remove the post data and permalink line that is shown. Also, as you can tell that the site is in Chinese. How can we change the read more to another language?

Thanks for the help and great theme.

feeleep

If well understood, you’d like to change permalink structure to something else, correct? If so, then I don’t see any problems here, just go to Dashboard
Settings > Permalink
...and make the custom permalink structure. My apologies if your question was misunderstood!

As for how to translate your theme copy to Chinese (including that “READ ON”), it has been explained in theme Manuals. There’s a “languages” folder inside of the theme’s root (“thewall/languages”). Open it and spot “en_EN.po” – localization file. You’ll need POEdit application or any other similar gettext file editor to translate default theme phrases to Chinese. No matter what please take a look at the theme manuals for more details.

Default-user

Hi there. thank you for the reply. What we want to do is to actually remove that line that is showing the information “Post 2013/09/16 permalink”. We are not looking at replacing it with something but we want to have that gone. Thank you and looking forward to your assistance.

feeleep

I’m not the ”.htaccess” expert but I think it can be masked if you modify rewrite rule(s). At the time of WP install or manual permalink change via Admin, WordPress writes down new set of rewrite rules to ”.htaccess” file. Have a look at the manuals at Apache.org, maybe you’ll be able to dig something out: http://goo.gl/HyTix
Beware: if you are on Windows server, something like that won’t work!

Is it possible to show the author of each post on the front page grid?

feeleep

Yeap, that would be possible but it has to be added to the template source code. I’ll be glad to assist if you decide to go for a theme.

dxqdesign Purchased

Hi there Your template is great, but I’ve met a few minor bugs: I want to know you already to use lightbox plugin for your template?I use Lightbox Plus ColorBox, it worked just fine on Firefox, on the other browsers it does not work and Post liking function on my site it does not work( https://www.dropbox.com/s/g57t0ye6bw8xj72/test.jpg). Let me know what “plugins: you use. Help me please. Thank you!

feeleep

OK, just as I thought, there’s a JS error because jQuery Cookies plugin can’t be loaded.
http://goo.gl/TGr9Za
It looks like there is no such file in given location so be sure to get it there. Everything will be fine once you do so.Now…
Did you properly install the theme? Any errors during installation?
Why is your home page URL different than the rest of the site? Are there any ”.htaccess” redirects?
I could continue with questions but let’s get the missing js file to the right place first and see whether is solves the problem. By me, it should be OK.

dxqdesign
dxqdesign Purchased

Thanks for your feedback, my other home page because I’m using some domain name, just a test, It seems it is difficult for me now, because I don’t have a programmers:) I will give you 5-star rating now

feeleep

Mate, I’m sorry I wasn’t able to help you more but I can only access your site in Browser. It means I can’t upload missing file to the server nor check whether your theme was installed properly. It would be great if you can do that by using an FTP client, just browse to
yourdomain.com/wp-content/themes/thewall/js/jCookie/
...and check whether “jquery.cookie.js” can be found there. In “js” folder you should be able to see 8 sub-folders and 4 more javascript files.
Lemme know if I can help somehow!

Hi, I have a small problem with the pictures in my portfolios and i’m not sure if it’s just me being stupid, a problem of the theme or a problem of the lightbox plugin.

I have several pictures in my portfolio posts and they are all displayed at the upper end when the portfolio is clicked. now when you click on the pictures, a lightbox opens as it’s supposed to (i use Lightbox Plus ColorBox 2.6). The problem is that the pictures are not recognized as a group and therefore navigation with arrows and the slideshow option are not available, although everything is set up correctly in the lightbox settings.

On your demo page, this is working correctly, so i’m not sure where the problem lies. I uploaded the images via the “add media” button in the editing page of the portfolio, and they show up connected to this post.

any ideas why this isn’t working?

thanks in advance

feeleep

I’m sure it will be OK if you replace “Lightbox Plus ColorBox 2.6” with “jQuery Colorblox 4.6” ( http://wordpress.org/plugins/jquery-colorbox/ ).

doxidox

alright, thank you, i will try that

edit: works perfectly, thanks again!

feeleep

Great to read it!

The Wall is a beauty!!!

Just wondering, I already have plugins running products, events and directory-listings on my site. Will your theme support these custom post types and allow me to put them on the front page?

Can I also add reviews to every box?

Cheers,

Johnny

feeleep

Custom Post Type is more like theme related because the theme itself should support it via templates (custom taxonomy, single CPT, archive CPT, etc.). So, I’m not sure it’ll work that way. I mean “event”, “directory listing” or “product” are Custom Post Types and the custom means that theme authors created them at will; no guarantee that another theme will support it.
However, when we talk about plugins then everything should be working fine because WP plugins are not theme related but rather used as WordPress extensions.
You mentioned reviews … is it a plugin or custom post type that relates to your “old” theme?

Hi there Is it possible to have the Homepage display a combination of Portfolio and News items, without duplicating content? Thank you

feeleep
It is possible, but you will have to make a custom template for that purpose. Your new template must include both post and portfolio types into the loop.

$args = array( 'post_type' => array( 'post', 'portfolio' ) );
$my_query = new WP_query( $args );
if( $my_query->have_posts() ) : while( $my_query->have_posts() ) : $my_query->the_post();
// ... the loop stuff
endif;
endwhile;
I guess it should not be so hard if you take a look at how “page-portfolio.php” custom template has been coded out. Basically, you don’t need to change much; template name (which needs to be unique) and post_type in $sofa_query_args.
ozhill Purchased

Great Theme.

I am planning to use only the Portfolio section and want to make it on the front page. I would like to know how.

Great thanks for your support in advance

feeleep

For that purpose you’ll need a page that can be selected as a static home page ( http://awesomescreenshot.com/0182l40heb ).

If you are missing that custom template, feel free to download it HERE. Once downloaded, unzip to a local drive and then upload into the theme’s root folder (“wp-content/themes/thewall”).

Remember, it’s a Custom Template! In order to create portfolio page, go to Dashboard,
Pages > Add New
...and then assign Portfolio template to that very page ( http://awesomescreenshot.com/0452l42kcc ).

Be sure to select the page you just created for a static home page, see Dashboard,
Settings > Reading >> Front page displays : A static page
( http://awesomescreenshot.com/0182l40heb )

Hopefully it makes sense, lemme know if you need my assistance!

Hi feeleep,

I think this theme is great, but I have a minor issue with it. I am using a plugin named S2member to place Paypal buttons here and there, the pluing is using a form to display and collect data, the code goes like this:

<form action=”https://www.paypal.com/cgi-bin/webscr” method=”post”> <input type=”hidden” name=”business” value=”address@mysite.com” /> <input type=”hidden” name=”cmd” value=”_xclick” /> <!- Instant Payment Notification & Return Page Details -> <input type=”hidden” name=”notify_url” value=”http://mysite.com/?s2member_paypal_notify=1” /> <input type=”hidden” name=”cancel_return” value=”http://mysite.com/” /> <input type=”hidden” name=”return” value=”http://mysite.com/?s2member_paypal_return=1” /> <input type=”hidden” name=”rm” value=”2” /> <!- Configures Basic Checkout Fields -> <input type=”hidden” name=”lc” value=”” /> <input type=”hidden” name=”no_shipping” value=”1” /> <input type=”hidden” name=”no_note” value=”1” /> <input type=”hidden” name=”custom” value=”mysite.com” /> <input type=”hidden” name=”currency_code” value=”USD” /> <input type=”hidden” name=”page_style” value=”paypal” /> <input type=”hidden” name=”charset” value=”utf-8” /> <input type=”hidden” name=”item_name” value=”Description and pricing details here.” /> <input type=”hidden” name=”item_number” value=”sp:0:72” /> <input type=”hidden” name=”amount” value=”0.01” /> <!- Configures s2Member’s Unique Invoice ID/Code -> <input type=”hidden” name=”invoice” value=”<?php echo S2MEMBER_VALUE_FOR_PP_INV(); ?>” /> <!- Associates Purchase With A User/Member (when/if applicable) -> <input type=”hidden” name=”on0” value=”<?php echo S2MEMBER_CURRENT_USER_VALUE_FOR_PP_ON0; ?>” /> <input type=”hidden” name=”os0” value=”<?php echo S2MEMBER_CURRENT_USER_VALUE_FOR_PP_OS0; ?>” /> <!- Identifies The Customer’s IP Address For Tracking -> <input type=”hidden” name=”on1” value=”<?php echo S2MEMBER_CURRENT_USER_VALUE_FOR_PP_ON1; ?>” /> <input type=”hidden” name=”os1” value=”<?php echo S2MEMBER_CURRENT_USER_VALUE_FOR_PP_OS1; ?>” /> <!- Displays The PayPal Image Button -> <input type=”image” src=”https://www.paypal.com/en_US/i/btn/btn_xpressCheckout.gif” style=”width:auto; height:auto; border:0;” alt=”PayPal” /> </form>

seems like the form is creating empty lines in html for each and every code element beginning with ”<input type=”hidden”...”

The main result is a huge empty space right above the Paypal button.

Is there an easy way to fix this?

feeleep

It’s really strange because Browsers don’t render input type=”hidden” elements! So I believe that there must be something else. What exactly? Well, at this point I can only guess, I’d love to see your website and check all out in Firebug to be sure. In case you’d like to keep your website URL confidential feel free to send PM (click on my avatar then use contact form in sidebar of my profile page) and I’ll be glad to take a look.

arutai Purchased

Hey Feeleep,

I love that the images (in image-format posts) in your demo open in colorbox without having to actually open the post. Unfortunately, it’s not working for me. The featured images aren’t appearing on the category page. And the larger images aren’t loading.

I have installed and activated Jquery Colorbox.

It seems the category template variables are loading more than then need to.

<figure class="featured-preview">
    <a href="<?php echo $link; ?>" class="cboxElement" rel="nofollow" title="<?php the_title(); ?>"><img src="<?php echo $link; ?>" class="colorbox-<?php echo $rnd; ?>" alt="<?php the_title(); ?>" /></a>
</figure>

What should look like this:

<figure class="featured-preview">
<a class="cboxElement" title="MY_TITLE" rel="nofollow" href="http://WP.MYURL.COM/wp-content/uploads/2014/05/IMAGE_fullsize.jpg">
<img class="colorbox-1965529" alt="IMAGE" src="http://WP.MYURL.COM/wp-content/uploads/2014/05/IMAGE_medium.jpg" />
</a>
</figure>

Is blowing out to this:

<figure class="featured-preview">
<a class="cboxElement" title="MY_TITLE" rel="nofollow" href="<a href=" http:=""><img class="colorbox alignleft wp-image-2179 size-full" src="http://WP.MYURL.COM/wp-content/uploads/2014/05/IMAGE_medium.jpg" alt="IMAGE_medium" width="660" height="1063" /></a>">
<img class="colorbox-1965529" alt="LARRY" src="<a href=" http:="" /><img class="colorbox alignleft wp-image-2179 size-full" src="http://http://WP.MYURL.COM/wp-content/uploads/2014/05/IMAGE_medium.jpg" alt="IMAGE_medium" width="660" height="1063" />">

</figure>

Any idea what is happening?

arutai
arutai Purchased

No, I haven’t modified category.php. Just to make sure, I replaced it with a fresh version.

wp.insmallpackages.com

It looks like the $link variable that is used as the hyperlink and the image source is pulling more than the simple URL. If so, it would look like this:
http://wp.insmallpackages.com/wp-content/uploads/2014/05/R27.jpg

Currently, the variable is pulling the anchor tag, the hyperlink, as well as the image tags, source, title, alt tag, and dimensions:

<a href="http://wp.insmallpackages.com/wp-content/uploads/2014/05/R27.jpg"><img class="alignnone wp-image-2599 size-full" src="http://wp.insmallpackages.com/wp-content/uploads/2014/05/R27.jpg" alt="R27" width="370" height="370" /></a>

Is there some setting or simple calibration I am missing?

arutai
arutai Purchased

Problem solved. I was inserting the image itself into the content window instead of the link to the image. Yes, it helps to read the manuals.

feeleep

OK, that’s a great news mate :) Glad to read everything works right!

Random shout-out for excellent support !!! Very prompt and forthcoming.

feeleep

I appreciate it, thanks a bunch!

jusemp Purchased

Hi feeleep,

I bought this theme a few days ago. I love this theme. Till now, I have a question on index page (blog), I set it as pagination to display post, but I found only display 10 posts in each page. Is it possible to change this number? For example I want to display 20 posts each page? If possible, would you tell me where I can modify it (maybe editor?)

Thanks

Default-user
jusemp Purchased

Hi feeleep, I had resolved it, I am sorry for it.

feeleep

No problem, glad to read you’ve got it sorted out!

hgag Purchased

Hello there,

Bought the theme a while ago and find it absolutely superb. One question though – <-nextpage-> doesn’t seem to work with this theme to break up my post. Please advise, thanks!

feeleep

Sorry for a late reply! Could you please be so kind and create a temp Admin account for me so I can take a look and fix the problem – if any. Feel free to send login credentials to my PM. How? Just click on my avatar and use contact form in the sidebar of my profile page.

Default-user
hgag Purchased

PM’d, thanks!

feeleep

OK, I’ve got it and I’ll get back to you soon.

Hi, we purchased the theme and love it so far. One minor bug. On our home page, the theme is displaying the shortcode instead of the content in the excerpts. Any idea how we can fix this? We didn’t run into this on other themes. Thanks!

http://giftsforgfs.com/
feeleep
Try to open “functions.php” and add the following code (the very bottom of a file will be just fine):
add_filter( 'the_excerpt', 'shortcode_unautop' );
add_filter( 'the_excerpt', 'do_shortcode' );
I guess that should force the excerpt to render shortcode.

I tried this and no luck. You can see that the shortcode also doesn’t work in the individual post: http://giftsforgfs.com/curious-bartender-artistry-alchemy-creating-perfect-cocktail/

feeleep

Are you doing copy-paste code when text editor (TinyMCE) in “Visual” mode? If true then the most probably it’ll be interpreted as a regular text. Try to copy-paste shortcode when TinyMCE in “Text” mode.
I can’t think of any other reason of why shortcodes don’t work.

by
by
by
by
by
by