Discussion on Thinker - Retina Responsive Multipurpose WP Theme

156 comments found

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

Hi – how can I use my own image for the

  • in thinker theme? I added custom css but it isn’t replacing them and I can’t see what css file it is referencing – thanks
  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

How do I swap my own bullet images in for list-style: disc;?

I’ve tried adding through the custom.css and the custom area in the settings for the theme, and editing the main css – no luck. Can’t see where this bit of css is coming from – looks like it’s through a programmed function rather than css….?

Softwebmedia

We don’t suggest you to use background image for default list style because it will mess all other elements which are using “ul li” in the theme.

Adding background image is simple by adding background image url, list style none and padding content like below sample code

ul li { 
list-style: none; 
background: url(http://domainname.com/background-image-full-path.png) no-repeat  0 0; 
padding-left: 25px; 
}

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

Hi, thanks – that worked except

1. the custom icon now shows in the top bar menu 2. the bullets are high and when I change the css it moves the entire line and not just the image

should I just do a separate top bar menu class for ul/li?

Softwebmedia

You have to do everywhere where ul li is used in the theme. You have to set background property – none and padding as per elements. OR you can create new class for icon list like #content .my-icon ul li {...} and use list items inside .my-icon div tag so it will not affect to any other elements.

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Please help I am trying to make certain elements into 3 columns, and I have tried the code you have mentioned for other service styles, etc with no success. In particular, I need help with the “Small Icons” style seen here. http://50.87.144.43/~adpro I need it in 3 columns rather than stacked. What code do I use and where should it be placed? The short code generator doesn’t give an option for columns.

Softwebmedia

Hi adprints,

It looks you added services shortcode in column shortcode to fix the issue. Services with small icon in 3 column looks fine from here.

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

All of a sudden I have a grey line running along my sidebar and up into the slider on my front page at http://www.baddogdesign.com/mcclartycreative

Any idea why? I couldn’t ferret it out in the inspector…

Softwebmedia

Hi bigpacific,

We can see content padding top is change 40px to 10px which is moving sidebar border 30 up.

#content { padding:40px 0; }

Thank you :)

Default-user

Hi… it turned out to be this piece of the css:

.custom_two_third { margin: -10px -41px -10px 0; padding: 40px 43px 40px 0; }

Softwebmedia

This will create more issues, if you will check in 1024px resolution width you will get two borders between two third column and sidebar.

  • Bought between 50 and 99 items
  • Germany
  • Has been a member for 1-2 years

Hi! i have problems with the revolutions slider. i cannot edit the sliders. On Top of the Backend-Site “Revolution Slider” i have always this message:

Warning: simplexml_load_file(): I/O warning : failed to load external entity ”/www/htdocs/w0113914/wp-content/plugins/revslider/settings//slider_settings.xml” in /www/htdocs/w0113914/wp-content/plugins/revslider/inc_php/framework/settings.class.php on line 673

Settings (slider_settings) Error: Wrong xml file format: /www/htdocs/w0113914/wp-content/plugins/revslider/settings//slider_settings.xml

0 /www/htdocs/w0113914/wp-content/plugins/revslider/inc_php/framework/settings.class.php(676): UniteFunctionsRev::throwError(‘Wrong xml file …’)

1 /www/htdocs/w0113914/wp-content/plugins/revslider/settings/slider_settings.php(110): UniteSettingsRev->loadXMLFile(’/www/htdocs/w01…’)

2 /www/htdocs/w0113914/wp-content/plugins/revslider/inc_php/framework/base_admin.class.php(341): require(’/www/htdocs/w01…’)

3 /www/htdocs/w0113914/wp-content/plugins/revslider/revslider_admin.php(192): UniteBaseAdminClassRev::requireSettings(‘slider_settings’)

4 [internal function]: RevSliderAdmin->adminPages(’’)

5 /www/htdocs/w0113914/wp-includes/plugin.php(429): call_user_func_array(Array, Array)

6 /www/htdocs/w0113914/wp-admin/admin.php(217): do_action(‘toplevel_page_r…’)

7 {main}

View (slider) Error: Settings slider_params not found

How can i solve that?

Softwebmedia

Hi VERESdesign,

Please send your website admin login details ( from our profile page form) so we can test it and give you feedback.

Thank you :)

VERESdesign

Hi Softwebmedia today i used the “real” domain and now the problem is solved. Thank you for your help.

But i have a new little Problem. :-D now you can visit the site unter aufnahmepruefung.at … i have a siderbar and a revolution slider in the header at every page. But wenn i used a link with a “tag” e.g. http://www.aufnahmepruefung.at/tag/latinum/ so theres no sidebar and no slider. :(

how can i solve that? is it possible to create a standard-template so that on every site is the same headerimage and the same siderbar? (i need different headerimages for more tag-sites but one header ist better than no header :-)

Thank you.

Softwebmedia

Hi VERESdesign,

We replied your email with attached files, please check.

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

We needed to bump up the logo to have it be in proportion with the rest of the front page, but it’s breaking the layout (pushing it out horizontally) on mobile devices. Is there a way I can handle that via CSS or settings within the theme?

Softwebmedia

Hi bigpacific,

We are not getting your question, if you are asking about logo position left to center in mobile devices then you can do with below custom code


@media only screen and (max-width: 767px) {
#logo_header_wrap { text-align: center; }
#logo_header_wrap .logo { float:none; }
}

@media only screen and (min-width: 480px) and (max-width: 767px) {
#logo_header_wrap { text-align: center; }
#logo_header_wrap .logo { float:none; }
}

Thank you :)

Default-user

I did that but now the logo does not show at all, only type in place of it…

Softwebmedia

Please send your website URL so we can check it.

Default-user
http://www.baddogdesign.com/mcclartycreative

I had to make the logo larger in the settings area for the desktop version but I don’t know how to get the code to place a smaller version on handheld devices. Right now only the alt tag is showing and the bounding box extends off the screen to the right.

Thanks

Softwebmedia

Hi bigpacific,

It looks some custom changes in core coding is making conflict with auto responsive logo image coding. You can test your website with original source theme file. ( You can also test by deactivating extra plugins which are not included with the theme).

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 1-2 years
mevsim Purchased

I have 2 problems.

I get the logos in full width in the foot area? see also picture!

http://ebay.webcard.de/image/screen9.jpg and the logos will automatically change. unfortunately it does not work.

please help

Softwebmedia

Hi mevsim,

Logo slider is created to display only in content area so it will not work in footer section. For auto slide you have to set auto slider property value “true” slider shortcode ( auto_slide="true" )

Thank you :)

Default-user
mevsim Purchased

this is my code:

[logo_slider heading_style="heading_style1" title="Partner" font_size="14" font_color="#333333 "auto_slide="true" slider_speed="1000" display_logos="20" lightbox="true"]

but is not function!!

Softwebmedia

Please send your website URL so we can check it.

Softwebmedia

Hi mevsim,

There was one typo mistake in older version of logo slider shortcode…please use below shortcode where we changed

font_color="#333333 "auto_slide="true" to font_color="#333333" auto_slide="true"


(double quote after colour value and space before auto_slide)


[logo_slider heading_style="heading_style1" title="Partner" font_size="14" font_color="#333333" auto_slide="true" slider_speed="1000" display_logos="20" lightbox="true"]

Thank you :)

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years

Hello, I have 2 instances of this theme running. 1 Fresh install and 1 that I am working on for a client. In both cases, the logo will not show up on mobile.

Is there a certain image format or dimensions that I have to use?

Softwebmedia

Hello baldwincc,

Please check you have set logo with in

Admin > Appearance > Theme Options > Logo Settings > Standard/Non-Retina Logo Width > Enter standard logo width here

Thank you :)

  • Bought between 1 and 9 items
  • Has been a member for 0-1 years
zajac2 Purchased

Hi, One question more. I am using [services_style5] on one of the pages. I would likte that when a client click on the small picture a lightbox comes and another picture will be showed (excually the same picture but in higher resolution). The same shuld happen when a client click on the link it self. Right now I have link=”#” and if you click on it you jump to the top of the page (or the page is reloaded, I don’t know….). Its disturbing… Could you help me with that. Thank you in advance.

Greetings from Berlin

Softwebmedia

Hi zajac2,

Lightbox property is not added in services_style images. We are also looking for code which can give flexible lightbox feature so you can display anywhere image in lightbox with link of image on text or thumbnail.

Please contact us via our profile page form so we can give quick solution.

Thank you :)

  • Belgium
  • Bought between 50 and 99 items
  • Has been a member for 5-6 years
neeltje Purchased

Really nice theme,

i have a question about:

[services_style1 title=”Service One” link=”#” icon=”icon-shield” columns=”one_half” position=”last”] [/services_style1]

- i would like to remove the hover from this shortcode - i would like the hover color (the nice blue) to become the actual color of the icon and the service title

i suspect it’s an inline css style so i don’t no how or where to change it :-)

Thanks, Nele (Belgium)

Softwebmedia

Hi Nele,

You can remove hover color effect with below custom css style (add in child theme css or main theme’s custom.css file)

.services_style1.swm_services:hover a { color:#606060; }
.services_style1:hover .icon i[class^="icon-"]:before { color:#bcbcbc; }

Thank you :)

Default-user
neeltje Purchased

Thank you, I used the custom.css to make the changes that i wanted. I also would like to remove the title text link from all the service styles, i tried deleting link=”#” from the shortcode but no change :-)

Also i would like to delete the icon-chevron-sign-right from the service style 4. My goal is to make the servicestyles into a design element rather than a navigation element so that people don’t feel the need to click on them :-).

Softwebmedia

You can create custom shortcode function like below


if (!function_exists('swm_services_style31')) {
    function swm_services_style31( $atts, $content = null ) {
    extract( shortcode_atts( array (
    'columns' => 'one_third',
    'img_src' => '',
    'position' => '', 
    'title' => '', 
    'sub_text' => '',
    'target' => '_self',
    'link' => '#' 
    ), $atts ) );
 $output = '';
 $output .= '<div class="'.$columns.' '.$position.'">';
    $output .= '<div class="services_style3">'; 
    $output .= '<div class="service_pic"><img src="'.$img_src.'" alt=""></div>';
    $output .= '<div class="swm_services">'; 
    $output .= '<div class="swm_services_title">'.$title.'</div>';
    $output .= '<p>'.$sub_text.'</p>'; 
    $output .= '<div class="clear"></div>';
    $output .= '</div>';
    $output .= '</div>';
    $output .= '</div>';

    return $output; 
    }
 add_shortcode( 'services_style31', 'swm_services_style31' );
    }

Shortcode will look like


[services_style31 title="Website Design" link="#" sub_text="custom and responsive design" img_src="http://thinker.premiumthemes.in/wp-content/uploads/2013/09/services3-pic1.jpg" columns="one_third" position="other"]

Removed link, icon codes and changed function and shortcodes names
“swm_services_style3” to
“swm_services_style31”
in above example.

Thank you :)

Default-user
neeltje Purchased

Great thanks i used custom css to make the changes that i wanted but great support i’ll be rating your theme a full 5 stars

Softwebmedia

Thank you neeltje for the rating :)

  • Has been a member for 0-1 years

I tried searching the comments… is this theme workable with other wordpress plugins, like Simple Press or a store option? Really like the look and all the other extras… Great job! Just want to be sure it will work for my purposes.

Softwebmedia

Hi onthefarminiowa,

Thank you for your compliments :)

We are working on WooCommerce support with the theme (80% complete) and then we will add bbPress support. Approx end of this month we will upload next updated version so then you can use this theme for your website.

Default-user

Thanks for your quick reply. I don’t really care for bbPress, but I do like SimplePress, using it more for sharing information that can be found, not lost in a feed. I’m new to adding WordPress plugins and wonder what difficulties I might expect if I added a plugin that the theme was not designed around. Should I expect problems, so I need to choose my theme carefully, or are most of the free plugins compatible if the WordPress software is up to date? A couple others on my team appear to like this theme as an option, so I’m trying to figure out whether it will work for us. Is there a way to contact you other than through this online contact medium?

Softwebmedia

We used default core features with the theme so this theme will be compatible with many wordpress plugins. Sometimes you will face little css fix issue as per plugin’s html structure which you can fix from child theme custom css file.

You can use our profile page contact form for theme discussion.

  • Bought between 10 and 49 items
  • Germany
  • Has been a member for 1-2 years

Hi there, very fine Theme. But I like to link away from a servicebox. So what do I have to insert (like target=blank)? [services_style3 title=”Title” link=”http://www.example.de” sub_text=”Lorem ipsum” img_src=”example.jpg” columns=”one_fourth” position=”first”] Thank you in advance! Regards Patrick

Softwebmedia

Hi Patrick,

We are not getting your question. Are you want to add feature in shortcode (target=blank) to open linked page in new window? Please give us feedback so we can give you detail answer :)

monoklin

Yes, exactly! :-)

Softwebmedia

You can add this feature by overriding current shortcode function. Open child theme’s function.php file and paste below shortcode function.

Go to Admin > Appearance > Editor page and click on right side “Theme Function” link which will open functions.php file in editor box and then add below function after star line.


if (!function_exists('swm_services_style3')) {
    function swm_services_style3( $atts, $content = null ) {
    extract( shortcode_atts( array (
    'columns' => 'one_third',
    'img_src' => '',
    'position' => '', 
    'title' => '', 
    'sub_text' => '',
    'link' => '#' 
    ), $atts ) );
 $output = '';
 $output .= '<div class="'.$columns.' '.$position.'">';
    $output .= '<div class="services_style3">'; 
    $output .= '<div class="service_pic"><a href="'.$link.'" title="" target="_blank"><img src="'.$img_src.'" alt=""></a></div>';
    $output .= '<div class="swm_services">'; 
    $output .= '<span><a href="'.$link.'" title=""  target="_blank"><i class="icon-chevron-right"></i></a></span>'; 
    $output .= '<div class="swm_services_title"><a href="'.$link.'" title=""  target="_blank">'.$title.'</a></div>';
    $output .= '<p>'.$sub_text.'</p>'; 
    $output .= '<div class="clear"></div>';
    $output .= '</div>';
    $output .= '</div>';
    $output .= '</div>';

    return $output; 
    }
add_shortcode( 'services_style3', 'swm_services_style3' );
    }

This function will automatically open all links of services style 3 in new window.

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

I’m working on http://www.baddogdesign.com/mcclartycreative

I don’t know why but the nice colored hovers over the services headings and icons are gone, and I can’t seem to change where the link takes people. Even if I add the link=”my page/” it still shows as # in the status bar.

Curious if I can make this work…

Softwebmedia

Services shortcode title link property should be


title_link="http://....." 

Default-user

Thanks, that worked. My colours and mouseover highlights are still gone for the services icons… and my ‘read more’ are showing as black/grey rather than coloured as per settings?

Default-user

(I did not change any settings. I am using W3 Total Cache and tried deactivating it to see if the display changed but it did not. If I deactivate that plugin my top bar black menu loses its background and shows a gap between it and the main logo/nav area.

Default-user

I might hire an outside resource – now my top bar formatting is gone it should be flush agains the logo/nav and have a black background

Softwebmedia

Hi bigpacific,

You can debug this issue with several ways like

Deactivate all plugins which are not included or recommended by this theme.

Upload original version of theme with diff. folder (like “new-thinker” and zip it as “new-thinker.zip), upload and activate it to check difference between customize and original version’s code.

Thank you :)

  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 0-1 years
  • India

Hi,

There is problem with social media icons are not visible except mozilla browsers, Your help will be appreciated.

Thanks

Softwebmedia

Hi nagarajpapanna,

Please send your website URL so we can check it and give you feedback.

Thank you :)

nagarajpapanna

www.yogatree.in

Softwebmedia

Hi nagarajpapanna,

Social media icon’s 16px x 16px size images are deleted in theme’s images/icon folder.

http://www.yogatree.in/wp-content/themes/thinker/images/icons/facebook.png ( this is 32px size width)


Please check original theme’s icons folder and upload all 16px icon size as it is or you can delete current theme and upload latest version ( or original version) of the theme.

Thank you :)

nagarajpapanna

I have changed the icons to 16px still i am not able to see the icons except mozilla browser and search icon is not working any help on these both will be appreciated

Softwebmedia

We can see 16px size icons in sub pages header beside search box. Please delete cookies/temp. or you can try in another pc to view updated layout.

Search box has “type keywords” and “enter” function to work and search icon is static icon as a search box background.

nagarajpapanna

I have asked my 5 other friends to check (who haven’t seen the website before, even they are not able to see the icons) What do you think it is?

Softwebmedia

Hi nagarajpapanna,

You can test it with this website : http://ctrlq.org/screenshots/

Enter any inner page url (like http://www.yogatree.in/our-story/ ),
click button “Capture Screenshot”
and then after capturing process, download screenshot and you will find in
title section – right side – beside search box – two icons are visible ( facebook and linkedin)

Thank you :)

nagarajpapanna

Hi I wanted to add Phone requirement to contact form, Page as well as widget please help me thanks in advance right now i am using contac7 widget but it is not responsible and it is not matching to the site style

Softwebmedia

Hi nagarajpapanna,

Please use updated version 2.0 which has many improvement in css coding and it will work with contact form field in content area.

For footer area please use below custom css code to match form field with footer colors.


#footer input[type="text"],#footer input[type="password"],#footer input[type="email"],#footer input[type="tel"],#footer input[type="url"],#footer textarea { outline: 0; border-color: #282828; color: #777; background:#1e1e1e; }

Thank you :)

nagarajpapanna

Hi There,

The search i con is not working then i would like to remove the search option please guide me on that

Softwebmedia

Hi nagarajpapanna,

You can hide search icon with below css style

.icon-search:before { display:none; }

Thank you :)

nagarajpapanna

Hi There, I mean not only icon i want remove Serch Box as well i dont want search option any where in the site

Softwebmedia

You can hide it from admin > appearance > theme options > general > search box > set “OFF” mode.

nagarajpapanna

I am sorry to say I dont see search option as you mentioned in”admin > appearance > theme options > general > search box > set “OFF” mode.”

Softwebmedia

Please update theme with latest version. Latest version has this feature. :)

  • Bought between 10 and 49 items
  • Has been a member for 4-5 years

I just ran a test with browser stack and there are some errors – most I am okay with as they are on old browsers, but on Mavericks Chrome and Firefox there is a hostgator error showing rather than the site, and on Mountain Lion Firefox 25 the design is broken. What are the browsers and OS supported by the theme? I couldn’t find that info. Thanks!

Softwebmedia

Theme is compatible with latest version of Firefox (v.27) and Chrome(v.33). Both browsers are constantly updating (sometimes weekly) so practically it’s not possible to test all older versions like internet explorer (IE8,IE9,IE10,IE11).

Default-user

Can you look into the Mavericks issue? A lot of users are upgrading and having an ugly Hostgator error page show is awful…

Softwebmedia

When we tried to check your website ( http://baddogdesign.com/mcclartycreative/ ) in iPad, it is displaying some mobile device off/on message. Please remove this settings so we can view website.

  • Bought between 10 and 49 items
  • Egypt
  • Has been a member for 4-5 years

Hi. Does the theme have RTL support?

Softwebmedia

Hi immanence,

This theme is coded with LTR support and RTL support requires manual work in HTML/CSS/PHP files.

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 0-1 years

Hello,

i bought this theme a few month ago and everything worked great, but now i have 2 problems:

1. Since a few weeks when i’m opening the website on my Smartphone there is no navigation !! and the same thing is when i resize the browser window the navigation disappears ?? Why?? How can i fix this? It seems that the responsive animation doesn’t work correctly.

2. An Other thing is that the Theme works very slowly. For example when i go to a navigation point it loads few seconds… I speed optimized the website already, but are there some specially settings to speed up the theme/page?

Hope you can help me.

Thanks

Softwebmedia

Hi marc-lang,

Please send your website URL so we can check it.

Thank you :)

  • Bought between 10 and 49 items
  • Has been a member for 0-1 years
  • Referred between 1 and 9 users

I’ve never been able to get the “Recent Work” widget to display portfolio items from only one category.

Am I missing the latest ultra elements update or something, would love to get this going. Thanks

Softwebmedia

Hi web2mobile,

You can use exclude property to hide all other portfolio categories portfolio items display like below sample exclude property has portfolio categories ids 10,21,56.

[recent_projects_style1 column="2" display_projects="2" 
lightbox="true" display_text="true" title_text_size="14" 
excerpt="false" excerpt_type="category" excerpt_text_size="11" 
exclude="10,21,56"]

If you have seletected multiple categories for portfolio item then it will not display if any category is in exclude property.

Thank you :)

  • Bought between 50 and 99 items
  • Has been a member for 4-5 years

Great theme, thanks!

I’ve installed/activated the plugins, but I’m getting this message: “Hi! Please activate your copy of the Revolution Slider to receive automatic updates & get premium support.”

In the Revolution Slider tab, I can see it’s asking for a Code Canyon license key.

Please help?

Softwebmedia

Hi nergizing,

This will only apply if you have purchased revolution slider directly from code canyon and you can then add license key. We are regularly updating plugin with theme updates so don’t worry about this message.

Thank you :)

by
by
by
by
by
by