417 comments found

Hi, I’m interested in purchasing the theme but when checking its responsiveness….it is not responsive.

- I opened the theme using this URL http://themeforest.net/item/unique-magic-power-beauty/full_screen_preview/3909455, in both my iphone and ipad mini and the website defaults to the middle of the page. This isn’t responsive…the display should go all the way across the device whether I’m using a mac, mini or my iphone.

- Also, when I changed the direction of the devices (standard vs. changing to the long view) the screen did not change. This also isn’t responsive

1) What url should I use to check the responsiveness? I may be using the wrong URL. Thank you…

PersianArt
Hi, the url is: http://themes.persitheme.com/unique/

I have not any apple device and check responsive by window resize and some online site that simulation this device size, also I did not heard from person for this issue, if you can please check it again.

good luck

Default-user

The url you posted works better but there are still errors when I view on a device:

1) When viewing on my iPhone, the copy within the flash panel is skewed and is not scaling down to view correctly on a phone. It looks fine on iPad mini

2) The ‘What you get’ section on the homepage doesn’t view correctly when viewed on the iPhone. Something is off with it when viewing on a phone

PersianArt

1- unfortunately I have not this device to check it but when I resize the window in my pc the copyright section view correctly and text come to center.

2- yes because this section use 50% for width by percent-column shortcode, it will be solved to next version that I try to release it the next few days.

Thank you

roopu Purchased

Can you tell me how can I choose Home 2, 3, 4…. on wordpress admin panel

PersianArt

Hi, you must create your pages include homepages by shortcode, there is no any option fir this purpose.

if you need create pages like demo please use xml file.

good luck

niclas Purchased

Can you supply an export xml of your revolution slider settings? It would help a lot to understand the effects you have.

Thanx /N

PersianArt

send me message from my profile page form then I will send you export file to your email.

niclas Purchased

Theme has some problems when you are using Safari 6.1 on MAC OS X 10.8.5. So far I have found the following issues:

- Using the Persian Art Admin Panel freezes Safari. - Adding content in a page and using visual mode, then when you use short code and enter data in the field the Content field gets really long so you have to scroll way down to find the button to insert. - Color picker scrolls in own layer and does not follow the window.

Most annoying is that Persian Art Admin Panel is freezing the system. (Works ok with FireFox on same system)

B.R. /N

PersianArt

Hi, unfortunately I have not any apple device to check it for freezing. I test on safari for pc and it works fine.

about colorpicker, yes it is scroll because it is positioned to body element and by scrolling body it is scroll too, but it is external plugin and I can not do anything, also it not very important issue.

about textarea content height, this is issue on the 3.8.1 and you can fix it by do this (I will fix it later)

go to > includes > css > themeoption.css and add this (maybe after line952 )
#shortcode-form-wrapper table textarea {
    height:auto !important;
}

thank you for your report
good luck

I’m trying to show error messages with a login plugin I am using but I’ve found this in the theme’s functions.php file, which is stopping error messages from being shown:

// removes detailed login error information for security add_filter(‘login_errors’,create_function(’$a’, “return null;”));

I’m trying to override it in my child theme but I’m not having success, this is what I’m using in the child functions.php:

add_action( ‘after_setup_theme’, ‘my_child_theme_setup’ ); function my_child_theme_setup() { remove_filter(‘login_errors’,create_function(’$a’, ”;”)); }

Must be something simple I’m missing right?

PersianArt

Hi,

you can remove it or comment like this:
/* add_filter(‘login_errors’,create_function(’$a’, “return null;”)); */
Default-user

Yes, but I don’t want to adjust core files, when I update the theme that change will get overwritten. So I wanted to add something into my child theme. But the code I’m trying above is not working.

PersianArt

I use anonymous function, then you need remove it if you want, No problem, this add more security and is optional, I will comment it in the future update, then anyone can remove comment, if needs.

goodluck

Hi PersianArt! I’m managing a web with your theme (awesome and very usefull)... Evrything is ok, but when I see the web on my phone, tablet… there are 2 things with problems in responsive (sorry my english, It isn’t so good). First in Home Page: Logo is covered by the social icons and the phone number and email icons. Logo appears with his size, but above it appears social icons and top information. The second trouble about responsive is in Contact page at grey block with contact information… Web url ‘www.-.com’ is covered for street address, and email address ’.com’ is cut.

An other question is… Where can I change the language from the contact form (not widget). I mean, the error messages on web (‘Please enter a valid email address’, etc…)and the confirmation mail for clients? I’ve changed the text ‘Name, subject, and comments’ but the others I don’t find them. I’ve translated every page contact.php to spanish but it doesn’t appear translated on web.

Thanks very much in advance!

Good job with the theme!

PersianArt

Hi, if you have online site please write your url to visit it.

please use last version. in the last version you can use your text. (please read update in item description on the themeforest before update)

Default-user

Thanks for answer so fast! :)

I’ve solved first problem. Top information covered logo because his size was with %. I’ve resized with photoshop and take off the %, and now It works perfectly!

But in grey box (contact-info) in responsive… the last 3 letters (’.com’) ( are cut. I meant, in responsive I can see the email address without ’.com’... what can I do?

One question… I’d like to put the whatsapp icon close to the mobile number in this grey box… how can I put an icon in here?

The language from error messages in contact form (I’ve found the answer reading comments here..) was in js/jquery.custom.js And solved too! Except the ‘My site, Name, Comments’ items from email received, that I’ve changed it in contact-page.php in my language but I continue receiving emails in english :s

Thanks!!! a lot of thanks!
PersianArt
for contact-info responsive add this lines to (css/responsive.css) where you need (@media only screen and (max-width:800px) or other section):
.contact-info > .col2,
.contact-info > .col3,
.contact-info > .col4 {
    width:100%;
}
you must put it like image in your lines, (use add media or frame shortcode)
<img src="..." />0123456789

I suggest use new version of theme for text in the form. but for text in email received use language file, or in the contact-page search again, there is 2 text, try find another text and translate it.

good luck

How to erase the typical Blog Informations date in article and date, skills, client,project and tags in portfolio

I think, I should touch the index.php, single.php and the archiv …. but I can’t find the code. Can you please help me?

http://www.dgtcm.de
PersianArt

Hi, in new version there is option for this purpose, but please read update section at end of the item description on themeforest.

good luck

Default-user

I’m afraid to update this big project – I already readthe update warnings ;-) What would you think, how much time it takes to update all the sliders and sidebars in the dgtcm.de ? But you mean: With the update, I can easyly change and delete the date of a posted articla in the optionsector?

PersianArt

please consider already options are for blogpage only and not work on singlepages.

I dont know how much may around 1 hour based on how much you used slider and frame shortcode, now for select images for frame and slider shortcode theme used new media uploader and it is very easy to use.

and after update widgets that you set for sidebars will be inactive and you need drag them from inactive section to sidebars (maybe 1-2 minute)

you can download the new version and test and see it on local server for new options.

goodluck

niclas Purchased

Hi, I have noticed that when using h3 tags characters like – and – don’t show. They will be presented with a blank space.

Chosen font for headings are Museo Sans WP is v3.8.1 and Unique version is 1.5

Default-user
niclas Purchased

Screenshot is sent in mail. And basically when I write content with h3 tag the dashes endash and emdash and hyphenate (minus sign) won’t show. They are replaced with blank space.

When source is viewed it look like this where the – has been replaces with the 8211 code

protect your IT assets – and ultimately your company

Default-user
niclas Purchased

Hi, Screenshot is in your mail.

When writing content and I use – or – characters or like the ™ character they don’t show. You get blank spaces instead.

If you look at the page source you’ll notice that the – has been changed to html code8211 ”...protect your IT assets – and ultimately your company…”

But I think it is a font problem. I have found that several of the fonts you included in the theme show the same problem but other is showing the correct characters.

I think that hyphenation signs – and the en dash (code8211) and the em dash (code8212) are so common that to include fonts that can’t handle those is a problem.

PersianArt

Thank you but as you said this is a font problem and I can not do anything about them.

Thanks

niclas Purchased

In the theme there is a Font upload option and I’m not experienced with the different kind of webfonts.

What kind of fonts can I use to upload?

I have tried add font with the following types of web fonts fontname.eot fontname.woff fontname.ttf fontname.svg

I only get error messages like

“fontname.xxx” has failed to upload due to an error Sorry, this file type is not permitted for security reasons.

PersianArt

for upload you must use cufon fonts only (they are js files)

Hello there,

I’ve installed the theme on WPMU and page / post parameters have disappeared… They are now displayed as “custom post type” options and it’s very difficult to choose settings with true/false/yes/no (not sure I’m clear). Any clue? Thanks Guillaume

PersianArt

Hi, I did not test theme for WPMU then I can not say it is ready for that then already I have not any suggetion, can you send me you username and password from my profile page form to see your dashboard?

good luck

Hi! Im using your theme in this site: http://fundacionquantum.com.ar/

I dont know why the text seems cut in the first line, after the slider, can you help me?

PersianArt

Hi, please show to me on the screenshot, you can put it here

http://redpen.io/
niclas Purchased

1. How do I upgrade from version 1.5 to 2.0 and keep all settings so I don’t have to manually re-enter all settings?

2. Are you planning to support child-themes? If so – when do you think that we can see that version? (I think this is essential for a premium theme to support)

3. Are you planning to support multi language via WPML?

Default-user
niclas Purchased

1. Thanks, but it did not work as I hoped :) I’ll have a look in a few days and see if I can give you a list of settings that is “lost” when doing it like you said.

2. v1.5 seem not to be child ready?. I guess you mean that v2.0 is child ready?

3. No, I believe that WPML (with string translation installed) is managing like 99% but if you have the contact page then inside the field you have “Name”, “Email”, “Message” and button text “Submit” is not possible to translate. Same if you have the contact as a widget in page footer – all in english but heading above contact widget is possible to translate via the WPML string translate add-on.

Default-user
niclas Purchased

3 part two: In PersianArt Admin Panel you have the Copyright settings. Theres no way to translate content in the text on “left” Side or text on “right” Side fields. Not that I can see anyway

PersianArt

don’t worry about loss thing, you did not loss any thing, you only need less than hour (basd on you number of page that use slider or frame shortcode) for setting again on theme panel like logo, favicon, background that now are bast on url.

2- please test v2.0 and aware me about your experience

3- in new version contact page and widget contact page use fields to write directly in theme desired labe/placeholders and messages.

4- in the panel on copyrght settings you can add your text, without any problem.

good luck

niclas Purchased

New issues with your v2.0 theme

v1.5 was responsive but v2.0 is not. When viewing the site the main menu (menu) is not working. It will present a drop down menu choice list but nothing happens when you choose new menu item. When doing the same on v1.5 all works.

How do I fix so that it is what you say it is – responsive? Yes I have set it as responsive in PersianArt Admin Panel.

(Tested on your standard theme site with your content imported via supplied xml-file)

Default-user
niclas Purchased

Well that will not solve the problem. You need to remove other spaces as well to solve it.

( '#menu-wrapper select' )
to (2 spaces removed)
('#menu-wrapper select')
and also in
( 'option: selected' )
to (3 spaces removed)
('option:selected')
PersianArt

No, no needs any other space issue, if after mentioned fix you see did not happened anything this is for browser cache and if you empty cache it work correctly with only fix that I said before that.

These space that you mentioned is only for better read (based on Handbook, JavaScript Coding Standards on wordpress)

Thanks and good luck

Default-user
niclas Purchased

I believe you are right but as info – I had cleared cache and also restarted browser and problem were still there so I made changes as above and worked right away.

niclas Purchased

Chrome v33 – Some text is not showing until page is reloaded.

To se if you get same problem have a look at your “Live Preview” of the theme here at theme forest and then go to menu choice “Short Codes” – “Testimonial”

On Chrome on OS X and on Win7 you don’t see the text in the testimonial “bubbles”. I can select it but can’t see it.

We get it on our home page in three different areas – Stunning text, where first line of text is not showing but all other are. In your headlines “What you get” and “Welcome” both don’t show on our page until reload and same for testimonial bubble that don’t show text inside bubble.

This is only on Chrome and both on Win7 and OS X 10.8.5

Have any ideas on how to solve that problem?

Default-user
niclas Purchased

Link to live site + screenshot + video recording sent in mail.

Please note that I can not reproduce the problem when running exactly the same installation on localhost. It is only a problem when installed on web hosting server.

With that said – I have tested on totally different web hosting providers/companies and the same problem shows up on all tested systems.

Default-user
niclas Purchased

OK – Thought that I should let you all know what I found so far regarding the problem with Chrome v33 and text not showing.

It took me a while and I have investigated 30 sites that use the Unique-theme, and I found that approx 30% showed the problem and 70% did not. I also made tests at two different web hosting providers and at both I could reproduce the error.

Tests was done with 9 different PCs with Windows 7 and Chrome 33, 1 MAC with OS X with Chrome 33, 1 MAC with Win7 and Chrome 33 in virtual environment. So I think I covered the most.

So I was sure that I was not the only one that had the problem. It is not possible to reproduce the error on my local system and I guess it has to do with cage and speed issues.

Actually it’s not the theme that is the big problem but it is the fact that Chrome v33 and Google Fonts are not compatible (amazingly)

If you use Google fonts in the theme you are most likely to have the problem. If you have the chosen font installed locally you will not have the problem (but your costumer might anyway)

Easiest way to see the error i action is with Chrome 33 and go to http://themes.persitheme.com/unique/shortcodes/testimonial/

Important is to have cleaned your cache. As soon as you refresh/reload the page you will se the text again. If you can see the text the first time you test – delete your cache open new tab paste the URL and press enter. If you still can see the text then repeat clearing cache and try again. Still can see = you have that font installed in your system.

Any way – The problem is related to Google fonts and Chrome v33. If you don’t use them you don’t have an issue.

I have not found a solution to the problem and if someone else do find a solution I’d appreciate a comment!

Hope it can save some one else hours of investigating work …

PersianArt

Thanks

Hi PersianArt! I have 2 questions:

I’ve put a little slider in the ‘Who where are’ Page with pictures about the services. I’ve upload 6 pictures more or less, but the slider only shows 3.

This is the shortcode:

[slider width=”210” height=”130” effect=”fade” align=”left” showcaption=”off” showborder=”off” bordercolor=”” showdirection=”off” showcontrol=”“] url-1,url-2,url-3 [/slider]

Where can I modify this for show my 6 pictures? I’ve put all of the them (their urls) in the shortcode separated by commas, but only shows 3.

And one more question…

In contact form from contact page, the words ‘Name’, ‘Email’, ‘Message’ are in english. If you do click on It, It disappears for your enter name, mail or message… until here everything is ok; but if I translate this words on page-contact.php to spanish, when I am in Contact page web, this words don’t disappear and I have to delete the word ‘Name’ (‘Nombre’) to write…

I translate It here for ‘Name’ for example: <?php if (isset($success_message)) echo $success_message; else { ?>

<label for=”contactName” data-rel=”Name”><?php _e(‘Name’, ‘my_framework’); ?></label> <input type=”text” name=”contactName” id=”contactName” value=”<?php if (isset($_POST[‘contactName’])) echo $_POST[‘contactName’]; else echo ‘Name’; ?>” class=”requiredField <?php if (isset($nameclass)) echo $nameclass; ?>” onFocus=”if(this.value==’Name’) this.value=’’;” onBlur=”if(this.value==’‘) this.value=’Name’;” />

Thanks in advance!

PersianArt

Hi, like many theme, I did not consider content for this page also customization is not in support, please did not request again.

I think shoulde use this code:
<?php 
        if ( have_posts() ) while ( have_posts() ) : the_post(); global $more; $more=0;
            if ($pagecontentonoff!='false') the_content();
        endwhile;
        ?>
before this codes
<?php $wp_query = new WP_Query('post_type=portfolio&portfolio-category= .......

good luck

Default-user

Great! It works very very well! thanks very much :)

Default-user

Why in portfolio page, when I click on the ‘WEBSITE’ button It goes to ‘Error 404 not found’? It only works if I write links to another page into the website, but if I leave ‘Project Url’ empty or write another thing, It goes to ‘Error 404 not found’ o.O

Hi Persian Art, thank you for you awesome theme.

Please can you tell me how to increase the TM slider height so the caption is still visible?

Many thanks Neil

PersianArt

Hi, if you need change height then you should change height in style.css and in slider.php

from dashboard you can remove caption.

good luck

niclas Purchased

Wide, Boxed, Block When upgrading from 2.0 to 2.0.1 setting under Unique panel “general > page style > theme style” has changed from Wide to Block.

Where is that setting value stored? (in which files and where?)

Default-user
niclas Purchased

When I upgrade from 2.0 to the new version 2.0.1, then I get a change in the settings of the setting I previously done in “general > page style > theme style”

I had it set to wide but after upgrade it was changed to block.

When I make the change – it must be stored somewhere like in a database or in some other plain file (php/css etc)

I asked where is that setting stored?

PersianArt

all option was stored in the database

Default-user
niclas Purchased

Strange. It was changed when upgrading. But it’s no big deal. I just changed it back.

niclas Purchased

I have set up an multi lingual site using WPML with add-on “String translation”.

Previously you said that theme was WPML ready, and it is at most parts but I have trouble finding out how to translate the contact widget and the following items;

(The “Title” is possible to translate (identified by WPML as “widget title”, but the ones below is not found by WPML)

Successful message

Name label/placeholder

Name error message

Email label/placeholder

Email error message

Email validate error message

Message label/placeholder

Comment error message

And I can’t find any way of translating the Submit button texts via WPML.

Can you help me understand how to translate that? (I do understand that you cannot be WPML-support but the question is about the PersianArt widget)

Are you sure that the widgets are compatible with WPML? Can you have a look at the widget and if it was not compatible provide either new widget code that is WPML compatible or tell me where and how to update the widget code?

Thanks in advance /Niclas

Default-user
niclas Purchased

Sorry to say but I do have a huge problem to understand your english…and I’m also not a php-programmer even if I understand some parts, so I need more help than that.

Maybe I understand you wrong but;

It is NOT the label “Name error message:” that I want to translate. It is the content of the field that correspond to the label.

The only thing I need to translate is the content of the fields in the widget – so I guess that you say that i need to edit something in the file includes/widgets/persian-art-contact-widget.php

There I need to edit something but I can’t understand what part since it is not the label but the content in the field.

What line and change from and to what?

PersianArt

excuse me for my bad english language skill, I understand your purpose, as I say due to putting option for write directly in the fields, I did not use translate function for this text,

don’t worry I will new change in this text and release new version as soon as possible that you can find this texts with WPML

please waiting

Default-user
niclas Purchased

Thats OK, Thanks!

niclas Purchased

With the Shortcode Testimonial

If I have 20 different testimonials and on the homepage I only want to display 3 specific testimonials in the bubble & carousel – is that possible?

Perhaps use the categories in some way or multiple names?

PersianArt

hi, already there is no way because I think this is not important but if you think customer needs this option I will add later

good luck

Default-user
niclas Purchased

Can you please add that function? I would say more than me needs that!

PersianArt

unfortunately I forgot it because the only request was your message please wait. I think about it

Hi, How to make theme update properly?? There’s no button anywhere in the panel

Kris

PersianArt

simply activate another theme then delete old version and upload new version and activate it.

good luck

by
by
by
by
by
by