1689 posts Envato Elite Author
  • Affiliate Level 2
  • Author Level 8
  • Collector Level 1
  • Top Monthly Author
+8 more
Tean
says

If you have a white textfield and you try to fade it in from alpha 0 to 1, on the end of the tween it will look like there is a sudden jump, like there is another layer of white applied on the textfield.

I really dont know how to describe it better, I have encounter this many times…

This actually applies for colors 0xcccccc to 0xffffff.

In other words I cannot use too light text color if I cannot ignore this thing, which I cant :D

Why is this happening, is there a way to solve this?

111 posts
  • 7 Years of Membership
  • Author Level 3
  • Collector Level 1
  • Exclusive Author
+2 more
savorks
says

Did you set publish flash player version to 10 ? I remember this happen in FP9 or earlier version of players.

EDIT .If you need use FP9 maybe try embed font for that text field.

8586 posts Community Moderator
  • United Kingdom
  • 8 Years of Membership
  • Moderator
  • Winner
+10 more
MSFX
Moderator
says

i’ve seen this too, no idea how to get around it, I tried all sorts :(

hope someone has a fix :)

edit: get it with FP9 and 10 :(

9 posts
  • 8 Years of Membership
  • Collector Level 2
  • Exclusive Author
  • United States
nosrevlah08
says

Are you using a timeline tween or actionscript tween? Here is what I do:

- Make text field a movie clip.

- Set the text field “anti-alias” to “animation”.

I don’t get that “jump” you are referring to, but I have seen it before on some sites.

Hope this helps.

1689 posts Envato Elite Author
  • Affiliate Level 2
  • Author Level 8
  • Collector Level 1
  • Top Monthly Author
+8 more
Tean
says
Are you using a timeline tween or actionscript tween? Here is what I do:

- Make text field a movie clip.

- Set the text field “anti-alias” to “animation”.

I don’t get that “jump” you are referring to, but I have seen it before on some sites.

Hope this helps.

Thanks, but setting anti-alias to animation ruins text look all together…

2054 posts
  • Affiliate Level 3
  • Author Level 12
  • Collector Level 2
  • Power Elite Author
+11 more
bitfade
says

try to set blendMode = “layer”

1163 posts
  • Affiliate Level 2
  • Author Level 6
  • Collector Level 3
  • Top Monthly Author
+6 more
FlashTang
says

txt_mc.blendMode=”layer” (or you can change this in properties’ panel)
txt_mc.alpha=0.5

but txt_mc background color should be 0×000000 or at least <= 0xcccccc gray color ;)

p.s haha ,the same time

821 posts We're a nice team!
  • Top Monthly Author
  • Weekly Top Seller
  • Trendsetter
  • Elite Author
+12 more
ThemeFocus
says
txt_mc.blendMode=”layer” (or you can change this in properties’ panel)
txt_mc.alpha=0.5

but txt_mc background color should be 0×000000 or at least <= 0xcccccc gray color ;)

p.s haha ,the same time

:)

1689 posts Envato Elite Author
  • Affiliate Level 2
  • Author Level 8
  • Collector Level 1
  • Top Monthly Author
+8 more
Tean
says

Wow, blend mode to layer really works :)

Thanks guys!

3757 posts
  • Trendsetter
  • Elite Author
  • Spain
  • Author Level 8
+12 more
pezflash
says
try to set blendMode = “layer”

Wonderful! didn’t know it had a solution.

by
by
by
by
by
by