18 posts
  • 8 Years of Membership
  • Collector Level 4
  • United States
bubberz
says

Hi…newbie to FLASH .

I have two scenes in my FLASH file, and the first is the preloader.

When the screen comes up, it’s blank for a bit, then the preloader comes in around 60-70%.

I have a slow connection (sloooooowww DSL ), but other sites don’t seem to have this problem. Do I put the preloader in the same scene?

Here’s my first scene code: stop();

myInterval = setInterval(preload,100);

function preload() { var current = _root.getBytesLoaded(); var total = _root.getBytesTotal(); var pctLoaded = Math.round(current/total*100); pct_txt.text = pctLoaded; }

if (current >= total) {
    gotoAndPlay("Scene 1",1);
    clearInterval(myInterval);
}
356 posts
  • 8 Years of Membership
  • Affiliate Level 1
  • Collector Level 4
  • Exclusive Author
CreativeMedia
says

We can give tell you how it loads if you post a link to the file.

3072 posts
  • Affiliate Level 3
  • Author Level 6
  • Collector Level 2
  • Trendsetter
+8 more
wickedpixel
says

your flash file uses lots of data from library? ...files like sounds, clips, fonts, classes , etc …that are loaded first and then your preloader…
The export for actionscript may cause that… check your publish settings… and export your stuff in other frame than where you have your preloader…

18 posts
  • 8 Years of Membership
  • Collector Level 4
  • United States
bubberz
says

Thanks for the replies!

Here’s the URL to the site: http://www.bandeliergrill.com/BGMain.html

wickedpixel, I’ll try your suggestion tonight.

1 post
  • 8 Years of Membership
  • Author Level 2
  • Collector Level 2
  • Exclusive Author
+1 more
mkprogramming
says

Yeah, the issue is that your project is most likly loading a lot of movieclips and images on the first frame along with the pre-loader. If you make all your movieclips and such not load on the first frame, and place them all on the second frame (for just a split second) and make the real content on the third frame, your pre-loader should work just dandy :).

18 posts
  • 8 Years of Membership
  • Collector Level 4
  • United States
bubberz
says

wickedpixel,

You mention: The export for actionscript may cause that… check your publish settings… and export your stuff in other frame than where you have your preloader…

...I’m checking my “Publish Settings”, “FLASH” tab for this…and see the ActionScrip 2.0 setting. If I only have 1 frame on the preloader scene called “Preloader”, but multiple in the following scene / 2nd scene called “Scene 1”.

Do I add a class path such as: “Scene 1”, “1”

27 posts
  • 9 Years of Membership
  • Author Level 4
  • Collector Level 3
  • Exclusive Author
+2 more
sparias
says

Bubberz, on the publish section, you just have to put frame 2 for the publish settings,, it doesn’t matter if you put your preloader on the first scene with just one frame, that’s all, it has worked for me!

18 posts
  • 8 Years of Membership
  • Collector Level 4
  • United States
bubberz
says

sparias,

So, with my preloader scene having only on frame and layer, and my main scene having 50+ frames, I just need to set the Publish Settings / Flash / ActionScript “Export Frame For Classes” to something like 2…even though my prelaoder scene has 1 frame?

..right?

Thanks for the help!

by
by
by
by
by
by