Discussion on Lambda - Responsive Moodle Theme

eva_pi supports this item

Supported

271 comments found.

​This theme depends on bootstrapbase from moodle core which is no longer supported as of version 3.7. Again ​Essential theme is not compatible with moodle 3.7. Will lambda be available for moodle 3.7 and later versions? Will there be any compatibility issues? ​

Don’t worry: Theme Lambda is already fully compatible with the latest Moodle version 3.7.1+ :)

waiting for moodle 3.7

Hi,

the latest version of Theme Lambda is already compatible with Moodle 3.7 (https://themeforest.net/item/lambda-responsive-moodle-theme/9442816#item-description__changelog )

Please feel free to contact me again if you have any further questions.

Regards,
eva_pi

Clet

Clet Purchased

does this theme no longer supports new moodle 3.7? i’m just in the process of upgrading moodle but looks like it needs the bootstrap base which is no longer supported on 3.7…. what the solution for this?

Hi,
please download the latest theme version again. There you will find an installation package for Moodle 3.7. You have to use this theme folder during your Moodle upgrade.

I am trying to download the Lambda theme for Moodle 3.7 (theme-lambda-upload-moodle_37.zip) however I can only download up to Moodle 3.4 (theme-lambda-upload-moodle32-34.zip) can you tell me where I can find the download for Moodle 3.7

Hi, I have a question regarding the upcoming Moodle 3.7. They say themes based on Bootstrap version 2 (including bootstrapbase, Clean and More) will be deprecated and removed from core. Is this affecting Lambda and if yes will there be a new version coming?

Hi,
don’t worry: I am already working on a theme update for Moodle 3.7. Of course I will keep Theme Lambda compatible with the upcoming Moodle versions.

Hello Dear,

This theme is not working with moodle 3.7+. What should i do know. I cant downgrade it too. It messed up.Help me with this problem.

Thank you

Hi,
you mustn’t downgrade the theme but use the latest theme version instead.
After an upgrade of your core Moodle instance, you always have to make sure that you are using the latest versions of all installed plugins.
Please download the current version of Theme Lambda, there you will find an installation folder for Moodle 3.7.

I just bought this theme and install it with Moodle 3.7 but after activate the theme as default I randomly got 2 pop-up errors with message like “Undefined” and “Invalid JSON string” on some random pages/sections. Please help, thanks!

Hello. After upgrading to 3.8 there is no more option to collapse/expand blocks inside moodle. There are no controls left of the block title that will enable to ​collapse or expand certain block. Is there a fix for that or is that change implemented on purpose.

There is already a ticket opened here for the same issue: https://moodle.org/mod/forum/discuss.php?d=388170​

We used lambda from the beginning and it was a great theme but this never versions lack some stuff from old versions.

Hi,
unfortunately the ‘minimize’ and ‘dock’ icons are indeed gone because these features are no longer supported by this Moodle version. You can check the Moodle 3.7/3.8 core themes “Classic” and “Boost”, you won’t find these icons/features at the core themes, too.
With Moodle 3.7, the ‘dock’ feature is even removed from the core Moodle theme settings (see also: https://moodle.org/mod/forum/discuss.php?d=381465).
If you like to keep the extra space for your course contents which the Moodle dock provided, then you could switch to Theme Lambda’s collapsible sidebar. In contrast to the Moodle core Boost theme, this sidebar is a fully configurable block region and you can place all your blocks there:
http://redpithemes.com/Documentation/assets/options_blocks.html

Hello,

I am using Moodle 3.7 and the corresponding version of Lambda theme. That’s fine, but when uploading images to resources, there is no option for images to be responsive, I don’t have those settings. Is it a bug in the topic and can it be fixed?

Hi,
Moodle automatically adds a class for your images to be responsive when you insert them at the Atto editor (‘Auto size’ checkbox).

Hi TIM, I’ve some error with lamda, when upgrade moodle 3.7 to 3.8.3+ this is the error :

“Capability ”moodle/community:add” was not found! This has to be fixed in code. ” Can you get me the solution for this problem?

line 453 of /lib/accesslib.php: call to debugging()
line 34 of /blocks/community/block_community.php: call to has_capability()
line 228 of /lib/blocklib.php: call to block_community->user_can_addto()
line 2252 of /lib/blocklib.php: call to block_manager->get_addable_blocks()
line 1236 of /lib/blocklib.php: call to block_add_block_ui()
line 374 of /lib/blocklib.php: call to block_manager->ensure_content_created()
line 27 of /theme/lambda/layout/columns3.php: call to block_manager->region_has_content()
line 1374 of /lib/outputrenderers.php: call to include()
line 1304 of /lib/outputrenderers.php: call to core_renderer->render_page_layout()
line 244 of /course/view.php: call to core_renderer->header()

Hi,
the only line which points to the theme folder and Lambda is regarding the block management and this is because of an error in the block_manager in one of the lines above. The “Capability “moodle/community:add” is not part of the theme, it belongs to the Moodle core. So I doubt that your issue is theme related. But you could try and temporarily switch to the default Moodle core themes “Classic” or “Boost” to see if there are any differences.
Please let me know if you are getting any different results with one of the Moodle core themes.

Hi,

There is a bug/error for modal scrolling, please find following details for reproducing a bug/error:

CASE I 1. Go to any courses 2. Create any assignment > in editing page 3. Navigate to ‘Submission types’ > ‘Accepted file types’ 4. The pop-up modal appears 5. BUG/ERROR found -> CANNOT scroll to the modal bottom. 6. I can’t click OK/confirm (Freezed Modal). 7. This ERROR symptom occurs in all places where has the MODAL.

CASE II 1. Go to any courses 2. Go to ‘Participant’ > ‘Enrol users’ 3. Let’s add with more than 20+ students (until ‘Enrol users/Cancel’ buttons move down by disappearing from the screen) 4. BUG/ERROR found -> CANNOT scroll to the modal bottom. 5. I can’t click ‘Enrol users/Cancel’ buttons.

PLEASE check this bug/error because there are many pages which are belongings by pop-up modal and cannot work properly.

Best regards, Krit Th.

​Hi,
I am currently working on the next theme update for Moodle 3.7 which will fix all issues which you have reported.
The update will be available soon. Once it is published at themeforest, you will get an official notification email. You just have to login at themeforest with the account that you used to purchase the item.
Please feel free to contact me again if you have any further questions.
Regards,
eva_pi

For some reason after updating the theme and Moodle to 3.7 the Admin block’s collapsible menu options are not visible any more. The icon and title “Administration” are there, but with nothing underneath. When I inspect the element it seems that there is a “hidden block_settings” class being applied to it.

<section class=”hidden block_settings block card mb-3” id=”inst17” role=”navigation” aria-labelledby=”instance-17-header” data-block=”settings”>

When I delete the word “hidden” from this line so that it reads as follows, then the collapsible menu is visible again.

<section class=”block_settings block card mb-3” id=”inst17” role=”navigation” aria-labelledby=”instance-17-header” data-block=”settings”>

Can anyone help with this?

I see you are working on a new Moodle theme based on the Boost core (separate to Lambda). Whilst we have been very happy with Lambda we will be looking to move to a Boost based theme early next year.

Do you have any details about the new theme (including the anticipated release date)? If it’s as full featured as Lambda, we’d be very interested in taking a look at it.

Hi,
my roadmap has changed a little bit because of the release notes for the upcoming Moodle version 3.7. All Bootstrap 2.3 based themes will get deprecated with this new Moodle version. So I will – contrary to my earlier plans – at first publish a new Bootstrap 4 based update for Theme Lambda. This version will of course include all features that the old version offers – plus some new enhancements! :)
After that, I will continue to work on my new BS4 based theme. But due to the focus on the update of Theme Lambda, it is still in an early stage of development and there is nothing exciting which I can show you yet…

With the latest updates ​​(Moodle 3.9.2+​ and Lambda 1.98.13) the ​Atto-Editor ist broken:

- the icons are ugly and incorrectly positioned​ - in the text area, the scroll bars are missing and the text overflows - …

​Thank you

Hi,
this is not a general issue with the theme, the Atto editor should still be displayed correctly with the latest Moodle version. Are you perhaps using the wrong installation file for the theme? At first, please unzip your download from themeforest. In the folder ‘theme’ you can find the installation files, separated for Moodle versions 3.2-3.6, 3.7, 3.8 and the latest Moodle version 3.9. You have to use the file for Moodle 3.9.
If this doesn’t help you, please open a ticket at the support forum: https://redpithemes.ticksy.com/

Sorry for the confusion: The new “latest”-3.9 Moodle version has indeed made some changes to the general structure for the stylesheets of the Moodle core: The Atto editor no longer has its own CSS file for layout and design. This was “outsourced” to the core theme “Boost”. With that, Lambda cannot load this CSS file for the layout of the Atto editor since it is not a child theme of “Boost”. This is fixed now.

Hi, is compatible for moodle 3.2? and is multilanguage?

Hi,
thank you for your interest in Theme Lambda for Moodle. The theme is already fully compatible with Moodle 3.2 and it will work fine with this version. Moodle offers many features to support multiple languages, Theme Lambda is for example compatible with the Moodle multilanguage filter.

Hello, can you please confirm if that theme is compatible with MOODLE 2.9.9-0 and MOODLE 3.2.2-0 ? Thank you.

Hi,
yes, you can use the theme with Moodle 2.9.9+ and 3.2.2.+.

hello Is this theme currently compatible with MOODLE 3.8.1+ ??

Hi,
thank you for your interest in Theme Lambda for Moodle. Theme Lambda is fully compatible with the latest Moodle version 3.8.1+.

Hello —Pre-sale question – What is the latest version of Moodle supported?

Hi,
thank you for your interest in Theme Lambda for Moodle. Theme Lambda is fully compatible with the latest Moodle version 3.7.1+.

Will there be an update to this theme for Moodle 3.5? I read that there is a major change in Bootstrap for this version.

Hi,
this change will only affect the Moodle core Boost theme. Theme Lambda will of course be fully compatible with Moodle 3.5.

I just bought this theme. I would like to know If this theme is compatible with version 3.3 Moodle. Thanks.

Hi,
the theme is fully compatible with the latest Moodle version 3.2.1 – but Moodle 3.3 is not released yet. The download at moodle.org is only a development version of the incoming Moodle 3.3 and should be used only for testing and development purposes. You can install the theme also at a Moodle 3.3 dev site and it should work fine, but a full compatibility can not be assured before Moodle 3.3 is officially released.

by
by
by
by
by
by