iamarif

iamarif supports this item

Supported

36 comments found.

mwax321

mwax321 Purchased

Getting the following errors all over the site:

Warning: strpos(): needle is not a string or an integer in /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-content/plugins/kirki/field/class-kirki-field-color.php on line 60

Warning: Cannot modify header information – headers already sent by (output started at /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-admin/includes/misc.php on line 1114

Warning: Cannot modify header information – headers already sent by (output started at /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-admin/post.php on line 198

Warning: Cannot modify header information – headers already sent by (output started at /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home8/mwaxmanc/public_html/veterinarynurseconsulting/wp-includes/pluggable.php on line 1216

I saw you have a post on github with the kirki developers. Was this ever resolved?

It’s ok. Could you open the inc/customizer/lifeband-customizer.php and find all color control just like this:

Kirki::add_field( ‘lifeband_config’, array( ‘type’ => ‘color’, ‘settings’ => ‘lifeband_primary_color’, ‘label’ => esc_html__( ‘Primary Color’, ‘lifeband’ ), ‘section’ => ‘lifeband_section_color_general’, ‘default’ => ’#ffbb00’, ‘priority’ => 10, ‘choices’ => array( ‘alpha’ => true, ), ) );

You must find type => color and check the default values.. Some default values are empty. Please remove this lines from all color control if they’re emtpy ‘default’ => ’ ’. Please don’t remove if they’ve hex values.

Note: i read the github kirki and they’re talking about this..

mwax321

mwax321 Purchased

That didn’t fix the issue, but rather than fix it here, I created a pull request for kirki to fix the glitch.

The problem exists on class-kirki-field-color.php line 60. Change line 60 to:

if ( property_exists( $this, 'default' ) && $this->default != null && ! empty( $this->default ) && (is_string($this->default) || is_numeric($this->default)) && strpos('rgba', $this->default) === false ) {

Thank you very much mwax321..The kirki developers must be update their plugin just like your solution..I keep follow the request..

I purchased this theme and am incredibly happy with it. However, I’m struggling to find a way for the words inside the slide button to be centered. They sit at the top of the button. How can I move just the words (not the whole button) down a few pixels?

I’m happy from your happiness..

Please follow this below steps; - Open slide settings - Go slide button tab in styling - And give some padding top

Screenshots below..

1.http://demo.iamarif.com/uploads/lifeband/help-desk/step1.png 2.http://demo.iamarif.com/uploads/lifeband/help-desk/step2.png 3.http://demo.iamarif.com/uploads/lifeband/help-desk/step3.png

If you need another help please open a from here: https://iamarif.ticksy.com/

Thanks, Best Regards..

Hi! How do I change the color for the mobile menu, as well as the color of the stripe below the author bio in mobile view. Im not having this problem in computer view, just mobile and cannot find a customize option.

Also, although I have changed the colors of the menu links, they still show as red when you hover over, and always have a line through them.

Thanks in advance!

You’re welcome kylieugarte.. When you’ve free time if you give me some rating i also appreciate to you..

Best regards..

Yes I will leave a rating now :) Sorry for my many questions- this is my first time editing a purchased theme, so I am learning. Is there a way to edit the color over the images in post style grids? I’ve noticed that there is red over my services and yellow over my blog posts. I would prefer no color, just the plain images.

Thank you again iamarif

Please add this css lines for removing overlays (you can add additional css in customizer or kc composer settings part);

For service;

.post-type-grid-list-services .service-box figure .bg-image:before { background: transparent;}

For my blog posts;

.section-blog-posts .post .bg-image:before, .section-related-posts .post .bg-image:before, .post-type-grid-list-post .post .bg-image:before { background: transparent; }

You’re welcome again and i thank you for big rating and nice comments..

Best regards..

some weird yellow color is showing in mobile version. must be blue instead of yellow.

https://www.testversie-site.nl/stap/

Also the menu turns yellow, I custom css’ed it but it looks to me like a bug

I saw your rating i want to write from here one more time. You did not wait for supporting for an hour.. Always write comments from here in bad faith..And one more time i want to write here you’re the first person unpleasant about my themes and help desk..

I think you were in bah faith if you wait enough time for supporting i can check it out and solving the problems..

And one more thing there are many people and customer here pleasant about my themes and services..

So,You could really refund instead of giving it a bad rating..

Thank you anyway purchasing my theme..

I want to add a e-mail link to a textblock but the icon is not visible

I saw your rating i want to write from here one more time. You did not wait for supporting for an hour.. Always write comments from here in bad faith..And one more time i want to write here you’re the first person unpleasant about my themes and help desk..

I think you were in bah faith if you wait enough time for supporting i can check it out and solving the problems..

And one more thing there are many people and customer here pleasant about my themes and services..

So,You could really refund instead of giving it a bad rating..

Thank you anyway purchasing my theme..

I like the leaves, but the leaves are in front of a tekst.

https://www.testversie-site.nl/stap/

I saw your rating i want to write from here one more time. You did not wait for supporting for an hour.. Always write comments from here in bad faith..And one more time i want to write here you’re the first person unpleasant about my themes and help desk..

I think you were in bah faith if you wait enough time for supporting i can check it out and solving the problems..

And one more thing there are many people and customer here pleasant about my themes and services..

So,You could really refund instead of giving it a bad rating..

Thank you anyway purchasing my theme..

<solved>

Hi i read all comments and i think you solved the problem..

I saw your rating i want to write from here one more time. You did not wait for supporting for an hour.. Always write comments from here in bad faith..And one more time i want to write here you’re the first person unpleasant about my themes and help desk..

I think you were in bah faith if you wait enough time for supporting i can check it out and solving the problems..

And one more thing there are many people and customer here pleasant about my themes and services..

So,You could really refund instead of giving it a bad rating..

Thank you anyway purchasing my theme..

What is the best way to copy paste a new page from an old page? I copied a test page and everything is out of position.

Hi..You must follow these steps:

1. In page you want to copy and paste. Save page content to section (This is the screenshot: http://demo.iamarif.com/uploads/lifeband/help-desk/save-page.jpg )

2. In this step opens a kc modal box and you must hit the plus button at the top (This is the screenshot: http://demo.iamarif.com/uploads/lifeband/help-desk/savetonewsection.jpg)

3. When you click a new page open. Enter the section name and select lifeband pages categories. (This is the screenhot: http://demo.iamarif.com/uploads/lifeband/help-desk/addnewsectionpage.jpg)

4. Now you can create a new page and choose the saved section or page from the template library and clone it. (This is the screenhot: http://demo.iamarif.com/uploads/lifeband/help-desk/clone-page.jpg)

Simply, we save the section and reuse via kc template library..

Best regards..

I got the error : Fatal error: Can’t use function return value in write context in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/themes/lifeband/inc/customizer/lifeband-custom-styles.php on line 274

why? can you help me

You can find lifeband-custom-styles.php here: wp-content/themes/lifeband/inc/customizer/lifeband-custom-styles.php

I fix this by updating my php version, I had some problems with Kirki but the answer of @mwax321 helped me a lot.

Yes there is an error about Kirki.. I opened an issue for this but there is no permanent solution but as you said i suggest the solution of @mwax321 answer..

Thanks purchasing,

Best regards..

Hello, the theme was working well, (I follow the comets to solve some issues) but now I’m getting the error:

Warning: require_once(LIFEBAND_THEME_ROOT_ABS/inc/prebuild-sections/sections.php): failed to open stream: No such file or directory in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/plugins/lifeband-extensions/lib/kc-sections/importer.php on line 40

Fatal error: require_once(): Failed opening required ‘LIFEBAND_THEME_ROOT_ABS/inc/prebuild-sections/sections.php’ (include_path=’.:/usr/local/php5_6/lib/php’) in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/plugins/lifeband-extensions/lib/kc-sections/importer.php on line 40

How can I solve this?

Hi thank you for purchasing the theme.. First one is a warning only.. If you WP_DEBUG (‘false’) it disappear..

Normaly the path is true and i check it my local and it’s working no problem..

But you can try this one in lifeband-extensions plugin… Find lifeband-extensions/kc-sections/importer.php and go to line 40 and find this line: $template = require_once LIFEBAND_THEME_ROOT_ABS . ’/inc/prebuild-sections/sections.php’;

Replace LIFEBAND_THEME_ROOT_ABS with get_template_directory()

So there is an error about the path..

Best regards..

Hello Again, I really like the theme, but I got the same error again … an plus 2 errors more

The 2 first when I go to my wp-admin area Warning: strpos(): needle is not a string or an integer in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/plugins/kirki/field/class-kirki-field-color.php on line 60

Warning: Cannot modify header information – headers already sent by (output started at /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-includes/pluggable.php on line 1216

theese 2 next in the front , the view for the user

Warning: md5() expects parameter 1 to be string, array given in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/plugins/kirki/modules/webfonts/class-kirki-fonts-google-local.php on line 118

Warning: md5() expects parameter 1 to be string, array given in /home/content/83/7326483/html/sites/wonderlife.pe/www/wp-content/plugins/kirki/modules/webfonts/class-kirki-fonts-google-local.php on line 118

Do you have any updates ? because the error are all of them relate to kirki , hope you can help me .

I’ll create an issue about this error again.. But first you must apply this solution again :

https://github.com/thewax/kirki/commit/2fb31f398c7de61542ecf496153471f518972800

Because this solution in kirki plugin file and i think you update the Kirki plugin so your changes gone away.. Please do this solution again and not update the Kirki Plugin..

Hello, is there a way to get rid of the vimeo plugin which seems to be built into the theme? Is laying a cookie. Vimeo is not allowed to the GDPR. Mike

Hi.. Yes you can remove it.. Please go to the theme root and find inc/misc.php file.. Search “vimeoplayer” in this file and completely remove this line from the file:

wp_enqueue_script(‘vimeoplayer’, LIFEBAND_THEME_ROOT. ’/assets/scripts/mb.vimeoplayer.min.js’, array(‘jquery’), esc_attr($lifeband_theme->get( ‘Version’ )), true);

Best regards..

Hi, great theme. A have a few small questions:

- How do I change the yellow background color in the mobile version menu? - How do I change the yellow mouse over color of the testimonials prev next button texts? (http://www.bureau130.at42.atention.hosting/) - how do I change the colors of regular links (like the red and blue ones on this page: http://www.bureau130.at42.atention.hosting/onderzoek/) - there’s a yellow background under the coach name and title in mobile version, how do I change that color?

and a slightly bigger problem: when I visit my testsite in Internet Explorer, the page title is not centered in the header but all the way on top: http://www.bureau130.at42.atention.hosting/onderzoek/

how do I fix this?

I’m sorry again i forgot css code for the mobil menu bg color.. Here is the code you must add custom css area…

#mobile-menu-trigger { background-color: #yourhexcolor }

I think my stupid mistakes not your questions..

Best regards..

thank you, I have changed the mobile menu color now :-)

the IE problem still exists, I’m using IE 11.

I test it out with IE 11. It must work i can send screenshot..if you send me wp-admin infos to hi@iamarif.com i can check.. Maybe someting wrong about the adding css..

89366d7a-10b9-467e-976f-d03052f899a8

This is my purchase code.. I installed in a dev domain the lifeband coach theme but none of the images or the design that is shown in the preview appears.

It is like simple , not designed blog wordpress. No photos, no background.

Can you help me? First Should I install everything ( the complete folder or only wordpress files?) after installing. what should I do to tet the prebuilt website I bought?

Is there a way to chat with you?

Hi.. Please watch the installation video in documentation file.. You can import one click just like a demo.. After that if you’ve problem i try to assist you..Of course you must have fresh WordPress install before import demo..

Best regards..

After downloaded the complete theme,,, a) should I extract the folder b) then , which is exactly the unzipped file I must upload ( which is the name? is it a compressed folder or not

c) what is the MACO for?

d) I upload lifeband mainfiles and I received these error messages.. after trying to installed plug ins

not a string or an integer in /home4/marceromano/programacoaching.com/wp-content/plugins/kirki/field/class-kirki-field-color.php on line 60

Warning: Cannot modify header information – headers already sent by (output started at /home4/marceromano/programacoaching.com/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home4/marceromano/programacoaching.com/wp-includes/pluggable.php on line 1216

Warning: Cannot modify header information – headers already sent by (output started at /home4/marceromano/programacoaching.com/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home4/marceromano/programacoaching.com/wp-admin/includes/misc.php on line 1116

Warning: Cannot modify header information – headers already sent by (output started at /home4/marceromano/programacoaching.com/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home4/marceromano/programacoaching.com/wp-includes/option.php on line 919

Warning: Cannot modify header information – headers already sent by (output started at /home4/marceromano/programacoaching.com/wp-content/plugins/kirki/field/class-kirki-field-color.php:60) in /home4/marceromano/programacoaching.com/wp-includes/option.php on line 920

Can you please help me?

a) You don’t need the extract zip file (lifeband.zip) b)lifeband.zip is the theme file.. You must use this one after install the WordPress.. c) Not important d) Please first watch a video how to install WordPress from youtube or google.. You can find many video about these..Unfortunately you must know how WordPress install..

Then please again watch theme installation video from documentation.. (lifeband-mailfiles->documentation->index.html) When you open the index.html page you can find right of the page theme installation video link..

About the Errors: If you install the theme following the video steps and still getting this errors..

Please visit this link:

https://github.com/thewax/kirki/commit/2fb31f398c7de61542ecf496153471f518972800

This explain: Go to kirki plugin folder and find the class-kirki-field-color.php file (wp-content/plugins/kirki/field/class-kirki-field-color.php) And change two lines.

If you’ve some problems about the errors. Please email me hi@iamarif.com ( You must share hosting information with me. I can upload the fixed file about the plugin..)

But please first watch again theme installation video and follow all steps correctly…

Hi, i do i use a custom font (not a google font, a font bought separately)?

Hi..Thank you for purchasing the theme..

Unfortunately, there is no option for custom fonts..But you can add regular way..

1- Convert your font to web font (http://www.font2web.com/) 2- Upload fonts assets/fonts 3- Upload css assets/css 4- Be sure the font path is true in css file 5- Call css file in functions.php ( wp_enqueue_style(‘custom-font’, get_template_directory_uri.’/assets/css/custom-font.css’, null, esc_attr($lifeband_theme->get( ‘Version’ ))); ) 6- Write your css for your custom fonts in body,h1,h2,h3,h4,h5,h6, p, a and whatever you want..

Thanks.. Best Regards..

When I try to activate the extension, I get this error:

“Plugin could not be activated because it triggered a fatal error.

Fatal error: Cannot redeclare class OCDI_Plugin in /home/content/p3pnexwpnas12_data03/26/41837626/html/wp-content/plugins/lifeband-extensions/lib/one-click-demo-import/one-click-demo-import.php on line 21”

Perhaps related, none of the demo content is showing up on any of the pages (it only shows up in the admin).

How can I resolve this?

I should clarify, when I try to active the “Lifetime Extensions” plugin

It was about the redeclaring the OCDI_Plugin class..I mean it say the plugin has installed before. Please reinstall the wp again from scratch and follow these instructions..

1- Import lifeband.zip 2- Begin install all plugins 3- Activate all plugins installed 4- One click import

Normally this is the first time this kind of an error.. I thinks it’ll be working this time.. If it won’t i can install for you no problem..

by
by
by
by
by
by