Discussion on The Barber Shop - One Page Theme For Hair Salon

Discussion on The Barber Shop - One Page Theme For Hair Salon

3.75 (8 ratings) 3.75 stars
Cart 283 sales
Well Documented Envato Checkmark

themeton supports this item

Supported

This author's response time can be up to 1 business day.

55 comments found.

Problem with Import Demo Data

Parse error: syntax error, unexpected ’$this’ (T_VARIABLE), expecting ’;’ or ‘{’ in \wp-content\themes\nrgbarbershop\framework\classes\lib\wp.importer\parsers.php on line 407

Solution

add “{” to line 405 in file parsers.php after “function __construct()” and import demo data will be work :-)

Thank you really for the advance :)

Hi, How to fix this error: “Parameter must be an array or an object that implements Countable in /home/senso85/domains/artelab.senso85.seo-linuxpl.com/public_html/wp-content/themes/nrgbarbershop-1.8/nrgbarbershop/framework/classes/lib/Less/Visitor/toCSS.php on line 113”

Hello,

Have you tried it with latest version which updated end of last week?

Thanks a lot

Can’t import demo data as when I try it the One Click Demo Data button doesn’t do anything and when I try the WordPress Importer tool in Tools I get the following error: Before you can upload your import file, you will need to fix the following error:

Unable to create directory uploads/2018/12. Is its parent directory writable by the server?

I have had a look and the directory is there.

That is all fixed now as it was the uploads directory that was setup incorrectly

Thank you really much!

I’ve registered for the support site but not had an email with my registration details?

Thanks for you found the solution. Thanks

I didn’t find the solution to this, can you help please as I cannot get on the support site

Hi there. Could you tell me your issues here?

How do I link to a page section within the text? I have tried book here and book here but both just send the page back to the top?

Got your theme through Elements. I can’t get the menu active/hover bg to change, not when I change the Menu Active Color in the customizer and not even when I change the css – not even !important works.

Edit: nvm, was a blonde moment. It was the cache.

Thanks for your effort :)

The plugins are not working properly. where i can set up side menu? I cant find any options over there… Keep saying troubles when i wanna post new set up…

Hello,

Could you send me your site credentials via mail?
I think there have a something suspicious.

Thanks

I have sent u an email through the form on the page u have linked.

Hello,

Have you updated your VC plugin? You can delete and install again. And I asked a question on email reply. Please check there.

Thanks

Hello,

I want to create website with 2 languages. Is it possible one of those raw icons on left side to open in new window?

Yes possible. I don’t know how you manage your 2 language sites. So I’d recommend some translation plugins to use. And I don’t think there have a problem to open in a new window. So what type of menu do you wanna use? I mean if you’re using regular menu there have an option to open it in new tab. If it is on one page scroll menu then we need to decide something.

Thanks a lot

Hi there! Is there any way to build regular page and multipage sites? And also how to change the menu when using multipage site?

Hello,

It’s very simple and possible. Please just use your site regular as wordpress sites, create your pages and menus for your primary menu location. Only one page thing is related on front page now and one page layout. Then otherwise everything is supposed to regular wordpress sites. Please let me know if this is not clear.

Thanks

Can someone please help me upload this to my website? im have troubles.

Hello,

What type of issues do you have? Please follow install instructions from the documentation file. Also you should try manual install method.

Thanks

Hey Guys,

Could you please update the theme or at least the plugins (visual composer)

Thanks :)

And where to add the Google Map API?

Thanks :)

Hello,

As you requested, I’ve updated the theme with latest VC version today. Please update there your 1.8.3 theme version and update your VC. You have to delete your older VC and reinstall the new from required plugin mention.

V1.8.3 - 16 Mar 2020
    UPDATE: Visual composer 6.1
    FIX: Class conflict with a plugin
    FIX: WooCommerce obsolete function
    FIX: PHP 7.2 compatibility
Please use this plugin for allowing API for the GMap. https://wordpress.org/plugins/api-key-for-google-maps/

Thanks a lot

How can i contact the support for this theme?

My purchase code is valid – but i cant register at the forum.

Please Help – Need Support!

Hello,

Please send me a mail from my profile page. I’ll create an user for you manually. Also you can send me your issue details in the mail.

Thanks a lot

I bought and used this theme two years ago.

However, the loading speed of the page has been too slow from the time of purchase.

I previously asked about loading speed, but you did not give a satisfactory answer. (You tell me that your theme is fine.)

I would like to know if I can request an optimization task to improve the loading speed at an extra cost.

What I want is fast page loading.

Please help.

Hello

Typically it’s beyond the support boundary that increasing customer’s site speed. But achieving a good result on our theme is beneficial for other customers.

So please give me your site address and take a look at some speedometer web services like google page speed, pingdom tools and gtmetix and see what’s going on there.

Thanks a lot

I don’t want to expose the site URL for security reasons.

Is it okay if I tell you the URL in your email?

I would appreciate it if you could give me an email address if you could.

Yes please send me a mail from my profile page. Thanks

Is this theme compatible with WordPress 5.5.1?

Hello,

I don’t see any inconvenience on the latest version. If you face something I’ll definitely help you.

Thanks

I don’t see any updates in WP for this theme. is that correct? is version 1.6.5 the latest? Plugins state that Visual composer can not be updated, but it came with the theme when I purchased it in 2017. Any thoughts?

Thank you

Hello

Latest version is 1.8.4 for now. You can get later VC version is it. Please download again and update there.

Thanks

by
by
by
by
by
by