Discussion on Richer - Responsive Multi-Purpose Theme

Discussion on Richer - Responsive Multi-Purpose Theme

Cart 1,552 sales
Well Documented

ArtstudioWorks does not currently provide support for this item.

470 comments found.

CREATPHYS

CREATPHYS Purchased

Bonjour, ça ferais plus sérieux de vendre un thème mis à jours … dernière mise à en jours en 2018 ?? Message d’erreur Woocommerce…

de tous les thème que j’achète c’est le seul jamais mis à jours…

Hello, theme is not supported anymore. When you purchase theme you see that theme is not updated. Anyway, please explain what error you have and we can fix it.

blass98 Purchased

Hello, I’ve a query about mobile navigation. It is possible to modify the word NAVIGATION ?, I couldn’t find where to do it. Thank you !

www.lcmabogados.com.ar/img/Print.jpg

Hi, ‘navigation’ text you can find in the wp-content\themes\richer\framework\js\superfish.js :line 55

blass98 Purchased

PERFECT! Thank You so much for your help and quick response :)

I’m using safari 15.0. The Favicon in the General theme options and the Logo upload button in the Header are not responding.

Thanks. I replaced the file and now I can upload it. But now, when I click Save All Changes, the loading icon keeps moving and I can’t complete the operation.

I forgot to mention that I am using Wordpress 5.8.2.

I’ve been waiting for the process to complete for tens of minutes now, but it never ends. I thought I was finally able to upload the file, but now I can’t save it. I’ve been unable to make any progress since yesterday. Unfortunately, I’m not going to use it anymore. I would like a refund.

theme options are not saving – fresh install, new site. I imported the theme backup and save doesn’t work. any suggestions. There are no plugins or after markup. only WP installed and the theme and recommended plugins. thanks

Hi, please donload latest version here https://drive.google.com/file/d/1z44il-ba91l-1NcRH7IrKFU_6WOVkDzr/view?usp=sharing, it will fix those issues. Also, clear cache after updated theme installation.

does this theme work with WP 5.7.1?

Hi,

No it doesn’t.

after we set up your theme , when we want to import main demo we get this error

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WP_Import has a deprecated constructor in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/wordpress-importer.php on line 38

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Warning: Invalid argument supplied for foreach() in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 365

Fatal error: Uncaught Error: Class ‘UniteDBRev’ not found in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php:129 Stack trace: #0 /home/swccomtr/public_html/wp-includes/class-wp-hook.php(287): ASW_importer(’’) #1 /home/swccomtr/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #2 /home/swccomtr/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #3 /home/swccomtr/public_html/wp-admin/admin.php(175): do_action(‘admin_init’) #4 /home/swccomtr/public_html/wp-admin/themes.php(10): require_once(’/home/swccomtr/...’) #5 {main} thrown in /home/swccomtr/public_html/wp-content/themes/richer/framework/importer/importer.php on line 129

Hi,

Please provide your wordpress dashboard credentials(login/pass&URL) to our email artstudioworks@gmail.com and we will import demo for you.

Hi, I purchased this and it’s not only got woocommerce templates that need updating but the demo import doesn’t work either. There are several other problems I’ve encountered, too. I’ve emailed directly about this but have had no reply. Since then I’ve found a much better alternative template which I’ve got working perfectly, so would like my purchase refunded. Hopefully i can get a reply here before i rate the product.

Hi, if you read theme description you see that it is compatible with wordpress under 5.0 and woocommerce under 4.0. We have updated version that you can check here https://themeforest.net/item/richer-responsive-multipurpose-theme/7840229/faqs/43783

Anyway, create refund request and we refund you.

Hello,

On our website store page http://in.sectrix.com/store/

The store sidebar is not appearing instead of that default blog sidebar is appearing in place of store sidebar even after selecting the store sidebar.

Can you please check this issue and if there is any resolution?

Hi,

This page is generated by woocommerce and wordpress as archive page, in this case your sidebar is Blog Widgets sidebar. If you want to add custom sidebar, create custom page with sidebar that you need and add products block to show your products.

Earlier it was working fine but not anymore.

Can you provide your wordpress dashboard credentials(login/pass&URL) to our email artstudioworks@gmail.com and we will check what is wrong.

Hi, after the update of wordpress I can’t seem to change any settings of your theme anymore? Is there a solution for that?

Wordpress version: 5.6

Richer version 3.2.5

thanks in advance

hello, i have the richer theme installed on my wordpress and i would like to update the theme, but i found no way to do it by wordpress, can you help me?

Hi,

1) Download latest package from themeforest; 2) Go to dashboard=>appearance=>themes and activate any other theme (e.g. – one of the standard); 3) Delete old theme; 4) Install the theme from newest package.

is thema compatible with the latest version of PHP – 7.4? thank you

We did not test theme with 7.4, we tested it with 7.2 and everything worked fine.

Greetings! I’ve been a long time user of the Richer theme, so far with no significant problems that i couldn’t find a solution – overall very pleased with it.

After WP v5.5 update, the drop down menu stopped working, but the jQuery Migrate plugin saved the day.

Now that i updated WP to v5.6, i have the same problem where the drop down menu isn’t working once again, but this time jQuery Migrate plugin doesn’t seem to help.

Can you offer some help / guidelines with this, please? Should i upload the files that you offer in the FAQ, or do i need to switch to another theme and redo the whole website?

Thanks a lot!

THANK YOU! They worked just fine, much appreciated!

theme options are not saving – fresh install, new site. I imported the theme backup and save doesn’t work. any suggestions. There are no plugins or after markup. only WP installed and the theme and recommended plugins. thanks

Recently i got the template, i managed to import demo content and everything. However, I am not able to change the logo from customize and the options given in theme options is not working. As in i am not able to submit the changes or make any changes in theme options at all.

Hi,

Please, contact us through email artstudioworks@gmail.com we will provide you files to fix the issues and make it works with wordpress 5.2+

Hi there, can you please update the theme including the latest WPBakery?

After the big update of WordPress 5.5 all sites that use Richer theme crash.

I see last update was end of 2018.

Thank you and keep up the good work!

Hi,

To fix some js issues please install Helper jQuery Migrate plugin. Latest version of WPBakery available here http://artstudioworks.net/recommended-plugins/js_composer.zip

Thank you, for this. However, some issues remain. Can you please update the theme with the latest WPBakery please?

You can download latest version of WPBakery Page Builder plugin here http://artstudioworks.net/recommended-plugins/js_composer.zip

does the theme work with wordpress 5.5?

Hi,

Theme works with 5.5, however you need to install this plugin https://wordpress.org/plugins/enable-jquery-migrate-helper/

Hello ASW!

With the new WP 5.5 version it seems some functionalities of the Richer theme stop working. In my website it was the dropdown menu that stop working (i haven’t found anything else yet).

I found info about a migration tool known as jquery-migrate will no longer be enabled by default in WP 5.5. This may lead to unexpected behaviors in some themes or plugins who run older code.

I install this plugin (Enable jQuery Migrate Helper) and it solved the problem, but i believe this should be solved with an theme update.

Can you do it?

Yes, i use child theme, i would appreciate if you provide the code.

Hi,

We researched this issue and you need to know that jQuery migrate can cause some errors, because WordPress 5.5 has updated jQuery version and new version of jQuery migrate will be available with WordPress 5.6. Currently you can use this plugin https://wordpress.org/plugins/enable-jquery-migrate-helper/

Thanks!

Hi, author. I’ve been using the richer theme for a long time for my business website but I recently had issues with scrolling which makes it difficult for desktop users to use the site. The page vibrates or shakes when scrolling up or down. And it happens on almost all the webpages. What might be the problem? This is the link to the site – https://bit.ly/3hzLICg

Hi,

Try to use option to disable smoth scrolling, go to theme options -> layout -> Disable Smooth Scrolling

Solved. Thanks.

has theme been tested with WP 5.4.2?

It works with wordpress 5.4.2, but theme is not integrated with Gutenberg editor.

ok so I just have to install the old WP editor to edit the pages.

You can use WPBakery Page Builder (Visual composer) or classic wordpress editor.

Is this theme compatible with PHP 7.2?

Hi, We tested the theme with PHP 7.2.4 and everything works fine.

Can you show me the phpinfo for that installation running over PHP 7.2.4?

Is this theme no longer being update? Last update was November 2018? If that’s the case, you shouldn’t be allowed to sell it still?

We don’t plan to update the theme. There is no problem with theme and it works with wordpress 5.0+

by
by
by
by
by
by

Tell us what you think!

We'd like to ask you a few questions to help improve ThemeForest.

Sure, take me to the survey